This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA PROBLEMAS DE PAUSA CON ARTILLERY GENIUS PRO 2022
#1
HOLA!
hace poco adquiri una artillery genius pro del año 2022 las cuales cuentan con placas electronicas ( TFT Y PLACA MADRE) de la misma firma artillery, ya no son MKS
resulta que me di cuenta que esta tiene un error catastrófico, la impresora imprime perfecto la tengo calibrada y todo, pero el error empieza cuando le pongo pausa para manipular algunos ajustes y al reanudar la impresión esta vuelve al lugar donde quedo, pero el extrusor no avanza, tan solo hace los movimientos de retracción, por lo que descarto que sean problemas con el hotend, por que el filamento no termina mordido tampoco, ni suena el motor haciendo el típico (clack) de perdida de pasos. 
así que se descartan los errores más típicos, Y TAMBIEN ES MUY IMPORTANTE DESTACAR que este error también pasa con el sensor final de filamento que trae de fabrica, al acabarse la impresión hace todo perfecto (alerta, desplazamiento, reanudar) pero cuando vuelve donde quedo, sucede lo mismo solo se mueve hacia atrás el extrusor (para las retracciones) pero este no avanza para extruir filamento.
Pense que tenia problemas con el firmware por lo cual la actualize a marlin 2.0.9 y le active el comando de pausa avanzada M600, ya que no venia de fabrica con esta opción, la verdad e visto el firmware pero sin resultados positivos, y también pasa el mismo error con el comando M600 después de la pausa. la verdad nose que mas intentar, me a decepcionado bastante artillery.
si logro solucionar el problema lo compartiré, ya que e visto que mucha gente le pasa lo mismo con sus artillery de este año.
saludos!!
  Responder
#2
Hola, me temo que hay algo de confusión con la pausa de la impresión (para hacer algo y reanudar después) y la pausa avanzada (que se utiliza para el cambio de filamento asistido).
La primera se realiza mediante la opción del menú general (que aparece cuando hay una impresión en marcha) o con el comando M25 y se reanuda mediante la opción correspondiente del menú o con el comando M24.
La segunda se realiza con el comando M600 e integra todos los pasos necesarios para el cambio de filamento: se descargará el filamento a cambiar y se pedirá confirmación para reanudar, realizandose entonces la carga del nuevo filamento (utilizando los valores configurados para ello en la pausa avanzada), antes de continuar la impresión en el punto donde se interrumpió.
En ambos casos, si se definen los parámetros NOZZLE_PARK_FEATURE y PARK_HEAD_ON_PAUSE, se aparcará el cabezal durante el tiempo que dure la pausa, habilitándose el comando M125, que realiza una pausa con aparcado (al que llama el comando M25).
Por tanto, si lo que se quiere es pausar la impresión por algún motivo, pero no es para cambiar el filamento, hay que utilizar la pausa normal (no el comando M600).
En todo caso, es bastante raro que no continúe la extrusión al reanudar la pausa (en cualquiera de sus formas), por lo que yo diría que el problema debe estar en la configuración del firmware o que haya algún bug que quizá se haya corregido en versiones más recientes (la 2.0.9 ya tiene un tiempo).
Te recomiendo que utilices la última versión de Marlin que incuya las últimas correcciones hasta la fecha (2.1.x o bugfix-2.1.x) y que la configures de forma correcta para tu impresora, partiendo de los archivos de configuración que trae por defecto Marlin.
  Responder
#3
Alguien ha solucionado esto? no encuentro nada de información para resolverlo (tengo 4 artillery genius pro) las cuatro hacen lo mismo que describen aqui. una de ellas fué comprada a fines de 2022 y las otras 3 a mediados de 2023.
me cuesta creer que un bug así no haya sido resuelto aun o que no haya publicaciones resolviendolo (creo que no estare usando los terminos de busqueda correctos)


(11-09-2022, 08:35 PM)joaquin.cl escribió: HOLA!
hace poco adquiri una artillery genius pro del año 2022 las cuales cuentan con placas electronicas ( TFT Y PLACA MADRE) de la misma firma artillery, ya no son MKS
resulta que me di cuenta que esta tiene un error catastrófico, la impresora imprime perfecto la tengo calibrada y todo, pero el error empieza cuando le pongo pausa para manipular algunos ajustes y al reanudar la impresión esta vuelve al lugar donde quedo, pero el extrusor no avanza, tan solo hace los movimientos de retracción, por lo que descarto que sean problemas con el hotend, por que el filamento no termina mordido tampoco, ni suena el motor haciendo el típico (clack) de perdida de pasos. 
así que se descartan los errores más típicos, Y TAMBIEN ES MUY IMPORTANTE DESTACAR que este error también pasa con el sensor final de filamento que trae de fabrica, al acabarse la impresión hace todo perfecto (alerta, desplazamiento, reanudar) pero cuando vuelve donde quedo, sucede lo mismo solo se mueve hacia atrás el extrusor (para las retracciones) pero este no avanza para extruir filamento.
Pense que tenia problemas con el firmware por lo cual la actualize a marlin 2.0.9 y le active el comando de pausa avanzada M600, ya que no venia de fabrica con esta opción, la verdad e visto el firmware pero sin resultados positivos, y también pasa el mismo error con el comando M600 después de la pausa. la verdad nose que mas intentar, me a decepcionado bastante artillery.
si logro solucionar el problema lo compartiré, ya que e visto que mucha gente le pasa lo mismo con sus artillery de este año.
saludos!!
  Responder
#4
(11-09-2022, 08:35 PM)joaquin.cl escribió: HOLA!
hace poco adquiri una artillery genius pro del año 2022 las cuales cuentan con placas electronicas ( TFT Y PLACA MADRE) de la misma firma artillery, ya no son MKS
resulta que me di cuenta que esta tiene un error catastrófico, la impresora imprime perfecto la tengo calibrada y todo, pero el error empieza cuando le pongo pausa para manipular algunos ajustes y al reanudar la impresión esta vuelve al lugar donde quedo, pero el extrusor no avanza, tan solo hace los movimientos de retracción, por lo que descarto que sean problemas con el hotend, por que el filamento no termina mordido tampoco, ni suena el motor haciendo el típico (clack) de perdida de pasos. 
así que se descartan los errores más típicos, Y TAMBIEN ES MUY IMPORTANTE DESTACAR que este error también pasa con el sensor final de filamento que trae de fabrica, al acabarse la impresión hace todo perfecto (alerta, desplazamiento, reanudar) pero cuando vuelve donde quedo, sucede lo mismo solo se mueve hacia atrás el extrusor (para las retracciones) pero este no avanza para extruir filamento.
Pense que tenia problemas con el firmware por lo cual la actualize a marlin 2.0.9 y le active el comando de pausa avanzada M600, ya que no venia de fabrica con esta opción, la verdad e visto el firmware pero sin resultados positivos, y también pasa el mismo error con el comando M600 después de la pausa. la verdad nose que mas intentar, me a decepcionado bastante artillery.
si logro solucionar el problema lo compartiré, ya que e visto que mucha gente le pasa lo mismo con sus artillery de este año.
saludos!!

Hola vi que en este foro aun no tiene respuesta concreta al tema así que paso a dejar la mía para ver si ayuda en algo, tengo una Artillery Genius Pro desde hace un año mas o menos, nunca tuve problemas con ella hasta que se me dio por explorar el comando M600 actualizando desde la pagina oficial de Artillery el Firmware. Al hacer cambio de filamento y darle a reanudar impresión me pasa exactamente el problema que detallan y intentando hacerlo manual sin el comando M600 note que al pausar manualmente me provocaba el mismo error, luego de instalar varios Firmware de distintos creadores consulte con mi hermano que tiene la misma impresora, diciéndome que al pausar el no tiene ese error y que el lo cambia manual.
Luego de meditarlo bastante hice la pregunta clave.... Que programa de laminado usas!?... el usa Cura Ultimaker y yo Prusaslicer, navegando en internet por ese lado descubrí que Prusaslicer tiene conflictos con la marca Artillery, conflictos que a día de hoy aun no han reparado y no se si lo vallan a hacer, uno de esos problemas es el que importa en este tema y esta en la pausa de impresión, así que la solución rápida es que si vas a pausar por algún motivo en especial o quieres usar el comando M600 para cambio de filamento instales el Laminador de Cura Ultimaker, dejo el enlace oficial y espero te sirva saludos.

https://ultimaker.com/software/ultimaker-cura/
  Responder
#5
Hola @Novato101, bienvenido al foro.
Me temo que tu solución al problema, asignando la culpa al laminador, no tiene ningún fundamento técnico: los programas de corte no tienen niguna influencia en como se realizan las funciones de pausa en la impresora, todo está programado en el firmware y ellos lo único que hacen es poner los comandos que desencadenan esas funciones: que los pongan o no y que lo hagan en los lugares adecuados del archivo de impresión ya es otro tema, pero en cómo se realizan dichas funciones no influyen en nada.
Y sobre que haya incompatibilidades de algún programa de corte con impresoras concretas, me temo que lo dudo mucho, aparte de que puedan tener configurados datos erróneos de algún modelo: quitando las medidas, el tipo de firmware y unas pocas cosas relacionadas con el equipamiento, no suelen tener nada específico relacionado con el modelo de impresora y los comandos gcode que utilizan todos, son universales para el firmware concreto de la máquina (la inmensa mayoría Marlin).
En mi opinión, que ya he expresado antes, este problema de la falta de extrusión después de la pausa, tiene que ser algo relacionado con el firmware y por ahí debe buscarse la solución: en todo caso, no sabemos si @joaquin.cl consiguió solucionarlo o no con el cambio de firmware que le sugerí.

P.S.: Por otra parte, acabo de caer en la cuenta de que quizá sí pueda estar relacionado con el laminador, aunque no por un problema de compatibilidad, sino por cómo se maneja la extrusión (CURA por defecto utiliza posicionamiento absoluto y acumula el total extruido durante la impresión; desconozco como lo gestiona Prusaslicer y en todo caso, si esto puede ser la causa del problema): investigaré un poco en esta dirección.

P.S.: Prusaslicer también utiliza posicionamiento absoluto para la extrusión, aunque reinicia la posición en cada retracción, nada que pueda influir, pues solo incluye el comando M600 sin parámetros, por lo que se utilizan los configurados en el firmware.
La verdad es que no veo cómo podría esto afectar al problema que estamos tratando, pues en teoría Marlin guarda la posición del eje E antes de pausar y la vuelve a colocar al reanudar la impresión, por lo que creo que se descarta como causa del problema.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Cortocircuitó ARTILLERY GENIUS jazznavi 1 12 Hace 4 horas
Último mensaje: Simemart
Lengua DUDA Artillery X2 vs X3 plus Hannibal_023 0 40 18-07-2024, 08:54 AM
Último mensaje: Hannibal_023
  CONSULTA Artillery Genius ¿Placa Quemada? Jose_D 3 523 15-07-2024, 08:11 PM
Último mensaje: Simemart
  CONSULTA Artillery genius eje Y no funciona palet90 17 388 05-07-2024, 06:20 AM
Último mensaje: trafuga
  La Artillery X1 nunca alcanza los 260º para imprimir en ABS Jesushh369 53 1,247 26-06-2024, 08:39 PM
Último mensaje: Simemart