This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Daño de conectores de placa de los termistores (Artillery Genius)
#1
Hola, tengo una artillery genius y al cambiar el hotend de la impresora, tuve un descuido y estaba conectada entonces al momento de conectar todo genero un corto, al revisar que todo estuviera en orden note que el termistor de el hotend no estaba funcionando, me marcaba una temperatura de 136 grados, al conectar otro termistor para asegurarme que no fuera este el que estuviera dañado, me seguía marcando la misma temperatura, entonces lo que hice fue cambiar, en la placa el conector del termistor por el que se encuentra libre en la atillery genius, y al conectar la impresora funciono correctamente pero al momento de poner a calentar el hotend y la cama, la cama comenzo a sacar humo debido a que esta seguia calentando y la temperatura que marcaba era incorrecta, lo que hice fue intercambiar la conexion de el hotend y de la cama, asi consegui que funcionara la cama, entonces lo que no funcionaba era en la placa, alguien sabe si tengo que cambiar la placa completa, o hay algun otro pin al que pueda conectar el termistor, o si pueda arreglar el pin de la placa?
  Responder
#2
Hola @Carlos05, bienvenido al foro.
Lo primero, darte un par de consejos: el primero, que nunca manipules ninguna parte de la impresora y mucho menos las correspondientes a la parte eléctrica/electrónica, cuando esté conectada a la corriente y funcionando (ya has visto las consecuencias) y el segundo, aprovechando que ya eres miembro del foro, que si no estás seguro de como realizar algo, mejor lo consultes por aquí antes de hacer ningún cambio en la impresora.
El cortocircuito que ha sucedido en el hotend, como mínimo ha dañado el circuito de la placa que controla el termistor del primer hotend (tu placa viene preparada para dos extrusores/hotends), cuyo conector es el rotulado como TH1.
En todo caso, no debería haber afectado en nada a la cama caliente, por lo que no entiendo por qué has tenido que manipular su conexión a la placa (conector TB): ¿no indicaba bien la temperatura de la cama?
Hay tres posibles soluciones para el problema del termistor del hotend: cambiar la placa por otra nueva; reparar el circuito, cambiando el/los componente/s dañados; utilizar el circuito del termistor del extrusor E1 (conector TH2) en lugar del averiado.
La segunda es la más complicada y depende de los conocimientos que tengas en este tema.
La tercera es la más inmediata, ya que tienes todo lo necesario y para ello, solo tienes que cambiar el cable del termistor del conector TH1 al TH2, intercambiar la asignación de pines a los termistores en el firmware, compilarlo y grabarlo de nuevo en la placa.
La asignación de pines para los termistores en esa placa, está en el archivo pins_RAMPS.h, aunque yo te recomiendo que lo hagas en el propio archivo de la placa, que es pins_MKS_GEN_L.h, incluyendo en él las siguientes líneas (en rojo):

...
#ifndef Y_CS_PIN
  #define Y_CS_PIN 63
#endif

#define TEMP_0_PIN  15
#define TEMP_1_PIN    13


#include "pins_RAMPS.h"
  Responder
#3
(17-07-2022, 01:15 PM)Simemart escribió: Hola @Carlos05, bienvenido al foro.
Lo primero, darte un par de consejos: el primero, que nunca manipules ninguna parte de la impresora y mucho menos las correspondientes a la parte eléctrica/electrónica, cuando esté conectada a la corriente y funcionando (ya has visto las consecuencias) y el segundo, aprovechando que ya eres miembro del foro, que si no estás seguro de como realizar algo, mejor lo consultes por aquí antes de hacer ningún cambio en la impresora.
El cortocircuito que ha sucedido en el hotend, como mínimo ha dañado el circuito de la placa que controla el termistor del primer hotend (tu placa viene preparada para dos extrusores/hotends), cuyo conector es el rotulado como TH1.
En todo caso, no debería haber afectado en nada a la cama caliente, por lo que no entiendo por qué has tenido que manipular su conexión a la placa (conector TB): ¿no indicaba bien la temperatura de la cama?
Hay tres posibles soluciones para el problema del termistor del hotend: cambiar la placa por otra nueva; reparar el circuito, cambiando el/los componente/s dañados; utilizar el circuito del termistor del extrusor E1 (conector TH2) en lugar del averiado.
La segunda es la más complicada y depende de los conocimientos que tengas en este tema.
La tercera es la más inmediata, ya que tienes todo lo necesario y para ello, solo tienes que cambiar el cable del termistor del conector TH1 al TH2, intercambiar la asignación de pines a los termistores en el firmware, compilarlo y grabarlo de nuevo en la placa.
La asignación de pines para los termistores en esa placa, está en el archivo pins_RAMPS.h, aunque yo te recomiendo que lo hagas en el propio archivo de la placa, que es pins_MKS_GEN_L.h, incluyendo en él las siguientes líneas (en rojo):

...
#ifndef Y_CS_PIN
  #define Y_CS_PIN 63
#endif

#define TEMP_0_PIN  15
#define TEMP_1_PIN    13


#include "pins_RAMPS.h"
Bueno primero que nada, gracias por responder, en cuanto a lo de el conector de la cama, es correcto no marcaba bien la temperatura es por eso que cambie el conector al de el hotend, la solución que mencionas de cambiar la asignación de pines ya lo hice, lo que hice fue cambiar el termistor del hotend th1 al th2 pero al ver que la cama no marcaba bien la temperatura, para comprobar que no fuera el termistor propio de la cama, lo que hice fue intercambiar los conectores, puse la cama en th2 y el hotend en tb al hacer esto, conseguí que la cama funcionara nuevamente, pero ahora el extrusor no funcionaba, asi comprobe que no estaba dañado ningún termistor, ni el de la cama ni el de el hotend, porque los habia hecho funcionar individualmente, al cambiar los pines en el firmware solo lo hice en "pins_RAMPS.h" no se si esto pueda afectar en algo, al final en el firmware lo que quedo fue algo así:

#define TEMP_0_PIN        14  // Analog Input
#define TEMP_1_PIN        13  // Analog Input
#define TEMP_BED_PIN      15  // Analog Input

Cambie el de la cama para ver si asi funcionaba, y si, funcionó, pero el del hotend dejo de funcionar, marcando la temperatura en 17, y cuando lo ponía a calentar, subia pero no marcaba bien la temperatura, también de nuevo para asegurarme que no fuera el termistor, lo deconecte del hotend y la maquina seguia marcando el hotend a 17 grados.
La verdad quisiera evitar cambiar la placa porque es una pieza que no es muy barata y tendria que cambiar el cableado a la nueva, en cuanto a reparar el circuito, tendría que reparar los conectores o la placa en si?(pregunto esto porque tengo una placa de una antigua impresora 3d de la cual podria sacar algunos componentes) Y por último sabes si cambiar la asignación de pines solo en "pins_RAMPS.h" pueda afectar en algo?
  Responder
#4
OK. Entiendo entonces que no son correctas las indicaciones de temperatura cuando se utilizan los conectores TH1 y TB, por lo tanto en el cotrocircuito se han averiado los dos circuitos de dichos conectores, lo que reduce las posibles soluciones solo a las dos primeras: como es bastante raro que suceda esto, quizá sea un indicio de que puede haber otros componentes afectados, lo que haría que no fuese suficiente con arreglar esos dos circuitos y solo el cambio de placa solucionase el problema.
La mejor opción para el cambio, sería comprar un modelo idéntico, que te evitará tener que sustituir ningún otro componente de la impresora: sería cambiar una placa por la otra y a funcionar.
Los pines de los conectores de la placa son TH1->pin 13, TH2->pin 15, TB->pin 14 y se puede cambiar su asignación tanto en el archivo de la placa como en el de la RAMPS, no hay diferencia entre hacerlo en uno u otro.
Para la reparación de la placa, primero tendrías que identificar los componentes afectados y depués sustituirlos por otros, preferiblemente nuevos: desoldar y volver a soldar el mismo componente, no suele dar buenos resultados.
Estos circuitos suelen llevar una resistencia y un condesador, que en esa placa parece lógico que sean los que se encuentran al lado de cada uno de los conectores; los valores ya son más dificiles de saber, pues MKS no libera los esquemas ni el BOM de sus placas, aunque no habría ningun problema en colocar los valores que lleve otra placa similar.
  Responder
#5
Ok, de nuevo gracias por responder, intentare desmontar la placa y ver que parte fue lo que se daño, en cuanto a lo de si se daño otros componentes la verdad a simple vista no se ve que haya pasado ya que todo lo demas de la impresora funcinoa correctamente, pero aun asi revisare la placa, debido a la mala lectura de el termistor me lleva a pensar que quiza lo que se daño fue la resistencia asi que revisare eso a detalle, actualizare el post si logro solucionarlo, gracias.
  Responder
#6
Hola de nuevo, tras desconectar por completo la placa madre, note rapidamente que un mosfet se había dañado.
[Imagen: IMG-20220717-170640-resized-20220717-050734456.jpg]

La vdd no se mucho de como cambiarlo pero intentare siguiendo tutoriales, saben si el mosfet dañado si tiene que ver con el termistor?
  Responder
#7
Que se vea afectado el mosfet es bastante habitual cuando se produce un cortocircuito en el hotend, pero como no indicabas que hubiese problemas con el calentamiento (que el elemento no caliente o lo haga nada más encender la impresora) no lo indiqué en mi respuesta: ese es uno de los posibles daños que puede haber aparte de los termistores, podría haber más.
Ese mosfet (seguramente es el del primer extrusor, conectado a HE0) no tiene relación directa con los circuitos de los termistores, se han averiado ambos por las líneas de alimentación debido al cortocircuito y cambiarlo no solucionará los problemas con los termistores.
No sé a qué te estás refiriendo con cambiar la vdd, esa es la abreviatura del voltaje de trabajo de un chip, no un componente concreto.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Ayuda con MKS GEN L 1v.0 Artillery Genius rgl3dprint 46 13,632 06-08-2022, 11:22 AM
Último mensaje: Simemart
  Genius y cama a -15ºC jorge_txapux 1 88 20-06-2022, 09:38 PM
Último mensaje: Simemart
Guiño ARTILLERY HORNET, FILAMENTO Chauli31 1 99 20-05-2022, 04:30 PM
Último mensaje: Simemart
  Artillery x1 deja de soltar filamento Rustyrasman 3 206 10-05-2022, 08:28 PM
Último mensaje: Simemart
  CONSULTA Artillery Genius ¿Placa Quemada? Jose_D 1 208 27-04-2022, 09:33 PM
Último mensaje: Simemart