Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Regular pasos E1 (segundo extrusor)
#1
Buenas,
Alguien sabe cómo regular los pasos de un segundo extrusor en marlin?
#define DEFAULT_AXES_STEPS_PER_UNIT { x, y, z, E0 }
Actualmente está es la conf, entonces yo introduzco E1, de este modo:
#define DEFAULT_AXES_STEPS_PER_UNIT { x, y, z, E0, E1}
Pero no compila, alguien entiende del tema.

Gracias
Citar
#2
Mirate esta pagina, https://www.spainmakers.com/tutoriales/c...-extrusor/
Citar
#3
(18-08-2019, 03:10 PM)p52sarup escribió: Buenas,
Alguien sabe cómo regular los pasos de un segundo extrusor en marlin?
#define DEFAULT_AXES_STEPS_PER_UNIT { x, y, z, E0 }
Actualmente está es la conf, entonces yo introduzco E1, de este modo:
#define DEFAULT_AXES_STEPS_PER_UNIT { x, y, z, E0, E1}
Pero no compila, alguien entiende del tema.

Gracias

Busca # Define DISTINCT_E_FACTORS Y habilita

Y los pasos como lo estabas poniendo.


Enviado desde mi SGP712 mediante Tapatalk
Citar
#4
Mil gracias, me faltaba habilitar esa función.
Citar
#5
Hola, habilitar el parámetro DISTINCT_E_FACTORS solo es necesario si se quieren configurar valores distintos para los extrusores que tengamos.
Si todos van a tener los mismos, no es necesario ponerlos, ya que se tomarán los del primer extrusor para todos los demás.
Para poder contestar con propiedad habría que saber el hardware de que se trata y el error que se produce al compilar.
Citar
#6
Ya está solucionado, al tener dos extrusores diferentes necesitaba calibrarlos independientemente. Yo lo hacía como es debido, pero claro no activaba ese parametro, por tanto me daba error de compilación. Ya está todo solucionado muchas gracias.
Citar
#7
(18-08-2019, 10:15 PM)p52sarup escribió: Ya está solucionado, al tener dos extrusores diferentes necesitaba calibrarlos independientemente. Yo lo hacía como es debido, pero claro no activaba ese parametro, por tanto me daba error de compilación. Ya está todo solucionado muchas gracias.
No si eso me paso a mi. Hasta que di con la tecla tela. Aunque pusiese el mismo valor. En E1 no me dejaba copilar.
Y si no ponía valor en el E1 copilaba. Pero como no está seguro que valor cogía para el E1.
Pues rebuscando y releyendo. Di con la tecla.
Además resulta que también tenía que cambiar los pasos.
Buf menos mal que me hice un readme.txt que si no.


Enviado desde mi SGP712 mediante Tapatalk
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  DUDA Pasos extrusor prosit 0 102 03-12-2019, 08:42 PM
Último mensaje: prosit
  Como Calibrar los pasos y velocidad del Extrusor Juda777 10 338 29-10-2019, 02:46 AM
Último mensaje: Juda777
  DUDA Sorpresa con pasos del extrusor Wildense 6 290 21-09-2019, 03:28 AM
Último mensaje: Wildense
  Calibracion pasos/mm anycubic i3 mega Limbotron 5 768 29-07-2019, 02:37 PM
Último mensaje: Simemart
  Segundo extrusor pasos a seguir sacha 4 4,342 17-05-2019, 06:46 PM
Último mensaje: Diego C.