This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
DUDA Imprimir con el segundo extrusor
#1
Triste 
Hola, hace poco me compré mi primer impresora 3D, es una Hellbot Magna 2 230 con dos extrusores y un hotend 2 en 1 con cambio en frío. A veces utilizo unicamente el segundo extrusor agregando al inicio del Gcode T1 en la primer fila. El problema que tengo con esto es el siguiente: Al iniciar la impresión comienza a calentar la cama normalmente pero no el hotend por lo que queda en frio y no extruye el filamento. Como solucion lo unico que pude hacer es definir la temperatura del hotend manualmente desde la impresora una vez ya iniciada la impresión, pero a la vez el hacer esto me genera otro inconveniente que es que, cuando finaliza la impresión el hotend no se apaga automáticamente.
(cuando utilizo únicamente el primer extrusor no me genera ningún tipo de inconveniente)

Así lo uso con el segundo extrusor y para usar el primero lo mismo pero cambiando el T1 de la primer fila por T0 o no pongo nada.


INICIAR GCODE

T1
G28 ;Home
G1 Z15.0 F6000 ;Move the platform down 15mm
;Prime the extruder
G92 E0
G1 F200 E3
G92 E0



FINALIZAR GCODE

M104 S0
M140 S0
;Retract the filament
G92 E1
G1 E-1 F300
G28 X0 Y0
G90
G1 X0 Y200 F2000
M84

Quien sea que me pueda ayudar con esto o decirme si simplemente no se puede hacer nada al respecto se lo agradecería muchísimo  Sisi3
  Responder
#2
Hola @francogoldaraz, bienvenid@ al foro.
Poner a mano en el archivo gcode los cambios de herramienta no es una forma correcta de trabajar, pues eso puede generar que queden cosas sin definir, como parece ser tu caso.
Lo correcto es tener bien configurada la máquina en el programa de corte, de forma que se indique en él qué extrusor se va a utilizar y así el archivo tenga los comandos gcode apropiados.
Si utilizas CURA, la última versión trae ese modelo entre las impresoras soportadas, por lo que dicha configuración la tienes hecha.
Con respecto al problema concreto que comentas, habría que revisar el archivo gcode para ver que otros comandos incluye además de los que se ven en esos script que indicas.
  Responder
#3
(04-09-2021, 04:34 PM)Simemart escribió: Hola @francogoldaraz, bienvenid@ al foro.
Poner a mano en el archivo gcode los cambios de herramienta no es una forma correcta de trabajar, pues eso puede generar que queden cosas sin definir, como parece ser tu caso.
Lo correcto es tener bien configurada la máquina en el programa de corte, de forma que se indique en él qué extrusor se va a utilizar y así el archivo tenga los comandos gcode apropiados.
Si utilizas CURA, la última versión trae ese modelo entre las impresoras soportadas, por lo que dicha configuración la tienes hecha.
Con respecto al problema concreto que comentas, habría que revisar el archivo gcode para ver que otros comandos incluye además de los que se ven en esos script que indicas.

Hola, muchas gracias por tu respuesta, actualmente utilizo Cura 4.9.1 porque hace un par de meses al menos en la ultima versión no me funcionaba el MKS Wifi Plugin.
Voy a probar otra vez con la ultima versión y si funciona bien ver si puedo cambiar de extrusor allí mismo porque en la versión que estoy utilizando no me lo permite.
Es mas que nada por comodidad y no tener que andar cambiando las bobinas de filamento constantemente.
  Responder
#4
La versión de CURA 4.9.1 incluye ese modelo entre las impresoras soportadas.
  Responder
#5
(04-09-2021, 09:55 PM)Simemart escribió: La versión de CURA 4.9.1 incluye ese modelo entre las impresoras soportadas.
Sisi lo tengo configurado con el modelo de mi impresora pero por lo que se no se puede cambiar el extrusor directamente desde cura, o en teoría si pero no funciona.
  Responder
#6
He estado revisando la configuración que tráe CURA para ese modelo y efectivamente no parece muy correcta.
En todo caso, no concuerda con la que se indica en un manual que se incluye en la tarjeta SD para realizarla y creo que la mejor opción debería ser configurar la impresora desde cero, utilizando la información que se facilita en ese manual.
Helbot también facilita perfiles de impresión, que supongo serán los que se utilizaron para generar las impresiones de prueba que se adjuntan en la SD (sería lo lógico, pero a saber).
Si utilizas solo el segundo extrusor para imprimir, debes tener mucho cuidado con las asignaciones de extrusor: aparte de indicar cual se utilizará para imprimir la pieza, si utilizas en el perfil de impresión algún tipo en el apartado de adherencia, deberás seleccionar el segundo extrusor para realizarlo (por defecto utiliza el primero) y como es lógico, desactivar el uso de la torre auxiliar.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Impresora se detiene 1 segundo Edgard 3 550 09-01-2021, 12:53 AM
Último mensaje: ofitecno
  Problema al imprimir ciertos diseños. Tac tac extrusor Comediaan 9 3,196 02-11-2019, 08:51 PM
Último mensaje: wasonn
  Regular pasos E1 (segundo extrusor) p52sarup 6 1,166 18-08-2019, 10:37 PM
Último mensaje: Rafa330
  Segundo extrusor pasos a seguir sacha 4 5,940 17-05-2019, 06:46 PM
Último mensaje: Diego C.
  MOVER SEGUNDO EXTRUSOR EN LCD pica2079 3 1,537 19-08-2015, 04:09 PM
Último mensaje: pica2079