This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Desplazamiento de capas?
#1
Hola.

El caso es que creo que tengo desplazamiento de capas dependiendo de la pieza que haga. Pero lo curioso es que siempre que pruebo con un cubo de calibracion siempre pasa lo mismo:

En el eje Y, cuando tiene que hacer el dibujo de la letra parece que se desplazan capas, tanto cuando empieza a hacer la letra como cuando acaba:
[Imagen: Ejes_Normales.jpg]


Pero al imprimir otro cubo con la letra de los ejes cambiados (la letra X corresponde al eje Y, la letra Y corresponde al eje X por detras) para confirmar que solo pasaba en un eje, pasó esto:
[Imagen: Ejes_cambiados2.jpg]



[Imagen: Ejes_cambiados1.jpg]


Parece que ocurre lo mismo pero esta vez el desplazamiento de abajo ocurre en un eje y el de arriba en otro.

A alguien la ha pasado esto?

Gracias.
  Responder
#2
Hola compañero. 

Has conseguido averiguar por qué se producía esto? Me está pasando ahora en una CR10 S4...

Gracias!


(13-09-2018, 05:04 PM)Replikante escribió: Hola.

El caso es que creo que tengo desplazamiento de capas dependiendo de la pieza que haga. Pero lo curioso es que siempre que pruebo con un cubo de calibracion siempre pasa lo mismo:

En el eje Y, cuando tiene que hacer el dibujo de la letra parece que se desplazan capas, tanto cuando empieza a hacer la letra como cuando acaba:
[Imagen: Ejes_Normales.jpg]


Pero al imprimir otro cubo con la letra de los ejes cambiados (la letra X corresponde al eje Y, la letra Y corresponde al eje X por detras) para confirmar que solo pasaba en un eje, pasó esto:
[Imagen: Ejes_cambiados2.jpg]



[Imagen: Ejes_cambiados1.jpg]


Parece que ocurre lo mismo pero esta vez el desplazamiento de abajo ocurre en un eje y el de arriba en otro.

A alguien la ha pasado esto?

Gracias.
  Responder
#3
Hola, yo diría que eso no es un desplazamiento de capas, pues solo lo veo en la arista vertical del cubo y no en el centro de la cara, sino más bien que el cabezal de impresión se pasa ligeramente al finalizar cada línea del perímetro en donde sucede, debido a una velocidad excesiva y/o a una configuración inapropiada de aceleraciones y/o jerk/junction deviation (lo que se esté utilizando).
Que no suceda en las capas que tienen el hueco de la letra, seguramente sea porque en ellas las líneas que terminan en esa arista, son iguales o menores que la mitad de las otras.
  Responder
#4
Muy buenas

Viendo todas las "aguas" que tiene tu cubo de calibración me recuerda a un problema similar que tuve.

Has revisado toda la mecánica de la impresora? Correas bien tensas y excéntricas

A lo que me da la vista veo que las aristas del cubo no están alineadas.

Yo revisaría eso principalmente o coméntanos si ya lo has hecho para ir descartando cosas.

Un saludo
  Responder
#5
Hola,  Buenos dias a todos. Aprovecho este post, ya que a mi me esta sucediendo algo similar.
Con las partes que pude reutilizar de una impresora Pruse P3 Steel de 200x200x200 hice una de diseño propio con perfiles Bosch de tamaño 300x300x300.
La cama es una plancha de aluminio de 3mm y una resistencia de silicona de 220V. En la parte de arriba tiene un pad magnetico.
Conclusion es que todo esto hace que la cama sea mas pesada que la anterior que era solo la cama caliente y el cristal.
La cosa es que pierde pasos en el eje Y pero de forma muy ocasional. En un principio eran mas los problemas, luego de algunos ajustes mejoro, pero no del todo.
Revise la tension de la correa, suavidad del eje, incluso la posibilidad que el cable de alimentacion de la resistencia, bloqueara el eje. Esta todo bien.
Luego reduje las velocidades de 3600 mm/min a 1800 mm/min y lo seguia haciendo en algunos casos.
El momento donde mas lo hace, es cuando hace los movimientos bruscos de un lado al otro al hacer rellenos de partes chicas.
De alli es que tambien le reduje la aceleracion con lo cual mejoro bastante motivo que me llevo a subir un poco la velocidad que quedo en 2400 y la aceleracion en 1100 (de 2500 que estaba).
La cosa es que en determinadas piezas lo sigue haciendo y me malogra todo el trabajo.
Otra de las cosas que he revisado es la Vref del driver y se lo he subido un poco hasta 1.1 que seria el maximo. El motor en su momento cuando lo compre ya hace unos años, decia ser de alto torque, pero quien sabe.
Entre las cosas que me quedaria tocar seria el JERK (que segun lei deberia estar entre 10 y 16 y esta en 10) o intentar reemplazar el motor por unos NEMA 17 mas alto que tiene un poco mas de torque. Espero vuestros comentarios y adjunto fotos.
En la primera se ve claramente los primeros 2 mm perfecto con capas sin relleno y luego el salto de pasos.
[Imagen: 20211025-083000.jpg]
En esta como seria la pieza terminada, pero tambien saltaron pasos

[Imagen: 20211025-083938.jpg]

Aqui otro ejemplo

[Imagen: 20211025-083129.jpg]

Desde ya nuchas gracias por la ayuda. Saludos

Jose
  Responder
#6
Hola, para decir hasta cuanto puedes subir el Vref del driver, se encesita saber que modelo es y la referencia del motor.
Puede que 1100 mm/s² sea una aceleración demasiado alta para una impresora tipo Prusa I3 y con una cama tan pesada: para probar, puedes ponerla en 650 mm/s² (incluso bajar hasta 400 mm/s²).
El jerk te influirá poco en este aspecto y en todo caso, 10 es un valor bastante razonable: por probar, puedes ir subiendo (hasta 20 como máximo) y ver que pasa.
¿Qué polea tiene en el eje Y? Porque si es de 20 dientes, con solo poner en su lugar una de 16 dientes, ganarías un 25% de fuerza (habría que cambiar los micropasos por milímetro configurados para ese eje en el firmware).
  Responder
#7
Gran sonrisa 
Hola Simemart buenos dias. Gracias por las respuestas. Te deboras el foro hombre, no hay post que no tenga alguna respuesta tuya  Clap Clap Clap Clap Clap Clap Clap

(25-10-2021, 02:46 PM)Simemart escribió: Hola, para decir hasta cuanto puedes subir el Vref del driver, se encesita saber que modelo es y la referencia del motor.
Cuando compre los componentes originales era un kit de 3D Gadgets. Alli decia 0.8v para los ejes y 1.1 para el extruder. Con lo cual asumi que los motores se pueden calibrar hasta 1.1

(25-10-2021, 02:46 PM)Simemart escribió: Puede que 1100 mm/s² sea una aceleración demasiado alta para una impresora tipo Prusa I3 y con una cama tan pesada: para probar, puedes ponerla en 650 mm/s² (incluso bajar hasta 400 mm/s²).
Estaba originalmente en 3000. Este parametro lo debo enviar desde el slicer con un M204 porque modificandolo en Marlin no queda memorizado. Otra cosa que note ayer es que aun con 1100 en algunos momentos la aceleracion seguia siendo alta. Parecio solucionarse cambiando tambien los valores de Axmax y Aymax (aunque no tendria nada que ver si la aceleracion de trabajo esta en valores menores)

(25-10-2021, 02:46 PM)Simemart escribió: El jerk te influirá poco en este aspecto y en todo caso, 10 es un valor bastante razonable: por probar, puedes ir subiendo (hasta 20 como máximo) y ver que pasa.
Subir el JERK no empeoraria la cosa o es a la inversa?. Tenia entendido que un JERK mas alto implica pendientes de aceleracion mas grandes por ende mas brusco

(25-10-2021, 02:46 PM)Simemart escribió: ¿Qué polea tiene en el eje Y? Porque si es de 20 dientes, con solo poner en su lugar una de 16 dientes, ganarías un 25% de fuerza (habría que cambiar los micropasos por milímetro configurados para ese eje en el firmware).
Esto no lo habia tenido en cuenta. Vere como sigue el tema y puede ser otra alternativa
Desde ya gracias por tu ayuda. Saludos

Jose
  Responder
#8
Sobre el primer punto:
¿que drivers tienes instalados, A4988 o DRV8825?
Los motores suelen llevar una pegatina indicando el modelo.
Sobre el punto 2:
3000 mm/s² es el valor que suele traer por defecto Marlin, pero hay que ajustarlo a la impresora concreta.
Si no toma en cuenta el valor configurado, se debe a que no estás refrescando la memoria EEPROM y está utilizando siempre el valor almacenado: después de grabar Marlin en la placa, envía un comando M500.
Como te indicaba, 1100 mm/s² puede ser aún demasiado: prueba con 650 mm/s² o incluso con 400 mm/s².
Las aceleraciones máximas influyen como límite superior: si pones un valor menor al configurado para la aceleración, se tomará este en lugar de aquel para la aceleración.
Sobre el punto 3:
a más jerk, más suaves los movimientos en los cambios de dirección, pues indica la diferencia de velocidad a partir de la que los movimientos se realizarán con aceleración en lugar de hacerse de forma instantánea (o casi).

P.S.: Si estás utilizando Marlin 2, ten encuenta que el jerk suele estar desactivado y se utiliza en su lugar Junction Deviation.
  Responder
#9
Los drivers son A4998. Estoy por cambiarlos por los TCM2208.
Los motores no tienen ninguna referencia lamentablemente. Como fueron comprados hace tiempo, mi duda es cuanto era "alto torque" en ese momento y cuanto es ahora.
Probare lo del M500, por ahora estoy con scrips en el Simplify.
Respecto a la aceleracion, ahora esta en 500 y no ha vuelto a fallar. Lo tendre a prueba. He hecho piezas que habian fallado y ahora no lo hace.
Respecto al JERK no lo he tocado y por ahora lo dejare asi, ya que con la disminucion de aceleracion parece haberse solucionado.
Desde ya muchisiiiiiiimas gracias por tu valiosa ayuda.
Saludos

Jose
  Responder
#10
Te dí la información incompleta: para refrescar los valores de la EEPROM, debes enviar primero el comando M502 y después el M500.
El límite de intensidad de los A4988 es 2A por lo que, con casi total seguridad, la limitación está en los motores.
Si son normales, con cuerpo de 40 mm o 48 mm de largo, seguramente sean de 1,7A o 1,8A: si los A4988 tienen resistencias de senseo de 0,1 Ohms (R100), el voltaje de referencia máximo que se puede configurar para 1,7A es 1,36V; para 1,8A sería 1,44V.
En todo caso, eso serían los valores máximos, pero los ejes de la impresora deberían moverse lo suficientemente suaves como para no necesitar tanta intensidad en los motores.
Con el cambio a los TMC2208, eliminarás mucho ruido de funcionamiento, pero no ganarás nada de fuerza en los motores respecto a los A4988.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Huecos en capas superiores y perimetros astur84 5 719 12-02-2021, 07:40 PM
Último mensaje: Simemart
Triste CONSULTA Impresiones raras en capas finas Ronald 4 485 20-01-2021, 07:03 PM
Último mensaje: Ronald
  CONSULTA marcas desplazamiento javi2 7 763 13-12-2020, 07:46 PM
Último mensaje: Simemart
  Problema hueco entre capas Ender 3 Brais_24 0 600 26-10-2020, 11:15 AM
Último mensaje: Brais_24
Pregunta CONSULTA Capas exteriores con cicatrices o formas de gota - Ender 3 sekghast 1 503 23-10-2020, 10:49 PM
Último mensaje: dasafur