Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
problemas con marlin para kms robin nano v1.2
#1
buenos días, he comprado una SAPPHIRE plus 

aqui teneis una review para quien no la cocozcais   https://3dprintbeginner.com/sapphire-plus-review/


me ha venido con el marlin mal, los ejes los muevo bien, pero cuando doy a home, z baja, no me queda otra que tocarla, así que me he decidido a actualizarlo 

he conseguido estos archivos de fabrica pero no puedo compilarlos, no consigo añadir la placa al menu, por mucho que lo intento solo me salen las propias del arduino

no paso del minuto 4 de este video https://www.youtube.com/watch?v=GCjKUoqccPA

placa https://github.com/makerbase-mks/MKS-Robin

marlin de la maquina https://github.com/le3tspeak/Marlin-2.0....h0TmoSEbq4

arduino; he probado el ARDUINO 1.8.13 y BETA BUILDS https://www.arduino.cc/en/Main/Software
Citar
#2
no sale mi placa, me esta resultando imposible
resim
Citar
#3
Tu placa monta un procesador ARM de 32 bits. No funciona con Arduino.

Debes instalar Visual Studio Code y PlatmormIO para poder compilarlo y subirlo.

Citar
#4
estoy intentando compilarlo con el programa virtual studio code. con platformio.ini y el auto build marlin. no carga la placa.
resim

#if ANY (SAPPHIRE_PRO, SAPPHIRE_PLUS, BLUER)
// All OK!
#else
#error "3D Printer Preset not Set properly see Configuration.h or delete the line here for a printer without a preset."
#endif
Citar
#5
en el marlin me han dicho que tengo que desactivar l alinea 62 //#define SAPPHIRE_PRO ya que está configurado para 2 impresoras de tamaños diferentes. cada vez que lo todo , luego me da mil errores

https://github.com/le3tspeak/Marlin-2.0....guration.h


también he intentado hacer el marlin en esta pagina, copiando los datos del marlin de gitud, al pasarlo al virtual studio code, me salen errores a patadas, no hay forma de crear un bin, ni por casualidad



sigo sin poder actualizar la placa, pelea pelea con el virtual studio code y no hay manera, uso este programa ya que la placa es de 32

me estoy planteando comprar otra placa, con suerte algo mas conocida y que sea más fácil de compilar. me he quedado sin ideas
Citar
#6
Yo a mi Sapphire Pluss, le puse el marlin de un foro aleman y funciona bien, ahora estoy imprimiendo un nuevo soporte para el extrusor y ya tengo el BL touch en cuanto este impreso, tengo que volver a compilarlo, si quieres te paso el link o el codigo ya compilado y vas haciendo pruebas.

Ahh tambien acabo de encontrar este link, de un grupo de discord , no lo he probado, pero lo tienes incluso compilado para ahorrarte dolores de cabeza
https://github.com/le3tspeak/Marlin-2.0....o/releases
Citar
#7
He conseguido instalar y entender algo el marlin gracias al canal del Facebook.

Ahora ya puedo hacer origen. Pero no me imprime. El eje Y hace un ruido cloc cloc como si tuviese pulsación

Doy a cargar una pieza. Hace bien origen va a al centro de la cama y se para

Estoy hasta las narices de este trasto
Citar
#8
me tiene desquiciado, los ejes se mueven bien al hacer o,o, o pero una vez que lo hace, a la máquina se le va la cabeza completamente

le doy a mover el eje x o y solamente y se mueven los 2 haciendo un ruido sordo clac clac que parece que se va a partir .
sin mover nada, en reposo el eje y parece que tiene pulsaciones, hace un ruido rítmico, y parece que hace un paso pa delante otro para atrás y no es el baile del verano

este es mi marlin , una burrada, son 3 maquinas en una. la linea 63 activa la mia . plus

https://pastebin.com/TbapuDXf?fbclid=IwA...IDjvAm27Qk
Citar
#9
Te recomendaria ir a lo basico, pon el programa que viene de base y comprueba a ver que funcione el movimiento bien, sino es que tienes alguna conexion mal
Citar
#10
Si es el mismo que estoy usando yo , en la sapphire plus, ahora estoy afinandola pero yo lo tengo con el BL touch. Despues de un par de retoques ya empieza a ir fina fina, lo que no recuerdo es que es lo que he tocado XD
Recuerdo que en un momento me paso lo que me comentaste y hacia ruido y no se movia, tambien tenia problemas con el tamaño de la cama y lo solucione:

// #define Custom_Stepper_Drivers

Y asi se soluciona, utilizando los del plus, tambien tube que cambiar la direccion del stepper Z . A parte de eso esta funcionando bastante bien y empiezo a comprender el codigo y como va
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA driver mks robin josepm 1 114 07-05-2020, 01:59 PM
Último mensaje: Simemart
  Marlin Builder v1.0: Configurando firmwares Marlin online y de forma muy sencilla Peter13 4 1,186 20-04-2020, 10:07 AM
Último mensaje: Peter13
  Marlin 1.1.5 para Prusa i3 pro B Geeetech BLTouch/3D Touch pablognu 4 5,871 06-01-2020, 10:43 PM
Último mensaje: Fdom97
  Error al compilar Marlin 2.0 para la SKR 1.3//RESUELTO mrprlopper 0 693 21-11-2019, 05:10 PM
Último mensaje: mrprlopper
  Problema al compilar marlin para placa cr-10 Rocaforte 22 2,684 14-04-2019, 05:23 PM
Último mensaje: Rocaforte