Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Prusa + raspberry imprime circulos a tirones
#1
Buenos dias a todos. Estoy imprimiendo con una prusa conjuntamente con ramps 1.4 + raspberry y octopy y la impresion va genial a excepción de cuando deben ejecutarse círculos. Cuando realiza lineas rectas o diagonales, el movimientos es uniforme, pero al realizar circulos, da tirones. Voy a intentar subir un video para que pueda verse. A Alguno os ha pasado? puede ser tema de baudrate?

resim

Aquí esta el video de los famosos tironeshttp://cloud.tapatalk.com/s/5c18c683f0df...104953.mp4

Enviado desde mi SM-G965F mediante Tapatalk
Saludos desde Puente Genil!
Citar
#2
Hola, a mi no me parece que sean tirones, sino sucesivas líneas impresas.
Los circulos no lo son realmente, sino que se aproximan a polígonos regulares. Dependiendo de cuantos lados se definan en el programa de diseño, serán más circulares o menos.
Por como se mueve, parece que tienes definidos los círculos con pocos lados y por eso parece discontinua la impresión.
Puedes comprobarlo en la previsualización del programa de corte que estés utilizando o, si haces tu los diseños, en la configuración del programa que uses.
Citar
#3
(18-12-2018, 02:29 PM)Simemart escribió: Hola, a mi no me parece que sean tirones, sino sucesivas líneas impresas.
Los circulos no lo son realmente, sino que se aproximan a polígonos regulares. Dependiendo de cuantos lados se definan en el programa de diseño, serán más circulares o menos.
Por como se mueve, parece que tienes definidos los círculos con pocos lados y por eso parece discontinua la impresión.
Puedes comprobarlo en la previsualización del programa de corte que estés utilizando o, si haces tu los diseños, en la configuración del programa que uses.
El problema solo lo produce al conectarla a la raspberry. Directamente por USB al pc no produce estas paradas, por lo que no debe tratarse de este problema. Gracias de todas formas. Seguimos investigando

Enviado desde mi SM-G965F mediante Tapatalk
Saludos desde Puente Genil!
Citar
#4
Si con Sd no te pasa, es muy probable que sea eso... como te dice Simemart, realmente nunca vas a imprimir un circulo, si no sucesivas lineas rectas que finalmente hacen un circulo. El problema con los circulos es que por cada recta que se genera, se genera una instrucción de movimiento, y el buffer de instrucciones tiene un limite.

A cuantos baudios comunicas? Si estas usando una raspi directamente con octoprint, yo probaria a comunicar a 115000baudios. Por ultimo... aunque poco probable, podría ser un problema con el buffer de comunicaciones (o el buffer circular mas bien) que tiene el firmware para almacenar las instrucciones. Si es muy pequeño, podria ocuurrirte esto (Ademas, veo que le das caña a la velocidad de impresión)
Creo que el tamaño del buffer se puede incrementar, pero yo solo lo haria si ya estas comunicando a una velocidad alta.
Citar
#5
(18-12-2018, 06:27 PM)Shellmer escribió: Si con Sd no te pasa, es muy probable que sea eso... como te dice Simemart, realmente nunca vas a imprimir un circulo, si no sucesivas lineas rectas que finalmente hacen un circulo. El problema con los circulos es que por cada recta que se genera, se genera una instrucción de movimiento, y el buffer de instrucciones tiene un limite.

A cuantos baudios comunicas? Si estas usando una raspi directamente con octoprint, yo probaria a comunicar a 115000baudios. Por ultimo... aunque poco probable, podría ser un problema con el buffer de comunicaciones (o el buffer circular mas bien) que tiene el firmware para almacenar las instrucciones. Si es muy pequeño, podria ocuurrirte esto (Ademas, veo que le das caña a la velocidad de impresión)
Creo que el tamaño del buffer se puede incrementar, pero yo solo lo haria si ya estas comunicando a una velocidad alta.
Muchas gracias Shelmer. Mañana probare a cambiar los baudios. Os mantengo informados

Enviado desde mi SM-G965F mediante Tapatalk
Saludos desde Puente Genil!
Citar
#6
Pues mi gozo en un pozo... tras bajar a 115000, si buien da la sensacion de ir algo mas fluida en los circulos, no deja de dar los famosos tirones. Voy a probar a quitarle la curva exponencial de aceleracion que tengo configurada en el marlin por aquello de simplificar los calculos de la maquina al realizar dicho trazado.

Si es verdad que, a titulo informativo, el display de la impresora antes parpadeaba ligeramente al conectarla por USB a la raspberry y ahora apenas lo hace...

Otra curiosidad es que la lectura de temperatura en dicho display fluctua dos grados arriba y abajo constantemente cuando la raspberry esta conectada, cosa que no hace si la desconecto...
Saludos desde Puente Genil!
Citar
#7
(18-12-2018, 06:27 PM)Shellmer escribió: Si con Sd no te pasa, es muy probable que sea eso... como te dice Simemart, realmente nunca vas a imprimir un circulo, si no sucesivas lineas rectas que finalmente hacen un circulo. El problema con los circulos es que por cada recta que se genera, se genera una instrucción de movimiento, y el buffer de instrucciones tiene un limite.

A cuantos baudios comunicas? Si estas usando una raspi directamente con octoprint, yo probaria a comunicar a 115000baudios.  Por ultimo... aunque poco probable, podría ser un problema con el buffer de comunicaciones (o el buffer circular mas bien) que tiene el firmware para almacenar las instrucciones. Si es muy pequeño, podria ocuurrirte esto (Ademas, veo que le das caña a la velocidad de impresión)
Creo que el tamaño del buffer se puede incrementar, pero yo solo lo haria si ya estas comunicando a una velocidad alta.

Shellmer, he probado multiples opciones, pero continuo con los famosos tironcitos al imprimir circulos. Respecto del tamaño del buffer de comunicaciones, supongo que te refieres a esto?:


resim


Cual he de aumentar? afectaria en algo deshabilitar la lectura de la SD? no la uso ultimamente para nada
Saludos desde Puente Genil!
Citar
#8
Pues mi gozo en un pozo.... tras variar todas las opciones habidas y por haber dentro del apartado buffers del marlin y haber deshabilitado la SD, no he obtenido ninguna variacion respecto del comportamiento en las curvaturas. Seguimos con los dichosas microparaditas en las curvas. Mientras menor es el radio de la curva, peor se comporta...


resim

Empiezo a estar bastante desconcertado y segun he leido por el foro, no soy el unico con esta casuistica:

https://www.spainlabs.com/foros/tema-Pru...cro-pausas
Saludos desde Puente Genil!
Citar
#9
He encontrado esto por el foro:

https://www.spainlabs.com/foros/tema-Pru...de-segundo
Citar
#10
(18-01-2019, 10:42 AM)titanium escribió: He encontrado esto por el foro:

https://www.spainlabs.com/foros/tema-Pru...de-segundo

Hola titanium. Gracias por el aporte. Voy a tener que centrarme en intentar imprimir desde la SD, aunque ahora no me detecta los archivos de la SD... Esta claro que tengo algun problema de comunicacion entre Arduino y raspberry. Te mantengo informado en cuanto realice mas comprobaciones.
Saludos desde Puente Genil!
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  APORTE [TUTORIAL] Conectar Ramps/OVM20 con Raspberry Pi Zero cansi22 11 1,927 29-11-2018, 03:28 PM
Último mensaje: mundo2017
  PROBLEMA PARA MANTENER LA TEMPERATURA MIENTRAS IMPRIME Jordiquad 0 467 31-10-2014, 12:08 AM
Último mensaje: Jordiquad