Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Prusa I3 imprime con pequeñas micro-pausas
#1
Buenas a todos, me llamo Borja, hace unos años adquirí una Prusa I3 que se hizo en una compra conjunta en el foro:
https://www.spainlabs.com/foros/tema-Ofe...a+conjunta

La verdad que la tuve un tiempo parada y ahora he retomado las impresiones 3D, pero tengo un problema y no doy encontrado de donde puede venir, solo he encontrado en un foro ingles alguien que creo le pasa algo similar.

Los movimientos del eje X / Y no son suaves, y siempre que haya un vértice en el modelo 3D, obtengo un freno o un tartamudeo minúsculo, muy pequeño y, por lo tanto, un poco más de extrusión no deseada, dejando un pequeño punto en la pieza, que termina llena de granos por la superficie. Es como si en lugar de LINE-LINE-LINE-LINE, va LINE-PAUSE-LINE-PAUSE-LINE-PAUSE, donde LINE es una instrucción de código G y la PAUSE es una cuestión de milisegundos, pero el tiempo suficiente para causar el problema.
Este problema no lo tengo en piezas de lineas rectas, solo en piezas con muchos quiebros.

También me he fijado que esto no parece suceder durante las primeras capas de impresión.

He probado a bajar velocidades incluso a 10mm/s y mejora algo pero siguen ahí las pausas, reduje el flow, baje temperaturas (estoy usando ABS a 220ºC). Ahora mismo estoy con un nozzle de 0.5 y una altura de capa de 0.2, pero creo que daría igual cual utilizara.

Estoy terminando de imprimir una figura de Groot, luego os subo alguna foto a ver si entendeis lo que quiero decir y un pequeño video a ver si alguien me da alguna idea.

Un saludo
Citar
#2
Hola titanium. Tengo el mismo problema que tu. De hecho, hice un hilo al respecto. Voy a seguir probando esta noche con el tema del buffer y te mantengo informado:

https://www.spainlabs.com/foros/tema-Pru...-a-tirones
Saludos desde Puente Genil!
Citar
#3
Estaba pensando yo... no habreis tocado el XYJerk?
Este parametro regula a partir de cuanta velocidad han de realizarse deceleraciones. Si la velocidad del extrusor es mayor, se ejecuta un frenado, si es menor, se cambia de dirección directamente sin decelerar.

Si no te pasa en la primera capa puede ser debido a que esa capa suele imprimirse mas lento de lo normal y puede que no llegues a la velocidad del XYJerk

El parametro esta en el configuration.h, no recuerdo su nombre exacto ahora y no puedo verlo. Aun asi... si no habeis tocado esos valores no deberia daros problema.
Citar
#4
Yo no he tocado ningún parámetro la verdad. La cuestión es que las 15 o 20 primeras capas no hace esas pausas, el movimiento cuando va extruyendo por el perfil de la pieza es continuo y suave.

Por eso pienso que lo del buffer ese que comentabais puede ser, es como si hasta un número concreto de movimientos todo fuera fluido pero a partir de ahí va a saltos. Yo también imprimo desde un mini pc ya que mi impresora no tiene para SD, así que tengo conectada a ella un pc portatil pequeño. Cuando quiero hacer un a pieza la paso por Cura en un pc de sobremesa que tengo, guardo el GCode en una SD y luego me voy con esa SD al portatil que está conectado a la impresora y abro el archivo de la SD con Repetier y lanzo la impresión.

Otra cosa que me fijé es que en repetier cuando está imprimiendo y hace cada uno de esos pequeños movimientos y hace las pausas, en la parte inferior va lanzando este mensaje con cada movimiento:

gl_Paint-1.OpenGL error:InvalidValue

He buscado por google pero no he llegado a saber que significa....
Citar
#5
Hola, por lo que comentáis parece que el problema está en la transmisión del gcode, en tu caso por el Repetier y en el de @Manueldr80 por el Octoprint.
El error que indicas es del sistema gráfico del PC que estás utilizando para ejecutar el Repetier, lo que puede indicar un problema en dicho programa o en el sistema operativo.
Si no tienes lector de tarjetas, tendrás que utilizar otro software para enviar el gcode a la impresora y comprobar si se soluciona. Prueba con Pronterface que es bastante sencillo y no demanda muchos recursos.
También deberías probar a cambiar el ordenador utilizado, si te es posible. Si dices que es un portátil pequeño, puede que después de un rato esté enviando con cuentagotas los comandos a la impresora.
Como una posibilidad remota, comprobar que en el archivo Configuration_adv.h tenéis así la siguiente línea: #define FASTER_GCODE_PARSER.
Citar
#6
He instalado el Pronterface, y aunque creo que el problema viene del pc, de momento he superado la altura de capas de las anteriores impresiones y de momento no hay micropausas, a ver como termina. Gracias Simemart.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Duda en configuración Cura, no imprime bien los interiores PacoMB 5 354 06-03-2019, 01:58 PM
Último mensaje: Nullz
  CONSULTA A PESAR DE NUEVA ELECTRÓNICA, NO IMPRIME Anetero 7 544 14-12-2018, 08:27 PM
Último mensaje: Anetero
  CONSULTA SOLUCIONADO Solo me imprime la primera capa y se detiene Juan Javier 4 527 25-11-2018, 01:38 PM
Último mensaje: Juan Javier
  CONSULTA pausas inexplicables entre capas LUIS SANMARTIN 11 942 12-09-2018, 06:53 PM
Último mensaje: LUIS SANMARTIN
  Problemas con piezas pequeñas pio_crespo 4 624 29-08-2018, 09:07 AM
Último mensaje: buratatxo