Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema configuracion steps
#1
Aunque este tema viene dado a raiz de otro tema "Fallo a media impresion" lo posteo en un nuevo.
Resulta que cuando intento configurar los steps del extrusor resulta que por mucho que suba el valor de los steps, no me incrementa la cantidad de material extruido.

Siguiendo los consejos de "ehodes" y "Simemart" he estado intentando configurar los steps de extrusor. Yo siempre lo habia hecho extruyendo 10 mm y midiendo la cantidad de hilo extruido. Pero esta vez he intentado regular los steps extruyendo 50mm. Y sorpresa solo me extruye 48.

Y por mucho que suba el valor(es como si hubiera llegado al maximo) siempre me extruye 48.

Por el contrario si en Pronterface le pongo un valor de 105 al Print Flow, me extruye los 50mm

¿Tengo que configurar marlin de alguna otra forma? ,¿alguna otra solucion?

Asi es como tengo configurado Marlin

/**#define DEFAULT_AXIS_STEPS_PER_UNIT   { 160, 160, 800 , 1674.397 }  
 * Definicion cambiada 04/08/2018 */
#define DEFAULT_AXIS_STEPS_PER_UNIT   { 160, 160, 800 , 4000}  
//  Titan aero  motor steps * Micro-Steping * Gear Ratio  /  (Hobb Diameter* Pi)  ==  (400*32*3)/(7.3*pi)=1674.397    //
/**
 * Default Max Feed Rate (mm/s)
 * Override with M203
 *                                      X, Y, Z, E0 [, E1[, E2[, E3[, E4]]]]
 */
#define DEFAULT_MAX_FEEDRATE          { 200, 200, 10, 35 }

/**
 * Default Max Acceleration (change/s) change = mm/s
 * (Maximum start speed for accelerated moves)
 * Override with M201
 *                                      X, Y, Z, E0 [, E1[, E2[, E3[, E4]]]]
 */
#define DEFAULT_MAX_ACCELERATION      { 1200, 1200, 75, 1200 }

Agradezco cualquier ayuda
Citar
#2
Para variar los steps se hace como te indica @Simemart en el post que comentas : https://www.spainlabs.com/foros/tema-Fal...-impresion

Te puede estar pasando que no subas bien Marlin a tu placa y continue con los valores que tenia.

Personalmente no veo correcto abrir nuevos posts con el mismo problema ya que se pierde información.

Saludos.
Citar
#3
El cambio de post es porque, aunque parte del mismo problema, entiendo que el tema es totalmente diferente.

Pero bueno tengo que decir que aunque no se cual es el motivo, realmente es lo que tu decias y no modificaba los parametros.

Ahora lo he hecho directamente desde el pronterface con el codigo M92 y grabado con el M500 y me ha quedado bien calibrada.

Gracias
Citar
#4
Hola, el problema que estabas teniendo se debe a que, teniendo habilitado el parámetro EEPROM_SETTINGS en Marlin, los valores configurados en el firmware se sustituyen en el siguiente reseteo por los almacenados en la EEPROM.
Dado que, justo después de subir el firmware siempre realiza un reset, nunca se tienen en cuenta dichos valores, sustituyendose por los anteriores que están grabados en la EEPROM.
Esto lo indica claramente Marlin en el comentario de esa sección:

...
//=============================================================================
//============================== Movement Settings ============================
//=============================================================================
// @section motion

/**
* Default Settings
*
* These settings can be reset by M502
*
* Note that if EEPROM is enabled, saved values will override these.(Tengase en cuenta que si está habilitada la EEPROM, los valores guardados sobreescriben estos.)
*/
...


Este comportamiento es algo que trae de cabeza a muchos usuarios.
Siempre que se cambian los valores de esta sección, hay que hacerlo fuera del firmware y después salvar la memoria EEPROM antes de reiniciar la máquina.
O bien deshabilitar el parámetro EEPROM_SETTINGS.
Citar
#5
bingo !!!!
No, si al final aprenderé alguna cosa
 
Gracias
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Tests, calibración y configuración juanma_jp 2 260 26-09-2018, 06:26 PM
Último mensaje: juanma_jp
  APORTE Tutorial Instalación y configuración driver TMC2130 en Ramps campy 42 9,477 01-09-2018, 12:28 AM
Último mensaje: cerutti
  APORTE Configuración de driver TMC2208 con UART y Marlin 1.1.8 shiryou 11 2,630 14-06-2018, 07:20 PM
Último mensaje: manolo25leon
  Problema eje Z configuracion sonbonet 2 545 11-06-2017, 09:52 AM
Último mensaje: sonbonet
  Sacar datos de configuracion de cura a partir del gcode decker 2 2,475 17-03-2017, 11:41 PM
Último mensaje: decker