Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
DUDA Ayuda a revivir vieja impresora clónica Prusa i3
#1
Hola. Vengo aquí en busca de ayuda. Estoy intentando revivir una vieja impresora 3D de tipo prusa i3.

Es de las primeras Prusa i3 clónicas que se hicieron con marco de aluminio. Me enteré de una conjunta que se hacía en forocoches en mayo de 2013: https://www.forocoches.com/foro/misc.php...id=3261016. La pedí y me llegó en septiembre de 2013. La monté y estuvo funcionando durante un tiempo. La cuestión es que no iba "perfecta" y quería mejorarle algunas cosas. Quería actualizar el Marlin, ponerle un display LCD gráfico, cambiar a un extrusor de 1,75mm (llevaba uno de esos tochos de 3mm con un cabezal de aluminio). Compré el display, también un kit de eje Z nuevo (para substituir las varillas M5 por un eje de 8 mm en condiciones), un extrusor MK8. Tuve un problema y es que con el kit de eje Z y X no me llegó el soporte que une el extrusor con el carro. Pensaba en fabricarme uno con una plancha de aluminio, pero lo fui dejando y al final la dejé tirada en un rincón. Hace poco pensé en volver a retomar el tema y decidí que la montaría y la volvería a hacer funcionar.La tengo "mas o menos" montada pero me he atascado en el tema del Marlin. Para que os hagáis una idea de que impresora és os dejo unas cuantas fotos:

Foto de la impresora con el nuevo eje Z y X, además del extrusor MK8 (Me falta ajustar los finales de carrera y lo tengo así temporalmente):
   

Foto de la Ramps (me parece a mi que es una 1.4):
   

Foto de la controladora (es una Beduino, clónica de Mega2560):
   

Los ejes que he puesto ahora son unos TSHL-300-8D, similares a estos (creo que de paso tienen unos 2mm):
https://es.aliexpress.com/item/32916461598.html

Y ésto es lo que decía al conectarse a ella (sí, todavía tiene el Marlin 1.0.0, ¡es prehistórica!):
(19-06-2017, 06:30 PM)dragonet80 escribió:
Cita:17:18:53.221 : echo: External Reset
17:18:53.221 : Marlin1.0.0
17:18:53.221 : echo: Last Updated: Oct 13 2014 21:06:34 | Author: (none, default config)
17:18:53.221 : Compiled: Oct 13 2014
17:18:53.221 : echo: Free Memory: 5244  PlannerBufferBytes: 1232
17:18:53.225 : echo:Hardcoded Default Settings Loaded
17:18:53.225 : echo:Steps per unit:
17:18:53.229 : echo:  M92 X80.00 Y80.00 Z4000.00 E775.00
17:18:53.229 : echo:Maximum feedrates (mm/s):
17:18:53.233 : echo:  M203 X400.00 Y400.00 Z2.00 E45.00
17:18:53.233 : echo:Maximum Acceleration (mm/s2):
17:18:53.234 : echo:  M201 X1000 Y1000 Z10 E1000
17:18:53.237 : echo:Acceleration: S=acceleration, T=retract acceleration
17:18:53.238 : echo:  M204 S1000.00 T2000.00
17:18:53.246 : echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s),  Z=maximum Z jerk (mm/s),  E=maximum E jerk (mm/s)
17:18:53.250 : echo:  M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00
17:18:53.250 : echo:Home offset (mm):
17:18:53.250 : echo:  M206 X0.00 Y0.00 Z0.00
17:18:53.254 : echoLenguaID settings:
17:18:53.254 : echo:   M301 P22.20 I1.08 D114.00
17:18:54.583 : FIRMWARE_NAME:Marlin V1; Sprinter/grbl mashup for gen6 FIRMWARE_URL:https://github.com/ErikZalm/Marlin/ PROTOCOL_VERSION:1.0 MACHINE_TYPE:Mendel EXTRUDER_COUNT:1 UUID:00000000-0000-0000-0000-000000000000
17:18:54.615 : X:0.00 Y:0.00 Z:0.00 E:0.00 Count X: 0.00 Y:0.00 Z:0.00
17:18:54.615 : echo:Active Extruder: 0


Y ahora van aquí mis preguntas:

1) ¿Cual es la versión de Marlin que recomendáis teniendo en cuenta que mi placa controladora es una Mega2560? ¿La 2.0.4.4, la bugfix 2.0.x, la dev 2.1.x, la 1.1.9, la bugfix 1.1.x?
2) En el "configuration.h" hay un montón de opciones, algunas las tengo claras pero otras no:
 2.1) ¿Mi Ramps es una 1.4 EFB o es algún otro modelo?
 2.2) En "thermal settings", los sensores de temperatura no tengo ni idea de que modelos son y ¡hay un montón para elegir! Por si sirve de ayuda, la cama caliente es de "repparts3d.com" y pone MK2, pero sin desmontarla  no puedo sacarle una foto al sensor (creo recordar que era como una lentejita muy pequeño). Y el del extrusor es el que viene de serie con el MK8: https://es.aliexpress.com/item/32857261608.html
 2.3) En PID veo que tenía los valores por defecto. ¿Van bien esos?
 2.4) Los drivers creo que son los A4988, si alguien me lo confirma me quedo mas tranquilo.
 2.5) Valores de pasos, aceleraciones, etc de los ejes. Entiendo que para el eje Y, como no ha cambiado nada, debería dejarlo igual que lo tenía. El eje X también sigue igual (he cambiado los soportes pero no el motor ni la correa). En cambio el eje Z ha pasado de tener una varilla roscada M5 a un eje de 8 mm de tipo trapezoidal, ¿como calculo estos valores? ¿alguien que use este mismo tipo de eje, me puede decir los suyos? Y los valores para el extrusor MK8 igual, ¿me podéis decir que valores necesita?
 2.6) El display gráfico que compré es este: https://es.aliexpress.com/item/32550988155.html. En Marlin, ¿a que modelo corresponde? ¿reprapdiscount, reprapworld, otro?
 2.7) Ahora mismo no tiene ventilador de capa, pero creo que es muy necesario, ya buscaré uno y haré una boquilla especial para mi extrusor. ¿Recomendáis algun modelo? Cuando lo ponga, ¿hay que configurar algo en Marlin?

Son muchas preguntas. Me hace ilusión volver a hacer funcionar esta impresora. Seguramente mas adelante me compre una con cama de 300 o 400, pero ahora mismo intentaré hacer funcionar ésta otra vez.
Citar
#2
Mi conjunta de repparts3D era de esa misma época, la pagué en febrero y vino en septiembre de 2013 (pero en CloneWars, la hizo GhostHawk que también andaba en este foro, que se fundó en aquella época más o menos), la tuya lleva rodamientos arriba del eje Z (al menos que se los haya puesto tú) y la original no los llevaba, de hecho, esos rodamientos empeora el funcionamiento.

Edito: Te confirmo que es la misma conjunta, acabo de recordar que GhostHawk creó el hilo tanto en forocoches como en los grupos de Google (o sea, que no son dos conjuntas diferentes hecha por él). ¿cuantas fueron? Creo que unas 230 impresoras 3D o así ¿no?

OJITO con el fusible rearmable (la pastilla amarilla más grande tapada por los cables) porque se fundía rápido, quedaba en corto y la impresora salía ardiendo, muchos tuvimos suerte, se quemaba y la cama calentaba nada más encender la impresora, y así detectabas el fallo. Lo mejor es meter un relé SSR para que no pase tanta corriente por ahí.

Por aquí tengo el firmware de aquella impresora todavía con marlin 1.0, hecho por el compañero del foro Overcraft3D, así que puedes ver el termistor de la cama que lleva, drivers y demás. Sus vídeos de montaje están todavía en Youtube de esa impresora en concreto. Si quieres el firmware avisa. https://www.youtube.com/watch?v=KUGuKDVhkDM

Lo primero de todo es elegir qué Marlin quieres montar. Ya solo eso es una discusión eterna y eres tú el que debe decidir.

1) En mi opinión personal, Marlin 2.0 está hecho para placas de 32 bits, para 8 bits no está optimizado, así que prefiero meter un Marlin 1.1.9 bugfix.
Realmente puedes meter el 2.0 porque tu placa tendrá 256 kB de memoria y cabe.
Yo Marlin 2.0 no lo he tocado, pero aquí hay una guía hecha por otro compañero del foro: https://3dwork.io/configurar-marlin-2-0-x-desde-cero/
Ulticampy V2: fundiendo plástico sin descanso...
Citar
#3
(04-03-2020, 01:38 PM)Lepes escribió: Mi conjunta de repparts3D era de esa misma época, la pagué en febrero y vino en septiembre de 2013 (pero en CloneWars, la hizo GhostHawk que también andaba en este foro, que se fundó en aquella época más o menos), la tuya lleva rodamientos arriba del eje Z (al menos que se los haya puesto tú) y la original no los llevaba, de hecho, esos rodamientos empeora el funcionamiento.

Edito: Te confirmo que es la misma conjunta, acabo de recordar que GhostHawk creó el hilo tanto en forocoches como en los grupos de Google (o sea, que no son dos conjuntas diferentes hecha por él). ¿cuantas fueron? Creo que unas 230 impresoras 3D o así ¿no?

OJITO con el fusible rearmable (la pastilla amarilla más grande tapada por los cables) porque se fundía rápido, quedaba en corto y la impresora salía ardiendo, muchos tuvimos suerte, se quemaba y la cama calentaba nada más encender la impresora, y así detectabas el fallo. Lo mejor es meter un relé SSR para que no pase tanta corriente por ahí.

Por aquí tengo el firmware de aquella impresora todavía con marlin 1.0, hecho por el compañero del foro  Overcraft3D, así que puedes ver el termistor de la cama que lleva, drivers y demás. Sus vídeos de montaje están todavía en Youtube de esa impresora en concreto. Si quieres el firmware avisa. https://www.youtube.com/watch?v=KUGuKDVhkDM

Lo primero de todo es elegir qué Marlin quieres montar. Ya solo eso es una discusión eterna y eres tú el que debe decidir.

1) En mi opinión personal, Marlin 2.0 está hecho para placas de 32 bits, para 8 bits no está optimizado, así que prefiero meter un Marlin 1.1.9 bugfix.
Realmente puedes meter el 2.0 porque tu placa tendrá 256 kB de memoria y cabe.
Yo Marlin 2.0 no lo he tocado, pero aquí hay una guía hecha por otro compañero del foro: https://3dwork.io/configurar-marlin-2-0-x-desde-cero/

Sí, creo que era ese mismo, ahora lo he recordado.

A mi el fusible no me ha dado problemas, aun lo tengo montado. Habré tenido suerte.

Si tienes el código fuente del firmware con los valores de nuestra impresora puesto, sí, me gustaría mucho que me lo pasaras.

Como yo todavía no tengo argumentos para decidir sobre el firmware, te haré caso y probaré con el bugfix 1.1.9.

Muchas gracias.

P.D: Perdonadme todos que repitiese el mensaje varias veces. Me salía un error de base de datos y no pensaba que se estuviese publicando. Ya he borrado los repetidos.
Citar
#4
Te he preparado una carpeta en mi dropbox con lo siguiente:
- arduino-1.0.5.zip El arduino necesario para compilar el Marlin que te paso.

- Marlin.zip Configurado por Overcraft3D

- Imprimibles.zip, En su interior tienes todo esto:

- Adjustable_Blower_fan... Un difusor para ventilador de capa para tu extrusor Greg_Wade

- Bird-Nose_for_Greg_Wade: Es un pico de pato para cambiar de filamento rápidamente, así no tienes que aflojar los tornillos del extrusor con los muelles. Yo marcaba con rotulador en el pico de pato y en el idler la posición de apriete justa y así siempre lo ponía en el mismo sitio.

- E3D_v4_Hot_end_Model: Si vas a imprimir con ABS vas a necesitar esto, son una serie de embudos para el hotend E3D v4 para que el ventilador de las aletas del fusor no echen aire a la boquilla.

- Y_Axis_Belt_Tensioner: Necesitas un rodamiento 606ZZ para este tensor del eje Y

Dentro de "imprimibles.zip" en un fichero de texto de cada carpeta tienes el enlace de thingiverse de todo eso. Si hay un archivo ".blend" es de Blender 2.7 aunque puedes abrirlo con blender 2.8 sin problemas. No recuerdo bien, pero normalmente lo importo en Blender, quito errores que tengan o modifico algo y después lo exporto a STL, realmente no me acuerdo de lo que hice para cada cosa.

Por el error del foro, puedes consolarte sabiendo que nos pasa a todos, cuando envias el mensaje da error, pero el mensaje queda colgado en el hilo, mejor cerrar la pestaña (porque se queda pensando y abrir el hilo de nuevo en otra pestaña). Si editas un mensaje ya publicado, funciona bien.

En cuanto a Marlin, yo aún tengo la 1.0.2 en mi ulticampy, funciona bien y no necesito nada de lo nuevo que han puesto, así que te diría que no te calientes mucho con eso, de todas formas, siempre lo puedes actualizar (yo habré modificado y metido marlin más de 20 veces y siempre sin ningún problema)

Cuando lo hayas descargado avisa y lo quito de dropbox, no me queda mucho espacio. Gracias!

Saludos!
Ulticampy V2: fundiendo plástico sin descanso...
Citar
#5
(05-03-2020, 12:08 PM)Lepes escribió: Te he preparado una carpeta en mi dropbox con lo siguiente:
- arduino-1.0.5.zip El arduino necesario para compilar el Marlin que te paso.


Cuando lo hayas descargado avisa y lo quito de dropbox, no me queda mucho espacio. Gracias!
Lo he descargado, pero lo pruebo mañana o pasado cuando tengo un rato. A ver si me aclaro con el cambio de varilla M5 a trapezoidal de 8mm y con el extrusor nuevo que es lo que mas me preocupa. También he visto algo raro en la configuración de cama caliente, pero ya digo cosas mañana o pasado.

Muchas gracias.
Citar
#6
Ahora con el confinamiento ya he podido probarlo. @Lepes, he probado el firmware que me mandaste y el 2.0.4, pero al final me he quedado con el 2.0.5 que acaba de salir hace unos días. A base de pruebas el eje Z parece que ya está ajustado. He hecho la calibración del PID de la cama y tengo la pantalla gráfica funcionando. Me falta calibrar el extrusor, pero tengo que ir a buscar una bobina a casa de un amigo y con el confinamiento tendré que esperar a que tenga que ir a comprar víveres para poder ir.

Pero, justamente con la pantalla me ha surgido un problema: El encoder no funciona bien. Si pulsas el encoder se abre el menú, pero cuando lo giras a la izquierda o a la derecha no responde nada. Es como si los pines no estuviesen bien definidos o algo así. La pantalla era una RepRapDiscount Full Graphic Smart Controller. ¿Hay algún método para comprobar el funcionamiento del encoder? ¿Puede ser tema de pines?
He mirado este esquemático:
https://reprap.org/mediawiki/images/5/51...EMATIC.pdf
Y comprobando con el tester resulta que el pin BTN_EN2 normalmente está a 5V y cuando giro el encoder da pulsos a masa. En cambio el pin BTN_EN1 no cambia nunca y está como sin tensión siempre. Mañana haré mas pruebas a ver si consigo arreglarlo. A las malas, si el encoder está estropeado, y solo le funciona un canal, se puede modificar el Marlin de alguna manera para que ese canal funcione como un botón? Así almenos podría ir en un sentido y moverme por los menús.
Citar
#7
Buenos días. Esta mañana el encoder se ha arreglado "solo". Le he metido las puntas del osciloscopio para ver la señal. Al principio seguía como ayer, un canal iba bien pero el otro no. Pero después de jugar un rato con él ha empezado a funcionar el otro canal. No sé si ha sido por que tenía algún resto de soldadura o porquería que hacía derivación entre el pin de ese canal y el central y con las pinzas del osciloscopio se ha limpiado o era algo interno... pero ya funciona, misterios de la electrónica.
Citar
#8
Buenas! Hace como dos años me compré una Geeetech I3 Pro B prusa china con la que nunca llegue a imprimir por que en ese momento comencé el trabajo actual que tengo que me absorbe gran cantidad de tiempo y energía, pero con la situación actual veo la oportunidad de retomarlo (aprender) y ya luego podré "jugar" con ella... En resumen busco alguien que me pueda echar una mano con toda la puesta en marcha de la maquina, instalación del Marlin en la Prusa (modificaciones si hacen falta) y que programas necesito en el PC, preferiblemente me gustaría hacerlo por Whatsapp o voz... saludos y gracias de antemano. Veo que siguiendo manuales y demás me puedo tirar 2 semanas haciendo pruebas y tirandome de los pelos, que ya se como son estas cosas.... cosa que estoy seguro que alguien que "pilota" me puede ayudar a que esta semana pueda estar "imprimiendo"... Saludos y perdon por el churro.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  PROBLEMA Impresora 3D PRUSA i3 PRO w jordibe 10 1,398 17-01-2019, 08:02 PM
Último mensaje: Nullz
  DUDA Ayuda a identificar está impresora Volcano 1 1,003 28-09-2018, 04:17 AM
Último mensaje: Nullz
  presentacion prusa i3 1000 y ayuda con pantalla nextion FERMKS 3 762 03-06-2018, 07:47 PM
Último mensaje: FERMKS
  PROBLEMA EJE Z Y EXTRUDER PRUSA I3 AYUDA!! agl1 2 946 25-05-2018, 04:46 PM
Último mensaje: Erpirata
  Ayuda Prusa i3 steel.CREO QUE HE CARGADO LA RAMPS. hansugrove 26 3,140 10-10-2017, 06:40 PM
Último mensaje: hansugrove