Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Como Calibrar los pasos y velocidad del Extrusor
#1
Tengo un Problema con el extrusor
resulta que usando pronterface calente la boquilla a 200°C y le di extruir una distancia de 100mm con una velocidad de 100mm/min.
y extruyo 100mm pero lo hizo en 25 segundos no en los 60 segundo que se demora siempre y este problema me causa atascos en el extrusor que puede ser???
es una Kossel Delta con Autonivelacion

los parametros de los motores estan asi:

Filament settings:
 M200 D1.75
Steps per unit:
 M92 X200.00 Y200.00 Z200.00 E425.00
Maximum feedrates (units/s):
 M203 X200.00 Y200.00 Z200.00 E25.00
Maximum Acceleration (units/s2):
 M201 X4000 Y4000 Z4000 E4000
Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
 M204 P3000.00 R3000.00 T3000.00
Advanced: Q<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> X<max_x_jerk> Y<max_y_jerk> Z<max_z_jerk> E<max_e_jerk>
 M205 Q20000 S0.00 T0.00 X10.00 Y10.00 Z10.00 E5.00
Auto Bed Leveling:
 M420 S0
Endstop adjustment:
 M666 X0.00 Y-0.02 Z-0.02
Delta settings: L<diagonal_rod> R<radius> H<height> S<segments_per_s> B<calibration radius> XYZ<tower angle corrections>
  M665 L213.53 R104.71 H285.54 S160.00 B65.00 X0.00 Y0.09 Z-0.10
Citar
#2
Hola, pues como no se pueden contravenir las leyes de la física, si realmente extruye 100mm en 25 segundos, es que la velocidad no es 100 mm/m, sino 240 mm/m aproximadamente.
Comprueba la velocidad de extrusión que tienes configurada en el Pronterface, no te estés confundiendo con el % que hay debajo, que suele ser 100.
De todas formas, para estar seguro, hazlo mandando los siguientes gcodes:
M82
G92 E0
G1 E100 F100
El último es el que realiza la extrusión, por lo que al enviarlo es cuando tienes que medir el tiempo que tarda en completarla.
Citar
#3
(27-10-2019, 07:37 PM)Simemart escribió: Hola, pues como no se pueden contravenir las leyes de la física, si realmente extruye 100mm en 25 segundos, es que la velocidad no es 100 mm/m, sino 240 mm/m aproximadamente.
Comprueba la velocidad de extrusión que tienes configurada en el Pronterface, no te estés confundiendo con el % que hay debajo, que suele ser 100.
De todas formas, para estar seguro, hazlo mandando los siguientes gcodes:
M82
G92 E0
G1 E100 F100
El último es el que realiza la extrusión, por lo que al enviarlo es cuando tienes que medir el tiempo que tarda en completarla.

estimado gracias por ayudarme
te comento que envie el codigo en el pronterface: M82
G92 E0
G1 E100 F100
extruyo 100mm correcto pero se demoro 25seg 

estoy usando drv8825 con una configuracion de 32/1 nose que puede ser
Citar
#4
Los micropasos por milímetro solo influyen en la distancia recorrida, no en la velocidad.
Si has medido y extruye los 100mm, no es ese el problema.
En los gcodes que te indiqué antes, se me olvidó incluir la configuración de unidades. Sería así:
G21
M82
G92 E0
G1 E100 F100
Puedes probar por si hay alguna relación con las unidades.
La verdad es que es bastante raro y si todo es como indicas, lo único que se me ocurre es que esté mal el firmware, que es quien maneja realmente la velocidad de los motores.
Citar
#5
(27-10-2019, 08:25 PM)Simemart escribió: Los micropasos por milímetro solo influyen en la distancia recorrida, no en la velocidad.
Si has medido y extruye los 100mm, no es ese el problema.
En los gcodes que te indiqué antes, se me olvidó incluir la configuración de unidades. Sería así:
G21
M82
G92 E0
G1 E100 F100
Puedes probar por si hay alguna relación con las unidades.
La verdad es que es bastante raro y si todo es como indicas, lo único que se me ocurre es que esté mal el firmware, que es quien maneja realmente la velocidad de los motores.

pasa lo mismo imprime 100mm en 25 seg esto empezo despues de cambiar la placa madre antes tenia una mksbase mini 1.1  ahora le puese una MKS GEN 1.4 estoy usando marlin 1.1.9 ya no se que mas pueda ser
Citar
#6
Pues no se que decirte.
Comprueba que tengas configurados los drivers en Marlin. Si no lo haces, considera que son A4988, aunque no debería afectar a la velocidad de los motores.
En fin, nunca se sabe.
Citar
#7
Ya encontre la solucion
la placa es de 32bit y el marlin 1.1.9 es de 8 bit
instale el Marlin 2.0 de 32bit y los mismo ajustes y solucionado que imprimiendo muy bien
gracias igual por su ayuda
Citar
#8
Que lo hayas solucionado con el cambio de firmware no me extraña, pero el motivo que indicas no es el correcto. No se puede cargar el Marlin de 8 bits en una placa de 32 bits, ni lo contrario.
En todo caso, si tu placa es la MKS GEN 1.4, tiene una MCU de 8 bits y seguramente también lo habrías solucionado poniendo otra copia de la versión 1.1.9. Seguramente la que tenías instalada estaba corrupta.
Citar
#9
solo para comprobarlo instale el marlin 1.1.8 y el mismo problema baje nuevamente el 1.1.9 y vuelve a pasar lo mismo solo funciona bien con el marlin 2.0
que puede ser ???
ahora que estoy imprimiendo me percate que el LCD no lo puedo ocupar se pone demaciado lento los menu y desaparecen pero no se estropea la impresion

(27-10-2019, 10:51 PM)Simemart escribió:  No se puede cargar el Marlin de 8 bits en una placa de 32 bits, ni lo contrario.

y el marlin 2.0 funciona con 8 y 32bit ???
Citar
#10
Marlin 2.0 es a la vez para 8 y 32 bits. Dependiendo de la placa que se seleccione al compilar, se crea el firmware en uno u otro formato.
Si con la 2.0 funciona todo bien, seguramente sea alguna configuración.
Citar
#11
(28-10-2019, 12:59 AM)Simemart escribió: Marlin 2.0 es a la vez para 8 y 32 bits. Dependiendo de la placa que se seleccione al compilar, se crea el firmware en uno u otro formato.
Si con la 2.0 funciona todo bien, seguramente sea alguna configuración.

excelente ya me queda mas claro todo. y se resume a alguna configuración o firmware defectuoso ahora tengo otro problema pero abriré otro post para comentar muchas gracias por tu ayuda
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  DUDA Pasos extrusor prosit 0 102 03-12-2019, 08:42 PM
Último mensaje: prosit
  CONSULTA Ender 3 no disminuye velocidad al imprimir con Cura Sr. Kowi 6 228 20-11-2019, 12:35 PM
Último mensaje: Simemart
  CONSULTA Calibrar Z Youthanasia75 3 178 17-11-2019, 04:18 PM
Último mensaje: Youthanasia75
  velocidad de una Delta Kossel Juda777 1 163 29-10-2019, 12:19 PM
Último mensaje: Simemart
  DUDA Sorpresa con pasos del extrusor Wildense 6 289 21-09-2019, 03:28 AM
Último mensaje: Wildense