Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA Configuración Marlin
#1
Muy buenas tardes a todos. Luego de más de 60 dias de espera me llegó de EBAY el kit RAMPS 1.4 + arduino MEGA 2560, lo instalé en mi ANET A8 PLUS y me estoy encontrando con varios detalles en la configuración de MARLIN versión 2.0.5.4. Uno de ellos es que no me aparece en el LCD el “PREPARE” al cual estaba acostumbrado. Tampoco logro encontrar la forma de habilitar el nivelado manual. ¿Podrán ayudarme con estos detalles? 

Muy agradecido….

PD: Intenté agregar los archivos de configuración pero me fue imposible, agradezco si me pueden indicar como hacerlo
Citar
#2
Hola, para adjuntar los archivos de configuración, el mejor modo es incluir los dos en una archivo comprimido y adjuntar este desde la página que sale al pulsar sobre el botón Vista previa del mensaje: en ella hay un botón para buscar el archivo en el equipo y a la derecha otro para adjuntarlo.
A la vista de dichos archivos, podremos comentar los cambios a realizar para conseguir lo que se plantea en la pregunta.
Citar
#3
Quise adjuntar un archivo 7zip y me dice "corrige los siguientes errores" El tipo de archivo que adjuntaste no está permitido. Quita ese archivo o escoge alguno otro de diferente tipo." ?????

Citar
#4
Hola, los archivos que te permitirá subir el filtro del foro, deben tener extensión zip o rar: 7zip te permite generar ficheros con extensión .zip en lugar de su formato por defecto (.7z).
No sirve de nada incluir los archivos de configuración en la respuesta como has hecho, pues existe un límite de caracteres en las mismas y como puedes ver, está truncado y no aparece completo: te recomiendo que lo borres para facilitar la lectura del post.
En todo caso, parece que no has utilizado los archivos preconfigurados que Marlin tiene para ese modelo de impresora y veo que tienes configurado que hay un sensor (#define FIX_MOUNTED_PROBE) y definido el Z Safe Home (#define Z_SAFE_HOMING), pero no tienes cambiados los Z Probe Offsets que vienen por defecto (#define NOZZLE_TO_PROBE_OFFSET { 10, 10, 0 }), ni seleccionado un tipo de autolevel: ¿tienes instalado realmente un sensor como final de carrera del eje Z?
Creo que en tu caso, será más conveniente que utilices dichos archivos preconfigurados, que puedes descargar en un enlace que se encuentra al lado del de descarga de Marlin, que para la versión 2 te recomiendo sea la 2.0.x-bugfix en lugar de la que has utilizado (2.0.5.4).
Citar
#5
Estimado Simemart, corregido el post voy a descargar el bugfix e intentarlo como sugieres, gran saludo y muchas gracias. Después comento si hay progresos...
Citar
#6
Estimado SIMEMART, luego de romperme la cabeza, (debido a mis escasos conocimientos) subí el bugfix de Marlin 2, pero debido (y no se el porqué) demoraba casi 12 minutos en compilar, instalé la versión 1.1.9 bugfix solucionando así la demora en la compilación. Ahora, luego de configurarlo me encuentro con varios problemas el primero es que es imposible realizar el cambio de filamento en forma automática. Existen otros problemas, pero me gustaría irlos solucionando de a poco apelando a su buena disposición y voluntad. Como me fue imposible subir los archivos de configuración de acuerdo a vuestra guía de cómo hacerlo, envío un link con el contenido.
Muy agradecido.
https://drive.google.com/file/d/1XNKhL--...sp=sharing


https://drive.google.com/file/d/1XNKhL--...sp=sharing
Citar
#7
Hola, siento el retraso en la respuesta, pero estoy fuera de casa unos días y entro menos al foro.
Tu problema para subir los archivos, se debe a que en 7zip estás creando el archivo que genera esa aplicación por defecto, cuya extensión .7z no pasa el filtro del foro. Solo tienes que indicar, en dicha aplicación, que te haga un archivo .zip en lugar del .7z y podrás adjuntarlo sin problemas.
Respecto a la demora en la compilación de la versión 2, efectivamente tarda más que la 1, dependiendo mucho del desempeño del ordenador que se use pero, si la compilación termina con éxito, creo que merece la pena la espera.
Paso ahora a comentar lo que veo en esos archivos de configuración:

Configuration.h

1- Si no imprimes con filamentos técnicos y solo usas PLA, no es necesario que tengas unas temperaturas máximas tan altas. Puedes ponerlas así:

#define HEATER_0_MAXTEMP 240
#define BED_MAXTEMP 90


y tendrás un mayor margen de seguridad.

2- Aunque no es algo que vaya a dar ningún problema, tienes definido el driver del eje Z2, pero no tienes definido dicho eje en el archivo Configuration_adv.h.

3- Con vistas a la configuración de la retracción, conviene que aumentes el valor de la velocidad máxima del extrusor:

#define DEFAULT_MAX_FEEDRATE          { 300, 300, 5, 70 }

4- Las aceleraciones que tienes configuradas quizá sean algo elevadas. Puedes ponerlas así:

#define DEFAULT_ACCELERATION          1000    // X, Y, Z and E acceleration for printing moves
#define DEFAULT_RETRACT_ACCELERATION  1000    // E acceleration for retracts
#define DEFAULT_TRAVEL_ACCELERATION   1000    // X, Y, Z acceleration for travel (non printing) moves


Configuration_adv.h

1- Con la pantalla gráfica puedes habilitar un par de opciones que mejoran su uso:

#define SCROLL_LONG_FILENAMES
#define DOGM_SD_PERCENT


La primera permite ver completos los nombres de los ficheros de la tarjeta SD, cuando su longitud sobrepasa el tamaño de línea de la pantalla.
La segunda, muestra el porcentaje de impresión transcurrida.

3- Tienes habilitados los comandos de arcos, pero Marlin no los utiliza y lo único que hacen es consumir memoria. Puedes deshabilitarlos comentando la línea:

//#define ARC_SUPPORT               // Disable this feature to save ~3226 bytes

Sobre el problema con el cambio de filamento, tendrás que ser más específico, pues está habilitado pero puede que no estén definidos bien los parámetros en el apartado Advanced Pause del archivo Configuration_adv.h.
Citar
#8

.zip   CONFIGURACIONES.zip (Tamaño: 46.33 KB / Descargas: 2)

Estimado y muy atento Simemart, le informo que he modificado lo que usted me ha indicado, pero no he podido corregir lo que me indica en este apartado “2- Aunque no es algo que vaya a dar ningún problema, tienes definido el driver del eje Z2, pero no tienes definido dicho eje en el archivo Configuration_adv.h.” Podría indicarme como hacerlo por favor?
Con respecto a lo del cambio de filamento, le comento que no logro hacerlo, al darle la indicación desde la pantalla LCD “Unload filament”, se sitúa en home, levanta la temperatura a 180º, retrae unos pocos milímetros sin expulsar el filamento y a los pocos segundos vuelve a isertarse solo el mismo. ¿Existirá la forma de implementarlo de tal forma que se comporte como cuando vino de origen con el firmware y la placa original que funcionaba satisfactoriamente? Le recuerdo que ahora he instalado el kit Ramps con arduino mega 2560.
En origen se comportaba de la siguiente manera: al darle la indicación cambiar filamento, hacía un home, se elevaba el eje Z 20 milímetros, calentaba a 240º, retiraba el filamento, daba cinco pitidos y esperaba hasta la inserción del mismo, y presionando el botón el filamento se cargaba en forma perfecta.
Muy agradecido por su atención.

He seguido las instrucciones para subir el adjunto, pero como no se si ha funcionado agrego este link,

https://drive.google.com/file/d/112ZyKU1XIIBCGUGpnsrlPhjVSp-nRYCX/view?usp=sharing
Citar
#9
Hola, el archivo se ha adjuntado correctamente.
Ciertamente se me olvidó indicar como corregir ese punto 2. Solo hay que cambiar así la siguiente línea //#define Z2_DRIVER_TYPE A4988. Naturalmente, siempre que se tengan los dos motores del eje Z conectados al mismo driver. Si se quiere conectar cada motor a un driver independiente, cosa muy recomendable en este tipo de impresoras (si se tiene la posibilidad, como en este caso), hay que colocar otro driver en el zócalo libre de E1 en la RAMPS, conectar a su salida uno de los dos motores del eje Z y en el archivo Configuration_adv.h, poner así la siguiente línea:

#define Z_DUAL_STEPPER_DRIVERS

Con ello setendrá el doble de fuerza paramover el eje, pero con la misma regulación en el driver.
Sobre el cambio de filamento, todo lo relacionado con su comportamiento se configura en el apartado Advanced Pause del archivo Configuration_adv.h y para que lo haga como el original habría que conseguir su configuración y trasladarla a ese apartado del nuevo firmware.
Si no es posible conseguirla, habrá que configurar adecuadamente los parámetros: por ejemplo, el que controla cuanto retrocede el filamento para realizar el cambio es FILAMENT_CHANGE_UNLOAD_LENGTH, que por defecto viene configurado para 100 mm, lo que debería ser apropiado para un impulsor directo como creo lleva esa impresora, aunque quizá sea insuficiente y haya que aumentarlo.
En ese caso, hay que tener en cuenta que dicha distancia está limitada por el valor del parámetro EXTRUDE_MAXLENGTH, que se encuentra en el archivo Configuration.h y que por defecto tiene el valor de 200 mm.
Citar
#10
Estimado Simemart, logré encontrar el archivo original que me enviaron en su momento de la página oficial cuya carga de filamento funcionaba perfecto (con la placa ANET que viene de origen). Copié los parámetros correspondientes que vienen en el apartado Advanced Pause del archivo Configuration_adv.h, y los sustituí por los que vienen en el mismo apartado en el nuevo Marlin que tengo instalado (Marlin-bugfix-1.1.x), pero al compilar me saltan multiples errores. Adjunto el archivo que vino de origen con la máquina, como así también el archivo Marlin-bugfix-1.1.x que tengo instalado en este momento y con el cual no me funciona el cambio de filamento, para ver si usted puede tratar de ayudarme. Vuelvo a recordarle que tengo colocado en la máquina ahora el nuevo kit RAMPS 1.4 – Arduino Mega 2560.

Un gran saludo.

https://drive.google.com/file/d/1-NKL0934vPBsb7nCbvutAfxjsqxghAUW/view?usp=sharing
Citar
#11
Hola, el hecho de tener una RAMPS con Arduino Mega no tiene ninguna influencia en este tema, por lo que no debes preocuparte por ello.
Si el cambio que has realizado es sustituir el apartado Avanced Pause del nuevo Marlin por el que tráe la versión original, es normal que se presenten errores al compilar, puesto que la original es una versión 1.1.7 y la actual una 1.1.9: han cambiado tanto que, en la versión más reciente, hay parámetros que no existen en la más antigua y viceversa.
Lo único que puedo decirte es que intentes guiarte por la más antigua, para configurar la nueva con los mismos valores en los parámetros que coincidan en las dos y comentes las diferencias que aprecias entre el comportamiento anterior y el actual, para intentar identificar su causa.
Citar
#12
Simemart muchas gracias, lo haré y en breve comentaré los resultados.
Citar
#13
Estimado Simemart, bastante abrumado y confundido, he decidido comenzar de nuevo, y a los efectos vuelvo a seguir su recomendación anterior empezando desde cero. Descargué la versión bugfix-2.0.x de Marlin, trato de instalarla tal cual para empezar, y al compilar me da error de compilación. Ajunto el informe de errores para ver si me puede guiar.

Muchas gracias.


https://drive.google.com/file/d/1UEULiD-...sp=sharing


Archivos adjuntos
.zip   Errores.zip (Tamaño: 18.21 KB / Descargas: 1)
Citar
#14
Hola, antes de poder compilar, tienes que modificar los archivos de configuración que tráe por defecto en lacarpeta Marlin, para adaptarlos a la Anet A8 Plus, en este caso con placa RAMPS 1.4 EFB.
Lo mejor es comenzar por los cambios mínimos indispensables y después ir incorporando otras opciones, como el autolevel manual o el cambio de filamento, pero cuando ya funcione correctamente la impresora.
En el archivo Configuration.h, tendrás que cambiar las siguientes líneas (las que están en color verde no son obligatorias, aunque creo que sí recomendables) :

#define CUSTOM_MACHINE_NAME "Anet A8 plus"
#define TEMP_SENSOR_BED 1
#define HEATER_0_MAXTEMP 240
#define BED_MAXTEMP      90

#define X_MIN_ENDSTOP_INVERTING true // Set to true to invert the logic of the endstop.
#define Y_MIN_ENDSTOP_INVERTING true // Set to true to invert the logic of the endstop.
#define Z_MIN_ENDSTOP_INVERTING true // Set to true to invert the logic of the endstop.
#define Z_MIN_PROBE_ENDSTOP_INVERTING true // Set to true to invert the logic of the probe.
#define DEFAULT_AXIS_STEPS_PER_UNIT   { 80, 80, 400, 95 }
#define DEFAULT_MAX_FEEDRATE          { 300, 300, 5, 50 }
#define DEFAULT_ACCELERATION          1000    // X, Y, Z and E acceleration for printing moves
#define DEFAULT_RETRACT_ACCELERATION  1000    // E acceleration for retracts
#define DEFAULT_TRAVEL_ACCELERATION   1000    // X, Y, Z acceleration for travel (non printing) moves
#define S_CURVE_ACCELERATION

#define INVERT_X_DIR true
#define INVERT_Z_DIR true
#define X_BED_SIZE 300
#define Y_BED_SIZE 300
#define X_MIN_POS -26
#define Y_MIN_POS -6
#define Z_MIN_POS 0
#define X_MAX_POS 300
#define Y_MAX_POS 297
#define Z_MAX_POS 370
#define EEPROM_SETTINGS       // Persistent storage with M500 and M501
#define LCD_LANGUAGE en

#define SDSUPPORT


Y quedaría por definir la pantalla que está instalada, que creo es:

#define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER

En el archivo Configuration_adv.h:

#define STATUS_MESSAGE_SCROLLING
#define SCROLL_LONG_FILENAMES
#define DOGM_SD_PERCENT
//#define ARC_SUPPORT                 // Disable this feature to save ~3226 bytes


Para poder compilar, hay qe tener instalada la librería U8Glib en el IDE de Arduino.
Citar
#15
Amigo Simemart, luego de efectuar los cambios primarios me vuelve a dar otro error al compilar de los cuales le adjunto archivo. Gracias por su ayuda.


Archivos adjuntos
.zip   Errores2.zip (Tamaño: 19.58 KB / Descargas: 1)
Citar
#16
Hola, me temo que debes de tener algún problema en el entorno de compilación que estás utilizando, pero no podré verificarlo hasta que vuelva de nuevo a mi ordenador.
Puedes intentar desinstalar el ArduinoIDE que tienes actualmente (sin olvidarte de borrar las carpetas %LOCALAPPDATA%\Arduino15 y %USERPROFILE%\Documents\Arduino) y descargar la última versión en formato ZIP. Si lo haces, no te olvides de instalar de nuevo la librería U8Glib.
Citar
#17
Estimado Simemart, ok, lo haré, pero existen varias librerías ug8lib, cual y de donde debería descargarla? Muchas gracias
Citar
#18
Amigo Simemart, lo sigo molestando, disculpe....

Aquí subí los errores luego de hacer todo lo por usted explicado, también hay una captura de pantalla del ide de Arduino... No aparecen nada mas que las solapas Configuration.h, Configuration_adv.h y Version.h, es normal? o vendrá por este lado mi problema?

A la espera de vuestra colaboración y reiterando las disculpas por tanta molestia, lo saludo con atenta consideración.

https://drive.google.com/file/d/1EF6vo3i...sp=sharing

El archivo adjunto Errores3.zip que está incluido no es el correcto, el link si.


Archivos adjuntos
.zip   Errores3.zip (Tamaño: 130.92 KB / Descargas: 2)
Citar
#19
Hola, no tienes por qué disculparte pues no es ninguna molestia responder a tus preguntas, no dudes en hacer todas las que creas necesarias.
Ya estoy de nuevo en mi ordenador y he comprobado que las últimas versiones de Marlin 2 y el IDE de Arduino no se llevan nada bien (por lo menos en entorno Windows): tanto con la 2.0.6 como con la 2.0.x-bugfix se producen errores en fase de compilación, aunque no es el mismo en cada una de ellas.
Creo que le queda poco recorrido al Arduino IDE actual con Marlin 2 y que habrá que pasarse a Visual Studio Code con PlatformIO para realizar su compilación, pues en este último lo hacen las dos perfectamente.
Por ello, mi recomendación es que compiles utilizando VSC.
Para los interesados en la parte técnica, los errores que comento se producen en concreto compilando para la plataforma que está usando @lambda4 (Arduino Mega 2560+RAMPS 1.4+LCD gráfico).
En la versión 2.0.6 se debe a que la línea de comando final que genera el fichero del firmware compilado, excede el tamaño máximo que soporta Windows (32767 caracteres), lo que genera un error de fork/exec: El nombre del archivo o la extensión es demasiado largo.
Esto se debe a que, en la línea de comando que lanza dicho proceso, se le añaden al ejecutable que lo realiza (avr-gcc.exe) innumerables parámetros con las rutas para encontrar los distintos archivos precompilados que se unirán para generar el archivo .hex del firmware.
Quizá se podría solucionar utilizando un archivo que contenga todos esos parámetros, aunque ya habría que realizarlo de forma manual, lo que sería bastante engorroso en la práctica.
En la versión 2.0.x-bugfix, se ha modificado la estructura del sketch, añadiendo una nueva carpeta, D:\Temp\Marlin-bugfix-2.0.x\Marlin\src\lcd\tft que contiene varios ficheros relacionados con la pantalla.
En uno de ellos, de nombre tft_image.cpp, hay un include de un archivo denominado cstddef que no encuentro por ningún lado: ni en el propio sketch ni en las carpetas del Arduino IDE por lo que, como es lógico, se produce un error de fichero no encontrado.
Por lo que he podido averiguar, tiene que ver con algo relacionado con las cabeceras de C++, pero aún no lo tengo claro.
Es de suponer que, una vez solucionado este error, se presente también el que sucede en la versión 2.0.6 al realizar la generación del fichero binario.
Citar
#20
Muchas gracias Simemart.

Le comento que con respecto a su intervención " Creo que le queda poco recorrido al Arduino IDE actual con Marlin 2 y que habrá que pasarse a Visual Studio Code con PlatformIO para realizar su compilación, pues en este último lo hacen las dos perfectamente." "Por ello, mi recomendación es que compiles utilizando VSC.", soy desconocedor total del tema ya que soy en esencia un autodidacta (algo veterano 70 años), y solamente he aprendido a manejarme con Arduino. Existe algún lugar donde pueda interiorizarme del tema y aprender lo elemental para poder salir de este embrollo tan frustrante en el cual estoy sumergido? 

Un gran saludo.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Marlin Builder v1.0: Configurando firmwares Marlin online y de forma muy sencilla Peter13 4 1,349 20-04-2020, 10:07 AM
Último mensaje: Peter13
  ¿Cómo compartir en el foro la configuración de un programa? PacoMB 5 1,218 18-12-2019, 07:34 PM
Último mensaje: PacoMB
  No sé que he tocado en mi configuración del Cura... Kuassimodo 8 852 16-04-2019, 02:57 PM
Último mensaje: maxlinux2000
Información CONSULTA Problema de Configuracion de Marlin para Endstop marcelogustavo 2 2,131 08-06-2018, 08:51 AM
Último mensaje: tete
  Configuracion extrusor mk9 jpcamarero 1 941 09-11-2017, 01:24 PM
Último mensaje: Masoar