Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Arduino quemado, sin motivo
#1
Se me acaba de quemar el arduino, no he tocado nada en la impresora y lleva imprimiendo una larga temporada, ayer mismo imprimió durante Horas

Hoy calente el extrusor cambie el plastico, y conecte la raspberry pi para una impresión de 10 horas, y no me conectaba la rasPi y la pantalla tenia mas contraste del normal, normalmente tiene un bajo contraste, y de pronto la pantalla se volvio loca, empezo a oler a quemado y apareció humo, apagué corriendo y he mirado por encima y la ramps 1.4sb esta bien, pero el arduino tiene quemado el regulador de tensión.

¿porque se quema? No hice nada con la electrónica, no veo razón alguna... Y además he cogio miedo, y si pasa cuando no estoy en casa?

Enviado desde mi Nexus 6 mediante Tapatalk
Citar
#2
qué se ha quemado exactamente? posiblemente haya algún corto o haya fallado algún componente, a veces pasa (sobre todo con la cantidad de productos de china que hay hoy en día, que las calidades se notan), no le des más vueltas.
Citar
#3
El AMS 1117 es el regulador de tensión, por lo que he leído, es algo bastante común, pero me preocupa que pueda causar un incendio, la dejo con largas impresiones muy a menudo sola.

Enviado desde mi Nexus 6 mediante Tapatalk
Citar
#4
Dices que conectas la Rasberry, desde dónde la alimentas? Y el Arduino?
Puede ser que alimentes el Arduino a 12v y estés alimentando la Raspberry desde algún pin de Arduino/RAMPS?
NOVEDAD: CoreXY Eternal Edition (Custom) -> https://www.spainlabs.com/foros/tema-Ete...So-Edition
Mi Prusa i3, ¡con lista de componentes! -> http://www.spainlabs.com/foros/tema-Un-clon-mas
Citar
#5
(04-09-2016, 11:27 PM)WeSo escribió: Dices que conectas la Rasberry, desde dónde la alimentas? Y el Arduino?
Puede ser que alimentes el Arduino a 12v y estés alimentando la Raspberry desde algún pin de Arduino/RAMPS?
No, la rasPi desde un alimentador externo de 5V como hice siempre.

Enviado desde mi Nexus 6 mediante Tapatalk
Citar
#6
Y el Arduino?

El regulador de marras es lineal, así que no es raro quemarlo o que se caliente considerablemente si lo alimentamos a una tensión elevada y le pedimos bastante corriente.
NOVEDAD: CoreXY Eternal Edition (Custom) -> https://www.spainlabs.com/foros/tema-Ete...So-Edition
Mi Prusa i3, ¡con lista de componentes! -> http://www.spainlabs.com/foros/tema-Un-clon-mas
Citar
#7
Perdón. El arduino a través de la ramps



Enviado desde mi Nexus 6 mediante Tapatalk
Citar
#8
busca en CloneWars "regulador arduino", hay tuto con fotos para que no vuelva a pasar.

Saludos... y sí, Shit happens Triste
Ulticampy V2: fundiendo plástico sin descanso...
Citar
#9
He puesto un nuevo arduino que me han prestado, y se ha quemado el lcd, esta todo raro, iconos y caracteres raros, quemado vamos... esta calentando la impresora ahora a ver si imprime, deberia hacerlo...
Citar
#10
Vuelvo a tener problemas, creo que he aislado el problema.resim
Si conecto la cama, el componente Q3 se pone caliente y echa algo de humo a la vez que la cama se calienta sola, si la desenchufo todo funciona perfectamente, aunque sin cama.
resim
La cama Mk3 tiene esa resistencia, tengo otra vieja una Mk2b, y tiene la misma resistencia, luego intuyo que está bien.

A ver si alguien me puede ayudar porfavor.

Enviado desde mi Nexus 6 mediante Tapatalk
Citar
#11
Creo que no tiene nada que ver pero por si te pudiese servir de ayuda a mí se me quemó el arduino de mi prusa i3 steel porque me tocaron las soldaduras de la placa con el chasis de la prusa y me hizo un corto, y a raíz de eso me quemó una de las resistencias de la cama caliente y también la tuve que cambiar, un desastre, pero fue culpa mía porque no me di cuenta de lo cerca que estaba la placa del chasis, no recuerdo porque, por el arduino va en soporte de plástico para evitar esto, un saludo.
Citar
#12
Q3 es el MOSFET de la cama, es normal que se ponga caliente cuando la enciendes XD. Refrigeras la electrónica con algo? Mínimo te recomendaría poner un disipador a ese FET, y si puedes refrigerar la electrónica con un ventilador, mejor.

Los MOSFET chinos suelen ser justitos en cuanto a características y dan ese tipo de problemas, pero aún pueden durarte años (mi caso, por ejemplo).

De todos modos, a cuanto alimentas la cama? no me cuadra mucho 12 ohms (si la vista no me falla, y podrías utilizar la escala de 200 xD).
NOVEDAD: CoreXY Eternal Edition (Custom) -> https://www.spainlabs.com/foros/tema-Ete...So-Edition
Mi Prusa i3, ¡con lista de componentes! -> http://www.spainlabs.com/foros/tema-Un-clon-mas
Citar
#13
Es una ramps SB, crei que no deberían calentarse tanto, llega a humear y derretirse. Por otra parte la cama se calienta sola, doy corriente, el Fet se pone hirviendo y la cama se calienta, eso no debería ocurrir, opino yo.
La cama a 12 voltios.


Enviado desde mi Nexus 6 mediante Tapatalk

(13-09-2016, 05:41 AM)morbat escribió: Creo que no tiene nada que ver pero por si te pudiese servir de ayuda a mí se me quemó el arduino de mi prusa i3 steel porque me tocaron las soldaduras de la placa con el chasis de la prusa y me hizo un corto, y a raíz de eso me quemó una de las resistencias de la cama caliente y también la tuve que cambiar, un desastre, pero fue culpa mía porque no me di cuenta de lo cerca que estaba la placa del chasis, no recuerdo porque, por el arduino va en soporte de plástico para evitar esto, un saludo.
Gracias, pero así lo tengo desde siempre. Superado del chasis.

Enviado desde mi Nexus 6 mediante Tapatalk
Citar
#14
En cuanto ese "FET" se quema, se queda en corto, y da paso a la cama desde que metes alimentación.

Ya te han dado la solución: poner disipador a ese FET y meter aire frío como un condenado. Ya me habrás visto aconsejar un ventilador de 120 mm en otros posts ¿verdad?. La versión "SB" mejora un par de cosas, pero no hace un rediseño completo de la placa, ese es el verdadero problema.

Saludos!
Ulticampy V2: fundiendo plástico sin descanso...
Citar
#15
El compañero de staticboards está por el foro. Es raro que se haya quemado el FET (aunque tiene toda la pinta), precisamente una de las características de las que se alardea con la SB es que el MOSFET es caro y bueno.
NOVEDAD: CoreXY Eternal Edition (Custom) -> https://www.spainlabs.com/foros/tema-Ete...So-Edition
Mi Prusa i3, ¡con lista de componentes! -> http://www.spainlabs.com/foros/tema-Un-clon-mas
Citar
#16
Tengo otra ramps igual en la delta, encerrada debajo de la cama caliente y va como el primer dia, con tan solo un ventilador de 40mm, supongo que haya sido mala suerte.... O no!
Ayer encontramos un corto en casa, chisporroteo, humo, cables al rojo que derritieron la tapa del registro... Pienso que ouede llevar ahi varios dias, y que como pertenece a una instalación que no se usa mucho, pues fue poco a poco.

De otra manera, he contactado con staticboards y se la voy a enviar esta semana.

Enviado desde mi Nexus 6 mediante Tapatalk
Citar
#17
Lo primero de todo, tienes el Mosfet quemado, como te han dicho arriba, un mosfet quemado se queda en corto, por tanto la cama caliente se calentaría nada más enchufar la impresora, debes cambiarlo, no hay mucha más ciencia. Tienes también la opción de cambiarlo y utilizar un relé en lugar del mosfet, el nuevo mosfet no se te calentaría ni lo más mínimo e incluso puede que te calentase la cama caliente un poco mejor... eso si, deberias utilizar bang bang como método de control de temperatura.

Conforme a las ramps chinas (y las de BQ, porque me ha pasado, sabe dios de donde viene esa placa), hay que tener cuidado, pues las pistas de potencia son muy finas y se acaban calentando tanto que se queman... yo he tenido que puentearlas con un cable de 2.5'' y desde aquella no tuve problemas, me quede sin los leds indicadores porque se quemaron hasta las vias, pero al menos, funciona.

Por otra parte, los conectores de tu ramps puede que no admitan la potencia exigida, los mios eran azules y, por lo que se ve, los muy majos de los ensambladores pusieron conectores de 5A, el resultado fue una ramps con conectores chamuscados... los sustituí por unos de 16A verdes con conexión desenchufable y listo... exactamente los mismos conectores que la alimentación.

Por parte del arduino, quizá te parezca una chapuza, pero con comprarte un LM7805 de inserción, soldarle unos cables y ponerle un pequeño disipador, puedes arreglar tu arduino... eso si no se ha chamuscado también por una mala regulación de la tensión... por lo que cuentas tiene toda la pinta de que el regulador no se apago solo al sobrecalentarse como debería haber hecho y dio más tensión de la debida

La pantalla LCD es muy propensa a jorobarse... la de mi impresora jamás se estropeo, pero tengo una gran caja de LCDs jorobadas en mi taller ahí tirada. Si te pone caracteres raros prueba a apagar completamente la impresora, esperar unos segundos y volver a conectarla, a veces loquean si conectas y desconectas la corriente muy rápido, aun así, la impresora debería poder operar perfectamente hasta con la pantalla desconectada, si la conectas a un ordenador, el mismo software te da toda la información necesaria sobre temperaturas, así que la pantalla es bastante prescindible.

Perdonad el tocho, pero creo adecuado que, dada tu preocupación por encontrar la impresora ardiendo algún día, te informe de l oque ocurre con ciertas ramps y has de cuidarte... a ninguno nos gusta que las cosas se quemen, y yo mismo, tras cada cambio que realizo en código o hardware, estoy nervioso hasta haberla probado en varias impresiones seguidas.
Citar
#18
Para los "caracteres extraños" en el LCD es un tema de aislamiento, se le puede poner papel de aluminio (sí, papel albal) enrollando cada cable que va desde el LCD a la RAMPS). Creo recordar hay dos medidas de esos cables, unos miden 20 cm (que no tiene ese fallo) y otros 30-50 cm que sí lo tienen. También intenta que otros cables no se crucen con los del LCD (sobre todo los de la cama).

Saludos!
Ulticampy V2: fundiendo plástico sin descanso...
Citar
#19
(18-09-2016, 01:27 PM)Lepes escribió: Para los "caracteres extraños" en el LCD es un tema de aislamiento, se le puede poner papel de aluminio (sí, papel albal) enrollando cada cable que va desde el LCD a la RAMPS). Creo recordar hay dos medidas de esos cables, unos miden 20 cm (que no tiene ese fallo) y otros 30-50 cm que sí lo tienen. También intenta que otros cables no se crucen con los del LCD (sobre todo los de la cama).

Saludos!

Exacto, eso ocurre debido a interferencias en los cables, al ser tan largos, a menos que le metas una malla de por ejemplo, papel albal, tal como dice Lepes, cualquier cosa, desde la regulacion pid de los hotends, o la cama.. o los propios motores, que son bobinas al fin y al cabo, interfieren.
Lo ideal, aparte de rodearlos con papel de aluminio, es soldarle a esa malla un cablecito que la una a masa (GND), si no lo haces, puede que ayude, puede que no...

Aun así, si se le ha suministrado más tensión de la debida a la pantalla, puede que también se haya frito una linea que lleva al micro que controla la pantalla internamente... y con una única linea jorobada, salen caracteres extraños.

Por otra parte, si sigues con los cables de serie, los cortos... revisa que las conexiones estén bien aseguradas, porque como te digo, si uno de los cables de datos está mal conectado, saldrán cosas raras...
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA (ENLACE)Problema Arduino Mega Clon, componente quemado USB Thulsa_Doom 3 231 13-08-2018, 06:30 PM
Último mensaje: Thulsa_Doom
  "Algo" se ha quemado... shazam 4 840 04-10-2017, 11:30 PM
Último mensaje: Davebrave
  Arduino 2560 quemado jukaramgon 17 1,497 12-06-2017, 01:38 AM
Último mensaje: gabrielchapita
  Conector corriente quemado kntrip 12 1,594 10-07-2016, 10:35 AM
Último mensaje: fbforos
  se me ha quemado el regulador del arduino mega 2650 powerjets83 1 1,332 12-12-2014, 01:25 PM
Último mensaje: monchofb