This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
El extrusor de mi artillery genius sube de temperatura sin parar
#1
Hola buenos días,
Espero que me puedan ayudar, ayer cuando enciendo mi impresora(artillery genius) la temperatura del extrusor empieza a subir sin control y no para, he cambiado el termistor y sigue pasando lo mismo.
¿Alguna idea de que puede pasar?

Muchas gracias
  Responder
#2
Yo tengo el mismo problema con la cama caliente de mi cr10 pro. Enciendo la impresora y empieza a subir la temperatura de la cama hasta el infinito. Y no me da ningún error la impresora.
Igual es el mosfet o un fusible quemado. Revisa si tienes un cortocircuito en el cableado.
A ver si alguien que sepa de electricidad te da otra respuesta, yo se poco de electrónica.
  Responder
#3
Hola, esos síntomas son típicos de que el mosfet que controla el calentador en cuestión se ha quemado, lo que habitualmente hace que se quede en cortocircuito y conduzca de forma continua.
Aparte de las soluciones lógicas, que son sustituir el mosfet dañado por uno nuevo (hay que utilizar el soldador) o la placa por una nueva, si se tiene soporte para doble extrusión (la Genius creo que sí, la CR-10 Pro depende del modelo que lleve) y no se utiliza el segundo extrusor, se puede utilizar su salida en sustitución de la del calentador que está fallando, para lo que hay que modificar la asignación de pines, lo que implica cargar un nuevo firmware en la placa.
  Responder
#4
(02-04-2021, 05:15 PM)Simemart escribió: Hola, esos síntomas son típicos de que el mosfet que controla el calentador en cuestión se ha quemado, lo que habitualmente hace que se quede en cortocircuito y conduzca de forma continua.
Aparte de las soluciones lógicas, que son sustituir el mosfet dañado por uno nuevo (hay que utilizar el soldador) o la placa por una nueva, si se tiene soporte para doble extrusión (la Genius creo que sí, la CR-10 Pro depende del modelo que lleve) y no se utiliza el segundo extrusor, se puede utilizar su salida en sustitución de la del calentador que está fallando, para lo que hay que modificar la asignación de pines, lo que implica cargar un nuevo firmware en la placa.

Y sabrías decirme que Mosfet necesitaría para la artillery genius y de algún esquema para realizar lo que indica de poner la salida del segundo extrusor
  Responder
#5
Si no me equivoco, la Artillery Genius trae una placa MKS Gen L V1.0.
Si es así, estos son los cuatro mosfets que controlan los conectores HE0, HE1, H-BED y FAN:

[Imagen: Img1.jpg]

Como se ve en esa foto, tres son del modelo RU3060L (Q1, Q2 y Q3) y el restante del modelo HY1804 (Q4): los primeros son de 30V/53A y el ultimo de 40V/80A.
No he encontrado el esquema de esa placa, pero es de suponer que el HY1804 es el que alimenta la cama caliente y los otros tres los dos hotends y el ventilador de capa.
Para saber cual es cual, solo tienes que mirar los leds que llevan a su lado (D1, D2, D3 y D4) y que se iluminan cuando se activan: el del HE0 lo tendrás iluminado siempre, dado que calienta de forma continua.
Para utilizar la salida HE1 en lugar de la HE0 para el hotend, no se necesita ningún esquema, pues solo tienes que conectarlo en dicha salida en lugar de la habitual, pero para que funcione correctamente, tienes que grabar en la placa un nuevo firmware en el que hayas intercambiado los pines asignados a esos dos conectores.
En concreto, esa placa utiliza el mismo pinout que la RAMPS (Cama el 8, fan el 9, hotend el 10), añadiendo la salida HE1 con el 7: por lo tanto, habría que intercambiar la asignación de la salida al hotend (10 por 7 y 7 por 10). Con eso se utilizará para el hotend la salida HE1 en lugar de la HE0.
Una cosa a tener en cuenta es que, aunque se haga esta modificación, el conector HE0 seguirá teniendo corriente y su led encendido, por lo que conviene tapar de alguna forma ese conector para evitar un cortocircuito accidental.
  Responder
#6
(02-04-2021, 09:28 PM)Simemart escribió: Si no me equivoco, la Artillery Genius trae una placa MKS Gen L V1.0.
Si es así, estos son los cuatro mosfets que controlan los conectores HE0, HE1, H-BED y FAN:

[Imagen: Img1.jpg]

Como se ve en esa foto, tres son del modelo RU3060L (Q1, Q2 y Q3) y el restante del modelo HY1804 (Q4): los primeros son de 30V/53A y el ultimo de 40V/80A.
No he encontrado el esquema de esa placa, pero es de suponer que el HY1804 es el que alimenta la cama caliente y los otros tres los dos hotends y el ventilador de capa.
Para saber cual es cual, solo tienes que mirar los leds que llevan a su lado (D1, D2, D3 y D4) y que se iluminan cuando se activan: el del HE0 lo tendrás iluminado siempre, dado que calienta de forma continua.
Para utilizar la salida HE1 en lugar de la HE0 para el hotend, no se necesita ningún esquema, pues solo tienes que conectarlo en dicha salida en lugar de la habitual, pero para que funcione correctamente, tienes que grabar en la placa un nuevo firmware en el que hayas intercambiado los pines asignados a esos dos conectores.
En concreto, esa placa utiliza el mismo pinout que la RAMPS (Cama el 8, fan el 9, hotend el 10), añadiendo la salida HE1 con el 7: por lo tanto, habría que intercambiar la asignación de la salida al hotend (10 por 7 y 7 por 10). Con eso se utilizará para el hotend la salida HE1 en lugar de la HE0.
Una cosa a tener en cuenta es que, aunque se haga esta modificación, el conector HE0 seguirá teniendo corriente y su led encendido, por lo que conviene tapar de alguna forma ese conector para evitar un cortocircuito accidental.

Muchísimas gracias por toda la información ahora cuando llegue a casa miro lo que me comentas y te digo si se ha solucionado todo, gracias de nuevo, voy a realizar lo que me comentas de cambiar los pines pero como grabo en el firewall lo que me indicas de cambiar la salida? Lo de tapar el HE0 te refieres a los cables?
  Responder
#7
Hola, vi el problema y debido a que a mi me paso algo similar hice un pequeño manual de como intercambiar pines en el marlin, se los comparto por si les sirve de algo.


Archivos adjuntos
.pdf   cambiar Pines en marlin.pdf (Tamaño: 643.99 KB / Descargas: 52)
  Responder
#8
(02-04-2021, 05:15 PM)Simemart escribió: Hola, esos síntomas son típicos de que el mosfet que controla el calentador en cuestión se ha quemado, lo que habitualmente hace que se quede en cortocircuito y conduzca de forma continua.
Aparte de las soluciones lógicas, que son sustituir el mosfet dañado por uno nuevo (hay que utilizar el soldador) o la placa por una nueva, si se tiene soporte para doble extrusión (la Genius creo que sí, la CR-10 Pro depende del modelo que lleve) y no se utiliza el segundo extrusor, se puede utilizar su salida en sustitución de la del calentador que está fallando, para lo que hay que modificar la asignación de pines, lo que implica cargar un nuevo firmware en la placa.


Sabes si existe alguna manera de medir el mosfet con un multímetro para confirmar si está quemado?, antes de ir a ponerle el cautín.
Gracias
  Responder
#9
Hola @Gusavo, bienvenid@ al foro.
Por supuesto que la hay, tienes varios ejemplos en Youtube, solo tienes que poner la frase "comprobar mosfet con multímetro" y obtendrás muchos videos explicando cómo hacerlo.
Pero en este caso, si la salida del calentador da corriente sin que esté ordenado un calentamiento (la pantalla de la impresora lo indica), el resultado de la comprobación es previsible y esta es más bien innecesaria.
  Responder
#10
(22-12-2021, 09:12 PM)Simemart escribió: Hola @Gusavo, bienvenid@ al foro.
Por supuesto que la hay, tienes varios ejemplos en Youtube, solo tienes que poner la frase "comprobar mosfet con multímetro" y obtendrás muchos videos explicando cómo hacerlo.
Pero en este caso, si la salida del calentador da corriente sin que esté ordenado un calentamiento (la pantalla de la impresora lo indica), el resultado de la comprobación es previsible y esta es más bien innecesaria.

Hola, mira que así como lo mencioné anteriormente, en la pantalla el ventilador estaba en 0 pero en el extrusor estaba girando, sin embargo después de desarmar todo el extrusor y volverlo a armar hoy vino a funcionar como debería, ya se puede apagar y encender desde la pantalla y no volvió a dar problemas, estoy pensando que puede haber sido alguna interferencia cuando conecté la impresora al pc y traté de moverla desde Pronterface.

Gracias por responderme y estaré comentando cualquier cosa.

¡Saludos!
  Responder
#11
Hola amigos tengo el mismio problema con el extrusor cuando enciendo mi impresora(artillery genius) la temperatura del extrusor empieza a subir sin control y no para, he cambiado el termistor y sigue pasando lo mismo...y entonces segí todos los pasos q aquí pusieron pero el Marlin me da error al copilarlo en Arduino. Como puedo resolver esto?

De antemano Gracias
  Responder
#12
Hola @pepe.tresde, bienvenido al foro.
Para poder indicarte algo con propiedad, tendrás que dar más información sobre qué versión de Marlin estás compilando y una pantalla donde se vea el error que se produce.
Como se indica en este post, si el calentador del hotend funciona en cuanto se enciende la impresora, el problema es del mosfet que controla dicho calentador y las posibles soluciones son las que comento en la respuesta #3.
  Responder
#13
(05-04-2022, 05:22 PM)Simemart escribió: Hola @pepe.tresde, bienvenido al foro.
Para poder indicarte algo con propiedad, tendrás que dar más información sobre qué versión de Marlin estás compilando y una pantalla donde se vea el error que se produce.
Como se indica en este post, si el calentador del hotend funciona en cuanto se enciende la impresora, el problema es del mosfet que controla dicho calentador y las posibles soluciones son las que comento en la respuesta #3.

Buen día ya logre comunicar el Arduino con la impresora Artillery genius compile la nueva version de Marlin modficado, sollo tengo una duda sobre la tarjeta fisica: ¿Tengo que deconectar el conector HE1 para que no se siga sobrecalentando el Mosfet dañado? o lo dejo conectado? de antemano gracias por su respuesta Sisi1
  Responder
#14
Hola, entiendo que el mosfet dañado en tu placa es el que controla la salida HE0 y no debería calentarse si no hay nada conectado en esa salida.
La salida HE1 es la que hay que utilizar en sustitución de la HE0 para conectar el hotend, realizando la modificación indicada en el archivo de pines de la placa: como es lógico, deben estar conectados en ella los cables del calentador del hotend.
  Responder
#15
(20-04-2022, 09:42 AM)Simemart escribió: Hola, entiendo que el mosfet dañado en tu placa es el que controla la salida HE0 y no debería calentarse si no hay nada conectado en esa salida.
La salida HE1 es la que hay que utilizar en sustitución de la HE0 para conectar el hotend, realizando la modificación indicada en el archivo de pines de la placa: como es lógico, deben estar conectados en ella los cables del calentador del hotend.

Hola de nuevo ya hice los cambios en el Marlin, pero abrí el Arduino pra copilarse, no puedo hacer que Arduino me reconozca el puerto donde conecto mi Artillery, Creen que puedan hacer favor de ayudarme con esto?
  Responder
#16
Lo primero que debes hacer es comprobar si el ordenador detecta la conexión de la placa por USB y le asigna un puerto COM, para lo que debes abrir el Administrador de dispositivos, conectar el cable USB a la impresora y encienderla: debe producirse un cambio en el Administrador y aparecer un nuevo dispositivo en el apartado Puertos COM y LPT.
Si no aparece, puede ser debido a que la placa esté dañada, que el cable esté defectuoso o mal el puerto USB: si cambiando de cable y de puerto USB en el ordenador no se soluciona, seguramente sea la placa y tendrás que sustituirla.
Si aparece, el puerto COM que se le asigne a la impresora, es el que tienes que configurar en el IDE de Arduino.
  Responder
#17
[Imagen: Clipboard01.png][Imagen: Clipboard02.jpg]




disculpa no se porque se instalan muchos puertps usb si milaptop solo tiene 3 y en cualquiera q trato de copilar el Marlin al final me sale error
  Responder
#18
Hola, esos puertos que se muestran en la captura de pantalla, no son USB sino COM y aunque algunos dispositivos USB se manejan mediante esos puertos (como la placa de la impresora), no son equivalentes.
Ninguno de esos puertos corresponde a la impresora, por lo que es normal que no te funcionen para subir el firmware compilado a la misma: ¿se crean al conectarla o ya están presentes sin que la impresora este conectada?
Por lo que se muestra, parecen corresponder a un dispositivo Bluetooth, que por cierto parece que no tiene correctamente instalado el driver (aparece en el apartado Otros dispositivos como Dispositivo periférico Bluetooth): en todo caso, la impresora no aparece en esa pantalla.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Temperatura motor extrusor 21Curiosos 4 133 03-07-2022, 02:52 PM
Último mensaje: Simemart
  Ruleman/Rodamiento Extrusor Artillery Genius gnasmanya 1 257 11-12-2021, 04:05 PM
Último mensaje: Simemart
  CONSULTA Extrusor Artillery Genius gnasmanya 2 290 11-12-2021, 09:13 AM
Último mensaje: gnasmanya
  DUDA Problema eje z, sube en vez de bajar Alex001 5 1,530 28-03-2020, 03:46 PM
Último mensaje: Simemart
  DUDA motores del eje Z sin fuerza, cambio de drivers nico1234 2 1,469 12-10-2019, 07:40 PM
Último mensaje: hondapa