Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Ajuste de los pololus en caliente
#1
Buenas

Yo conocía, de mis investigaciones previas que había otro método para calibrar los pololus, que no incluía desmontar toda la electrónica y estar reseteando la placa cada dos por tres, sino que hacías una lectura en vivo desde el propio pololu para saber el amperaje entregado instantáneo.

El método está descrito aqui:

http://reprap.org/wiki/Pololu_stepper_driver_board

Ahora me falta por saber, exactamente, que modelo de pololu tenemos nosotros (los de la conjunta) ¿ghosthawk? ¿alguien? Lengua
Citar
#2
Las discusiones de como hacer las cosas nos pasa por no leer bien antes jajaja

Los pololus de la conjunta no son estos A4988?¿ Pregunto
Citar
#3
tanto los pololu como los stepsticks usan el A4988 (aunque hay mas chips tb en otros modelos), incluso visualmente parecen tener el mismo esquema, por lo que supongo que la diferencia es solo el numero interno de capas para aguantar mas o menos corriente, y quizas el valor de alguna resistencia para soportar mas o menos corriente.

Los de la conjunta son stepstiks, los famosos de geeetech morados son pololus, aunque tb tienen otros mas baratos rojos que son stepsticks. Todos con el A4988.

Alguien ha calculado cual es la corriente que se entrega al motor cuando el multimetro a la entrada de la electronica marca 200 y 400?
Citar
#4
Yo voy a intentar hacerlo esta tarde
Citar
#5
Bueno ya he realizado la medida en mis pololus. Hay que medir la VREF asi:

resim

Y tengo:
En los pololus con 200mA VREF= 0.518
En los pololus con 400mA VREF= 0.730

Cita:VREF max = (TrimpotMaxR/(TrimpotMaXR+R5)) x VDD = (100,000 / (100,000 + 20,000)) * 5 = 4.16V
ITripMAX (effectively max motor current) = VREF / ( 8 x Sense_resistor) = 4.16 / ( 8 * 0.05 ) = 10.4A

To calculate amps from measured VREF: A = VREF / 0.4
To calculate VREF required for a target current: VREF = A * 0.4

Luego

A = 0.518 / 0.4 = 1.295 Amperios (para x e y)
A = 0.730 / 0.4 = 1.825 Amperios (para z y extrusor)

Esos son los valores que coinciden con los de la calibracion de la corriente a la entrada de la electronica, por si alguien lo quiere ajustar asi.

Ah, tal cual dice la wiki, para los stepsticks de la conjunta, el valor se ha de multiplicar por 4. Ya que el valor de RS de los pololus es 0.05 pero el de los stepsticks de 0.2. La formula seria:

Vref = A * 8 * RS.

A= VREF / 1.6 para stepsticks.
Citar
#6
OverCraft escribió:Bueno ya he realizado la medida en mis pololus. Hay que medir la VREF asi:

resim

Y tengo:
En los pololus con 200mA VREF= 0.518
En los pololus con 400mA VREF= 0.730

Cita:VREF max = (TrimpotMaxR/(TrimpotMaXR+R5)) x VDD = (100,000 / (100,000 + 20,000)) * 5 = 4.16V
ITripMAX (effectively max motor current) = VREF / ( 8 x Sense_resistor) = 4.16 / ( 8 * 0.05 ) = 10.4A

To calculate amps from measured VREF: A = VREF / 0.4
To calculate VREF required for a target current: VREF = A * 0.4

Luego

A = 0.518 / 0.4 = 1.295 Amperios (para x e y)
A = 0.730 / 0.4 = 1.825 Amperios (para z y extrusor)

Esos son los valores que coinciden con los de la calibracion de la corriente a la entrada de la electronica, por si alguien lo quiere ajustar asi.

Ah, tal cual dice la wiki, para los stepsticks de la conjunta, el valor se ha de multiplicar por 4. Ya que el valor de RS de los pololus es 0.05 pero el de los stepsticks de 0.2. La formula seria:

Vref = A * 8 * RS.

A= VREF / 1.6 para stepsticks.

Inicialmente ajusté los míos así también, pero luego ni de coña podían mover los motores y tocó ponerlos a tope... ¿A ti te van bien con este ajuste? ¿Tus drivers son los mismos que los de la conjunta o los has comprado en otro lado?

Un saludo.
Citar
#7
Los drivers que tengo pimchados son los de geeetech si, no los de la conjunta. Puedes hacer una tabla con los vref ke obtienes con tu calibracion para ver como de equivalente es?
Citar
#8
Los de la conjunta al minimo dan 0v, a la mitad 0.85/0.89v y al maximo 1,82/1,61v
Citar
#9
Dudas de novato

¿La medida que se hace entre el tornillo de ajuste y la primera pata? siempre es asi? o depende del driver?

Los de la conjunta para que estén en 200 y 400 tendrían que dar 0.32 y 0.64 respectivamente?
Citar
#10
No merece la pena que tratéis de buscar una equivalencia entre medida real y lo que dice el polímetro porque no la vais a sacar. Uno de los pololus de nuestra impresora el polímetro mide 400mA y es de los stepsticks limitados a 1A. Con eso lo digo todo.

La medida que da el polímetro es simplemente falsa y dependiente de polímetro a polímetro así que tratar de buscar relaciones inexistentes solo va a servir para confundir a la gente y continuar con los problemas que estaba habiendo de gente creyendo que los pololus suyos estaban defectuosos.

Símplemente lo que hay que hacer es divulgar el método correcto de medida y dejarse de chorradas.
Citar
#11
erdabyz escribió:No merece la pena que tratéis de buscar una equivalencia entre medida real y lo que dice el polímetro porque no la vais a sacar. Uno de los pololus de nuestra impresora el polímetro mide 400mA y es de los stepsticks limitados a 1A. Con eso lo digo todo.

La medida que da el polímetro es simplemente falsa y dependiente de polímetro a polímetro así que tratar de buscar relaciones inexistentes solo va a servir para confundir a la gente y continuar con los problemas que estaba habiendo de gente creyendo que los pololus suyos estaban defectuosos.

Símplemente lo que hay que hacer es divulgar el método correcto de medida y dejarse de chorradas.

Al principio pensaba que la modulacion seria mas leve, pero por lo visto se pasa mas del 60% en bajo y el multimetro no es una medida muy fiable, aunque es una referencia. Es cierto que los pololus dan mas corriente con el multimetro que los stepsticks de la conjunta, pero al medirlo de la otra forma calculando el VREF, dan aun mas del doble o triple de corriente de salida modulada tambien, por lo que la medida sienda incorrecta, sigue siendo una referencia.

El problema ahora es, vale ahora sabemos como medir los drivers con mas precision. Pero cual es la corriente a la que tenemos que ajustar los motores? No creo que calculando una corriente de 400 mA reales con el metodo del VREF el motor funcione correctamente. Mas teniendo en cuenta que con 400mA mal medidos a la entrada, mis drivers dan una medida real de mas de 1800mA. A cuanto deberian funcionar, a 1500A como medida fiable? 1200A? 1000A? Esta claro que menos no, xk aunque el metodo antiguo no fuera fiable, si que era una referencia. Ahora tendremos que buscar el valor adecuado para que no pierda pasos.

Si encontramos unas medidas buenas para todos, grabo un video explicandolo todo.
Citar
#12
OverCraft escribió:
erdabyz escribió:No merece la pena que tratéis de buscar una equivalencia entre medida real y lo que dice el polímetro porque no la vais a sacar. Uno de los pololus de nuestra impresora el polímetro mide 400mA y es de los stepsticks limitados a 1A. Con eso lo digo todo.

La medida que da el polímetro es simplemente falsa y dependiente de polímetro a polímetro así que tratar de buscar relaciones inexistentes solo va a servir para confundir a la gente y continuar con los problemas que estaba habiendo de gente creyendo que los pololus suyos estaban defectuosos.

Símplemente lo que hay que hacer es divulgar el método correcto de medida y dejarse de chorradas.

Al principio pensaba que la modulacion seria mas leve, pero por lo visto se pasa mas del 60% en bajo y el multimetro no es una medida muy fiable, aunque es una referencia. Es cierto que los pololus dan mas corriente con el multimetro que los stepsticks de la conjunta, pero al medirlo de la otra forma calculando el VREF, dan aun mas del doble o triple de corriente de salida modulada tambien, por lo que la medida sienda incorrecta, sigue siendo una referencia.

El problema ahora es, vale ahora sabemos como medir los drivers con mas precision. Pero cual es la corriente a la que tenemos que ajustar los motores? No creo que calculando una corriente de 400 mA reales con el metodo del VREF el motor funcione correctamente. Mas teniendo en cuenta que con 400mA mal medidos a la entrada, mis drivers dan una medida real de mas de 1800mA. A cuanto deberian funcionar, a 1500A como medida fiable? 1200A? 1000A? Esta claro que menos no, xk aunque el metodo antiguo no fuera fiable, si que era una referencia. Ahora tendremos que buscar el valor adecuado para que no pierda pasos.

Si encontramos unas medidas buenas para todos, grabo un video explicandolo todo.

De hecho en el post explicación que hice exageré un poco las cosas, me di cuenta más tarde. Los A4988 usan un método de limitación de corriente algo más sutil de lo que expliqué, en realidad lo que ajustas con Vref es la corriente a la que salta el limitador, no la corriente media. Según el modo de microstepping en que esté el A4988 este se ajusta para cortar la corriente de forma más suave o más brusca y de eso depende el valor medio de la corriente final aplicada al motor. En modo normal de funcionamiento con los motores que tenemos la corriente media inyectada al motor debería ser sobre el 95% de la corriente ajustada con Vref. En cualquier caso ajustar con Vref es lo que se tiene que hacer. La cosa es que la corriente que piden los drivers no es tan impulsiva como dije y con los condensadores que llevan los drivers a la entrada la corriente demandada en global debería ser casi continua. Pero ojo ojo, que los motores son cargas inductivas y los multímetros en modo corriente tienen cierta resistencia interna para medir la corriente justamente, y los cutremultímetros NO son precisos en corrientes bajas midiendo en modo de 10A aparte de que aunque en teoría deberían sacar el valor medio la realidad es que como haya guarrería (y las cargas inductivas meten guarrería) ya habéis visto que cualquier parecido de lo que miden con la realidad es pura coincidencia.

Mi recomendación respecto a la corriente sería que la gente pusiera todos los drivers a tope (si son los de la compra conjunta, si son los normales que van a la mitad que los ajusten a 1A por fase) y fuera. Así los motores van a ir por debajo de 1A por fase, que es menos de la mitad de la corriente para la que están diseñados y no se deberían calentar demasiado. Es muy difícil quemar los drivers (tienen protección térmica y si hay gente que se los ha cargado probablemente la causa sea mucho más oscura que un simple calentón durante el funcionamiento normal de la máquina) y con 1A no se calientan demasiado si la prusa está bien ventilada. Si con eso la impresora les pierde pasos es que hay algo muy muy mal montado o hay muy muy mala suerte.

Por subir la corriente lo que haces es que el motor responda más rápido y con más precisión pero se caliente más. Yo creo que 1A por fase está bien como compromiso y es bien fácil de ajustar. Aparte que si los motores son los que dice Ghosthawk que son tampoco hay mucho más margen de maniobra alimentándolos a 12V cuando la resistencia por fase de las bobinas es de 1,25 ohm.

EDIT: Overcraft, ten en cuenta que con el polímetro en todo caso estarías midiendo la corriente de las DOS fases del motor, y mirando el datasheet del A4988 con un motor parado y nada más arrancarlo lo que se estaría midiendo en realidad sería el 70,7% de la corriente por las dos fases del motor. Con la corriente limitada por fase a 1A (driver a tope) la gente ha estado midiendo entre 200 y algo más de 400mA cuando la corriente real sería 2x0,707=1,41A. El error es bastante mayor del 60% xD.
Citar
#13
De todas maneras, no le veo el sentido de saber el amperaje exacto del controlador del PaP si al final lo estamos ajustando a ojo "para que no pierda pasos"

Yo lo he dejado a ojo, subiendo hasta que no perdía pasos y verificando que no se caliente mucho con poco uso (tras un rato imprimiendo es normal que se pongan a tope) y aún así sólo perdía poquitos pasos el eje Y.

Luego le casqué un ventilador de 75mm encima y ahora van de lujo. Frescos frescos y no pierden ni un paso, que es lo que deberíais de hacer.
Citar
#14
Por aquí otro con problemas. He montado un extrusor directo y como ya suponía antes de hacerlo no hay forma de hacerlo funcionar, le falta potencia aún estando el driver al máximo.

De que forma se puede solucionar? Puenteando el potenciómetro para subir vref? No me hace nada de gracia tener que comprar dirvers nuevos porque estos no funcionen como deberían.
Citar
#15
hinjeniero escribió:Por aquí otro con problemas. He montado un extrusor directo y como ya suponía antes de hacerlo no hay forma de hacerlo funcionar, le falta potencia aún estando el driver al máximo.

De que forma se puede solucionar? Puenteando el potenciómetro para subir vref? No me hace nada de gracia tener que comprar dirvers nuevos porque estos no funcionen como deberían.
Por lo que sé, para esos extrusores se usan nema más gordos de los 17 (21?) o con la reductora integrada.
Citar
#16
Alguno si he visto pero mayoría usan el Nema 17 (de hecho apenas hay extrusores para nema 21) y no me extraña porque el 17 tiene fuerza de sobra. Ni el driver ni el motor están calientes ajustados al máximo por lo tanto lo mismo me daría poner un 21.
Citar
#17
Bueno he pedido un par de DRV8825 cuyo funcionamiento es el mismo pero pueden proporcionar mas intensidad. Además son de Texas Instruments, marca en la que confío infinitamente mas que en Allegro (de hecho ni a conocía).

Mientras tanto paso de esperar a que me lleguen y voy a modificar los que tengo cambiando el potenciometro de 20k a 30k que son los que tengo a mano.

resim


Lo sé las soldaduras dan asco pero mi JBC ha muerto (no, no son indestructibles) he tenido que echar mano del tipico soldador de 3€ de ebay.
Citar
#18
hinjeniero escribió:Bueno he pedido un par de DRV8825 cuyo funcionamiento es el mismo pero pueden proporcionar mas intensidad. Además son de Texas Instruments, marca en la que confío infinitamente mas que en Allegro (de hecho ni a conocía).

No se qué experiencia profesional tienes, pero si no conoces a Allegro es que no es muy larga... En cualquier caso Texas Instruments y Allegro Mycrosystems no se pueden comparar, una tiene menos de 1.000 empleados y la otra más de 30.000, pero eso no quiere decir que Allegro sea peor, solo que tiene una gama y mercado más acotado. Por ponerte un ejemplo, la gran mayoría de sensores de efecto hall acaban siendo de Allegro. Mola Mola Mola

Si te interesa compararlas desde el punto de vista financiero:
- http://www.insideview.com/directory/alle...ystems-inc
- http://www.insideview.com/directory/texa...corporated
Citar
#19
Experiencia profesiona nula, aún estoy en la universidad.

No digo que TI sea peor o mejor que Allegro solo que esta última no me inspira tanta confianza. Del mismo modo que Yageo no me inspira la misma confianza que Nichicon, o durex que condones carrefour.

Pero de todos modos desarollar un integrado es un trabajo para el cual se necesita un equipo extremadamente cualificado de modo que lo fabrique quien lo fabrique no debería fallar por cuestiones de mal diseño, aunque esa es la teoría.

Aún así está bien saber que hay vida más allá de TI, Maxim, Analog Devices, ST, NS,...



Volviendo al tema del hilo, he probado con el controlador modificado y no ha servido, funciona exactamente igual hasta 2/3 partes del recorrido del potenciometro (obviamente porque se corresponde con 20k) y a partir de ahí no sabría decir si da más o menos potencia pero aparece el tipico sonido de bobinas y los motores se comportan de forma extraña. También se calienta mucho más el integrado.

Tendré que esperar al DVR8825.
Citar
#20
hinjeniero escribió:Experiencia profesiona nula, aún estoy en la universidad.

No digo que TI sea peor o mejor que Allegro solo que esta última no me inspira tanta confianza. Del mismo modo que Yageo no me inspira la misma confianza que Nichicon, o durex que condones carrefour.

Pero de todos modos desarollar un integrado es un trabajo para el cual se necesita un equipo extremadamente cualificado de modo que lo fabrique quien lo fabrique no debería fallar por cuestiones de mal diseño, aunque esa es la teoría.

Aún así está bien saber que hay vida más allá de TI, Maxim, Analog Devices, ST, NS,...



Volviendo al tema del hilo, he probado con el controlador modificado y no ha servido, funciona exactamente igual hasta 2/3 partes del recorrido del potenciometro (obviamente porque se corresponde con 20k) y a partir de ahí no sabría decir si da más o menos potencia pero aparece el tipico sonido de bobinas y los motores se comportan de forma extraña. También se calienta mucho más el integrado.

Tendré que esperar al DVR8825.

vigila porque el pinout no se corresponde, yo intenté montar esos DRV8825 en PCBs propias cuando aun no habian salido los de Pololu y es una odisea si los quieres en plan "casero"
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Problema al Regular pololus Agustin 6 616 29-12-2016, 10:18 PM
Último mensaje: Agustin
  Consumos ajuste pololus urkot666 12 1,954 27-04-2016, 03:45 PM
Último mensaje: urkot666
  Conexión de los pololus al revés nmsolutions 1 789 17-10-2015, 03:38 PM
Último mensaje: nmsolutions
  Problema al calibrar pololus. Manu3l 17 2,758 24-09-2015, 04:11 PM
Último mensaje: sifou
  Ajuste pasos eje z Furonet 1 1,249 27-02-2015, 12:19 AM
Último mensaje: IsMaxice