This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
problema marlin mks robin nano 1.2
#1
buenas tardes a todos, hace poco me registre pero llevo tiempo sigueido el foro y usando la información tal util que encuentro en el
 
bueno he montado una impresora cartesiana con una placa mks robin nano 1.2 y pantalla tft de 3.5 mi problema es primero que no soy capas de compilar marlin de ninguna manera, he intentado con varios y nada no soy capaz de hecho incluso alguno que ya esta configurado no me lo compila y me da errores cada vez diferentes, lo ultimo ha sido solucionar todos los errores y me manda este mensaje de error 

PS C:\Users\cadds\OneDrive\Escritorio\Marlin-2.0.X-SapphirePro-3.5TFT (MEDIO CONFIGURADO)> platformio run --silent -e mks_robin_nano
Warning! Ignore unknown configuration option `build_src_filter_flags` in section [env:linux_native]
UnknownPlatform: Unknown development platform 'PackageItem <path=C:\Users\cadds\.platformio\platforms\ststm32 metadata=PackageMetadata <type=platform name=ststm32 version=5.6.0 spec={'owner': 'platformio', 'id': 8020, 'name': 'ststm32', 'requirements': None, 'uri': None}'
PS C:\Users\cadds\OneDrive\Escritorio\Marlin-2.0.X-SapphirePro-3.5TFT (MEDIO CONFIGURADO)> echo "done" >"C:\Users\cadds\AppData\Local\Temp\ipc"
PS C:\Users\cadds\OneDrive\Escritorio\Marlin-2.0.X-SapphirePro-3.5TFT (MEDIO CONFIGURADO)>

soy principiante y no tengo ni idea, en segundo lugar, consigo configurar a traves de la pantalla todos los parametros y cuando conecto el sensor de temperatura del hotend me da error en un ntc de 100k 3590 y me marca 360 grados, no se cual sera el problema ya que es nuevo, muchas gracias de antemano y un saludo
  Responder
#2
Hola @CADDS, bienvenid@ al foro activo.
Por lo que veo en esos mensajes de error, tienes los archivos en una ubicación (\OneDrive\Escritorio\) que puede ser una fuente de problemas al realizar la compilación y creo recordar que respondí la consulta de otro usuario que tuvo este mismo problema y utilizaba ese mismo almacenamiento: coloca la carpeta de Marlin en una ubicación local de tu equipo y que no esté dentro del perfil de usuario; por ejemplo, en una carpeta creada directamente en C:\.
Por cierto, ¿qué Marlin estás utilizando? Porque ese nombre de carpeta (Marlin-2.0.X-SapphirePro-3.5TFT (MEDIO CONFIGURADO)) parece indicar una versión para otra impresora: te recomiendo que descargues la última versión (2.1.x) de Marlin de su página oficial, y que la configures de cero para tu máquina.
Si necesitas ayuda para hacerlo, no dudes en pedirla por aquí.
El problema de temperatura puede ser debido a que tengas mal configurado en Marlin el sensor de temperatura (supongo que quieres decir un NTC 100K 3950, que en Marlin debería ir bien como 1 o 5) o a que estén en corto sus cables (a menor resistencia, mayor temperatura indicada).
  Responder
#3
(13-09-2023, 08:58 PM)Simemart escribió: Hola @CADDS, bienvenid@ al foro activo.
Por lo que veo en esos mensajes de error, tienes los archivos en una ubicación (\OneDrive\Escritorio\) que puede ser una fuente de problemas al realizar la compilación y creo recordar que respondí la consulta de otro usuario que tuvo este mismo problema y utilizaba ese mismo almacenamiento: coloca la carpeta de Marlin en una ubicación local de tu equipo y que no esté dentro del perfil de usuario; por ejemplo, en una carpeta creada directamente en C:\.
Por cierto, ¿qué Marlin estás utilizando? Porque ese nombre de carpeta (Marlin-2.0.X-SapphirePro-3.5TFT (MEDIO CONFIGURADO)) parece indicar una versión para otra impresora: te recomiendo que descargues la última versión (2.1.x) de Marlin de su página oficial, y que la configures de cero para tu máquina.
Si necesitas ayuda para hacerlo, no dudes en pedirla por aquí.
El problema de temperatura puede ser debido a que tengas mal configurado en Marlin el sensor de temperatura (supongo que quieres decir un NTC 100K 3950, que en Marlin debería ir bien como 1 o 5) o a que estén en corto sus cables (a menor resistencia, mayor temperatura indicada).

buenas y muchas gracias por tu respuesta, el marlin he probado con varios, ese es uno que me descargue de un usuario que ya lo habia configurado y compilado y queria probar en mi pc si lo compilaba pero  no hay manera, siempre me da algún error. voy a probar lo que me comentas de la carpeta y a ver que me dice el programa, en cuanto a la sonda de temperatura lo solucione desmontandola y resulta que los bales estaban tocandose y hacian corto se iva a resistencia minima y temperatra maxima, en lo que haga las pruebas lo comento por aqui
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
Pregunta CONSULTA MKS GEN L V1.0 + TMC22XX MrGrafeno 3 91 30-05-2024, 06:25 PM
Último mensaje: Simemart
Pregunta CONSULTA mks tinyBee y ts35 nesdewilde 1 61 22-04-2024, 10:03 AM
Último mensaje: Simemart
  MKS GEN L V1.0 5v sin corriente jarping 2 61 10-09-2023, 02:17 PM
Último mensaje: jarping
  mks gen l v 2.1 piranin 6 1,387 12-08-2022, 06:24 PM
Último mensaje: frank.sosa
  Pantalla mks tft70 V1. 1 en plaça btt octopus pro 21Curiosos 1 328 12-04-2022, 01:19 AM
Último mensaje: Simemart