This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA Ayuda configuracion autonivelacion delta
#1
Hola soy nuevo y tengo poco conocimiento, arme una impresora delta con mucho esfuerzo, la cual imprime bastante bien, pero con algunos problemas de nicelavion instale un censor de proximidad inductivo en pin zmin, el sensor se activa al llegar a la cana de aluminio pero no se detiente la impresora. El marlin es version 1 .1.3 me pidrian ayudar a configurar
  Responder
#2
Hola @siroloco, bienvenido al foro.
Las impresoras con mecánica tipo Delta no son la más recomendables para usuarios inexpertos, pues su funcionamiento no es tán intuitivo como en el caso de las de tipo cartesiano.
En concreto, difieren bastante en los apartados motivo de tu consulta: el homing y la utilización de un sensor de nivelación.
En estos modelos, el homing siempre se realiza en la posición MAX de los ejes y se ejecuta al mismo tiempo para XYZ: es decir, en la parte alta de la impresora, que es donde se encuentran los finales de carrera, uno en cada una de las tres columnas.
El sensor, si se tiene, solo se utiliza para la funcionalidad de autocalibración que tienen estas impresoras y que hay que activar en el firmware, pues viene desactivada por defecto.
Por todo ello, no tiene mucho sentido indicar que no se detiene la impresora al activarse el sensor, pues no es esa su función, así que mi recomendación es que instales la última versión de Marlin, descargada de su página oficial, que tendrás que configurar de forma apropiada a las medidas y componentes de tu impresora.
En todo caso, si el único problema que tienes es la nivelación de la cama, quizá sería mejor que liarse con la colocación del sensor, intentar hacer una buena nivelación, pues en este tipo de impresoras de cama fija, una vez conseguida no debería variar con el uso.
Si adjuntas los archivos de configuración que estás utilizando ahora (Configuration.h y Configuration_adv.h, incluyéndolos los dos en un archivo comprimido), quizá pueda indicarte si hay algo incorrecto en la configuración que estás usando.
  Responder
#3
Fotografía 
(17-08-2022, 01:32 PM)Simemart escribió: Hola @siroloco, bienvenido al foro.
Las impresoras con mecánica tipo Delta no son la más recomendables para usuarios inexpertos, pues su funcionamiento no es tán intuitivo como en el caso de las de tipo cartesiano.
En concreto, difieren bastante en los apartados motivo de tu consulta: el homing y la utilización de un sensor de nivelación.
En estos modelos, el homing siempre se realiza en la posición MAX de los ejes y se ejecuta al mismo tiempo para XYZ: es decir, en la parte alta de la impresora, que es donde se encuentran los finales de carrera, uno en cada una de las tres columnas.
El sensor, si se tiene, solo se utiliza para la funcionalidad de autocalibración que tienen estas impresoras y que hay que activar en el firmware, pues viene desactivada por defecto.
Por todo ello, no tiene mucho sentido indicar que no se detiene la impresora al activarse el sensor, pues no es esa su función, así que mi recomendación es que instales la última versión de Marlin, descargada de su página oficial, que tendrás que configurar de forma apropiada a las medidas y componentes de tu impresora.
En todo caso, si el único problema que tienes es la nivelación de la cama, quizá sería mejor que liarse con la colocación del sensor, intentar hacer una buena nivelación, pues en este tipo de impresoras de cama fija, una vez conseguida no debería variar con el uso.
Si adjuntas los archivos de configuración que estás utilizando ahora (Configuration.h y Configuration_adv.h, incluyéndolos los dos en un archivo comprimido), quizá pueda indicarte si hay algo incorrecto en la configuración que estás usando.

hola como estas, te agradezco infinitamente que me hayas contestado estoy un poco desilucionado hace semana que vengo lidiando con esto y no me sale mirando tutoriales y estudiando, y luchado mucho con la cama no pudiendo nivelarla nunca talves tenga algun desfasaje en torres o finales de carrer, por eso me decidi a poner sensor inductivo,  bueno la verdad quisiera mandarte los archivos pero me dice que los archivos no se pueden subir cuando intento cargarlos tal ves porque soy nuevo en el foro, ahi los edite y les cambie la extencion por .txt espero que los puedas ver.
[Imagen: 20220817-194122.jpg]

[Imagen: 20220817-194117.jpg]
te adjunto unas fotos de mi impresora casera con el sensor actibado y no se si sepuede te pasaria el texto del archiovo por aca o si me deja te lo mando por mensaje privado.-este es mi Email por si queres pasarme el tuyo para mandarte los archivos


.txt   Configurationh.txt (Tamaño: 43.82 KB / Descargas: 6)
.txt   Configuration_advh.txt (Tamaño: 27.4 KB / Descargas: 2)
  Responder
#4
Hola, como ya te indiqué, la mejor forma de adjuntar archivos sin problema es incluirlos en un archivo comprimido (ZIP o RAR).
La versión de Marlin que estás utilizando es muy antigua y está completamente obsoleta, deberías cambiar a la última versión: en todo caso, no veo nada que impida funcionar de forma correcta el sensor, aunque con estas versiones tan antiguas es difícil saber si falta algo.
Viendo tu impresora, me temo que tus problemas se deben más a la estabilidad de la estructura que a cualquier otra cosa.
  Responder
#5
(18-08-2022, 10:18 AM)Simemart escribió: Hola, como ya te indiqué, la mejor forma de adjuntar archivos sin problema es incluirlos en un archivo comprimido (ZIP o RAR).
La versión de Marlin que estás utilizando es muy antigua y está completamente obsoleta, deberías cambiar a la última versión: en todo caso, no veo nada que impida funcionar de forma correcta el sensor, aunque con estas versiones tan antiguas es difícil saber si falta algo.
Viendo tu impresora, me temo que tus problemas se deben más a la estabilidad de la estructura que a cualquier otra cosa.

Hola, te agradezco haberme ayudadado voy a actualizar marlin y darle mas rigidez a la estructura, y si no funcionara volvere a pedir ayuda. Desde ya muchas gracias por todo
  Responder
#6
(18-08-2022, 10:18 AM)Simemart escribió: Hola, como ya te indiqué, la mejor forma de adjuntar archivos sin problema es incluirlos en un archivo comprimido (ZIP o RAR).
La versión de Marlin que estás utilizando es muy antigua y está completamente obsoleta, deberías cambiar a la última versión: en todo caso, no veo nada que impida funcionar de forma correcta el sensor, aunque con estas versiones tan antiguas es difícil saber si falta algo.
Viendo tu impresora, me temo que tus problemas se deben más a HOLla estabilidad de la estructura que a cualquier otra cosa.

Hola como estas, te puedo hacer una consulta, actualice a marlin 1.1.9 y no puedo configurar el autoleving, busca mil formas y tutaoriales y solo obtengo que los brazos bajen hasta punto cer0, ahi se eleba y se detiene poniendo "probe failed" te adjunto los archivos por si me podes dar una mano con esto


Archivos adjuntos
.rar   Configuration.rar (Tamaño: 24.65 KB / Descargas: 6)
.rar   Configuration_adv.rar (Tamaño: 22.86 KB / Descargas: 4)
  Responder
#7
Hola, ese error es muy probable que sea de hardware y no de configuración del firmware, bien que esté mal el sensor o que esté mal conectado.
  Responder
#8
Gracias Genio, mil disculpas por molestar, es que entiendo poco de programacion y me pone mal, no poder acomodar esto. Te comento que el sensor esta conectado al pin zmin del arduino ramp 1.4, a la senal cable negro, los dos restantes negativo y positivo a 12 volts con divisor resistivo que vi mirando un tutorial, el sensor es inductivo NO NPN, el mismo se activa al llegar a aprox 2mm de la base de aluminio, pero ahi se levanta y se detiene.
  Responder
#9
No es ninguna molestia contestar tus preguntas, es lo que hago habitualmente en el foro.
La alimentación del sensor mediante un divisor resistivo no es muy fiable, siendo mucho mejor hacerlo mediante un optoacoplador. El esquema para un sensor NPN sería este:

[Imagen: Img6.jpg]

Si al activarse el sensor se detiene el movimiento del eje Z, parece que aquel funciona bien y en esos archivos no veo nada que esté mal configurado e hiciese que no funcionase el autolevel.
¿Qué hace exactamente cuando le ordenas el comando G29?
  Responder
#10
amigo gracias por todo, te cuento tenia confundido la auto calibracion con la autonivelacion de cama, ahora paso a comentarte cuando pongo autocalibracion en el lcd esto me sale en el pronterface yo pensaba que era el sensor pero creo que estoy equivocado y debe ser por algun parametro erroneo en el firm
G33 Auto Calibrate
Checking... AC
.Height:419.50 Ex:+0.00 Ey:+0.00 Ez:+0.00 Radius:70.00
. Tx:+0.00 Ty:+0.00 Tz:+0.00
ErrorLenguarobing failed
ErrorLenguarobing failed

bueno eso es cuando intento hacer autocalibracion mandop G28, hace homing, baja unos 10cm a una velocidad baja, se acelera hasta llegar a z0, se eleva 2 o 3mm y es cuando pone el error antes comentado.

por otra parte cuando intento hacacer autoniveladode cama que recien encontre la opcion en el firm para habilitar en el lcd osea G29 pone este error comienza a bajar y el eje Y se posiciona en -85 hasta que se estreya la punta del nozzle con la cama e intenta caminar en sentido -y y se detiene poniendo
echo:enqueueing "G28"
echo:enqueueing "G29"
ErrorLenguarobing failed
ErrorLenguarobing failed
Bueno amigo espero que me entiendas lo que quiero explicar

Correct delta settings with M665 and M666
  Responder
#11
Estoy un poco perdido, creo que tengo que calibrar todo manualmente y despues hacer ajuste fino co autocalubracion creo que es lo mad acertado
  Responder
#12
En las impresoras de tipo Delta, una cosa es la autocalibración (comando G33) y otra distinta el autolevel (comando G29).
Lo primero que debes hacer, es asegurarte de que el sensor funciona, enviando el comando M119 con él desactivado (debe indicar z_probe: open) y con él activado (debe indicar z_probe: TRIGGERED): hasta que no consigas eso, no podrás utilizar el sensor, ni para la autocalibración ni para el autolevel.
Si no consigues que te funcione el sensor, no veo mayor problema en prescindir de él, porque una cosa es que la cama esté deformada, para lo que sí sería útil el autolevel y otra que esté desnivelada, en cuyo caso lo correcto es que hagas una buena nivelación respecto a la boquilla.
  Responder
#13
Amigo gracias a tu ayuda estoy encaminando, me decidi a poner un diodo 1n4007 en la señal y esta funcionando el sensor, ahora estoy tratando de hacer autocalibracion te estare escribiendo si me surgen inconvenientes, gracias por tu ayuda
  Responder
#14
En el parametro donde se modifica hacia que lado y distancia del extrusor esta el sensor, no me deja poner mas de 10mm mi sensor esta ubicado de frente al extrusor y a 40mm por lo que tengo que poner -40 pero pero si pongo esto la autonivelacion da error y no inicia y si pongo -10 si inicia, tendre que reformar el effector ?
  Responder
#15
Tener el sensor tan separado de la boquilla limita mucho el tamaño máximo de la rejilla, pero eso no debería dar ningún error, siempre que estén bien configuradas el resto de las medidas de la impresora.
Para poder dar alguna indicación sobre el error, necesitaría más información, como cuando y de qué forma se produce y de qué tipo es.
  Responder
#16
Bueno amigo he desistido de las nibelaciones automaticas, por lo menos en esta delta ya lo implementare en una prusa que estoy haciendo.
Ahora tengo una duda como calculo los pasos por milimetros del extrusor en marlin 1.1.9 no encuentro la opcion
  Responder
#17
Los micropasos por milímetro que tienes, en esa configuración que adjuntaste, son:

#define DEFAULT_AXIS_STEPS_PER_UNIT  { DEFAULT_XYZ_STEPS_PER_UNIT, DEFAULT_XYZ_STEPS_PER_UNIT, DEFAULT_XYZ_STEPS_PER_UNIT, 760*1.1 }  // default steps per unit for Kossel (GT2, 20 tooth)

siendo los del extrusor 760*1.1 (es decir 836).
Como desconozco que tipo de impulsor tiene tu impresora (si tiene reductora o no) y a qué micropasos está configurado el driver del extrusor (se indica que es un DRV8825), no puedo decir si ese valor puede ser correcto o no.
Para poder calcular los micropasos por milímetro del extrusor, tendrías que saber qué distancia se mueve el filamento por cada revolución completa del motor del impulsor, cosa que a priori es difícil de saber.
Por ello, lo que se suele hacer es poner un valor aproximado para ese parámetro, ordenar una extrusión suficiente, medir lo que se desplaza realmente el filamento y aplicar la siguiente fórmula para calcular el valor exacto a configurar:

valor a configurar = valor configurado * distancia ordenada / distancia obtenida

Lo mejor es realizarlo sin colocar el filamento en el extrusor: córtalo justo a la salida del tubo Bowden, ordena una extrusión (de 100 mm, por ejemplo) y mide lo que ha salido el filamento del tubo.
Ten en cuenta que el motor del extrusor no se mueve, si el hotend no se encuentra por encima de una temperatura concreta (170ºC en tu caso).
  Responder
#18
Gracias amigo, saludos voy a hacer los calculos y cualquier cosa te vuelvo a escribir
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Custom delta skr1.4 turbo p52sarup 9 1,522 14-03-2021, 09:38 PM
Último mensaje: Simemart
  CONSULTA DELTA SIN AUTOLEVEL + MARLIN 2.0.6.1 eizarr 2 1,402 13-09-2020, 12:23 PM
Último mensaje: eizarr
  Mi Delta y mejoras zamahuikano 12 6,336 09-09-2020, 05:31 PM
Último mensaje: zamahuikano
  3KU Delta alpefe 7 2,138 16-06-2020, 11:54 AM
Último mensaje: alpefe
  Proyecto Delta Full Equip 2.0 Eduwitow 5 2,599 29-09-2019, 11:59 PM
Último mensaje: kaituss