This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA Temperatura de cama caliente incorrecta BQ Hephestos
#21
Ojo, solo tienes que unir el GND (-) de las dos fuentes y comprueba la salida que te indico.
  Responder
#22
Si no unes los negativos no te va a funcionar, lo sé por experiencia en arduino con relés con fuente externa
  Responder
#23
He unido las dos fuentes y el problema persiste.
He comprobado el pin que dices @Simemart , y es curiosísimo porque saca los 5V por defecto, sin hacer nada. Y cuando le das a calentar es cuando deja de dar los 5V.
Mejor paso un vídeo. Se puede ver fácilmente porque se enciende el led cuando da los 5V, está comprobado:



Vaya guerra os estoy dando  Facepalm
  Responder
#24
Por como se comporta, todo indica que imita el funcionamiento de la cama en la RAMPS: alimentación directa de 5V y control por GND.
Pero en la RAMPS se utiliza un mosfet interno que está controlado por el mismo pin del ATMega2560 que indica el esquema de BQ (17) por lo que, si no nos está engañando, la única explicación es que su firmware tenga modificado el comportamiento normal de Marlin.
En este caso, para que te funcione tendrás que cambiar esa conexión de esta forma:

[Imagen: Img1.jpg]

P.S.: Aunque no sea por esa causa por lo que no te funcionaba, debes conectar de todas formas el GND de las dos fuentes.
  Responder
#25
Prueba a meterle Marlin original, porque puede que la placa que lleva para controlar use una lógica diferente, no puedo con el firmware de BQ, al cambiarlo por el original en una Hephestos y Hephestos 2 el ruido cambio radicalmente y eso que lleva los DRV8825

El mosfet es externo el que controla la cama, cuando compras la cama de BQ te viene con el controlador y una fuente externa
  Responder
#26
(24-06-2021, 12:06 AM)Simemart escribió: Por como se comporta, todo indica que imita el funcionamiento de la cama en la RAMPS: alimentación directa de 5V y control por GND.
Pero en la RAMPS se utiliza un mosfet interno que está controlado por el mismo pin del ATMega2560 que indica el esquema de BQ (17) por lo que, si no nos está engañando, la única explicación es que su firmware tenga modificado el comportamiento normal de Marlin.
En este caso, para que te funcione tendrás que cambiar esa conexión de esta forma:

[Imagen: Img1.jpg]

P.S.: Aunque no sea por esa causa por lo que no te funcionaba, debes conectar de todas formas el GND de las dos fuentes.

He realizado el cambio según el esquema y efectivamente ahora solo se enciende el led al darle a calentar, que es como debería ser. Pero el problema es que no calienta la cama. Con las fuentes unidas del GND (-) y todo.
Lo he comprobado con el multímetro y no sale voltaje del mosfet. Por lo que me da a entender que el mosfet está averiado. ¿Qué opináis?
Me viene de camino un mosfet y un relé, en unos días me llegarán para probar si fuera el mosfet.


(24-06-2021, 10:34 AM)Macuho escribió: Prueba a meterle Marlin original, porque puede que la placa que lleva para controlar use una lógica diferente, no puedo con el firmware de BQ, al cambiarlo por el original en una Hephestos y Hephestos 2 el ruido cambio radicalmente y eso que lleva los DRV8825

El mosfet es externo el que controla la cama, cuando compras la cama de BQ te viene con el controlador y una fuente externa

Mientras tanto estoy intentando el tema del Marlin pero no tengo mucha idea. Cuando cargo el firmware en la impresora, dice que se ha cargado correctamente, pero la impresora se queda colgada con la pantalla azul. Solo hace un ligero pitido cuando pulso o giro el botón que lleva, pero nada mas.

He probado la configuración para la Hephestos que es mi impresora, pero en el nombre de la placa aparece RAMPS 14 EFB y me mosquea un poco porque mi placa es la Zum Mega 3D.
Intento cargar la configuración de la Hephestos 2 que sí aparece el nombre de la Zum Mega 3D pero lógicamente no funciona, da el mismo resultado.
Os paso imágenes, porque me ralla un poco el tema del nombre de las placas  Sisi3

[Imagen: Hephestos.png]
[Imagen: Hephestos-2.png]

Aunque en la configuración aparezca "no heated bed" y tal, pero ¿no debería funcionar el Marlin siendo la impresora Hephestos?
Perdonad mi ignorancia, estoy un poco pegado Smash2 Agradezco un montón vuestros mensajes


Edito: He encontrado un tutorial de @Alemgv en el que lo explica todo en un vídeo que comenta en este post. Voy a intentar seguirlo a ver si lo consigo
  Responder
#27
BOARD_BQ_ZUM_MEGA_3D

Esta es la placa que tienes que poner en board

Yo empezaría con los ejemplos preconfigurados para la Hephestos y cambiaría el nombre de la placa y activaría la cama, luego ya configuraría más adelante el marlin desde los propios archivos que lleva por defecto


No intentes usar unos archivos con otra impresora porque cambia configuraciones, la pantalla de la Hephestos y la de la Hephestos 2 no son iguales y por eso no te muestra nada en pantalla
  Responder
#28
(25-06-2021, 06:50 AM)Macuho escribió: BOARD_BQ_ZUM_MEGA_3D

Esta es la placa que tienes que poner en board

Yo empezaría con los ejemplos preconfigurados para la Hephestos y cambiaría el nombre de la placa y activaría la cama, luego ya configuraría más adelante el marlin desde los propios archivos que lleva por defecto


No intentes usar unos archivos con otra impresora porque cambia configuraciones, la pantalla de la Hephestos y la de la Hephestos 2 no son iguales y por eso no te muestra nada en pantalla

Vale voy a probar. A ver si durante este fin de semana consigo algo  Clap
  Responder
#29
He estado probando estos días y por mas que lo intento no consigo que se vea la pantalla de la Hephestos. No sé si debería meter esto en un tema nuevo.
Al meter el Marlin, da igual la version que sea, me aparecen unos cuadros blancos en la LCD. He probado varias versiones de Marlin y de Arduino y siempre hace igual. Con Visual Studio también lo mismo.
He aumentado el contraste desde la parte trasera de la pantalla para estar seguro:

[Imagen: 20210628-172538.jpg]


La cosa es que el Marlin al parecer se instala correctamente. Conecto la impresora usando el pronterface y aparece todo correcto (excepto el tema de la cama caliente, que falla porque no calienta):
[Imagen: pronterface.png]


Los ejes de la impresora funcionan perfectamente y de hecho mas silenciosos como habéis dicho, y el extrusor también funciona. Pero no sé qué hacer con la pantalla, le tengo puesta la REPRAP_DISCOUNT_SMART_CONTROLLER en Marlin, supongo que tengo puesta la correcta, aunque ya he probado también con otros modelos. La que tengo es esta:

[Imagen: 20210628-174225.jpg]


La pantalla solo se ve correctamente cuando instalo el firmware original de BQ, ¿será que le selecciono mal los drivers o algo? Le he probado los A4988 y los DRV8825.
Gracias de antemano por vuestro tiempo y perdonad la lata que voy a dar
  Responder
#30
Si tienes el marlin de BQ mira que pantalla está descomentada
  Responder
#31
La pantalla de BQ tiene su propio parámetro de definición, por lo que seguramente no sea compatible con la RepRap: BQ_LCD_SMART_CONTROLLER.
Si no calienta la cama, pero si se activa el led del mosfet externo, seguramente esté mal este último: comprueba el voltaje en la salida hacia la cama, cuando esté activado el led.
  Responder
#32
La pantalla BQ_LCD es la fullgrafic de siempre, la única diferencia es que los pines no están colocados en la misma posición que la fullgrafic de reprap, he estado mirando el marlin de BQ para la Hephestos con la Zum mega y para la pantalla es esto

Código:
// The RepRapDiscount Smart Controller (white PCB)
// http://reprap.org/wiki/RepRapDiscount_Smart_Controller
#define REPRAP_DISCOUNT_SMART_CONTROLLER


// The GADGETS3D G3D LCD/SD Controller (blue PCB)
// http://reprap.org/wiki/RAMPS_1.3/1.4_GADGETS3D_Shield_with_Panel
//#define G3D_PANEL

// The RepRapDiscount FULL GRAPHIC Smart Controller (quadratic white PCB)
// http://reprap.org/wiki/RepRapDiscount_Full_Graphic_Smart_Controller
//
// ==> REMEMBER TO INSTALL U8glib to your ARDUINO library folder: http://code.google.com/p/u8glib/wiki/u8glib
//#define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER

// The RepRapWorld REPRAPWORLD_KEYPAD v1.1
// http://reprapworld.com/?products_details&products_id=202&cPath=1591_1626
//#define REPRAPWORLD_KEYPAD
//#define REPRAPWORLD_KEYPAD_MOVE_STEP 10.0 // how much should be moved when a key is pressed, eg 10.0 means 10mm per click

// The Elefu RA Board Control Panel
// http://www.elefu.com/index.php?route=product/product&product_id=53
// REMEMBER TO INSTALL LiquidCrystal_I2C.h in your ARDUINO library folder: https://github.com/kiyoshigawa/LiquidCrystal_I2C
//#define RA_CONTROL_PANEL
// BQ SMART FULL GRAPHIC CONTROLLER
//#define BQ_LCD_SMART_CONTROLLER

// Support for Toshiba Flashair SD cards
#define FLASH_AIR

//automatic expansion
#if defined (MAKRPANEL)
#define DOGLCD
#define SDSUPPORT
#define ULTIPANEL
#define NEWPANEL
#define DEFAULT_LCD_CONTRAST 17
#endif

#if defined(miniVIKI) || defined(VIKI2)
#define ULTRA_LCD  //general LCD support, also 16x2
#define DOGLCD  // Support for SPI LCD 128x64 (Controller ST7565R graphic Display Family)
#define ULTIMAKERCONTROLLER //as available from the Ultimaker online store.

  #ifdef miniVIKI
  #define DEFAULT_LCD_CONTRAST 95
  #else
  #define DEFAULT_LCD_CONTRAST 40
  #endif
 
#define ENCODER_PULSES_PER_STEP 4
#define ENCODER_STEPS_PER_MENU_ITEM 1
#endif


#if defined (REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER)
#define DOGLCD
#define U8GLIB_ST7920
#define REPRAP_DISCOUNT_SMART_CONTROLLER
#endif

#if defined(ULTIMAKERCONTROLLER) || defined(REPRAP_DISCOUNT_SMART_CONTROLLER) || defined(G3D_PANEL)
#define ULTIPANEL
#define NEWPANEL
#endif

#if defined(REPRAPWORLD_KEYPAD)
  #define NEWPANEL
  #define ULTIPANEL
#endif
#if defined(RA_CONTROL_PANEL)
#define ULTIPANEL
#define NEWPANEL
#define LCD_I2C_TYPE_PCA8574
#define LCD_I2C_ADDRESS 0x27  // I2C Address of the port expander
#endif

//I2C PANELS

//#define LCD_I2C_SAINSMART_YWROBOT
#ifdef LCD_I2C_SAINSMART_YWROBOT
  // This uses the LiquidCrystal_I2C library ( https://bitbucket.org/fmalpartida/new-liquidcrystal/wiki/Home )
  // Make sure it is placed in the Arduino libraries directory.
  #define LCD_I2C_TYPE_PCF8575
  #define LCD_I2C_ADDRESS 0x27  // I2C Address of the port expander
  #define NEWPANEL
  #define ULTIPANEL
#endif

// PANELOLU2 LCD with status LEDs, separate encoder and click inputs
//#define LCD_I2C_PANELOLU2
#ifdef LCD_I2C_PANELOLU2
  // This uses the LiquidTWI2 library v1.2.3 or later ( https://github.com/lincomatic/LiquidTWI2 )
  // Make sure the LiquidTWI2 directory is placed in the Arduino or Sketchbook libraries subdirectory.
  // (v1.2.3 no longer requires you to define PANELOLU in the LiquidTWI2.h library header file)
  // Note: The PANELOLU2 encoder click input can either be directly connected to a pin
  //      (if BTN_ENC defined to != -1) or read through I2C (when BTN_ENC == -1).
  #define LCD_I2C_TYPE_MCP23017
  #define LCD_I2C_ADDRESS 0x20 // I2C Address of the port expander
  #define LCD_USE_I2C_BUZZER //comment out to disable buzzer on LCD
  #define NEWPANEL
  #define ULTIPANEL

  #ifndef ENCODER_PULSES_PER_STEP
#define ENCODER_PULSES_PER_STEP 4
  #endif

  #ifndef ENCODER_STEPS_PER_MENU_ITEM
#define ENCODER_STEPS_PER_MENU_ITEM 1
  #endif


  #ifdef LCD_USE_I2C_BUZZER
#define LCD_FEEDBACK_FREQUENCY_HZ 1000
#define LCD_FEEDBACK_FREQUENCY_DURATION_MS 100
  #endif

#endif

// Panucatt VIKI LCD with status LEDs, integrated click & L/R/U/P buttons, separate encoder inputs
//#define LCD_I2C_VIKI
#ifdef LCD_I2C_VIKI
  // This uses the LiquidTWI2 library v1.2.3 or later ( https://github.com/lincomatic/LiquidTWI2 )
  // Make sure the LiquidTWI2 directory is placed in the Arduino or Sketchbook libraries subdirectory.
  // Note: The pause/stop/resume LCD button pin should be connected to the Arduino
  //      BTN_ENC pin (or set BTN_ENC to -1 if not used)
  #define LCD_I2C_TYPE_MCP23017
  #define LCD_I2C_ADDRESS 0x20 // I2C Address of the port expander
  #define LCD_USE_I2C_BUZZER //comment out to disable buzzer on LCD (requires LiquidTWI2 v1.2.3 or later)
  #define NEWPANEL
  #define ULTIPANEL
#endif

// Shift register panels
// ---------------------
// 2 wire Non-latching LCD SR from:
// https://bitbucket.org/fmalpartida/new-liquidcrystal/wiki/schematics#!shiftregister-connection

//#define SAV_3DLCD
#ifdef SAV_3DLCD
  #define SR_LCD_2W_NL    // Non latching 2 wire shiftregister
  #define NEWPANEL
  #define ULTIPANEL
#endif


#ifdef ULTIPANEL
//  #define NEWPANEL  //enable this if you have a click-encoder panel
  #define SDSUPPORT
  #define ULTRA_LCD
  #ifdef DOGLCD // Change number of lines to match the DOG graphic display
    #define LCD_WIDTH 22
    #define LCD_HEIGHT 5
  #else
    #define LCD_WIDTH 20
    #define LCD_HEIGHT 4
  #endif
#else //no panel but just LCD
  #ifdef ULTRA_LCD
  #ifdef DOGLCD // Change number of lines to match the 128x64 graphics display
    #define LCD_WIDTH 22
    #define LCD_HEIGHT 5
  #else
    #define LCD_WIDTH 16
    #define LCD_HEIGHT 2
  #endif
  #endif
#endif

// sd browsing cache is set to twice LCD height
#define SD_CACHE_SIZE LCD_HEIGHT*2


// default LCD contrast for dogm-like LCD displays
#ifdef DOGLCD
# ifndef DEFAULT_LCD_CONTRAST
#  define DEFAULT_LCD_CONTRAST 32
# endif
#endif

https://github.com/bq/Marlin/blob/master...guration.h
  Responder
#33
Investigando en los archivos preconfigurados de Marlin, tanto de la versión 1 como de la 2, la placa ZUM Mega solo está definida para la Hephestos2 y en ese caso, se define la pantalla como BQ_LCD_SMART_CONTROLLER debido a que tiene, en el archivo de pines que se utiliza (el de la RAMPS), uno que solo se asigna para ella (LCD_BACKLIGHT_PIN).
Para la Hephestos se define la placa RAMPS y la pantalla Reprap Discount Smart Controller, no siendo necesario en ese caso definir ningún otro pin que los estandar Reprap: entiendo que si se tiene la placa ZUM Mega, debe indicarse la pantalla de BQ o no se definirá correctamente ese pin.
  Responder
#34
La Hephestos original venía con un Mega y una Ramps, luego cambiaron a la zum
  Responder
#35
Chicos, disculpad mi ausencia. No quería responder al tema sin ninguna noticia o nada que preguntar.
He estado estos días tocando el Marlin para arreglar la pantalla y no hay manera, estoy demasiado verde en esto... Pero bueno es un problema secundario.

Hoy me ha llegado el mosfet nuevo que pedí, y el funcionamiento es el mismo: se enciende el led cuando le doy a calentar, pero no calienta.
Me está ayudando mi padre, que entiende algo de electrónica, y me pregunta si el controlador del mosfet tiene corriente alterna o continua. Es decir, este conector:

[Imagen: mosfet.jpg]


No tengo ni idea pero intuyo que vosotros lo sabréis jeje Sisi3
Os debo unas cervezas, consiga arreglarlo o no  Qmeparto
Mil gracias por vuesto tiempo
  Responder
#36
Hola, como ya te indiqué en otra respuesta, lo que tienes que comprobar es si cuando se enciende el led, en los bornes del mosfet marcados como HOT BED tienes los 24V de la fuente de alimentación.
Si es así, lo que está mal es la cama, que seguramente tenga cortada la resistencia interna: puedes comprobarlo mediante un multímetro puesto en continuidad, midiendo entre sus dos cables de alimentación (desconectados del mosfet).
En tu impresora, lo único que funciona con corriente alterna son las fuentes de alimentación.
  Responder
#37
(06-07-2021, 12:03 AM)Simemart escribió: Hola, como ya te indiqué en otra respuesta, lo que tienes que comprobar es si cuando se enciende el led, en los bornes del mosfet marcados como HOT BED tienes los 24V de la fuente de alimentación.
Si es así, lo que está mal es la cama, que seguramente tenga cortada la resistencia interna: puedes comprobarlo mediante un multímetro puesto en continuidad, midiendo entre sus dos cables de alimentación (desconectados del mosfet).
En tu impresora, lo único que funciona con corriente alterna son las fuentes de alimentación.

Hay 19V en los bornes que dices. Pero cuando conectas la cama se va a 0V. He probado con una bombilla y hace igual, se va a 0V automáticamente.
La cama debería estar bien porque la he conectado directamente a la fuente de alimentación y calienta enseguida. Supongo que la cama está bien.
El mosfet tiene ya el nuevo, el que me llegó ayer de otro vendedor.
¿Me recomendáis que pruebe con un mosfet de otro tipo?
  Responder
#38
Si la cama calienta cuando se conecta directamente a la fuente de alimentación, entonces puede que esté bien, aunque no estaría de más que midieses su resistencia para estar seguros (directamente en sus cables, sin estar conectada a nada).
Sobre lo demás, no me queda claro en qué condiciones sucede lo que indicas. En todo caso, esos 19V que mides en los bornes HOT BED parece una caida de tensión demasido grande (si es que la fuente da 24V realmente).
Haz las siguientes pruebas, comprobando si se enciende el led del mosfet y/o hay tensión en los bornes HOT BED:
1- conectando en el mosfet solo fuente y placa;
2- lo mismo, pero ordenando calentar la cama.
El funcionamiento correcto sería que en el caso 1 el led esté apagado y no haya tensión en los bornes; en el caso 2, led encendido y 24V en los bornes.
Si ese mosfet está indicado para conmutar 24V (supongo que lo habrás comprado así), es perfectamente válido para realizar este montaje, por lo que no es necesario ningún otro: quizá el problema esté en el control por parte de la placa.
  Responder
#39
SOLUCIONADO.
Comprobando lo que decías @Simemart, a mi padre se le ocurrió la idea de que tal vez no eran 5V lo que tenía que recibir el controlador del mosfet. Le pusimos 9V con un cargador de esos de voltaje regulable y funcionaba perfecto. La cama empezaba a calentar y si ponías una bombilla se mantenía encendida. Con el controlador a 5V, los bornes se caían a 0V.
Le pidimos otro mosfet diferente, concretamente este:

[Imagen: 61s-VVIbf-VML-SL1001.jpg]

Ha llegado hoy y a la primera ya funciona perfecto  Sing
En cuanto al firmware, de momento le dejaré el original de BQ porque no soy capaz de hacer que se visualice la pantalla. Y bueno, ya con que funcione imprimiendo pues ya soy feliz  Mola

Os doy mil gracias a los dos. No lo hubiera conseguido sin vosotros  Lengua

Dejo una foto de la obra de arte. Solo tengo que recoger todo esto un poco  Qmeparto

[Imagen: 20210710-170823.jpg]
  Responder
#40
Me alegro de que lo hayas conseguido.
Un saludo.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Poner cama caliente en tronxy X1 Wibols 3 687 16-05-2021, 07:49 PM
Último mensaje: Simemart
  PID cama caliente mati1608 2 276 10-02-2021, 02:37 AM
Último mensaje: mati1608
  CONSULTA Anet E10 Cama caliente Halions 2 850 05-12-2020, 01:50 AM
Último mensaje: Halions
  DUDA Filamento no se adhiere a la cama caliente Anje 12 4,158 03-11-2020, 09:30 PM
Último mensaje: Escrafi
Fotografía Cama caliente magnética Ender 3 pro mikolynn 2 1,459 16-09-2020, 10:41 PM
Último mensaje: ForTyP