Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
tmc connection error
#1
Hola
Tengo unos TMC 2209 en una placa skr 1.3 y en la pantalla me sale tmc connection error. La tengo con la versión de marlin 2.0. En el pronterface cuando hago M122 me sale en lo de texting connection error: al low.
Gracias.
Citar
#2
Hola, como se indica en la descripción del comando M122, una respuesta de All LOW indica un problema de comunicación con los drivers TMC.
Tendrás que revisar como has configurado la placa SKR.
Citar
#3
En esto soy novato la configuración la tengo asi los drivers son los de bigtreetech tmc2209 v1.1 y los tengo tal como vienen, y en la placa tengo quitados todos los jumper de spi y conectados los de uart. También tengo la placa alimentada por el usb y es la segunda placa que tengo la anterior dejo de funcionar.

En marlin en configuration.h tengo puesto el eje X,Y,Z, E0 y E1 con tmc2209 si los pongo en TMC2209_STANDALONE se va el error, pero creo en standalone es cuando hace ruido 
Y en configuration_adv.h tengo definido el SENSORLESS_HOMING y los STEALTHCHOP de todos los ejes
Citar
#4
Este error es muy común en este tipo de impresoras, a mi me encanta tener en cuenta a las distribuidoras al por mayor en Chile que venden este tipo de artículos para poder buscar sugerencias.
Citar
#5
(30-08-2019, 12:04 PM)VladeRunner escribió: En esto soy novato la configuración la tengo asi los drivers son los de bigtreetech tmc2209 v1.1 y los tengo tal como vienen, y en la placa tengo quitados todos los jumper de spi y conectados los de uart. También tengo la placa alimentada por el usb y es la segunda placa que tengo la anterior dejo de funcionar.

En marlin en configuration.h tengo puesto el eje X,Y,Z, E0 y E1 con tmc2209 si los pongo en TMC2209_STANDALONE se va el error, pero creo en standalone es cuando hace ruido 
Y en configuration_adv.h tengo definido el SENSORLESS_HOMING y los STEALTHCHOP de todos los ejes

Los tmc no tienen suficiente voltaje para alimentarse desde usb con la skr, prueba a alimentarlos de forma normal por su conector (cambia antes el jumper para alimentarlo por 12-24v), yo cuando intentaba probar la placa con los uart (en mi caso eran los fysetc tmc2208 v1.0) daban ese error, pero al conectarlo con su alimentación desapareció el error. :Gran sonrisa

También ten en cuenta que los tmc2209 no tienen SPI, por lo que los pines de SPI tienes que quitarlos todos y configurar el firmware con TMC2209 (sin el standalone).
Citar
#6
Hola, no es que tengan poco voltaje sino que no tienen ninguno.
No son solo los TMC, ningún driver se alimenta desde el circuito de 5V de la placa, que es al que conecta la alimentación del USB. Normal que no se comuniquen, pues están sin alimentación.
El jumper que cambia entre USB o INT no afecta a la alimentación de los drivers, solo a cual es la fuente de la línea de 5V, si la conexión USB o el regulador interno que convierte a 5V el voltaje de alimentación de la placa (12V o 24V).
Aunque se tenga ese jumper en posición USB, si se tiene conectada la alimentación principal de la placa, fucionarán los drivers.
El problema de @VladeRunner es que no tiene conectada esa alimentación además del USB.

P.S.: Bueno, realmente los drivers sí tienen alimentación por la línea de 3,3V, cuyo regulador se alimenta a su vez de la de 5V.
Pero supongo que para que funcionen correctamente los drivers, deberán tener alimentación por la línea VBB (12V o 24V).
Citar
#7
La he conectado a la luz y sigue dando el fallo, ¿hay que hacerles algo de soldar al driver? he probado los tmc 2208 y he tenido que soldar dos puntos para que funcione en uart
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
Pregunta CONSULTA Cambio parámetros Offset - Error compilar goguito82 7 326 15-10-2019, 03:21 PM
Último mensaje: Simemart
  error área de impresión TUERTO79 9 595 21-10-2018, 10:39 PM
Último mensaje: TUERTO79
  CONSULTA Error después de pausar puxkill 2 437 09-10-2018, 12:46 PM
Último mensaje: buratatxo
  CONSULTA ERROR RARO - Ayuda! Joaquin3188 1 511 28-03-2018, 04:58 PM
Último mensaje: fbforos
  Error máx temp bed 147° ravenmorfeo 8 1,483 12-03-2018, 02:39 PM
Último mensaje: ninkair