Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
avrdude: stk500_recv(): programmer is not responding avrdude
#1
Buenas!!

Tengo un arduino mega 2560, creo que es un taurino.
Estoy en mac.
La placa que tengo seleccionada es: Arduino Mega y el port: /dev/tty.usbmodem411

Y al intentar cargar el ejemplo Blink me da el siguiente error...

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_recv(): programmer is not responding

He instalado el pkg que viene en el zip que te descargas de la web de arduino.

¿Alguien sabe que puede ser? He cambiado ya los usb, el cable y ya no se que hacer... seguro que hay algun fenomeno que sabe que puede ser...
Un saludo y gracias de antemano!
Citar
#2
He probado en otro ordenador con windows 7, y el error que me da ahora es este...

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51
Citar
#3
¿Llegó a funcionar alguna vez?

Se me ocurren dos cosas:
-Puerto COM incorrecto
-Bootloader dañado (te tocará volver a subirlo)
Citar
#4
Pues no lo se, yo estoy usandolo hoy por primera vez y queria probar el ejemplo Blink pero es imposible... no hay manera!

Desde windows, el adminstrador de dispositivos lo reconoce en el COM3, selecciono ese puerto en el programa y nada, sigue saliendo... Ahora da este otro:

avrdude: stk500_getsync(): not in sync: resp=0x21
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x7b
Citar
#5
Ya esta, el tema está en que estaba usando un IDE viejo... de echo baje el que se descarga en la web principal de arduino.cc en español.

Se puede cerrar el tema.
Citar
#6
Al final era la cosa más tonta...

Me alegro de que funcionase..a cacharrear!
Citar
#7
Hay veces que también suelta ese error, o uno muy similar, pero como warnings, y luego ya transmite el sketch. Sobre todo en mac.

Si ya está solucionado, a darle caña!!
Citar
#8
Un pequeño reflote por aquí.

Llevo la mañana cacharreando con un par de arduinos que tenía en un cajón. Un leonardo de la famosa campaña de Harold, y un mini que compré para un par de proyectos mini que tenía en mente hace 3 años. Para cargar los sketchs al mini, compré el típico conversor USB_UART con CP2102. He instalado el driver en Mac, y me reconoce el puerto, pero cuando le tiro a cargar, me sale el mismo error que al compañero.

He actualizado el IDE a 1.0.6. pero tiene el mismo comportamiento. He probado a cambiar el programador sin éxito.

Con el leonardo, me carga el programa y funciona OK, pero en cuanto pincho el Mini, no hay manera.

¿Alguna idea?

Gracias!
Citar
#9
El cp21012 vale para cargar el codigo?
Citar
#10
Hola grafisoft, teoricamente si. He seguido este "tutorial" http://forum.arduino.cc/index.php?topic=177990.0 y me he dado cuenta que realmente es un mini pro. Es lo que tiene rescatar componentes de una caja, ni siquiera sabes lo que hay dentro.

El caso es que todo sigue igual. He estado investigando un poco, y parece que el problema viene del bootloader.

Me he pasado a una máquina virtual con WXP, y tras instalar los drivers y actualizar el IDE me tira este error:
avrdude: stk500_getsync(): not in sync: resp=0x00

He probado a poner un LED entre la patilla 13 y GND para comprobar si tenía bootloader, y parpadea al ritmo del LED del arduino.

¿Voy a tener que cargar el bootloader?
Citar
#11
A mi todos los arduino pro mini que compré me vinieron sin bootloader
Citar
#12
Cuando pulsas el botón de enviar el código desde el ide de Arduino, ¿pulsas a continuación el botón reset del Arduino mini?
Citar