Calificación:
  • 5 voto(s) - 4.8 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Tutorial sensores BLTOUCH y 3DTOUCH
#61
Buenas.
Tengo este exactamente:
https://es.aliexpress.com/item/3D-Printe...0.0.7c5dCP
Con la última versión de Marlin tan solo la configuración normal, es decir, habilitar el sensor, como y donde se chequea la distancia, etc
Eso si, el 3DTouch va alimentado a parte con 5V, paso de 12V a 5V directamente de la fuente y le conecto la alimentación mientras que la señal de control va al que toca en la RAMPS. Hay algunos manuales que lo recomiendan dado que por el consumo el arduino se echa abajo y da errores, se queda pillado o directamente reinicia la impresora. Pongo una imagen de el circuito más simple para pasar de 12V o 24V a 5V.

resim

subir imagenes a un foro
Citar
#62
Hola a todos, hoy he podido hacer funcionar un BLtouch original después de algún problema... No soy capaz de ajustar el off set de Z. No lo memoriza, así que lo he tenido que ajustar a mano... Alguien puede explicarme otro método para que lo guarde?

Con el BLtouch se puede usar también un endstop por si se le va la cabeza al primero que corte el segundo?

Muchas gracias!

Enviado desde mi Aquaris X5 mediante Tapatalk
Citar
#63
(24-06-2017, 10:17 PM)Zolber escribió: Hola a todos, hoy he podido hacer funcionar un BLtouch original después de algún problema... No soy capaz de ajustar el off set de Z. No lo memoriza, así que lo he tenido que ajustar a mano... Alguien puede explicarme otro método para que lo guarde?

Con el BLtouch se puede usar también un endstop  por si se le va la cabeza al primero que corte el segundo?

Muchas gracias!

Enviado desde mi Aquaris X5 mediante Tapatalk

Tienes activada la eeprom? Es importante para que funcione. 

No se si habrás seguido estos mismos pasos, pero te comento, para ajustar el offset usa repetier y estos dos comandos: M851 y M500. 

Poniendo solo "M851" te mostrará el offset actual, que puedes cambiarlo poniendo por ejemplo "M851 Z-1.5", y luego acuérdate de guardarlo con "M500". Una vez cambiado puedes comprobrarlo bien poniendo de nuevo "M851" o haciendo home en Z, donde la distancia deberá ser diferente a la que tenías antes. 


En el marlin puedes configurar ambos endstops sin problema, me suena haber visto el trozo de código ya hecho en algún lado, sino es simplemente meter un condicional en la linea del endstop de Z.
Citar
#64
(24-06-2017, 11:59 PM)cna escribió:
(24-06-2017, 10:17 PM)Zolber escribió: Hola a todos, hoy he podido hacer funcionar un BLtouch original después de algún problema... No soy capaz de ajustar el off set de Z. No lo memoriza, así que lo he tenido que ajustar a mano... Alguien puede explicarme otro método para que lo guarde?

Con el BLtouch se puede usar también un endstop  por si se le va la cabeza al primero que corte el segundo?

Muchas gracias!

Enviado desde mi Aquaris X5 mediante Tapatalk

Tienes activada la eeprom? Es importante para que funcione. 

No se si habrás seguido estos mismos pasos, pero te comento, para ajustar el offset usa repetier y estos dos comandos: M851 y M500. 

Poniendo solo "M851" te mostrará el offset actual, que puedes cambiarlo poniendo por ejemplo "M851 Z-1.5", y luego acuérdate de guardarlo con "M500". Una vez cambiado puedes comprobrarlo bien poniendo de nuevo "M851" o haciendo home en Z, donde la distancia deberá ser diferente a la que tenías antes. 


En el marlin puedes configurar ambos endstops sin problema, me suena haber visto el trozo de código ya hecho en algún lado, sino es simplemente meter un condicional en la linea del endstop de Z.
Muchas gracias cna.
Lo he probado con repetier y solo me decía el offset, aunque pusiera uno nuevo y guardase no cambiaba.

He probado con la consola del Simplify y lo mismo...

Al final he probado desde la terminal de Octoprint y premio! Este me lo modificaba y me lo guardaba.

Ya solo me queda investigar lo que me dices del endstop, ya que no me fío por si falla el BLtouch


Enviado desde mi Aquaris X5 mediante Tapatalk
Citar
#65
(25-06-2017, 04:20 PM)Zolber escribió:
(24-06-2017, 11:59 PM)cna escribió:
(24-06-2017, 10:17 PM)Zolber escribió: Hola a todos, hoy he podido hacer funcionar un BLtouch original después de algún problema... No soy capaz de ajustar el off set de Z. No lo memoriza, así que lo he tenido que ajustar a mano... Alguien puede explicarme otro método para que lo guarde?

Con el BLtouch se puede usar también un endstop  por si se le va la cabeza al primero que corte el segundo?

Muchas gracias!

Enviado desde mi Aquaris X5 mediante Tapatalk

Tienes activada la eeprom? Es importante para que funcione. 

No se si habrás seguido estos mismos pasos, pero te comento, para ajustar el offset usa repetier y estos dos comandos: M851 y M500. 

Poniendo solo "M851" te mostrará el offset actual, que puedes cambiarlo poniendo por ejemplo "M851 Z-1.5", y luego acuérdate de guardarlo con "M500". Una vez cambiado puedes comprobrarlo bien poniendo de nuevo "M851" o haciendo home en Z, donde la distancia deberá ser diferente a la que tenías antes. 


En el marlin puedes configurar ambos endstops sin problema, me suena haber visto el trozo de código ya hecho en algún lado, sino es simplemente meter un condicional en la linea del endstop de Z.
Muchas gracias cna.
Lo he probado con repetier y solo me decía el offset, aunque pusiera uno nuevo y guardase no cambiaba.

He probado con la consola del Simplify y lo mismo...

Al final he probado desde la terminal de Octoprint y premio! Este me lo modificaba y me lo guardaba.

Ya solo me queda investigar lo que me dices del endstop, ya que no me fío por si falla el BLtouch


Enviado desde mi Aquaris X5 mediante Tapatalk

Si te quieres asegurar, aliméntalo con un regulador de 5v externo en lugar de los 5v que saca la ramps. 
Por lo demás no tiene porque fallar, antes solo tenías 1 endstop en vez de 2 por seguridad, no?  Qmeparto
Citar
#66
(25-06-2017, 05:11 PM)cna escribió:
(25-06-2017, 04:20 PM)Zolber escribió:
(24-06-2017, 11:59 PM)cna escribió: Tienes activada la eeprom? Es importante para que funcione. 

No se si habrás seguido estos mismos pasos, pero te comento, para ajustar el offset usa repetier y estos dos comandos: M851 y M500. 

Poniendo solo "M851" te mostrará el offset actual, que puedes cambiarlo poniendo por ejemplo "M851 Z-1.5", y luego acuérdate de guardarlo con "M500". Una vez cambiado puedes comprobrarlo bien poniendo de nuevo "M851" o haciendo home en Z, donde la distancia deberá ser diferente a la que tenías antes. 


En el marlin puedes configurar ambos endstops sin problema, me suena haber visto el trozo de código ya hecho en algún lado, sino es simplemente meter un condicional en la linea del endstop de Z.
Muchas gracias cna.
Lo he probado con repetier y solo me decía el offset, aunque pusiera uno nuevo y guardase no cambiaba.

He probado con la consola del Simplify y lo mismo...

Al final he probado desde la terminal de Octoprint y premio! Este me lo modificaba y me lo guardaba.

Ya solo me queda investigar lo que me dices del endstop, ya que no me fío por si falla el BLtouch


Enviado desde mi Aquaris X5 mediante Tapatalk

Si te quieres asegurar, aliméntalo con un regulador de 5v externo en lugar de los 5v que saca la ramps. 
Por lo demás no tiene porque fallar, antes solo tenías 1 endstop en vez de 2 por seguridad, no?  Qmeparto
En eso tienes razón... Pero el final de carrera tiene menos tecnología

Enviado desde mi Aquaris X5 mediante Tapatalk
Citar
#67
Buenas tardes,
a mí me pasa algo divertido con el BL-Touch, tengo el de Getech. Cuando lo conecto y le indico que haga Home de Z me hace Z+ y se queda quieto, lo desconecto y sustituyo por un final de carrera normal y al hacer Home Z me lo hace correcto, Z- activa final, Z+ un poco y Z- hasta volver a pulsar el final y quedarse quieto en esa posición.

Estoy usando la versión de Marlin descargada desde Getech.

Comentar que tengo puenteada en la MEGA2564 el pin para que los pines del servo tenga alimentación, cuando conecto el vástago sensor entra y sale dos veces y se queda retraido con el led rojo conectado. Es lo único que he logrado.

Alguna sugerencia.
Citar
#68
Una pregunta tonta, con el marlin " marlin-RC8-bltouch-@mashirito-20170117.zip (Tamaño: 1.28 MB / Descargas: 170) Con la EEPROM, el debug de autoleveling y el test de repitibilidad activados" Que esta colgado en la primera pagina al compilar en teoría no tendría que dar error no?? Porque entiendo que esta puesto como lo tiene "mashirito" en su impresora , pues cargado sin tocar nada ya me da error, este concretamente:

Arduino:1.8.4 (Mac OS X), Tarjeta:"Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

SanityCheck.h:485: error: #error "Auto Bed Leveling requires a probe! Define a Z Servo, Z_PROBE_ALLEN_KEY, Z_PROBE_SLED, or FIX_MOUNTED_PROBE."
#error "Auto Bed Leveling requires a probe! Define a Z Servo, Z_PROBE_ALLEN_KEY, Z_PROBE_SLED, or FIX_MOUNTED_PROBE."
Citar
#69
(13-09-2017, 04:11 PM)satoo escribió: Una pregunta tonta, con el marlin " marlin-RC8-bltouch-@mashirito-20170117.zip (Tamaño: 1.28 MB / Descargas: 170) Con la EEPROM,  el debug de autoleveling y el test de repitibilidad activados" Que esta colgado en la primera pagina al compilar en teoría no tendría que dar error no?? Porque entiendo que esta puesto como lo tiene "mashirito" en su impresora , pues cargado sin tocar nada ya me da error, este concretamente:  

Arduino:1.8.4 (Mac OS X), Tarjeta:"Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

SanityCheck.h:485: error: #error "Auto Bed Leveling requires a probe! Define a Z Servo, Z_PROBE_ALLEN_KEY, Z_PROBE_SLED, or FIX_MOUNTED_PROBE."
    #error "Auto Bed Leveling requires a probe! Define a Z Servo, Z_PROBE_ALLEN_KEY, Z_PROBE_SLED, or FIX_MOUNTED_PROBE."

Revisa los pasos del tutorial y fíjate si están descomentadas las líneas que se indican en cada paso. 
No recuerdo si está configurado al completo el marlin (ahora mismo no puedo verlo) o si esa versión simplemente lleva metidos esos extras aparte pero le falta activar el bltouch.
Citar
#70
Gracias, de momento ya he podido compilarlo y pasarlo a la impresora, ahora toca configurarlo, al final era un error mio que al descomentar una linea me habia comido el simbolo #
Citar
#71
Acabo de instalar el 3d touch en una impresora 3dsteel de 3despana con el marlin modificado por ellos para la impresora y el 3d touch.
Se enciende la luz roja, doy a lo posición inicial, hace ejes x e y hasta el final de carrera, se pone en el centro de la impresora y sube en z un poco. Vuelvo a repetir y pasa lo mismo. Manualmente, voy a mover manualmente el eje z y me dice que estoy +13 mm, y claro , bajo hasta el 0 y esta a una altura de 10cm. Vamos que no sabe donde está el z. ¿Alguna solución? Gracias

Enviado desde mi Redmi 3 mediante Tapatalk
Citar
#72
Arreglado, simples problemas de conexión

Enviado desde mi Redmi 3 mediante Tapatalk
Citar
#73
(15-09-2017, 01:23 PM)robertote escribió: Acabo de instalar el 3d touch en una impresora 3dsteel de 3despana con el marlin modificado por ellos para la impresora y el 3d touch.
Se enciende la luz roja, doy a lo posición inicial, hace ejes x e y hasta el final de carrera, se pone en el centro de la impresora y sube en z un poco. Vuelvo a repetir y pasa lo mismo. Manualmente, voy a mover manualmente el eje z y me dice que estoy +13 mm, y claro , bajo hasta el 0 y esta a una altura de 10cm. Vamos que no sabe donde está el z. ¿Alguna solución? Gracias

Enviado desde mi Redmi 3 mediante Tapatalk

Pues yo he cargado este mismo marlin porque tengo la misma impresora de 3despana y se va los finales de carrera donde quieren y por mucho que los cambio no me hacen ni caso, has tenido que tocar algo mas aparte de la altura?? gracias
Citar
#74
Porque puede ser que me pase esto con el sensor 3d bluetoch no hay manera de que funcione https://youtu.be/UoKOLLYjs0A
Citar
#75
Yo lo que hice:

-Coloque el cacharro; coloqué el cable triple (donde indica el manual polos + y - bien colocados) el cable doble lo coloco quitando el cable final de carrera z y colocando este (ese fue mi fallo)
-Instalé el marlin preparado de 3despana, que es para husillos y cama de 200x300
- Una vez hecho esto si le das a que vaya a origen te hace final de carrera x e y y luego va al centro de la cama y baja hasta tocar y vuelve a subir.
-Si le das a nivelar plataforma tiene que comprobarte 9 puntos de la cama
A mi al principio no se me encencia la luz roja del 3d touch porque donde conectas el cable triple, justo debajo, hay un plastiquito amarillo que conectaba pines central y derecho y tiene que conectar el central y el izquierdo.

Suerte
Citar
#76
(19-09-2017, 04:41 PM)robertote escribió: Yo lo que hice:

-Coloque el cacharro; coloqué el cable triple (donde indica el manual polos + y - bien colocados) el cable doble lo coloco quitando el cable final de carrera z y colocando este (ese fue mi fallo)
-Instalé el marlin preparado de 3despana, que es para husillos y cama de 200x300
- Una vez hecho esto si le das a que vaya a origen te hace final de carrera x e y y luego va al centro de la cama y baja hasta tocar y vuelve a subir.
-Si le das a nivelar plataforma tiene que comprobarte 9 puntos de la cama
A mi al principio no se me encencia la luz roja del 3d touch porque donde conectas  el cable triple, justo debajo, hay un plastiquito amarillo que conectaba pines central y derecho y tiene que conectar el central y el izquierdo.

Suerte

Eso mismo he echo yo, entiendo que el puente va donde pone la foto que pongo, pero a mi no me funciona para nada, hace lo que en el video, seguiré provando
resim
Citar
#77
Así lo tengo conectado yo.
En el video no veo que se encienda ninguna luz, tiene que estar encendida una roja. Igual es el propio 3dtouch que está roto.
Citar
#78
(20-09-2017, 03:47 PM)robertote escribió: Así lo tengo conectado yo.
En el video no veo que se encienda ninguna luz, tiene que estar encendida una roja. Igual es el propio 3dtouch que está roto.


No se aprecia pero se enciende la luz , hacerlo tiene la intencion de hacerlo pero con este ruido de los motores del eje z, no se seguire probando.


Enviado desde mi iPhone utilizando Tapatalk
Citar
#79
Saludos!! estoy ajustando los offsets del bl touch en el Marlin. Cómo hago para medir el offset del eje Z asta el nozzle con un bl touch (en realidad es un 3d touch) ,hay que medir los milímetros con el embolo retraído o desplegado?o medir asta el plástico?


resim

Salud!
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Problema bltouch y primera capa Gonmoa 0 62 16-11-2017, 01:12 AM
Último mensaje: Gonmoa
  [TUTORIAL] Desatascar Nozzle cansi22 25 3,128 10-03-2017, 04:28 PM
Último mensaje: WeSo
  Tutorial: Repara modelos en 3D de manera fácil y rápida luzma 7 650 02-03-2017, 09:28 PM
Último mensaje: luzma
  Problema Bltouch elborjas1987 3 524 20-02-2017, 10:48 AM
Último mensaje: elborjas1987
  Oferta 3D touch (clon bltouch) xircom 51 5,621 01-02-2017, 02:34 PM
Último mensaje: joseslo