Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema para imprimir desde la impresora
#21
El error de la EEPROM seguramente sea debido a que no la has restaurado después del cambio del firmware y tiene aún los valores del anterior guardados en ella.
Cuando se cambia el firmware, hay que restaurarla: menu Control>Restaurar memoria seguido de Control>Guardar memoria o bien enviar los comandos M502 y M500.
Es raro que, configurando como he indicado, hayas tenido que desactivar la pantalla de arranque: algo hay distinto, pues a mí me complia con ella habilitada y me sobran 68 bytes.
Citar
#22
(25-03-2020, 10:58 PM)Simemart escribió: El error de la EEPROM seguramente sea debido a que no la has restaurado después del cambio del firmware y tiene aún los valores del anterior guardados en ella.
Cuando se cambia el firmware, hay que restaurarla: menu Control>Restaurar memoria seguido de Control>Guardar memoria o bien enviar los comandos M502 y M500.
Es raro que, configurando como he indicado, hayas tenido que desactivar la pantalla de arranque: algo hay distinto, pues a mí me complia con ella habilitada y me sobran 68 bytes.

Solucionado.... muchas gracias...

Ahora tengo una duda. Yo he instalado un sensor capacitivo de 18mm para hacer el autolevel y funciona bien cuando la impresora está fría pero me da la impresión que cuando pongo a calentar la cama y el extrusor hace lo que le da la gana y mide mal.

Existe alguna forma de que puede hacer las mediciones antes de empezar a calentar y así cuando caliente pase del detector porque ya están hechas las mediciones...
Digo de hacerlo cuando esté fría porque es cuando la medición en más fiable ya que cuando está caliente varía en función de la temperatura.


Muchas gracias nuevamente.

Hola otra vez.

Estoy haciendo pruebas y no se por qué el calentamiento de la cama se hace eterno. Llevo 20 minutos esperando que se caliente y sube un grado cada 3 minutos...
Esto es normal ?????
Citar
#23
Es verdad que los sensores capacitivos son bastante sensibles a la temperatura y las condiciones ambientales (humedad, etc.), es algo inherente a su sistema de detección.
Sobre lo que indicas de realizar las medidas en frío, todo sería probar que situación es más fiable, aunque hay algunas cosas a considerar para hacerlo de esa manera.
Una es que los programas de corte suelen incluir las órdenes de calentamiento antes de las del script de inicio en el archivo .gcode de la pieza,, por lo que las del script se ejecutan con los elementos ya calientes y esto influye tanto en el "homing" como en el autolevel.
Para poder realizar el primero en frío, habría que editar el fichero de cada pieza para cambiar la posición del G28, cosa bastante poco práctica, por lo que habrá que conformarse con hacer el "homing" en caliente.
Solucionar el problema con el autolevel es bastante mas sencillo: para ello solo habría que realizar el G29 al comenzar las sesiones de impresión y colocar en el scrip de inicio el comando M420 S1, en lugar del habitual G29. También podremos guardar las mediciones en la EEPROM (si tenemos activado su uso), para que se conserven entre reinicios y así no tener que realizarlas cada vez. Esto último, siempre que no cambien, cosa que sucederá si no tenemos una superficie de impresión fija.
Por ejemplo, si tenemos un cristal y lo quitamos para retirar la pieza, será dificil poder utilizar el autolevel realizando las mediciones en frio: tendríamos que esperar para hacer una nueva impresión a que los elementos calefactados se enfriasen y así realizar una nueva medición, ya que las medidas anteriores seguramente habrán variado al quitar y poner el cristal en la cama.
Sobre el problema del calentamiento de la cama, suele ser bastante más lento que el del hotend, pero no tanto como indicas. En todo caso, depende de la temperatura ambiente y de lo mejor o peor aislada que esté la cama.
Para mejorar este aspecto, es bastante recomendable colocar una lámina de corcho bajo ella, lo que disminuye sensiblemente los tiempos de calentamiento.
Otro aspecto a controlar es la resistencia del circuito de la cama, pues si es sensiblemente inferior a la teórica, no tendrá suficiente potencia para calentar correctamente.
La de la cama de serie suele ser de 1,3 a 1,5 Ohms.
Citar
#24
(26-03-2020, 04:36 PM)Simemart escribió: Es verdad que los sensores capacitivos son bastante sensibles a la temperatura y las condiciones ambientales (humedad, etc.), es algo inherente a su sistema de detección.
Sobre lo que indicas de realizar las medidas en frío, todo sería probar que situación es más fiable, aunque hay algunas cosas a considerar para hacerlo de esa manera.
Una es que los programas de corte suelen incluir las órdenes de calentamiento antes de las del script de inicio en el archivo .gcode de la pieza,, por lo que las del script se ejecutan con los elementos ya calientes y esto influye tanto en el "homing" como en el autolevel.
Para poder realizar el primero en frío, habría que editar el fichero de cada pieza para cambiar la posición del G28, cosa bastante poco práctica, por lo que habrá que conformarse con hacer el "homing" en caliente.
Solucionar el problema con el autolevel es bastante mas sencillo: para ello solo habría que realizar el G29 al comenzar las sesiones de impresión y colocar en el scrip de inicio el comando M420 S1, en lugar del habitual G29. También podremos guardar las mediciones en la EEPROM (si tenemos activado su uso), para que se conserven entre reinicios y así no tener que realizarlas cada vez. Esto último, siempre que no cambien, cosa que sucederá si no tenemos una superficie de impresión fija.
Por ejemplo, si tenemos un cristal y lo quitamos para retirar la pieza, será dificil poder utilizar el autolevel realizando las mediciones en frio: tendríamos que esperar para hacer una nueva impresión a que los elementos calefactados se enfriasen y así realizar una nueva medición, ya que las medidas anteriores seguramente habrán variado al quitar y poner el cristal en la cama.
Sobre el problema del calentamiento de la cama, suele ser bastante más lento que el del hotend, pero no tanto como indicas. En todo caso, depende de la temperatura ambiente y de lo mejor o peor aislada que esté la cama.
Para mejorar este aspecto, es bastante recomendable colocar una lámina de corcho bajo ella, lo que disminuye sensiblemente los tiempos de calentamiento.
Otro aspecto a controlar es la resistencia del circuito de la cama, pues si es sensiblemente inferior a la teórica, no tendrá suficiente potencia para calentar correctamente.
La de la cama de serie suele ser de 1,3 a 1,5 Ohms.

La resistencia de la cama es correcta, de hecho estaba trabajando correctamente con el otro firm. Calentaba infinitamente más rápido. Yo para la cama tengo instalado una placa con un mosfet que tiene un led que indica el disparo. Lo que aprecio es que con el anterior firm el disparo era en permanencia hasta alcanzar la temperatura. Con este firm el led está encendido hasta los 40 grados y los primeros 40 grado los sube rápido como siempre, el problema son los otros 10 grados hasta los 50 los sube dando pequeños pulsos.. no entiendo por qué ???? incluso entra en fallo la impresora y me dice que tengo que reiniciar. Entiendo que es por no haber alcanzado la temperatura. El mensaje que muestra en la pantalla de la impresora es. Calent. fallido: Cama. IMPRESORA DETENIDA. Por favor, reinicie.
Para laminar y generar el GCODE yo utilizo el programa Cura. Entiendo que lo que me dices de modificar los comandos es relativo a ir a la configuración de la impresora e insertar los comandos ahí lo he hecho pero sigue sin funcionarme. Puedes indicarme por favor como
Citar
#25
Vale, entonces ya veo cual es el problema que tienes con el calentamiento de la cama: se debe a que no has realizado la calibración del PID que indicaba en la respuesta donde puse las modificaciones a realizar.
La forma que yo indicaba es por PID, siendo más precisa que Bang-Bang para el control de la temperatura, pero para utilizarla es necesario configurar correctamente los valores mediante un PID Autotune (comando gcode M303). Si no lo haces así, estás utilizando los valores por defecto que trae Marlin para ello y que se corresponden con una cama totalmente distinta a la que tiene tu impresora, de ahí que no funcione bien.
Si no quieres hacer esa calibración, siempre puedes volver al sistema que tenías antes (Bang-Bang). Para ello solo tienes que poner, en el archivo Configuration.h, así la siguiente línea:

//#define PIDTEMPBED

Con eso volverá al sistema de control anterior y dejarás de tener los problemas de calentamiento actuales.
Si lo haces así tendrás más memoria libre, pues el PID consume más que Bang-Bang, así que seguramente puedas activar alguna otra cosa, como la pantalla de arranque si la tienes deshabilitada.

Sobre lo que indicas de los comandos en CURA, supongo que en relación con el autolevel, no te entiendo bien lo que dices haber hecho y que no te funciona.
Citar
#26
resim

Lo que te digo de Cura es que he intentado modificar en esta ventana. He pasado el comando G28 para arriba pero hasta que la cama está caliente no empieza a imprimir. Entonces el detector con la cama caliente no la controla y el cabezal se empotra contra la cama cuando va a buscar el 0 del eje Z.
Sin embargo con la cama fría funciona perfectamente lo curioso es que aunque intente regular el detector con la cama caliente no funciona siempre igual... no repite correctamente la medición.

he hecho el autotune
SENDING:M303
PID Autotune start
bias: 34 d: 34 min: 147.66 max: 152.17
bias: 33 d: 33 min: 148.44 max: 151.74 Ku: 25.45 Tu: 34.90
Classic PID
Kp: 15.27 Ki: 0.88 Kd: 66.62
bias: 32 d: 32 min: 148.43 max: 151.74 Ku: 24.59 Tu: 35.23
Classic PID
Kp: 14.75 Ki: 0.84 Kd: 64.96
bias: 32 d: 32 min: 148.49 max: 151.52 Ku: 26.86 Tu: 34.24
Classic PID
Kp: 16.11 Ki: 0.94 Kd: 68.97
PID Autotune finished! Put the last Kp, Ki and Kd constants from below into Configuration.h
#define DEFAULT_Kp 16.11
#define DEFAULT_Ki 0.94
#define DEFAULT_Kd 68.97
echo:busy: paused for user
echo:busy: paused for user
echo:busy: paused for user
echo:busy: paused for user
echo:busy: paused for user

He parado esto porque no paraba

Es suficiente ?????
Citar
#27
Me parece que tenemos un problema de comunicación y si no lo resolvemos no vamos a poder llegar a buen puerto: si no sabes como se hace algo de lo que te indico, tienes que decirlo para que te lo explique antes de intentarlo por tu cuenta.
Por tus anteriores comentarios, daba la impresión de que querías que la impresora se comportase como lo hacía antes, para lo que te indiqué la linea que tenías que cambiar. Simplemente con cambiarla y volver a subir el firmware a la placa, la impresora se comportará en el calentamiento de la cama como lo hacía con el anterior firmware.
Si no es lo que quieres y prefieres hacerlo por PID, tienes que indicar que no sabes cómo hacerlo para que pueda explicártelo antes.
El comando que hace el Autotune es el M303, pero hay que indicarle mediante varios parámetros qué dispositivo se quiere calibrar y cómo se quiere realizar.
Algo a tener en cuenta antes de realizarlo, es que los dispositivos no estén ya calientes al comenzar la prueba.
Para realizar el PID Autotune del hotend, hay que poner el siguiente comando: M303 E0 C8 Sxxx, sutituyendo xxx por la temperatura a la que normalmente se vaya a imprimir. Para PLA podría ser 200, lo que quedaría así:

M303 E0 C8 S200

Una vez que realice las 8 pruebas (es el parámetro C), saldrá lo que has puesto en tu respuesta anterior: PID Autotune finished! ...
Ahora hay que copiar las tres líneas que siguen a esa y ponerlas sustituyendo las que hay similares en el archivo Configuration.h.
El proceso para la cama es similar, solo cambian los parámetros E y S. Para PLA, podría ser algo así:

M303 E-1 C8 S60

Como antes, cuando terminese tendrán tres líneas a copiar sustituyendo a las que existen similares en el archivo de configuración.
Hecho eso, solo habrá que compilar y subir el firmware a la placa.
Si hay algo que no tienes claro, no dudes en preguntar antes de realizarlo.

Sobre lo del Autolevel, vamos por partes: lo que indicas de que cuando está caliente cama y hotend, se empotra la boquilla contra la cama no tiene nada que ver con que el sensor sea más o menos preciso en frio o en caliente, simplemente es que no te está funcionando cuando están calientes esos dispositivos y eso no es normal. Así que tendrás que indicar como tienes conectado ese sensor, pues algo no parece estar bien.
Por otra parte, lo que indicas de mover el comando G28 en el script no sirve de nada. Como te he indicado, CURA pone en el archivo de impresión de la pieza todo el script después de las órdenes de calentamiento, por lo que este no se ejecuta hasta que ya se han calentado cama y hotend.
Pero eso me hace pensar que lo que realmente quieres, no es solo que se realicen las mediciones del autolevel cuando esten frios cama y hotend, sino que se haga también el "homing" de Z.
Como ya te indiqué, eso no es viable de forma práctica pues te obliga a modificar a mano cada archivo .gcode que generes con CURA, pues es ahí donde habría que desplazar los G28 para que estuviesen por delante en la ejecución de las órdenes de calentamiento.
En resumen, es muy posible que no tengas bien conectado el sensor y en todo caso, que este no sea de los mejores que se pueden tener y sea muy poco preciso o algo errático, lo que no es raro en este tipo de dispositivos. Pero eso no implica necesariamente que no se pueda utilizar un sensor de ese tipo con cama y hotend calientes.
Yo lo tengo instalado en una de mis impresoras y lo utilicé durante mucho tiempo sin ningún problema con todo caliente. Eso sí, no era raro tener que calibrar el Z Offset cada cierto tiempo debido a las diferencias en la detección.
Citar
#28
(26-03-2020, 11:13 PM)Simemart escribió: Me parece que tenemos un problema de comunicación y si no lo resolvemos no vamos a poder llegar a buen puerto: si no sabes como se hace algo de lo que te indico, tienes que decirlo para que te lo explique antes de intentarlo por tu cuenta.
Por tus anteriores comentarios, daba la impresión de que querías que la impresora se comportase como lo hacía antes, para lo que te indiqué la linea que tenías que cambiar. Simplemente con cambiarla y volver a subir el firmware a la placa, la impresora se comportará en el calentamiento de la cama como lo hacía con el anterior firmware.
Si no es lo que quieres y prefieres hacerlo por PID, tienes que indicar que no sabes cómo hacerlo para que pueda explicártelo antes.
El comando que hace el Autotune es el M303, pero hay que indicarle mediante varios parámetros qué dispositivo se quiere calibrar y cómo se quiere realizar.
Algo a tener en cuenta antes de realizarlo, es que los dispositivos no estén ya calientes al comenzar la prueba.
Para realizar el PID Autotune del hotend, hay que poner el siguiente comando: M303 E0 C8 Sxxx, sutituyendo xxx por la temperatura a la que normalmente se vaya a imprimir. Para PLA podría ser 200, lo que quedaría así:

M303 E0 C8 S200

Una vez que realice las 8 pruebas (es el parámetro C), saldrá lo que has puesto en tu respuesta anterior: PID Autotune finished! ...
Ahora hay que copiar las tres líneas que siguen a esa y ponerlas sustituyendo las que hay similares en el archivo Configuration.h.
El proceso para la cama es similar, solo cambian los parámetros E y S. Para PLA, podría ser algo así:

M303 E-1 C8 S60

Como antes, cuando terminese tendrán tres líneas a copiar sustituyendo a las que existen similares en el archivo de configuración.
Hecho eso, solo habrá que compilar y subir el firmware a la placa.
Si hay algo que no tienes claro, no dudes en preguntar antes de realizarlo.

Sobre lo del Autolevel, vamos por partes: lo que indicas de que cuando está caliente cama y hotend, se empotra la boquilla contra la cama no tiene nada que ver con que el sensor sea más o menos preciso en frio o en caliente, simplemente es que no te está funcionando cuando están calientes esos dispositivos y eso no es normal. Así que tendrás que indicar como tienes conectado ese sensor, pues algo no parece estar bien.
Por otra parte, lo que indicas de mover el comando G28 en el script no sirve de nada. Como te he indicado, CURA pone en el archivo de impresión de la pieza todo el script después de las órdenes de calentamiento, por lo que este no se ejecuta hasta que ya se han calentado cama y hotend.
Pero eso me hace pensar que lo que realmente quieres, no es solo que se realicen las mediciones del autolevel cuando esten frios cama y hotend, sino que se haga también el "homing" de Z.
Como ya te indiqué, eso no es viable de forma práctica pues te obliga a modificar a mano cada archivo .gcode que generes con CURA, pues es ahí donde habría que desplazar los G28 para que estuviesen por delante en la ejecución de las órdenes de calentamiento.
En resumen, es muy posible que no tengas bien conectado el sensor y en todo caso, que este no sea de los mejores que se pueden tener y sea muy poco preciso o algo errático, lo que no es raro en este tipo de dispositivos. Pero eso no implica necesariamente que no se pueda utilizar un sensor de ese tipo con cama y hotend calientes.
Yo lo tengo instalado en una de mis impresoras y lo utilicé durante mucho tiempo sin ningún problema con todo caliente. Eso sí, no era raro tener que calibrar el Z Offset cada cierto tiempo debido a las diferencias en la detección.

Tienes que perdonar pero pensé que te había dicho antes que no sabía nada del tema. Lo poco que sé lo he aprendido contigo. En cualquier caso he optado por la opción de que el control de la cama caliente se realice como antes... así no me lio tanto y más adelante, una vez que consiga que me funcione el autolevel con la impresora caliente me pongo con el resto.

este es el control que utilizo..

]resim

y así está cableado...


resim

por el cable marrón van 12v hacia el detector. El retorno del detector (negro) va a la resistencia, el azul va al ánodo del Zener y al mismo tiempo al hilo negro que va al conector de la placa, el cátodo del Zener va al otro punto de la resistencia y al hilo rojo que va a la placa. No se que puede estar mal.... puedes echar un vistazo por favor...



gracias...
Citar
#29
No hay nada que perdonar, ya comprendí desde el primer momento que eres un usuario inexperto y por eso mi recomendación de que preguntes todo lo que no entiendas o sepas, antes de intentar hacerlo.
Cuando te indico alguna opción a tomar, como en el caso del PID Autotune, no pongo toda la información necesaria pues sino las respuestas serían interminables, solo entro en detalles cuando se decide que es lo que se va a realizar y en ese momento aún no estaba claro si te decidías por volver a la configuración anterior u optabas por el PID.
Me parece bien que en este momento no pongas el control por PID en la cama. Más adelante quizá quieras hacerlo, pues es bastante más preciso en el control de la temperatura pero, en todo caso y si aún no lo tienes hecho, es muy recomendable sacar la alimentación de la cama fuera de la placa, pues su consumo es muy elevado y se acaban teniendo problemas. Para hacerlo se necesita un mosfet o relé de estado sólido.
Si en algún momento decides ponerte con ello, tienes información en el foro y/o no dudes en preguntar.
Sobre la conexión que tienes en el sensor, el montaje del divisor de voltaje parece correcto, suponiendo que los cables negro y azul que van a la resistencia y al zener son los del sensor, que el cable negro conectado en el lado contrario va al pin de señal en el conector del final de carrera del eje Z (pin más cercano al borde de la placa) y que el cable azul restante va a GND, pero eso no significa que el dispositivo funcione bien: hay que comprobar el voltaje real que dá el divisor. Si es demasiado bajo, puede que la MCU tenga problemas para detectar la activación del sensor.
La única forma de comprobar esto último es con un polímetro, midiendo el voltaje que hay entre el pin de señal y GND cuando el sensor está inactivo y cuando se activa, pero midiendo cuando los calentadores (cama y hotend) están funcionando. Ni que decir tiene que todo esto hay que hacerlo con las máximas precauciones, para no producir ningún cortocircuito.
Este tipo de divisor de voltaje tiene estos inconvenientes, pues dependiendo de los componentes concretos que se usen (resistencia, zener, sensor), los voltajes de trabajo pueden variar.
Por ello, la mejor forma de alimentar el sensor a 12V es utilizar un optoacoplador que, en lugar de reducir los 12V a los 5V que necesita la línea de señal del final de carrera, funciona poniendo a GND dicha línea tal y  como hace el interruptor habitual.
El montaje, en este caso, sería así:

resim
Citar
#30
muchas gracias, lo más seguro es que cuando acabe la reclusión en la que estamos todos y pueda salir a la calle compraré un optoacoplador para esto pero ahora mismo el problema creo que es mal funcionamiento del detector porque ya se ve que el led no funciona cuando está caliente la cama. Es decir, con la cama fría el led del detector funciona y la impresora hace el autolevel bien pero cuando está la cama caliente el detector no se pone a "1" nunca. En fin.... me parece que tendré que cambiar el detector...

Otra cosa es esto que me has explicado que no he entendido...

"Para poder realizar el primero en frío, habría que editar el fichero de cada pieza para cambiar la posición del G28, cosa bastante poco práctica, por lo que habrá que conformarse con hacer el "homing" en caliente.
Solucionar el problema con el autolevel es bastante mas sencillo: para ello solo habría que realizar el G29 al comenzar las sesiones de impresión y colocar en el scrip de inicio el comando M420 S1, en lugar del habitual G29. "

No entiendo que es lo que tengo que hacer... He puesto el comando M420 S1 pero la impresora no hace el autolevel…. perdona la ignorancia...
Citar
#31
En esa explicación hay dos aspectos distintos: el "homing" del eje Z y el autolevel.
Para realizar el primero en frío cuando se inicia la impresión, necesariamente hay que conseguir que las órdenes de calentamiento estén después de las que realizan el "homing".
Pero eso solo es posible editando a mano los archivos que genera el programa de corte, pues es él quien coloca esas órdenes de calentamiento en dicho archivo y siempre lo hace antes de poner las que nosotros podemos indicar en el script de inicio, que es donde ponemos el G28.
Para realizar el autolevel en frío, la cosa es más sencilla, pero hay que tener en cuenta como es su funcionamiento.
Las mediciones que utiliza solo se pueden realizar mediante el comando G29, pero este no lo podemos incluir en el script de inicio por las mismas razones que vimos para el G28.
Por lo tanto, hay que realizar el G29 antes de empezar la impresión. Pero dado que el comando G28 desactiva el autolevel y hay uno al comienzo de la impresión, hay que volver a activarlo de nuevo y esto es lo que hace el comando M420 S1. Pero no realiza de nuevo las mediciones: las que utilizará el autolevel son las que se encuentren en la memoria RAM en ese momento.
Dado que están en RAM y esta se pierde al reiniciar la máquina, si las queremos conservar tendremos que tener activado el uso de la memoria EEPROM y guardar la memoria RAM en ella justo después de completarlas. Esto último se puede hacer por pantalla (menú Control>Guardar memoria) o enviando el comando gcode M500.
Es decir, el proceso para utilizar el autolevel realizando las mediciones en frío, tendría los siguientes pasos:
1- Colocamos el comando M420 S1 en el script de inicio del programa de corte, justo después del G28.
2- Con todo a temperatura ambiente, realizamos un G28 seguido de un G29. Cuando termina de hacer las mediciones, guardamos la memoria en la EEPROM.
Y eso es todo. A partir de ese momento, siempre que realicemos una impresión con ese script de inicio, se realizará el autolevel utilizando las últimas mediciones que tengamos guardadas en la EEPROM.
Si queremos renovarlas, tendremos que realizar de nuevo el punto 2 anterior.
Citar
#32
(27-03-2020, 11:38 PM)Simemart escribió: En esa explicación hay dos aspectos distintos: el "homing" del eje Z y el autolevel.
Para realizar el primero en frío cuando se inicia la impresión, necesariamente hay que conseguir que las órdenes de calentamiento estén después de las que realizan el "homing".
Pero eso solo es posible editando a mano los archivos que genera el programa de corte, pues es él quien coloca esas órdenes de calentamiento en dicho archivo y siempre lo hace antes de poner las que nosotros podemos indicar en el script de inicio, que es donde ponemos el G28.
Para realizar el autolevel en frío, la cosa es más sencilla, pero hay que tener en cuenta como es su funcionamiento.
Las mediciones que utiliza solo se pueden realizar mediante el comando G29, pero este no lo podemos incluir en el script de inicio por las mismas razones que vimos para el G28.
Por lo tanto, hay que realizar el G29 antes de empezar la impresión. Pero dado que el comando G28 desactiva el autolevel y hay uno al comienzo de la impresión, hay que volver a activarlo de nuevo y esto es lo que hace el comando M420 S1. Pero no realiza de nuevo las mediciones: las que utilizará el autolevel son las que se encuentren en la memoria RAM en ese momento.
Dado que están en RAM y esta se pierde al reiniciar la máquina, si las queremos conservar tendremos que tener activado el uso de la memoria EEPROM y guardar la memoria RAM en ella justo después de completarlas. Esto último se puede hacer por pantalla (menú Control>Guardar memoria) o enviando el comando gcode M500.
Es decir, el proceso para utilizar el autolevel realizando las mediciones en frío, tendría los siguientes pasos:
1- Colocamos el comando M420 S1 en el script de inicio del programa de corte, justo después del G28.
2- Con todo a temperatura ambiente, realizamos un G28 seguido de un G29. Cuando termina de hacer las mediciones, guardamos la memoria en la EEPROM.
Y eso es todo. A partir de ese momento, siempre que realicemos una impresión con ese script de inicio, se realizará el autolevel utilizando las últimas mediciones que tengamos guardadas en la EEPROM.
Si queremos renovarlas, tendremos que realizar de nuevo el punto 2 anterior.

Me ha parecido ver en algún sitio que la utilización de la memoria EEPROM era parametrizable. Como puedo saber si la tengo activada o no ????

(27-03-2020, 11:38 PM)Simemart escribió: En esa explicación hay dos aspectos distintos: el "homing" del eje Z y el autolevel.
Para realizar el primero en frío cuando se inicia la impresión, necesariamente hay que conseguir que las órdenes de calentamiento estén después de las que realizan el "homing".
Pero eso solo es posible editando a mano los archivos que genera el programa de corte, pues es él quien coloca esas órdenes de calentamiento en dicho archivo y siempre lo hace antes de poner las que nosotros podemos indicar en el script de inicio, que es donde ponemos el G28.
Para realizar el autolevel en frío, la cosa es más sencilla, pero hay que tener en cuenta como es su funcionamiento.
Las mediciones que utiliza solo se pueden realizar mediante el comando G29, pero este no lo podemos incluir en el script de inicio por las mismas razones que vimos para el G28.
Por lo tanto, hay que realizar el G29 antes de empezar la impresión. Pero dado que el comando G28 desactiva el autolevel y hay uno al comienzo de la impresión, hay que volver a activarlo de nuevo y esto es lo que hace el comando M420 S1. Pero no realiza de nuevo las mediciones: las que utilizará el autolevel son las que se encuentren en la memoria RAM en ese momento.
Dado que están en RAM y esta se pierde al reiniciar la máquina, si las queremos conservar tendremos que tener activado el uso de la memoria EEPROM y guardar la memoria RAM en ella justo después de completarlas. Esto último se puede hacer por pantalla (menú Control>Guardar memoria) o enviando el comando gcode M500.
Es decir, el proceso para utilizar el autolevel realizando las mediciones en frío, tendría los siguientes pasos:
1- Colocamos el comando M420 S1 en el script de inicio del programa de corte, justo después del G28.
2- Con todo a temperatura ambiente, realizamos un G28 seguido de un G29. Cuando termina de hacer las mediciones, guardamos la memoria en la EEPROM.
Y eso es todo. A partir de ese momento, siempre que realicemos una impresión con ese script de inicio, se realizará el autolevel utilizando las últimas mediciones que tengamos guardadas en la EEPROM.
Si queremos renovarlas, tendremos que realizar de nuevo el punto 2 anterior.

Me ha parecido ver en algún sitio que la utilización de la memoria EEPROM era parametrizable. Como puedo saber si la tengo activada o no ????

La pregunta anterior la hago porque cuando le doy Guardar EEPROM en la pantalla de la impresora solo se escucha un pitido y al enviar el comando solo aparece SENDING:M500. No hay confirmación de que se guardase.
Citar
#33
Si se tiene la opción en el menú de la pantalla, se tiene activada la EEPROM. El pitido es la confirmación de que se ha realizado la orden.
Con el comando M500, solo hay confirmación si se tienen activados los mensajes, definiendo el parámetro EEPROM_CHITCHAT.
Entre las modificaciones de la configuración del firmware que indiqué en su momento, estában las líneas para habilitar la EEPROM y los mensajes de los comandos de esta, no sé está última la llegaste a poner así o no.
Citar
#34
(28-03-2020, 01:27 PM)Simemart escribió: Si se tiene la opción en el menú de la pantalla, se tiene activada la EEPROM. El pitido es la confirmación de que se ha realizado la orden.
Con el comando M500, solo hay confirmación si se tienen activados los mensajes, definiendo el parámetro EEPROM_CHITCHAT.
Entre las modificaciones de la configuración del firmware que indiqué en su momento, estában las líneas para habilitar la EEPROM y los mensajes de los comandos de esta, no sé está última la llegaste a poner así o no.

Muchas gracias.

Para solucionar el problema de la temperatura y el detector he bajado la temperatura de la placa al mínimo que me permite Cura. 28º. He visto que también me afecta un poco la temperatura del extrusor porque el detector también está muy cerca de la boquilla. Haciendo como me dijiste para hacer el autolevel con todo frio me está funcionando.
Muchas gracias, pensé que iba a tener que volver el firm original. ya me tenía agotado el tema.

Mientras no consigo un nuevo detector lo que voy a hacer es construir un soporte para el detector que esté alejado del extrusor. He estado buscando hoy todo el día en thingiverse pero no encontré nada. Seguiré buscando. Ahora por lo menos ya puedo imprimir.
Citar
#35
Me alegro que lo hayas solucionado, aunque sea en parte.
Sobre lo de alejar el sensor del hotend, procura hacerlo lo menos posible, porque cuanto más alejado se encuentre menor será la rejilla de medición.
Si el tipo de autolevel que se utiliza es el LINEAR y se imprime una pieza que exceda los bordes de la rejilla de mediciones, las partes que queden fuera de ella se imprimirán sin que actúe el autolevel.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Problema para calentar el extrusor GreenLion54 3 352 23-05-2019, 02:22 PM
Último mensaje: GreenLion54
  CONSULTA Problema con tornillos al imprimir en Anet A8 Gargantia 4 772 08-12-2018, 04:49 AM
Último mensaje: Gargantia
  problema al imprimir a 0.2 zzzzz 2 526 23-10-2018, 02:46 AM
Último mensaje: zzzzz
  Problema Autolevel cambia de un dia para otro urrielu 16 1,801 18-04-2018, 07:55 AM
Último mensaje: david.4
  Mejoras para los novatos con la impresora 3d anet a8 xabibal 0 2,071 29-03-2018, 09:33 AM
Último mensaje: xabibal