Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema con la temp. extrusor Anet e10 y Simplify 3d
#1
Pues estoy intentando imprimir por primera vez con Abs en la Anet e10, uso Simplify 3d, configuro el apartado de temperatura con temp. para el extrusor y para la cama caliente con el mismo índice para las 2, pero cuando voy a imprimir la tmp. de la cama se visualiza correctamente pero la del extrusor sigue a 0, he reconfigurado la imagen varias veces pero no consigo reflejar en la Anet la temperatura correcta. La Anet si le hago precalentar en ABS,  funciona bien por lo que considero que el fallo está en el G-code.
Alguna solución?

Saludos
Citar
#2
Supongo que tienes encuentra que el simplifica hasta que no calienta la cama no empieza a calentar el extrusor, no?

Enviado desde mi D6603 mediante Tapatalk
Citar
#3
Si, el tema es que no sale la temp. del extrusor en la pantalla, ahora estoy imprimiendo pero primero le digo que haga un precalentamiento y después le digo que me imprima la pieza pero sale la temp. por defecto de la impresora no la que figura en Simplify 3d.
Citar
#4
Puedes comprobarlo en el archivo del gcode. Ábrelo con un editor de texto (el bloc de notas vale) y tendrás un grupo de lineas similares a estas:

;   temperatureName,HOTEND,CAMA
;   temperatureNumber,0,0
;   temperatureSetpointCount,1,1
;   temperatureSetpointLayers,1,1
;   temperatureSetpointTemperatures,205,60
;   temperatureStabilizeAtStartup,1,1
;   temperatureHeatedBed,0,1
;   temperatureRelayBetweenLayers,0,0
;   temperatureRelayBetweenLoops,0,0


En la quinta están las temperaturas programadas para la impresión.

Como indica @ec2daw , primero calienta la cama y hasta que no llega esta a la temperatura fijada, no aparece en la pantalla el objetivo de temperatura para el fusor.

Edito: Naturalmente, eso se refleja después en los comandos gcode iniciales de la pieza.
Tendrás algo como esto:
...
M140 S60
M190 S60
M104 S205 T0
M109 S205 T0
...

El comando M140 fija la temperatura para la cama (los grados que pone despues de la S, 60 en este caso).
El M190 espera hasta que se alcanza en la cama la temperatura que pone después de la S (por eso no aparece todavía la del fusor en la pantalla, no se ha definido aún).
El M104 fija la temperatura del fusor a la que pone después de la S. La T debe de ser el numero del extrusor, aunque no está documentado en la información del Gcode de Marlin.
El M109 espera hasta que se alcanza la que pone después de la S. Lo mismo de antes para la T. La impresión no comienza hasta que se alcanza esa temperatura.

He quitado lo que había puesto sobre eliminar el M190, ya que no es correcto. Dado que el calentamiento del fusor es mucho más rápido que el de la cama, eso haría que la impresión pudiese comenzar antes de que la cama llegase a la temperatura fijada para ella.
Citar
#5
Muchas gracias, desconocía estos parámetros, creía que no funcionaba correctamente, donde poder aprender mas sobre estos parámetros?.

Muchas gracias
Citar
#6
Tienes un listado, más o menos completo, en esta página.
Un saludo.
Citar
#7
muchísimas gracias, Simemart, saludos a todos
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  ANET A8 offset de extrusor al comenzar a imprimir filosso 8 117 13-11-2018, 04:55 PM
Último mensaje: Simemart
  Problema movimiento extrusor kikirikiki 1 141 25-09-2018, 05:24 PM
Último mensaje: Simemart
  CONSULTA Problema anet a8: no carga sd ramigon 3 193 22-09-2018, 07:53 PM
Último mensaje: ramigon
  Anet A8 se resetea al calentar el extrusor Franet a8 6 1,742 06-09-2018, 04:43 PM
Último mensaje: Alfonzo CG
  No sube temp. del extrusor Jesushh369 2 367 28-08-2018, 01:03 AM
Último mensaje: Jesushh369