Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
No me detecta el ordenador la impresora
#1
Hola buenas, llevo tiempo sin poder usar la impresora porque me quede sin ordenador, ahora con un ordenador nuevo, he instalado el repetier 1.0.6 creo que es, y no detecta el usb ... el led de la impresora se enciende, es una prusa i3 con ramps 1.4.
Gracias de antemano
Citar
#2
Yo estoy igual. La tengo desde hace meses y no he conseguido que el windows reconozca el arduino mega. He probado con 3 PC distintos y nada de nada. He leído en mil sitios y probado mil cosas desde el administrador de dispositivos y nada. Yo en mi caso , mi prusa venia con el lcd con lo cual imprimo desde el primer día y lo que es de chiste es que de repente un amigo trae su pc y si lo reconoce. En mac aun no he probado a fondo conectarlo con el como ya he dicho tiro de tarjeta SD e imprimo sin problema.
Un amigo me dijo que era por la placa del pc , otro por las conexiones com y USB ...... Etc etc.
En resumen : yo tampoco lo he conseguido aun

Saludos
Citar
#3
Al instalar el repetier - host no se instalo los drivers para el hardware de arduino? Si no se instalo es eso lo que os falta.

http://arduino.cc/en/pmwiki.php?n=Guide/Windows

Saludos,
Citar
#4
copie la carpeta tal cual de arduino del pc viejo al nuevo, puede ser que el error sea, que el nuevo es de 64bit y el viejo de 32?
Citar
#5
Son arduinos originales?? Por que uno de los fabricantes del chip que controla el usb de arduino, a decidido que sus drivers dejen de dar soporte a las copias chinas... con lo cual, en el momento en que se actualiza no se que exactamente se va a la mierda la conexion PC-Arduino.

A mi me paso el 3 de octubre, y tras una tarde entera volviendome loco, consegui modificar el driver para que en vez de el chip original aceptase el chino... claro, el driver no esta firmado y para instalarlo en windows 8 hay que desactivar unas historias para que acepte el driver sin firma, pero funciona, si quereis os subo el driver modificado por mi, pero no me hago responsable... como se dice en estos casos, en mi pc funciona a las mil maravillas Lengua
Citar
#6
:zpistolas: Súbelo a la voz de ya, a qué esperas?
Citar
#7
Yo juraría que es original, lo compre en la conjunta de esta pagina, asi que sera original.. me esta volviendo loco esto... no entiendo porque no se instala el driver bien...
Citar
#8
No es original el arduino entoces. Es un modelo compartible.

Yo los tengo instalados desde hace bastante pero tengo dos, (funduino y beduino) y va bien la verdad
Citar
#9
Un arduino original es a un arduino 'compatible' una copia 1:1. No hay más diferencia que la serigrafía que cada fábrica pone sobre la PCB. Las pistas de la placa, los componentes, su distribución es la misma.

Shiryou, lo que te ha pasado es que Windows 8, por defecto necesita controladores firmados, si no no los instala. En cualquier caso, sólo tienes que activar la opción en W8 de permitir instalar controladores sin firmar cuando lo necesites: http://josmangarsal.es/instalar-drivers-...s-8-y-8-1/

Ni hay que modificar driver ni hay conspiración con el fabricante de los usb originales de Arduino.
Citar
#10
Pues seguramente el mío sea de los chinos. Pero el caso es que un amigo también tiene uno chino y en su segundo pc si pudo conectarlo al pc. Si fuerais tan amables colgaríais el driver modificado ? En breve recibo otra arduino y veremos como le cargo el Marlin. También decir que presionando F7 en windows 8 al arrancar , inicia sin firmar los controladores pero aun así yo no he podido.

Saludos
Citar
#11
@hectorri: te equivocas, eso es lo que tuve que hacer para instalar mi driver modificado. Que sea compatible, no quiere decir que sea original, dado que hay chips FT232R que no lo son, tengo entendido que es un chip de la controladora de USB. En este post del foro de arduino tienes mas informacion:
http://forum.arduino.cc/index.php?PHPSES...=270175.15
Que no me refiero a que el arduino sea pirata, como dices son copias 1 a 1, pero algun cambio debe haber a nivel interno en esos chip, yo ya te digo que despues de mucho leer, lo que encontre fue eso, que el chip FT232R es una copia china, y si tienes esa copia estas jodido por que los drivers de la controladora no funcionan...

Ya en general, para comprobar si os pasa lo mismo que a mi, hacer lo siguiente (os copio&pego del post que pongo antes):
"Control Panel:System: Device Manager: Ports: right click on USB deviceLenguaroperties: Details:Hardware IDs, good one shows this:
ftdibus\comport&vid_0403&pid_6001"

si el pid es 0000, enhorabuena, teneis un FT232R falso... falso, por que es una copia china del original (por lo que descubri despues de muchas vueltas buscando solucion), bueno, ahora vamos con la solucion... mas que nada, por que ayer se me olvido subiros los drivers, y como seguro que estais con el SAV y quereis usar vuestras impresoras, os lo dejo aqui puesto. Seguir los pasos 1 a 1, si lo haceis con cuidado no rompereis nada:

- Download the drivers, extract to a local folder.
- edit ftdibus.inf and ftdiport.inf with text editor
- replace "USBVID_0403&PID_6001" with "USBVID_0403&PID_0000" everywhere and save
- in the device manager, select the device and choose to update driver
- click "Browse my computer for driver software"
- click the "Let me pick from a list of device drivers on my computer"
- select "Universal Serial Bus Controller" from the list
- click "Have Disk"
- point it to the file "ftdibus.inf" you have just edited
- click install anyway when windows complains it's not signed
- repeat the procedure with the other inf file, "ftdiport.inf"

Esta ingles por que es la informacion que consegui de la gente del foro de arduino, a mi esto me funciono tal cual, excepto la instalacion de los drivers, en win7 es tal cual pone ahi, pero para poder instalarlos en win8 teneis que hacer lo siguiente:
http://www.howtogeek.com/167723/how-to-d...d-drivers/

y ya esta, cualquier cosa, no dudeis en mandarme un privado, si veis que no podeis modificar el driver decirmelo y esta tarde si que si, subo el driver... espero no olvidarme Lengua

------ EDITO: --------

@MerlinReady eso es lo que me pasaba a mi, en el portatil que es con la que funciona la prusa, no me lo reconocia, conectaba, pero no daba señal de vida, no podia controlar los motores ni nada, pero en el de sobremesa si, y la unica diferencia es que el portatil (que es de mi chica) lo tiene con el autoupdate de windows y el de sobremesa que es el mio no, con lo cual en mi sobremesa tengo los drivers antiguos con los que rula perfectamente, y en el portatil he tenido que hacer lo que pongo mas arriba


Y ya que estoy editando os dejo un poco mas de informacion sobre el "fake chip":
http://zeptobars.ru/en/read/FTDI-FT232RL...e-supereal


------ REEDITO: --------

Por cierto!! un saludo a todos! este es mi segundo post! jajajaa
Citar
#12
¿Puedes decir dónde has comprado esa placa Arduino?

No obstante, estamos hablando no de un problema de una copia de Arduino si no la falsificación del chip FTDI. Cosa que me parece de lo más rebuscado. No obstante, sigo manteniendo, y la información que aporta lo confirma, que los 'Arduino compatible' no tienen por qué dar ningún problema. Otra cosa es que los componentes usados en la placa sean falsificaciones o estén defectuosos.
Citar
#13
Si hectorri, no digo que el arduino sea falso, digo que el componente es falso, y el PID es claro, la explicacion es totalmente logica, 2 pcs, uno actualizado y otro no, es un tema de drivers (en mi caso al menos), el chaval que contacte en el foro de arduino, estuvo dos dias dandose cabezazos contra la pared por que tenia 3 arduinos con FT232 originales y 2 con el chip fake, los originales le funcionaban y los "fakes" no, formateo el pc, reinstalo y nada, y tras ver los PID y modificar los .inf funciono. Y a mi me paso lo mismo, solo lo reconocia mi pc, el portatil no, y con la LCD iba perfecto, es decir la placa estaba bien, era algo de drivers del portatil con lo cual en mi caso, blanco y en botella, hace la modificacion de los INF y funcionando de nuevo. Es raruno de cojones, ni siquiera parece que le pase a todo el mundo, pero el problema esta ahi, y la solucion a mi me funciono 100%...

A la pregunta de donde la compre, te dire que me vino con la impresora, es china, comprada en Aliexpress:
http://www.aliexpress.com/item/Hot-Full-...04108.html

y te dire tambien que yo no tenia ni P.I. de que pudiese haber arduinos fakes... o chips de arduino fakes... entiendo lo mismo que tu, si los componentes son 1:1 entiendo que es un compatible y que deberia de funcionar siempre...pero visto lo visto, en la practica parece que no es asi...
Citar
#14
Los pid me paso a mi. Y a la hora de flashear y lo cambie y listo. Me lo reconocio a la primera . pensaba que era un problema del cable o algo
Citar
#15
En 3,2,1 me pongo con ello a ver si de una piii vez consigo imprimir desde repetier y no desde el LCD y que cojones ..... poder conectar vía Sketch. Gracias a todos a ver que tal me sale.
Citar
#16
a mi me aparece en otros dispositivos, y me salen 2 id de hardware

USB/VID_02341&PID_0042&REV_0001
USB/VID_02341&PID_0042
Citar
#17
He conseguido que me lo detecte, pero no se el porque... me he descargado los controladores otra vez de arduino, los 1.0.6 he vuelto a instalar el driver y me ha pasado lo mismo, se instalan, pero al final dice k hubo un error... he cogido el dispositivo lo he desinstalado ya como ultima opción para dejarlo limpio, ha desaparecido lógicamente, lo e desenchufado y lo e vuelto a enchufar, y no me salia en otros dispositivos,(ya pensaba que la había liado k ya ni me salia ahí) he mirado en dispositivos USB y ahí estaba el cabrón, asignado como COM3... lo he probado en el repetier y por fin funciona, que gustazo.

Gracias a todos, a ver si tienes la misma suerte que yo MerlinReady jajaja
Citar
#18
Lagu menuda suerte amigo....
Es desesperante a la vez que frustante...
Desde Win 8 tal cual pone aquí :

- Download the drivers, extract to a local folder.
- edit ftdibus.inf and ftdiport.inf with text editor
- replace "USBVID_0403&PID_6001" with "USBVID_0403&PID_0000" everywhere and save
- in the device manager, select the device and choose to update driver
- click "Browse my computer for driver software"
- click the "Let me pick from a list of device drivers on my computer"
- select "Universal Serial Bus Controller" from the list
- click "Have Disk"
- point it to the file "ftdibus.inf" you have just edited
- click install anyway when windows complains it's not signed
- repeat the procedure with the other inf file, "ftdiport.inf"


Estos pasos los he hecho pero antes también actualizo el software del dispositivo com3 con el archivo arduino.inf, me deja elegir Arduino mega 2560 y de repente aparece Ardu mega 2560 con el triángulo amarillo y ya me quedo otra vez bloqueado.
Sin reiniciar hago lo mismo con los ftdiport y ftdibus que están en la carpeta OLD DRIVERS desaparece Arduino Mega como com3 y se convierte en serial port acompañado de error de código 10.
También he renombrado los ftdibus y port e iniciado win 8 sin firmar dispositivos previamente como indicais arriba.

Madre mia he bajado a win xp para probar y todo jajaja que barbaridad, me lo voy a tomar con calma porque por lo te hace las impresiones mas cortas el estar tan metido en el tema pero vamos es tela marinera.
Gracias a todos y enhorabuena a los que habéis podido conectarlo volvere a repasar todos los post y empezar desde cero con el pc que esta vacío por completo.
Citar
#19
Hola a todos de nuevo
Acabo de recibir un arduino nuevo y nada mas conectarlo por USB al PC me lo ha reconocido sin problema. En 5 minutos BLINK realizado.
Bueno la opción de que sea el chip de comunicaciones de la placa cobra más fuerza.
He leído en algún foro ingles el tema de cambiar ese chip e incluso he visto que se le puede soldar un puerto mini USB al arduino.
Por si os vale de ayuda y tal ..... Seguiré investigando el tema.
Gracias por ayudar en el post y en especial a Shiryou que ha perdido su valioso tiempo en ayudarme. Gracias compi.
Un saludo a todos.
Citar
#20
jajaja, de nada hombre... para eso estamos, como puse por ahi arriba, si a alguien le pasa y necesita el driver tuneado, que me mande un privado y se lo paso

un saludete
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  conecto la ramps a la placa mega y no detecta impresora wuasichu 11 1,222 05-11-2015, 02:01 PM
Último mensaje: diabliyo87
  Mini ordenador y pantalla táctil para impresoras Proyectos Arduino 9 1,768 27-02-2015, 10:14 PM
Último mensaje: CHA
  ¿ Que ordenador conectais a la impresora ? Tx360 3 697 28-11-2013, 10:35 AM
Último mensaje: yo_mismo