Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Microparones y se me resetea.
#1
Hola a todos, después de un tiempecito inactivo he vuelto a la carga con la impresión 3d. El caso es que ya tengo configurada mi Kossel a la cual le puse arduino + ramps, pero me da dos problemas y no consigo dar con la tecla. El primero es que tengo microparones durante la impresión, de mas un o menos 1 seg. se queda quieta y luego sigue como si nada, con el consiguiente pegote, como si por un momento no procesase información, tema de arguino + ramps chinas?, tema de marlin? otra cosa?. la otra es q cuando le pongo una velocidad de retracción alta en el simplify, por ejemplo de 80, se resetea la impresora al acabar de hacer homming, sin embargo a 30 de velocidad no me pasa, y no entiendo que tendra que ver una cosa con la otra. alguna proteccion en marlin?. Muchas gracias por vuestras respuestas.
Citar
#2
Lo de los microparones si utilizas usb para enviar el gcode probablemente sea tema de interferencias. Utiliza un cable mas corto o la sd.

Lo del extrusor es extraño, no te sabria decir que te puede pasar.
Citar
#3
(18-05-2018, 05:07 PM)Shellmer escribió: Lo de los microparones si utilizas usb para enviar el gcode probablemente sea tema de interferencias. Utiliza un cable mas corto o la sd.

Lo del extrusor es extraño, no te sabria decir que te puede pasar.


Muchas gracias shellmer, a raiz de tu respuesta he hecho una impresión desde la orange pi con octoprint y efectivamente, no me pasa, lo raro es que con la anet con el mismo cable tampoco me había pasado nunca.
Citar
#4
Podria ser a causa de la velocidad de comunicación tambien. Los microcontroladores tienen una tasa de error en la transmision serie diferente por cada velocidad distinta, y no la mayor velocidad precisamente es la que mas % de error puede tener... puede que comuniques a 115200 baudios con mucha tasa de error y sin embargo a 250000 apenas tengas... es muy dependiente de la frecuencia del reloj y el hardware usado.

Te dejo una tabla de la tasa de error de un atmega328 para que veas a lo que me refiero:
resim

Si tienes acceso al firmware de esa impresora, mira a que velocidad comunica tu anet y configurale los mismos baudios a tu Kossel. Eso o prueba configurando otras velocidades diferentes.

Y si eso no funciona... comprueba que no tengas ningun cacharro que pueda emitir interferencias cerca...
Citar
#5
gracias! esta tarde lo miro y reconfiguro en marlin.
Citar