Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Mi Tronxy X5S
Hola, lo mejor siempre es partir de las últimas versiones, tanto de Marlin como del IDE de Arduino, con un entorno lo más controlado posible.
Descargar versiones fuera de las páginas oficiales puede ser una fuente de problemas y no te permite saber el origen de los mismos.
Estos son los enlaces de descarga confiables: Marlin 1.1.9, ArduinoIDE 1.8.7, U8Glib (librería para pantallas de tipo gráfico).
Si la placa que usas no está soportada directamente por el IDE, tendrás que descargar los archivos de información del hardware e instalarlos en él: Sanguino y Anet.
Sobre lo que indicas de la regulación de la cama, el sistema que indicas por PWM se denomina PID.
Para configurarlo tienes mucha información en Internet sobre la cuestión, solo tienes que poner "ajuste PID cama".
Según la calidad de la placa que tengas, puede ser una buena idea utilizar un dispositivo externo (mosfet o relé SSR) para controlarlo y así evitar que se te queme el mosfet que lleva incorporado la placa.
Citar
Buenas tardes simemart, gracias por responder tan rápido, te comentó:
Estoy usando el arduino ide 1.8.15.0 que me descargue hoy mismo desde la web oficial. Por otra parte, la biblioteca use la del archivo de thingiverse y la he metido dentro de la carpeta arduino/libraries/U8glib.

El marlin 1.1.8 me lo baje de la página de thingiverse, es el mismo que uso el compañero wilt foster y recomendó cybermask. pero me da esos errores que no entiendo que son ni como solucionar. Los primeros errores se que son referentes a algo de la pantalla, lo demás ni idea.

He instalado el hardware de la placa sanguino y he seguido los pasos que se resumían en el archivo instrucciones del archivo de thingiverse.

adjunto datos de la placa y como hice todo y los errores mostrados. No se si habré fallado en algún detalle que no veo. Alguien podría resumir el proceso de forma escueta o si saben el fallo mejor que no puedo más con esta locura.

Un saludo y gracias a todos por la ayuda

resim

resim
Citar
Los errores que estás teniendo son del entorno de compilación.
Que el primero se produzca al trabajar sobre el archivo ultralcd_impl_DOGM.h, que en efecto contine rutinas para pantallas gráficas, no quiere decir que sea un error de pantalla como dices.
Como bien indica, lo que se produce es un error interno del compilador, no del sketch (Marlin).
Vuelvo a repetirte que no conseguirás eliminar estos errores si no partes de una instalación confiable.
Por ejemplo, el IDE de Arduino que figura en esas capturas de pantalla no es el que se descarga de la página oficial de Arduino, así que difícilmente puedes haberlo hecho como dices.
El original no lleva esa coletilla (Windows Store 1.8.15.0).
Por otro lado, la librería U8Glib no se instala en el IDE de Arduino como indicas. Hay que hacerlo desde el gestor de librerías o bien mediante un archivo .zip (el enlace que te he puesto).
Mi recomendación, como te indicaba en mi anterior respuesta, es que partas de un entorno limpio y descargues los archivos originales.
Como últimamente he contestado varias veces sobre este tema y no me gusta engordar post con cosas que no tienen que ver con su temática inicial, en lugar de detallarte aquí los pasos a seguir, creo que haré un post sobre todo esto.
Citar
Buenas de nuevo, he realizado todo según tus indicaciones del mensaje anterior y un post tuyo que conseguí donde comentabas como cambiar el marlin.

Según las indicaciones, he logrado avanzar más, ya compila solo que ahora me sale este error a la hora de cargarlo a la placa.

Porque podrá ser??

resim


Por otra parte estoy intentando hacerme un llavero, pero resulta que me salen las capas separadas entre sí, como si no se fundieran entre ellas, no se si será demasiada refrigeración o baja temperatura de extrusión?, homming z mal hecho? he probado de todo jugando con los parámetros mencionados anteriormente y no doy con la solución.

un saludo y perdonen por ser tan pesado

resim
Citar
Bueno, he seguido intentándolo y ahora resolviendo el problema de la comunicación entre el puerto COM3, leyendo por ahi en internet.

ahora resulta que me compila bien y va a enviar el sketch y me esta dando este fallo mientra se enviaba el sketch. ¿Que podrá ser ahora? :'(


resim
Citar
Buenas tardes, sigue dándome los mismos errores de comunicación o algo que no entiendo. SAbría alguien que podría ser esto??

gracias de nuevo
Citar
Hola, no había visto tus preguntas hasta ahora. Hay tantos subforos que uno se pierde mensajes.
El error que estás teniendo es debido a que no se comunican el IDE de Arduino con el bootloader de la placa.
Lo más habitual es que se haya perdido este último y en ese caso hay que volver a cargarlo en la memoria flash de la MCU.
No sé que placa estas utilizando, aunque el proceso suele ser el mismo para todas: necesitas un Arduino (Uno o Mega) como ISP externo.
Tengo un par de post publicados sobre el tema que puedes consultar.
Citar
hola soy nuevo en esto me podríais pasar la configuración paso a paso de cura para esta impresora?
Citar
Buenas tardes, no te preocupes simemart. La cuestión es que ya no me los errores de sincronización, al parecer e baudrate mal puesto. Por otra parte el error de abajo lo sigo teniendo no se porque no puede comunicar con la impresora, y esto me pasa con la tronxy x5s y la prusa i3 mk3 que no me deja actualizarla tampoco debido a este error. que podrá ser?

un saludo y gracias de nuevo.

resim
Citar