Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
LCD anet a8 compatible con ramps o mks gen ?
#1
buenas noches

alguien sabe si el display original de una anet a8 es compatible con una ramps o con una mks gen 1.4, queria cambiar solo la placa y nos se si es compatible o tengo que comprar alguna otra?
Citar
#2
Hola, pues en principio Marlin está preparado para utilizarla con la RAMPS 1.4 y la MKS GEN 1.4 (para Marlin, la MKS es una RAMPS).
Para ello, en el configuration.h al igual que en las A8, hay que descomentar la línea #define ZONESTAR_LCD.
Pero hay un problema en la conexión.
En teoría hay que utilizar el conector AUX-2 de la RAMPS (o de la MKS), ya que esos son los pines que están definidos en el pins_RAMPS.h para esa pantalla.
Pero, si no me equivoco, ese conector tiene intercambiados los correspondientes a +5v y GND respecto a como vienen en el conector de la Anet.
Es una cosa que tendrás que tener en cuenta, ya que no podrás conectar sin más el cable plano al conector de la RAMPS (o de la MKS).
Hay que modificar el cable, intercambiando las líneas de los pines 1 y 2.
Citar
#3
(13-03-2018, 01:25 AM)Simemart escribió: Hola, pues en principio Marlin está preparado para utilizarla con la RAMPS 1.4 y la MKS GEN 1.4 (para Marlin, la MKS es una RAMPS).
Para ello, en el configuration.h al igual que en las A8, hay que descomentar la línea #define ZONESTAR_LCD.
Pero hay un problema en la conexión.
En teoría hay que utilizar el conector AUX-2 de la RAMPS (o de la MKS), ya que esos son los pines que están definidos en el pins_RAMPS.h para esa pantalla.
Pero, si no me equivoco, ese conector tiene intercambiados los correspondientes a +5v y GND respecto a como vienen en el conector de la Anet.
Es una cosa que tendrás que tener en cuenta, ya que no podrás conectar sin más el cable plano al conector de la RAMPS (o de la MKS).
Hay que modificar el cable, intercambiando las líneas de los pines 1 y 2.



Ahh! lo que pasa es que voy a poner unos tmc2130 y como me venian 5 en el pack queria ponerlos todos y para el control del spi me ocupan buena parte de los pines del aux2 y del aux 3, no se como podria solventarlo, si se puede claro, mi idea es no usar la tarjeta sd pero de ser posible si la pantalla
Citar
#4
En ese caso, quizá tu mejor opción sea la MKS con una pantalla gráfica del tipo Reprap Discount Full Graphics (LCD12864).
La MKS porque ya trae por separado los conectores para la pantalla y no usa el AUX-3 como la RAMPS, en la que hay que utilizar el soldador.
Por menos de 10€ mejoras mucho la visibilidad y usabilidad de la impresora y además, te incluye un lector de SD. Solo tienes que reconfigurar un par de pines para que funcione.
Supongo que estarás al tanto de este post.

Edito:
Vale, ya veo que sí lo has visto y que ya te has decidido por la MKS.
La pantalla original podrías conectarla en el EXP1, intercambiando las lineas 1 y 2 como te indicaba en la anterior respuesta y reconfigurando la asignación de pines en el pins_RAMPS.

Edito2:
El pins_RAMPS quedaría así:
#if ENABLED(ZONESTAR_LCD)
#define LCD_PINS_RS 25
#define LCD_PINS_ENABLE 16
#define LCD_PINS_D4 27
#define LCD_PINS_D5 23
#define LCD_PINS_D6 17
#define LCD_PINS_D7 37
#define ADC_KEYPAD_PIN 35
#define BTN_EN1 -1
#define BTN_EN2 -1
#define BTN_ENC -1
// pin 29 N/C
#endif // ZONESTAR_LCD


Edito3:
Me acabo de dar cuenta de que puede que haya un pequeño problema con el ADC_KEYPAD_PIN: creo que necesita un pin analógico y en EXP1 solo hay digitales.
Habría que recablear esa linea y conectarla a un pin del AUX-2: el A11 o el A12.
Quedaría así:
#if ENABLED(ZONESTAR_LCD)
#define LCD_PINS_RS 25
#define LCD_PINS_ENABLE 16
#define LCD_PINS_D4 27
#define LCD_PINS_D5 23
#define LCD_PINS_D6 17
#define LCD_PINS_D7 37
#define ADC_KEYPAD_PIN 11 (o el 12)
#define BTN_EN1 -1
#define BTN_EN2 -1
#define BTN_ENC -1
// pin 29 N/C
#endif // ZONESTAR_LCD


Creo que es mucho mejor cambiar la pantalla y tener además SD.
Citar
#5
Hola Simemart, en el caso de tener una MKS Gen L y querer usar un LCD como este https://bit.ly/2MlpiJl que modificaciones tendría que hacer? o que configuración de Marlin habría que cambiar?
Citar
#6
(15-08-2018, 03:00 PM)Bucanero escribió: Hola Simemart, en el caso de tener una MKS Gen L y querer usar un LCD como este https://bit.ly/2MlpiJl que modificaciones tendría que hacer? o que configuración de Marlin habría que cambiar?

Hola, gracias por tu voto y comentario.
Para conectar esa pantalla a la placa que indicas no tendrás ningún problema.
Solo debes descomentar (quitar la // inicial), en el archivo Configuration.h, la línea siguiente:

//#define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER

y conectar los cables planos entre los conectores (estan serigrafiados con los mismos nombres).
No necesitarás el adaptador que trae en ese enlace (es para conectar a RAMPS).

Ten en cuenta que esta pantalla necesita, para compilar Marlin, la librería U8Glib.

Un saludo.
Citar
#7
(15-08-2018, 03:42 PM)Simemart escribió:
(15-08-2018, 03:00 PM)Bucanero escribió: Hola Simemart, en el caso de tener una MKS Gen L y querer usar un LCD como este https://bit.ly/2MlpiJl que modificaciones tendría que hacer? o que configuración de Marlin habría que cambiar?

Hola, gracias por tu voto y comentario.
Para conectar esa pantalla a la placa que indicas no tendrás ningún problema.
Solo debes descomentar (quitar la // inicial), en el archivo Configuration.h, la línea siguiente:

//#define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER

y conectar los cables planos entre los conectores (estan serigrafiados con los mismos nombres).
No necesitarás el adaptador que trae en ese enlace (es para conectar a RAMPS).

Ten en cuenta que esta pantalla necesita, para compilar Marlin, la librería U8Glib.

Un saludo.

Yo uso el archivo de configuracion de MArlin para la Anet A8, en el esta definida como LCD la Zonestar, debo de comentar esa linea o la dejo como esta y ademas descomento la que me has mencionado?, gracias y un saludo.
Me respondo a mi mismo, daban conflicto las dos pantallas, asi que solo he dejado la Full Grafics, me complia bien pero no se enciende el LCD, y esta bien conectada con la libreria añadida, no se que puede ser.
Edito y añado mis archivos de configuracion https://www.dropbox.com/sh/1i7e39kt7wx0k...DtJya?dl=0
Citar
#8
Hola, el include de la librería U8Glib que aparece al comienzo del Configuration.h lo has puesto tú, ¿no?
No lo pongas ahí, al habilitar ese controlador de pantalla ya lo hace en otro sitio.
La MKS GEN L lleva un ATMega2560 y puede comunicarse a 250000 baudios.
No veo nada incorrecto en los dos archivos.
Prueba haciendo esos cambios y vuelve a compilar.
Citar
#9
(15-08-2018, 07:24 PM)Simemart escribió: Hola, el include de la librería U8Glib que aparece al comienzo del Configuration.h lo has puesto tú, ¿no?
No lo pongas ahí, al habilitar ese controlador de pantalla ya lo hace en otro sitio.
La MKS GEN L lleva un ATMega2560 y puede comunicarse a 250000 baudios.
No veo nada incorrecto en los dos archivos.
Prueba haciendo esos cambios y vuelve a compilar.

Eso me aparece al meterme en Programas/Librerias y la seleccionaba de la lista que estaba alli, y se ponia esa linea, la he eliminado y he seleccionado buscandola y volviendo a instalarla, me dice que instalada pero ya no aparece la linea de include , he cambiado la velocidad y todo sigue igual, lo unico que consigo es que manteniendo pulsada la rueda haga un click click click y la pantalla parpadea muy levemente, tambien si giro la rueda en la placa se ilumina el led azul
Citar
#10
¿Seguro que tienes bien emparejados los conectores?
Citar
#11
(15-08-2018, 08:34 PM)Simemart escribió: ¿Seguro que tienes bien emparejados los conectores?

Seguro, lo he mirado y quitado y vuelta a pone mil veces
Citar
#12
Dices que no se ilumina la pantalla, ¿no?
Invierte los conectores para probar.
Esos síntomas suelen ser de tener cambiados los conectores.

Quise decir intercambia, no invierte. aunque tienen posición.
Citar
#13
(15-08-2018, 08:43 PM)Simemart escribió: Dices que no se ilumina la pantalla, ¿no?
Invierte los conectores para probar.
Esos síntomas suelen ser de tener cambiados los conectores.

Quise decir intercambia, no invierte. aunque tienen posición.

Nada de nada, sigue igual, se ilumina pero muy muy levemente y justo cuando hace el click click si mantengo la rueda pulsada, estara roto el LCD?
Citar
#14
Pues si que es raro.
He visto un video en Youtube que habla de un problema que hay en este tipo de pantallas clónicas con las soldaduras de los conectores, aunque no me aclaro muy bien cual es la solución que propone.
Si vas bien en inglés puedes verlo aquí.
Yo tengo una exactamente igual a la que pones en el enlace (y comprada en Aliexpress) y desde el primer momento funcionó bien.
Citar
#15
(15-08-2018, 09:24 PM)Simemart escribió: Pues si que es raro.
He visto un video en Youtube que habla de un problema que hay en este tipo de pantallas clónicas con las soldaduras de los conectores, aunque no me aclaro muy bien cual es la solución que propone.
Si vas bien en inglés puedes verlo aquí.
Yo tengo una exactamente igual a la que pones en el enlace (y comprada en Aliexpress) y desde el primer momento funcionó bien.
Con el Ingles mas bien me peleo,pero voy verlo, gracias
Edito, despues de verlo yo creo que dice que hay algun problema con las soldaduras de los conectores de la pantalla, no se como pero tendre que comprobar si estan bien soldados y si hacen algun mal contacto.

(15-08-2018, 09:24 PM)Simemart escribió: Pues si que es raro.
He visto un video en Youtube que habla de un problema que hay en este tipo de pantallas clónicas con las soldaduras de los conectores, aunque no me aclaro muy bien cual es la solución que propone.
Si vas bien en inglés puedes verlo aquí.
Yo tengo una exactamente igual a la que pones en el enlace (y comprada en Aliexpress) y desde el primer momento funcionó bien.

No te lo vas a creer, sabes como se ha solucionado?, girando los conectores de los cables 180º, osea, les he cortado la pestañita que llevan para poder darles la vuelta y que encajaran al reves y voala!!!!! me cago en todos los Chinos que no saben soldar derecho, increible pero cierto, leyendo los comentarios de este video https://www.youtube.com/watch?v=p4vasqd6los aunque al del video se le iluminaba la pantalla y a mi no, pues me he dicho, pues voy a probar, no veas la cara que se me ha quedado cuando lo he visto encendido y funcionando, al menos hemos aprendido algo, muchisimas gracias por todo, eres un fenomeno y lo sabes, si necesitas algo de mi pidelo sin dudarlo, un saludo y gracias.
resim

resim

poems by Owen Suffolk
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  RAMPS no calienta la cama joseslo 17 1,061 16-10-2018, 01:26 PM
Último mensaje: FlyMan
  CONSULTA Ramps 1.6 para anet a8 mafc 11 1,366 04-09-2018, 03:07 PM
Último mensaje: mafc
  pantalla anet 6 para la Anet 8 Nestor 12 3,779 12-04-2018, 08:35 PM
Último mensaje: Josnaro
  CONSULTA Anet A8+Ramps 1.4 esdrufao 7 1,403 10-04-2018, 03:32 PM
Último mensaje: Simemart
  Anet A6/A8 con placa Arduino Mega y Ramps 1.4 Altenife 1 725 09-04-2018, 12:08 AM
Último mensaje: Simemart