Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Error de compilación
#1
Hola soy nuevo en esto y busco ayuda.
Hace algo más de un año compré e instalé una Arduino UNO y empecé a usarla sin ningún problema, despuesde unos meses sin usarla, hace un par de días me puse de nuevo a trastear y empezó a darme "Error al compilar" sin mostrar ningún código de error, probé con varios de los ejemplos que incluye el software con el mismo resultado, con lo que descaté que se tratase de errores en el sketch. Al principio pensé que podría ser la versión del software de Arduino, tenía la versión 1.0, así que actualice a la versión 1.0.5, reinstalé drivers y seguía dando el mismo mensaje.
Después de probar un montón de cosas, he instalado la versión 1.5.4 con los mismos resultados, he activado las opciones de "mostrar salida detallada al compilar y subir" de Preferencias del menú Archivo dando los siguiente:

C:\Users\Miguel Ángel\Desktop\Ardu 1.5\arduino-1.5.4\hardware\tools\avr\bin\avr-g++ -c -g -Os -w -fno-exceptions -ffunction-sections -fdata-sections -MMD -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=154 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR -IC:\Users\Miguel Ángel\Desktop\Ardu 1.5\arduino-1.5.4\hardware\arduino\avr\cores\arduino -IC:\Users\Miguel Ángel\Desktop\Ardu 1.5\arduino-1.5.4\hardware\arduino\avr\variants\standard
C:\Users\MIGUEL~1\AppData\Local\Temp\build721039976017306327.tmp\Blink.cpp -o
C:\Users\MIGUEL~1\AppData\Local\Temp\build721039976017306327.tmp\Blink.cpp.o

No se me ocurre que puedo hacer, no se si será problema del sistema operativo del equipo, aunque no he cambiado nada salvo las actualizaciones periodicas que requiere WINDOWS. Uso un portatil SONY VAIO con Windows 7.

Agadecería que alguien me diese algo de luz.
Citar
#2
La placa la tienes bien seleccionada no? Borraste las librerias cuando reinstalaste el IDE? Igual te estan dando la lata, ya que si el problema esta en la compilacion la placa no tiene que estar mal ya que no influye.

Enviado desde mi Nexus 4 usando Tapatalk now Free
Citar
#3
La placa la tienes bien seleccionada no? Borraste las librerias del antiguo IDE? Igual te estan dando guerra ya que si se bloquea al compilar es problema del IDE y no del arduino...
Citar
#4
Gracias por la respuesta Triggerr.
Tenía instaladas dos versiones del IDE, para curarme en salud he desinstalado las dos (entiendo que así elimino las librerías), he vuelto a instalar la ver. 1.5.4, reinstalado los drivers y seleccionado puerto y tarjeta, pero me sigue dando el mismo error.
No tengo mucha idea de informática, me pregunto si podría tener algo que ver el firewall de Windows o el antivirus, tengo AVAST.
Citar
#5
EL arduino 1 lleva Atmega328?
Citar
#6
sI
Citar
#7
Prueba con este IDE:

http://forum.arduino.cc//index.php?PHPSE...c=118440.0
Citar
#8
¿Desinstalo primero el que tengo?
Cambio los drivers?
Citar
#9
m.loro escribió:¿Desinstalo primero el que tengo?
Cambio los drivers?

Desinstala TODO, haz una instalacion limpia
Citar
#10
He instalado el nuevo IDE y sigue el error
Citar
#11
He solucionado el problema. He visto que tenia instalado Java 7 y Java ™ 6, he desinstalado este útimo y limpiado el registro con CCleaner, he reiniciado y ha compilado sin problemas
Gracias
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  exit status 1 Error compilando para la tarjeta Arduino/Genuino Uno fcojavier 8 3,401 24-10-2018, 02:48 AM
Último mensaje: edmundo
  CONSULTA El arduino compila una vez y despues saca error Jose Eugenio 0 140 20-10-2018, 09:26 PM
Último mensaje: Jose Eugenio
  error compilar skecth homer32 5 3,801 30-08-2015, 04:07 PM
Último mensaje: homer32
  Error de compilación solo con IDE 1.6.5 see2u 0 620 04-06-2015, 05:07 PM
Último mensaje: see2u
  [Error]Full Graphics SmartLCD Controller arubengar 0 415 17-10-2014, 12:33 AM
Último mensaje: arubengar