Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Dummy Load con Control Digital
#21
Ranganok escribió:Hola, he estado mirando el esquema y no veo la reducción de la tensión... Me explico: si tienes una resistencia de sense de 1ohm, la corriente es lineal con la tensión aplicada. Es decir, pasará 1A por cada V que pongamos a la entrada (lo cual quiere decir que tendríamos hasta 5A en 1024 pasos).

Si quieres limitar esto o usar una Rsense más pequeña tendrás que:
1. Usar menos pasos en el PWM (implica menos resolución).
2. O dividir la tensión de salida del primer operacional (el que hace de filtro para el PWM) entre lo que toque.

Como vas a usar una resistencia de 0.5ohms como mínimo deberías dividir entre 2 para seguir teniendo 0-5V con 1024 pasos.

S2

Ranganok Schahzaman

PD: a lo mejor ya lo has solucionado por otro lado y no lo he visto.

Hay un divisor a la entrada del primer operacional Gran sonrisa

Esta para que a 5V tengas una salida de 1.5V para que la maxima corriente que pueda circular sea de 3A, teniendo la Rsense de 0.5Ohm, tener una Rsense de 0.5 en lugar de 1, nos permitia tener mayor rango de corriente, ya que si poniamos una de 1, la Vgs del mosfet iba muy justa.

Un saludo¡
Citar
#22
Desde la pantalla de movil no se ven bien las cosas, por eso te había dicho que a lo mejor lo tenías solucionado... Lengua

S2

Ranganok Schahzaman
Citar
#23
Version V1.1 de camino¡¡

resim

Os iremos informando de novedades, asi como cuando llegen las placas, las que queden, que seran unas 7 o asi, quedaran a disposicion del que este interesado en esta plaquita, asi como haremos una BOM completa, para saber que componentes se necesitan, los componentes asi mas especialitos, los teneis en el primer post¡¡
Citar
#24
Bueno compañeros, las placas ya llegaron, y estamos testeandolas y empezando a programar, pero nos hemos encontrado con que el funcionamiento no es el esperado. Al que le interese voy a dejar un video contando lo que sucede. No se mantiene el PWM estable, nose si achacarlo al OPAMP, o probar otros MOSFET. Parece como si no pudiera mantenerse estable y empezara a oscilar.





Seguiremos trabajando en sacar algo en claro, cualquier prueba que nos sugiráis es bien recibida.
Citar
#25
Estamos poniendo la placa por partes, por ahora, la parte analogica parece funcionar como debe
Citar
#26
Me he visto el video entero y me parece muy interesante, pero no tengo conociemientos para ayudar. Me falta mucha experiencia todavia.

Si el ruido tiene una frecuencia fija hay algo que lo provoca de forma fija, no son interferencias. Es la unica conclusión con sentido que he podido sacar.

A ver de donde es el problema que tengo ganas de ver la solucion
Citar
#27
Sobre la proto generando el pwm con un arduino a menor frecuencia que la del propio PIC funciona correctamente, en la simulaciones todo bien también... parece que la cosa va a estar en el propio PIC.
Citar
#28
El tema que comenta Weso, solo con la etapa ANALOGICA, tengo ahora mismo solo esto conectado:

resim

Pues bien, he ido cambiando el PWM, y los resultados son que a baja frecuencia la corriente es ESTABLE, varia apenas. Pero logicamente los filtros poco hacen, ya que son de 1Khz....., lo que no tiene mucho sentido, ya que estas trabajando entonces con un PWM:

En amarillo el PWM y en azul la señal VG, que es con la que atacamos la puerta del MOSFET:

TRABAJANDO A 250HZ

resim

Y luego a 2.5KHZ

resim

resim

Tiene mas sentido logicamente, porque tienes cierto rizado, estamos en una frecuencia cercana a la de corte.

Peeero, si subimos la tension de VIN (De la fuente que estamos sacando la corriente constante), tenemos que aumenta el rizado de VG, osea de la tension que ataca el MOSFET, y a su vez tenemos una variacion en la corriente, que en teoria debiera de ser constante:

resim

Y a su vez la frecuencia que tenemos de la señal VG, es decir del rizado, disminuye.

A todo esto, resultados, que para nada corresponden con la simulacion, ya que no tenemos un rizado tan bestia, quiero decir, e ilustro, simulacion a 2.5Khz:

resim

Cuando tenga un ratin, voy a probar sobre la proto board el mismo esquema pero con un LM324 aver que pasa. He estado simulando un poco Margenes de Fase y Ganancias, y a la salida del segundo Operacional (Si no lo he simulado mal, ya que bodes FTs y demas aun me cuesta), a frecuencias un poco elevadas, tiende un poco a la inestabilidad, y a partir de 1Khz, aproximadamente pierden en ganancia ambos bastante...., lo que me hace pensar que quiera oscilar el OPAMP. Nolose, son suposiciones. Pero estamos aqui para aprender no? jajajaja

Un saludo¡
Citar
#29
He realizado una serie de pruebas, para intentar sacar alguna conclusion. Situaciones:

CANAL 1 ES COLOR AMARILLO
CANAL 2 ES COLOR AZUL

1) Montaje BreadBoard, tension de alimentacion del OPAMP 5V, con tension de VIN de 5. Montaje con PWM

CANAL 1- Salida del segundo filtro
CANAL 2- Vref, tension de referencia

resim

CANAL 1- PWM de entrada
CANAL 2- Salida del primer filtro

resim

CANAL 1- VG (Tension de entrada al MOSFET)

resim

OBSERVACIONES: En teoria, en la primera grafica, VREF y la salida del segundo filtro, debieran de ser iguales, ya que corresponden a V+ y V- a lo sumo con un pequeño offset, pero podemos ver que la diferencia entre ambas es bastante elevada....

Es posible que como comentaba le compañero, este afectando alguna impedancia baja al OPAMP? En teoria 5V debiera de trabajar bien...

Si calculamos, tenemos una corriente de 0.43, y realmente estamos sacando 0.64....., logicamente, debido a la no correspondencia de V+ y V-

2) Montaje BreadBoard, tension de alimentacion del OPAMP 5V, con tension de VIN de 10. Montaje con PWM

CANAL 1- Salida del segundo filtro
CANAL 2- Vref, tension de referencia

resim

CANAL 1- PWM de entrada
CANAL 2- Salida del primer filtro

resim

CANAL 1- VG (Tension de entrada al MOSFET)

resim

En este caso, podemos observar, que las entradas V+ y V- del OPAMP si que se corresponden mejor que en el primer caso, es decir, que la tension de entrada (De la que sacamos corriente constante) en teoria afecta....

La corriente en este caso con el mismo PWM es de 0.28A de multimetro, y 0.44A segun los calculos.

Realmente la corriente debiera de ser constante, otra inconcruencia respecto las simulaciones.

3) Montaje BreadBoard, tension de alimentacion del OPAMP 12V, con tension de VIN de 5. Montaje con PWM

CANAL 1- Salida del segundo filtro
CANAL 2- Vref, tension de referencia

resim

CANAL 1- PWM de entrada
CANAL 2- Salida del primer filtro

resim

CANAL 1- VG (Tension de entrada al MOSFET)

resim

En este caso, alimentando el OPAMP a 12V, funciona mucho mejor, la corriente es estable a 5V y a 10V, te mantiene en 0.30A. Las entradas V+ y V- se mantienen bastante mas proximas.... seguimos con una tension en mosfet de unos 2V aprox, en VGS.

5) Montaje BreadBoard, tension de alimentacion del OPAMP 12V, con tension de VIN de 10. Montaje con PWM

CANAL 1- Salida del segundo filtro
CANAL 2- Vref, tension de referencia

resim

CANAL 1- PWM de entrada
CANAL 2- Salida del primer filtro

resim

CANAL 1- VG (Tension de entrada al MOSFET)

resim

Muy parecido al caso anterior, como digo, la corriente se mantiene constante de 5 a 10V, incluso llegando a 20V se mantiene....

Es decir, el comportamiento del OPAMP con 12V es mas bien correcto, pero la cuestion es que este OPAMP trabaja adecuadamente a 5V, asique algo se me escapa.

Es posible que sea problema de impedancias....., por eso quiero poner un seguidor en la tension de referencia...

Tengo que realizar una prueba metiendo DC en ved de PWM, y luego otras pruebas en la PCB que tenemos, pero por ahora esto es lo que tengo. Creo que no se me queda nada en el tintero por ahora.


Un Saludo y Gracias
Citar
#30
Hola,

Con filtros de 1.5kHz no elimináis la oscilación, tienen que ser de unos pocos Hz.

Tened en cuenta que los filtros bajan 20dB por década, por lo que para tener una atenuación buena de la señal PWM del microcontrolador habría que poner entre 60 y 80dBs por medio. Esto implica frecuencias de PWM muy altas y filtros con frecuencia de corte muy baja.

Por otro lado la alimentación de los AOs debería ser lo más limpia posible, para evitar que la oscilación en la alimentación se cuele en la señal.

Por último, el GBw de los AOs, hay que vigilarlo ya que si te pasas se puede poner en modo oscilante.

S2

Ranganok Schahzaman

PD: siento no poder extenderme má con la explicación pero desde el móvil es difícil...
Citar
#31
Volvemos a la carga, nunca mejor dicho jajajaja.

Estamos llevando a cabo pruebas sobre un circuito, montado en una placa de topos, ya que la protoboard daba muchisimos problemas y falsos contactos.

El circuito es sencillo, pero funcional:

resim

Cambios respecto al anterior?, tenemos un filtro de 100Hz, para un PWM de 15Khz, se comporta mas que bien. Resistencia de Shunt de 0.1ohm, para mejorar un poco la disipacion termica. Es por ello por lo que necesitamos un divisor resistivo, por que?, pues porque si tenemos 0.1ohm y queremos un limite de 3A, son 300mV de referencia, que calculando a partir de 5V tenemos que debemos multiplicar esos 5V por 0.06.

Por lo demas todo se mantiene igual, os dejo un video y luego comento cuales seran los siguiente pasos





Y una tabla en la que se han probado, valores de corriente a diferentes tensiones y DC, teniendo los valores maximos y minimos, podemos ver que tenemos un mantenimiento de la corriente estable mas que aceptable (Las temperaturas de la derecha las ultimas son con ventilador)

[gxls]1yYgJ9AX-sdRxPdmpn8p1TQlInzJJQgFnTUw_aNAz2kc[/gxls]

Como comento en el video, se agradecen cualquier tipo de sugerencias hacia el diseño o lo que fuere.

Los pasos a llevar a cabo ahora a corto plazo son:

-Comprobar funcionamiento con resistencia Pull-Down a la puerta del MOSFET de 50k
-Comprobar funcionamiento del circuito con PWM del PIC
-Calculo de resolucion del PWM del pic asi como incrementos.
-Decision de toma de medida para feedback con el ADC del PIC o empleando un INA250

Un Saludo

Carlos
Citar
#32
Aunque parezca que esto esta parado, seguimos trabajando en la V2:

resim

Es una version un poco mas avanzada, monta un PIC DSP30F2010, encoder para seleccionar la carga, un INA para la lectura de la corriente, una resistencia de SHUNT mas pequeña y de precision, referencia para los ADCs ya que no trabajamos a mas de 2V....
Citar
#33
Bueno, ya tenemos aqui la PCB de la v2.0, parece que la parte de potencia ya funciona correctamente, a falta de cargar programacion y demas....



Citar
#34
Ya la tenemos funcionando, en breve publicaremos por si a alguien le interesa...
resim


Archivos adjuntos Miniatura(s)
   
Citar
#35
Buenas noches¡

Bueno, a nivel de HW y Soft, por ahora, damos por terminada la carga programable, ya se encuentra 100% funcional.

https://github.com/JDGon/DummyLoad

Al final, solucionamos los problemas de inestabilidad añadiendo un filtro a la salida del operacional de control.

Tanto esquemas como software, los teneis al completo en el repositorio.

Tenemos medicion de corriente, medicion de tension de entrada, a si como medicion de temperatura, con corte por sobretemperatura programable. Capacidad de cargar hasta 3A, y tension de hasta 30V.
Citar
#36
No hay oferta si pillo una antes de que acabe el anuncio?? Me regalais el ventilador?? Jajaja

Ahora en serio quiero una Gran sonrisa
Citar
#37
Pues tenemos placas disponibles por si alguien se anima a montársela. Sabemos que es un target muy específico y poca gente le verá utilidad, pero al menos hemos cerrado el proyecto que teníamos colgando desde hace tanto tiempo xD
Citar
#38
Wooow! Es buenísimo. Ni bien pueda, me estaré haciendo una.

De paso estudio un poco el circuito.

Excelente proyecto, gracias.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  APORTE Osciloscopio Digital (Funcionamiento y Montaje) kuadri 1 875 03-08-2018, 10:41 AM
Último mensaje: kuadri
  App interesante electronica digital Bayaz 0 857 20-01-2018, 12:23 PM
Último mensaje: Bayaz
  driver DRV 8825 para control de motor homer32 8 1,852 16-05-2016, 09:54 AM
Último mensaje: homer32
  Digital Balance Charger and Discharger. ¿Cuál comprar? cybero 3 1,281 16-07-2015, 09:08 PM
Último mensaje: cybero
  Control leds con transistor TIP31 homer32 3 1,707 01-06-2015, 09:01 AM
Último mensaje: homer32