Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Centro de cama
#1
Hola: si el centro de la cama es X110, Y110; ami me da mirando la maquina de frente X100, Y95. Como puedo arreglar eso, es una ender 3 de origen
Citar
#2
Lo he arreglado en simplify cambiando los ofset pero, tendria que hacerlo con Pronterface para guardar en eprom pero no se los comandos
Citar
#3
Hola, supongo que te refieres a que cuando le indicas a la impresora que se mueva al punto X=110 Y=110, realmente se queda a 100 mm y 95 mm de los bordes respectivos de la cama.
Si es así, eso se debe a que no están bien los offsets de esos ejes.
Para corregirlo, tienes que enviar a la impresora el siguiente comando: M206 X10 Y15
Para que se conserven estos cambios cuando reinicies la impresora, tienes que grabar los datos en la EEPROM, bien por el menú de la impresora o bien enviando M500 (si está habilitado el uso de este comando).
Si quieres tener a mano todos los comandos Gcode del Marlin, puedes verlos en esta página.
Citar
#4
se me quedaba a esas medidas pero del centro, el home y todo lo hacia bien solo que no imprimia centrado en la cama. Es la ender 3
Citar
#5
Hola, cada vez se entiende menos lo que comentas.
Con lo de que se quedaba a esas medidas del centro, ¿quieres decir que se quedaba del centro a 100 mm en X y a 95 en Y?
¿O que se quedaba 10 mm a la izquierda y 15 mm hacia delante del centro de la cama?
Hay una gran diferencia entre las dos cosas.
Si es la segunda, haz lo que te indicaba en la otra respuesta para corregirlo.
Citar
#6
se quedaba 10 mm a la izquierda y 15 mm hacia delante del centro de la cama
Citar
#7
Muy bien. Para corregirlo solo tienes que hacer lo que te indicaba en mi primera respuesta.
Citar
#8
He hecho lo que me dices y nada. Decir que es una ender 3 con firware original, uso Pronterfade meto el M206 y luego M500 y no hace nada, no mejora, se queda a la misma medida
Citar
#9
Hola, por las fotos que veo de la pantalla, creo que la Ender 3 lleva un Marlin personalizado, por lo que los comandos M206 y M500, pueden funcionar o no.
Si está habilitado el parámetro NO_WORKSPACE_OFFSETS en el archivo Configuration_adv.h, no se podrá utilizar el M206.
Normalmente, ese paránetro viene deshabilitado por defecto en Marlin, pero puede que Creality lo haya cambiado..
Si esta deshabilitado el parámetro EEPROM_SETTINGS, no se podrá usar el M500. Si es así, lo indicará el Pronterface al enviarlo a la impresora.
Para comprobar si está o no disponible el comando M206, primero mira los offsets actuales que tiene la impresora.
Conecta el Pronterface y envía un comando M503. La impresora responde con los datos de configuración actuales más relevantes y entre ellos están los offsets.
Después de enviar la orden M206 X10 Y15, envía un comando M503 para volver ha obtener los datos anteriores y comprueba que se han incrementado los offsets: en 10 el X y en 15 el Y.
Si no es así, casi con seguridad el firmware original de la Ender tenga deshabilitado ese comando y en ese caso, la única forma de cambiarlos es reinstalando Marlin.
Si cambian y no funciona el comando M500, graba los valores actuales mediante la orden Guardar memoria del menú Control.
De todas formas, es raro que en una impresora de este tipo vengan mal configurados los valores del firmware.
Yo más bien me decantaría por una posición incorrecta de los interruptores de fin de carrera.
Citar
#10
Lo que me extraña es que en Simplify le reforme los offset y va al centro perfecto, en cura no se como hacerlo. Con esos comandos me hace los cambios en pronterface.


Archivos adjuntos Miniatura(s)
   
Citar
#11
El comando M206 te está funcionando bien.
No pones que hace cuando mandas el M500.
Tienes que salvar los nuevos valores antes de que se produzca un reinicio. Si al salir del Pronterface se está reiniciando la impresora y no los tienes salvados, vuelve a cargar los anteriores que están almacenados en la EEPROM.
Si no te funciona el M500, después de enviar el M206 y sin salir del Pronterface, guarda la memoria con el comando del menú de la impresora. Está en Control.
Citar
#12
Na, desisto, me arreglare con simplify hasta que ponga marlin2.
Cuando le pongo M500 pone SENDING:M500
Y desde la emisora con este firware desde control solo da acceso a temperatura y restaurar
Citar
#13
Cuando lees los parámetros de la placa, ¿te da los valores que guardaste?

También mira en el Cura los parámetros de máquina que tienes metidos. Si no sabes como cambiar los parámetros crea una nueva con los parámetros de tu máquina bien definidos.

resim
Citar
#14
Muchas gracias chicos, hasta que ponga marlin lo solucione poniendo en el script de inicio G29 X-5 Y-13
Citar