Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA MKS GEN L + TMC2130
#1
Buenos días, ante la desesperación y después de casi 15 dias de pruebas y un largo etc, me decido a preguntar, antes de que wallapop gane un nuevo cliente que vende una Ender3.

Verán, tengo montada una mks gen L + 4 drivers 2130 y una mks28tft.
Los movimientos e impresiones son mas que silenciosas, pero todas fallidas al rato de estar imprimiendo correctamente parece que z se saltara varios pasos y empieza a imprimir en el aire, sin soltar filamento.
Actualmente, me esta costando un montón nivelar la cama, ya que cuando parece que esta nivelada correctamente, inicio la impresión y al hacer home cabrían por lo menos media docena de hojas de papel entre extrusor y cama.
A priori solo estoy interesado en hacerla silenciosa, así que tengo los 3 jumpers quitados y los drivers conectados directamente con el pin sdi de xyz y el extrusor, doblado como vi en un tutorial. XYZ a 0'725v y E0 a 0'9v.
En Marlin, toqué la especificación de placa, el baudate para que funcionara el tft, y puse los 4 drivers descomentados en standalone aparte de instalar la librería tmc2130 stepper y la de u8glib.
A alguien se le ocurre que puede ser?
Estoy seguro que será una tontería en la que no caigo y se me ha atravesado.
Tal vez este hecha alguna guía con los componentes exactos que tengo, y que pudiera seguir... al menos no la he encontrado.

Saludos y gracias como siempre

PD:Imagen de las impresiones.
resim
Citar
#2
A ver...yo veo varias cosas raras.

Por las fotos y lo de que imprime en el aire, creo que quieres decir que es como si se saltara capas. Si se saltase pasos el eje se movería menos, por lo que la boquilla acabaría rozando la pieza, que es lo contrario. Corrígeme si me equivoco.

Como los quieres poner en modo standalone, los jumpers que configuran los micropasos si funcionan.
Si has quitado todos los jumpers, los tienes funcionando a full-step, cosa que tendrás que tener en cuenta a la hora de configurar los micropasos/mm en Marlin.

Esto podría explicar tu problema, para confirmarlo puedes conectarte con un software de control y mandarle G1 Z100, y medir con una regla si se ha movido esa distancia aprox.

Si ajustas la cama y sin mover nada inicias la impresión y la boquilla queda lejos, el problema no es la cama.

Si solo quieres usarlos en modo standalone, no hace falta cablear nada que yo sepa. Creo que no harian falta ni las librerías de Marlin, ni si quiera decirle que drivers son. Puedes poner el tutorial que has seguido? Parece que tienes un poco de lío entre el modo standalone y el modo SPI.
Citar
#3
Estaba comprobando en el datasheet del TMC2130 la configuración de micropasos en standalone y con los dos pines que lo controlan open (sin puentes) dice que funciona a 16 micropasos con interpolación a 256.
Si se colocan los dos puentes (pines a VCC_IO), también funciona a 16 micropasos, pero sin interpolación.
Coincido en que si faltan capas no es por pérdida de pasos, sino más bien por falta de material (deja de extruir), por lo que yo miraría en la dirección del extrusor y del impulsor.
Los TMC2130 son algo menos potentes que otros drivers y puede que la fuerza necesaria en el impulsor esté sobrepasando sus posibilidades.
Por ello, se suelen dejar los drivers "normales" en este eje o bien, se coloca un impulsor con reductora.
Citar
#4
Cita:Estaba comprobando en el datasheet del TMC2130 la configuración de micropasos en standalone y con los dos pines que lo controlan open (sin puentes) dice que funciona a 16 micropasos con interpolación a 256.
Si se colocan los dos puentes (pines a VCC_IO), también funciona a 16 micropasos, pero sin interpolación.
Correcto, me lié yo con los tmc2100 por hablar de memoria. Son 16.

Al final son las dos caras de la misma moneda, o sobra espacio o falta material. Pero si es que falta material, hay otro problema más con la configuración de la primera capa.

Igual que con el eje Z, para comprobar el extrusor, también puedes medir y marcar 100mm y decirle que extruya esa cantidad. Mejor si se hace varias veces.

Si es el extrusor, tendrás que aumentar la corriente. Si lo tuvieras cableado por SPI podrías consultar a los propios drivers si han perdido pasos. Sino quieres complicarte mejor que hagas lo que dice @Simemart y pongas un driver mas potente, que el extrusor apenas hace ruido ya que va muy despacio normalmente.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
Triste Problemas TMC2130 y modo stealthChop fbforos 14 1,001 20-02-2019, 04:21 PM
Último mensaje: fbforos
  APORTE Tutorial Instalación y configuración driver TMC2130 en Ramps campy 42 14,288 01-09-2018, 12:28 AM
Último mensaje: cerutti