Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA Home eje Z
#1
Triste 
Muy buenas a todos:

Soy Ivan y vivo en Madrid, hace 2 semanas que me compre la DIY Prusa i3 Pro B Acrilica de Geeetech, con montarla no tuve apenas problema salvo algun ajuste, ahora los estoy teniendo todos para ponerla en marcha, después de cambiar el firmware que no admitia, bajar a una versión mas antigua de arduino para instalar la que ofrece Geeetech, descubrir tras dos días que tenia los finales de carrera cambiados, ayer solucione el problema con los motores de los ejes Z que sonaban pero no subían, probé de todo después de leer muchísimo por todos lados (este es mi primer tema), al dejarlos sin peso ví que giraban, hice lo de subir la potencia en los pololu y nada, al final resulta que era la pieza de sujeción de la varilla y el eje superior(donde va el motor X) hacen demasiada fricción... La he ajustado centrando las varillas roscadas y ejes Z aflojando también el embrague, ya leí acerca de la mejora del rodamiento superior, cosa que haré próximamente. 

Después de poneros en antecedentes (estoy hasta el ....) voy con la PREGUNTA:

Ya por fin consigo los auto homes correctos en los ejes X e Y, pero a la hora de mover el eje Z no consigo que se mueva en dirección al fin de carrera (sube siempre) por lo que entiendo que no lo hace el Home, lo mismo me ocurre al probarlo en el Repetier-Host, al dar al Home en Z sube como varios mm, pero no baja, alguna sugerencia? 
Ayuda por favor, soy muy cabezota y no pienso tirarla a la basura XD. Smash2

Un saludo a todos y espero que sea mi ultima duda...y poder ayudar en un futuro a otros.
Citar
#2
Hola y bienvenido,

te pueden pasar dos cosas:

Que la dirección para el homing sea hacia ZMAX.

Que el movimiento del eje Z esté invertido.

Yo probaria a cambiar la conexión del motor en la placa, si tiene 4 cables, conéctalos haciendo un giro de 180º. Con eso deberias de invertir el sentido de la marcha del eje Z.

(y comentas a ver que tal).

Saludos.
Citar
#3
Gracias por la respuesta Drow! Mañana lo probare a cambiar el codigo en el arduino y os cuento como ha ido, ya que los cables venian soldados a los conectores y no hay manera de cambiarlos sin romper el conector...
Citar
#4
Si cambias la configuración de marlin, échales un vistazo a esto:

// ENDSTOP SETTINGS:
// Sets direction of endstops when homing; 1=MAX, -1=MIN
#define X_HOME_DIR -1
#define Y_HOME_DIR -1
#define Z_HOME_DIR -1

Así es como deberias tenerlo.

Para cambiar el sentido del eje Z :

#define INVERT_Z_DIR (true / false, lo que corresponda)

Saludos.
Citar
#5
he modificado el firmware poniendo true donde venia false aquí, y ya consigo que el eje Z suba y baje,
const bool Z_MIN_ENDSTOP_INVERTING = true
const bool Z_MAX_ENDSTOP_INVERTING = true

El problema ahora es que el eje Z no para cuando lo pisa su endstop, el Y y el X paran cuando pisan su endstop, lo primero que he comprobado es que el endstop y los cables Z están bien (continuidad con polimetro), es como si la entrada del arduino no reconociera el endstop. Lo tengo conectado entre el fin de carrera X e Y, como ví en el tutorial...
Mientras escribía esto, creo que dí con la solución. sube, baja y para.
Agradecer a Drow por tu ayuda.

const bool Z_MAX_ENDSTOP_INVERTING = true

lo saque por ensayo-error... alguien sabría explicarme aunque sea resumidamente el motivo o la lógica?
Citar