Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Arduino no comunica con el ordenador
#1
Tengo el arduino mega de la conjunta de 3de, me iba bien la impresora cuando de repente el pronterface deja de poder comunicarse con el arduino. Lo quito todo dejando sólo el cable del USB al ordenador (probado primero con el sobremesa y luego con el portátil) y el IDE de arduino no es capaz de comunicarse con él.

Se queda fijo el led del pin 13 y nada, intento cargar unos programas de prueba, no se enciende en ningún momento el led RX ni TX y el IDE al rato tira este error:

Código:
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

No se ve nada chamuscado ni hay nada que se caliente de forma anormal. ¿Alguna idea o me voy despidiendo del arduino?

Cuando pulso el boton de reset el led 13 se apaga y se enciende, entiendo que sigue funcionando.
Citar
#2
Has probado de reinstalar el driver?
Si no lo tienes reinstala de nuevo el último arduino de la web que trae todos los drivers.
Saludos

Enviado desde mi ST25i usando Tapatalk 2
Citar
#3
Es posible que sucedan dos cosas, que estes programandolo con algo conectado al Tx y Rx de otra cosa y es un error comun. Y lo otro es que puedas tener seleccionado otra placa en el IDE. Carlos3dx igualmente puede ser otra cosa ya que no soy experto pero ese error me ha dado a mi en esas dos situaciones. Espero sea de ayuda.
Citar
#4
pere_gs escribió:Has probado de reinstalar el driver?
Si no lo tienes reinstala de nuevo el último arduino de la web que trae todos los drivers.
Saludos

Enviado desde mi ST25i usando Tapatalk 2

Reinstalado el driver, pero es raro que suceda en dos ordenadores independientes como para ser algo de driver. Windows (7 y 8) lo detecta como Arduino Mega 2560 (COM5).

yeyeto2788 escribió:Es posible que sucedan dos cosas, que estes programandolo con algo conectado al Tx y Rx de otra cosa y es un error comun. Y lo otro es que puedas tener seleccionado otra placa en el IDE. Carlos3dx igualmente puede ser otra cosa ya que no soy experto pero ese error me ha dado a mi en esas dos situaciones. Espero sea de ayuda.

El error empezó mientras funcionaba, estaba con el pronterface, bajé el eje z, luego quise subirlo y me empezó a salir fallos de timeout. Está todo desconectado del arduino salvo el cable usb al ordenador. No hay nada conectado a Tx y Rx, y está correctamente puesto la tarjeta en el IDE.

Una idea tonta proveniente de alguien que no tiene nidea de electrónica ¿Si cojo un cable USB y lo corto para conectar los cables Tx y Rx directamente a los pines 0 y 1 funcionaría?
Citar
#5
Somos dos con pocos conocimientos de electronica, lo que si puedes hacer es programar ese Arduino Mega con otro por ISP. Son solo ideas que se me vienen a la mente
Citar
#6
Tengo entendido que para hacer eso tendrias que tener un convertidor USB -TTL. O RS232-USB.
Citar
#7
He probado a programar el Mega utilizando un Uno como programador ISP pero nada, no funciona, tira error y no se enciende el led de comunicación con el mega pero sí el de error.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Pitido al conectar mi pantalla smart full gráfic al ordenador Deme88 0 647 22-11-2016, 10:52 AM
Último mensaje: Deme88
  [PROYECTO] Ordenador A bordo para Coche cansi22 35 10,406 23-05-2014, 11:54 AM
Último mensaje: cansi22
  ¿Arduino MEGA o Arduino ADK? igargi 7 1,657 25-08-2013, 04:58 PM
Último mensaje: cansi22