This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 2 voto(s) - 2.5 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Backup SD
#1
Buenas a tod@s:

Estoy haciendo un script para automatizar los backups de la SD, para así, si se corrompe la SD pues no pierda los datos.

Utilizo el siguiente script (aún no está terminado y por eso hay líneas comentadas y no está bonito):


Código:
#!usr/bin/pyton

import time #Importa la biblioteca para saber la hora
import os




def backup(): #Metodo que hace el bakcup
    now = time.strftime("%y_%m_%d") #importamos fecha actual y la guardamos en la variable now
    
    time.strftime("%y_%m_%d") #importamos fecha actual y la guardamos en la variable now
    #La segona linia falta testejarla
    os.system('sudo umount /dev/root')
    #os.system('sudo umount /dev/mmcblk0p1 && sudo umount /dev/mmcblk0p2')     #desmontamos la SD
    os.system('sudo dd if=/dev/root of=/media/usb/'+now+'.img bs=1M')     #Hacemos la copia de seguridad y le decimos donde la queremos guardar
                                                                            #A parte le ponemos la fecha actual
    

backup() #Llamamos al metodo backup definido previamente
   

Me dice que la ruda /dev/root no es ninguna ruta o fichero, entonces... qué debo poner para que se haga el backup?

El resto de código funciona. Porque si comento la línea "os.system('sudo umount /dev/root')" y descomento la siguiente me funciona perfectamente.


Muchas gracias de antemano.
  Responder
#2
Creo que es porque root no es un device por eso no se puede desmontar, si te das cuenta, en la segunda línea desmonta los dispositivos mmcblk0p1 y 2, seguidamente, lo que hace es una copia de /dev/root a al disco o dispositivo USB.
"Enseñar es aprender dos veces".
  Responder
#3
Hay que acostumbrarse a usar los post que se abren, que si no esto es un descontrol! Guiño

http://www.spainlabs.com/foros/tema-Auto...p-de-la-SD
  Responder
#4
(19-12-2015, 04:02 PM)biketrial981 escribió: Hay que acostumbrarse a usar los post que se abren, que si no esto es un descontrol! Guiño

http://www.spainlabs.com/foros/tema-Auto...p-de-la-SD


Buenas a tod@s:

Sé que tengo este mensaje abierto pero aunque sea similar al ser un problema diferente.... pues creía que era mejor abrir otro hilo, pero bueno, lo tendré en cuenta para la proxima vez


Disculpad las molestias.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
Pregunta Backup SD raspberry pi Electromecánico 7 3,094 02-09-2017, 01:26 PM
Último mensaje: Electromecánico
  Automatizar backup de la SD Electromecánico 3 2,169 24-12-2015, 06:47 PM
Último mensaje: Electromecánico