This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA Fallo temp
#1
Hola tengo un problema os lo explico:

Estaba instalando un btt en la impresora 3D (tocando marlin para decirle ponerlo que funcionara bien) cuando vi que tenia un poco de pla enganchado en la boquilla Cogi el cepillo (se me olvido parar la impresora) y le di sin querer a la resistencia saltando una chispa y ahora me da fallo en temp(he cambiado tanto la resistencia como el sensor y sigue igual) es que me he cargado la placa no? (Es una markerbase 2.1) hay solucion?
  Responder
#2
Hola, lo más probable es que el cortocircuito haya dañado algún componente del circuito que controla el termistor del hotend en la placa y si es así, puedes tener tres posibles soluciones: reparar la placa, sustituyendo el/los componente/s dañado/s, cambiarla por una nueva o, si está libre el segundo extrusor, utilizar el circuito del termistor libre para sustituir al dañado.
Para hacer esto último, aparte de cambiar de conector el termistor (de TH1 a TH2), incluir en el archivo pins_MKS_GEN_L_V21.h, estas dos líneas que indico en rojo:

...
//
// Heaters / Fans
//
// Power outputs EFBF or EFBE
#define MOSFET_D_PIN                          7
#define TEMP_0_PIN  15
#define TEMP_1_PIN  13

...


compilar y volver a grabar el firmware en la placa.
  Responder
#3
(13-07-2022, 10:33 AM)Simemart escribió: Hola, lo más probable es que el cortocircuito haya dañado algún componente del circuito que controla el termistor del hotend en la placa y si es así, puedes tener tres posibles soluciones: reparar la placa, sustituyendo el/los componente/s dañado/s, cambiarla por una nueva o, si está libre el segundo extrusor, utilizar el circuito del termistor libre para sustituir al dañado.
Para hacer esto último, aparte de cambiar de conector el termistor (de TH1 a TH2), incluir en el archivo pins_MKS_GEN_L_V21.h, estas dos líneas que indico en rojo:

...
//
// Heaters / Fans
//
// Power outputs EFBF or EFBE
#define MOSFET_D_PIN                          7
#define TEMP_0_PIN  15
#define TEMP_1_PIN  13

...


compilar y volver a grabar el firmware en la placa.


gracias lo intentare, entiendo ( asi aprendo un poco mas XD ) que al hacer esto estoy girando los sensores de temperatura ( por si fueran 2 extrusores) y que Temp-0 es el sensor del hotend 0
si lo tengo libre pero lo intentare muchas gracias!!
  Responder
#4
Para Marlin, la temperatura del hotend 0 se controla con el termistor 0, la del hotend 1, con el termistor 1 y así sucesivamente para todos los que haya en la impresora, pero el pin de la MCU que controla cada uno de esos aspectos, se determina por la asignación que se indique en el archivo de pins de la placa: a Marlin le dá igual en que conector de esta se encuentre ese pin, el lo utilizará para controlar el dispositivo que lo tenga asignado en dicho fichero.
Al intercambiar la asignación de los pines de los termistores de los hotend 0 y 1, simplemente cambiamos el circuito que se utilizará para esa función, por lo que ahora el termistor del único hotend que tienes (en Marlin siempre es el 0), lo tendrás que conectar en el conector TH2 de la placa, que es al que está conectado el pin 15 de la MCU.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Impresora se detiene por fallo en la temperatura arielicho 3 797 21-04-2021, 11:51 AM
Último mensaje: Simemart
  (duda y problema) tmc 2209 uart y sensor autolevel fallo nivelacion sacha 37 6,754 14-08-2020, 12:29 AM
Último mensaje: sacha
  Temp en reposo de 739º!!!! Ko2Power 8 1,527 08-08-2019, 06:35 PM
Último mensaje: Ko2Power
  [PROBLEMA] Fallo con el motor del extrusor ¿¿?? ricardocastillovic 5 3,567 04-03-2018, 05:01 PM
Último mensaje: beto
  Fallo motor Z en RAMPS 1.4 LinP 1 1,878 20-01-2017, 11:43 PM
Último mensaje: LinP