This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Se pierde la comunicación de impresora a mi computadora
#1
Hola a todos, tengo este problema en mi impresora, es una customisada hecha por mi mismo, con ella ya he impreso varias piezas pero últimamente tengo el problema de que en algún punto de la impresión, se detiene abruptamente, siempre en la primer capa, pero conserva el movimiento en el ventilador, ya había investigado sobre esto y me pareció que era un problema de potencia, así que como remedio temporal, disminuía el porcentaje de la ventilación, pero ya no puedo bajarlo mas. 
Para imprimir tengo conectada la computadora a la impresora por un cable de arduino mega, el mismo arduino lo tengo programado con marlín 1.8.19, uso el shield ramps 1.5, uso 5 motores nema 17, y todo es alimentado por una fuente de 12v y 10A. Por favor espero puedan apoyarme.
  Responder
#2
Hola, no indicas si utilizas cama caliente pero si es así, esa fuente se queda algo corta y lo que sucede es que se queda congelado el Arduino Mega.
Para solucionarlo, tendrás que conseguir aumentar la potencia de la alimentación, bien cambiando a una fuente mayor o utilizando otra fuente para apoyar a la que ya tienes, pues variar la velocidad del ventilador no tiene una influencia apreciable en el consumo total de la máquina.
Si no tienes cama caliente, quizá el problema sea que la fuente pierde potencia en algún momento y eso bloquea el arduino: tendrás que comprobar su desempeño mediante un multímetro.
  Responder
#3
(12-06-2022, 11:31 PM)Simemart escribió: Hola, no indicas si utilizas cama caliente pero si es así, esa fuente se queda algo corta y lo que sucede es que se queda congelado el Arduino Mega.
Para solucionarlo, tendrás que conseguir aumentar la potencia de la alimentación, bien cambiando a una fuente mayor o utilizando otra fuente para apoyar a la que ya tienes, pues variar la velocidad del ventilador no tiene una influencia apreciable en el consumo total de la máquina.
Si no tienes cama caliente, quizá el problema sea que la fuente pierde potencia en algún momento y eso bloquea el arduino: tendrás que comprobar su desempeño mediante un multímetro.

Exactamente, no cuento con cama caliente, entonces como puedo medir el consumo de mi impresora?
  Responder
#4
Si no tienes cama caliente, esa fuente de 10A debería ser suficiente, por lo que puede que no esté funcionando bien.
Para comprobarla, debes medir el voltaje en condiciones de carga (con la impresora imprimiendo) y ver si baja mucho de los 12V nominales en esas condiciones.
Para medir su consumo real, la forma más sencilla es haciendo que toda la corriente que sale de la fuente pase por un multímetro en modo de medidas de intensidad (A), siempre que este tenga un modo con suficiente capacidad de medida (suelen tener uno de 10A): el consumo de una impresora de esas carácterísticas durante la impresión, debería ser menor de 5A en el peor de los casos.
  Responder
#5
(13-06-2022, 09:10 AM)Simemart escribió: Si no tienes cama caliente, esa fuente de 10A debería ser suficiente, por lo que puede que no esté funcionando bien.
Para comprobarla, debes medir el voltaje en condiciones de carga (con la impresora imprimiendo) y ver si baja mucho de los 12V nominales en esas condiciones.
Para medir su consumo real, la forma más sencilla es haciendo que toda la corriente que sale de la fuente pase por un multímetro en modo de medidas de intensidad (A), siempre que este tenga un modo con suficiente capacidad de medida (suelen tener uno de 10A): el consumo de una impresora de esas carácterísticas durante la impresión, debería ser menor de 5A en el peor de los casos.

Ya hice unas mediciones, la corriente es de 2.5A promedio, pero el voltaje es 9v, supongo entonces que el problema es la fuente
  Responder
#6
Efectivamente, la fuente está mal y esos 9V son insuficientes para el funcionamiento de la impresora durante las impresiones: tendrás que sustituirla.
  Responder
#7
Si la tensión de alimentación con la que alimentas arduino no baja de 6V, no debería ser ese el problema, excepto si lo alimentas por el pin +5V y la tensión es inferior..

Imagino que lo haces por Vin.

Si sólo se alimenta por el puerto USB (no tiene sentido y no es la mejor opción) y cae por debajo de 5V o si el pueto no es capaz de entregar la corriene que necesita arduino + ramps = problemas.

Si alimentas por el conector, te recomiendo que sea entre 5V y 7V (tanto si la fuente es la misma de los motores o externa).

Si utilizas el pin de 5V, tienen que ser 5V, ni más ni menos. (lo mismo, interna o externa).

Si optas por Vin, lo mismo que con el conector, entre 5 y 7V.

Los 7v es por la potencia que tiene que disipar en forma de calor el regulador de tensión. Si alimentas con 12V, reduces la corriente por debajo de 300mA.
A 9V serian 500mA aprox. y 1A a 7V. Estos cálculos son para una potencia máxima de 2W en el regulador.

Importante: si hay más de una fuente, no olvides unir siempre todos los negativos.
  Responder
#8
(14-06-2022, 07:24 PM)aspi3d escribió: Si la tensión de alimentación con la que alimentas arduino no baja de 6V, no debería ser ese el problema, excepto si lo alimentas por el pin +5V y la tensión es inferior..

Imagino que lo haces por Vin.

Si sólo se alimenta por el puerto USB (no tiene sentido y no es la mejor opción) y cae por debajo de 5V o si el pueto no es capaz de entregar la corriene que necesita arduino + ramps = problemas.

Si alimentas por el conector, te recomiendo que sea entre 5V y 7V (tanto si la fuente es la misma de los motores o externa).

Si utilizas el pin de 5V, tienen que ser 5V, ni más ni menos. (lo mismo, interna o externa).

Si optas por Vin, lo mismo que con el conector, entre 5 y 7V.

Los 7v es por la potencia que tiene que disipar en forma de calor el regulador de tensión. Si alimentas con 12V, reduces la corriente por debajo de 300mA.
A 9V serian 500mA aprox. y 1A a 7V. Estos cálculos son para una potencia máxima de 2W en el regulador.

Importante: si hay más de una fuente, no olvides unir siempre todos los negativos.

Con 9v, como bien indica Simemart, a la fuente le falta fuerza para alimentar a la impresora
  Responder
#9
Hola @aspi3d, veamos algunos puntos de tu respuesta que  creo que no son correctos:
Las especificaciones del Arduino Mega recomiendan que, por la línea de Vin (la misma del conector coaxial), debe alimentarse con un voltaje entre 7V y 12V para que funcione de forma estable: con 6V puede que funcione, pero estaría muy en el límite y es probable que tenga fallos en el funcionamienteo normal de la impresora.
Por el puerto USB se puede alimentar el Arduino Mega, pero no se puede utilizar la impresora, pues la alimentación de casi todos los demás dispositivos es a mayor voltaje (12V en este caso) y pasa por la RAMPS: en todo caso, la RAMPS solo tiene los circuitos que permiten al Arduino controlar esos dispositivos de mayor voltaje, pero no es él quien los alimenta en ningún caso.
El regulador interno del Arduino Mega dá una salida máxima de 1A a 5V, lo que equivale a 5W máximos.
Efectivamente, con esos 9V puede funcionar perfectamente el Arduino Mega, de ahí que en mi respuesta haya indicado "... el funcionamiento de la impresora durante las impresiones", pero todos los demás elementos aparte del Arduino (calentadores, motores, ventiladores, etc.) no llegarán a sus valores nominales de funcionamiento.
Si la fuente es de 12V y entrega 9V, claramente está defectuosa y seguramente baje mucho más en momentos puntuales de alta carga (como sucede al imprimir), lo que probablemente esté causando que la MCU se quede "colgada".
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA A partir de una altura pierde calidad JmsKp 2 1,075 30-01-2020, 02:19 PM
Último mensaje: JmsKp
  Ender 5 pierde funcion recuperar impresion OrtegoWRX 2 1,089 18-08-2019, 10:06 PM
Último mensaje: OrtegoWRX
  CONSULTA tronxy p802e auxilio la temperatura se pierde amento 2 1,189 04-11-2018, 10:14 PM
Último mensaje: amento
Pregunta CONSULTA Ayuda ? Comunicación [ Ramps <─> Arduino ] Txandro 10 2,969 20-09-2018, 12:30 PM
Último mensaje: Simemart