This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA codigos de error MKS Merlin nano
#1
Buenas a todos.

Tengo un problema con mi impresora 3d. Tengo una Anet A8, pero con toda la electrónica cambiada, lleva la placa MKS Merlin nano, va muy bien, pero últimamente me esta dando un problema. cuando lleva imprimiendo unos 10 - 15 minutos, sale un mensaje en rojo poniendo Error 6, y se para. He buscado los códigos de error para saber a que puede ser debido, pero no los encuentro. Alguien tiene los códigos de error de esa placa, o sabe a que puede ser debido. Gracias de antemano.
  Responder
#2
Hola, tu pregunta es bastante confusa, pues supongo que la placa que tienes es una MKS Robin Nano (Merlin no conozco nada en MKS) y esa placa no tiene códigos de error en sí misma, ni forma de mostrarlos si los tuviera.
Y sobre lo del mensaje de error en rojo, no creo que te salga en la pantalla monocromática de la A8, así que será necesaria una explicación más clara del problema para poder responderte con propiedad.
  Responder
#3
Simemart, si la versión de la placa es la 1.2 lleva su propia pantalla al ir con una faja y la versión de Marlin será la de MKS que no me gusta nada porque quita muchas configuraciones, seguramente sea un error de calentamiento porque no podrá mantener la temperatura
  Responder
#4
(17-02-2022, 11:48 PM)Macuho escribió: Simemart, si la versión de la placa es la 1.2 lleva su propia pantalla al ir con una faja y la versión de Marlin será la de MKS que no me gusta nada porque quita muchas configuraciones, seguramente sea un error de calentamiento porque no podrá mantener la temperatura

Ok, ya supuse que tendría una pantalla TFT en color y como indicas, los códigos numéricos de error seguramente estarán incluidos en la versión de Marlin modificada por MKS, por lo que será difícil saber a qué corresponde cada uno: yo no he encontrado en la GitHub de MKS ninguna información sobre ellos.

Si el error se produce en medio de la impresión, posiblemente sea un error de temperatura como indicas, aunque nunca se sabe: en todo caso, habrá que vigilar las temperaturas durante la impresión para ver si se detecta algo en ellas al saltar el error.
  Responder
#5
Hola.
Gracias a todos por contestar.
Si, efectivamente, es la Robin nano (no se porque siempre digo merlín, el subconsciente, supongo), y efectivamente, lleva una pantalla táctil a color, por eso sale el error en rojo. Yo también me he leído el github de MKS de pe a pa y no he encontrado los códigos de error.

Hace un tiempo, cuando iba a imprimir, comenzaba a calentar la cama  y me salía un error "error 7 " y se paraba la maquina. Como no podía arreglarlo, no sabia lo que era, y no encontraba los códigos (como ahora) contacte con MKS y me dijeron que se debía a que la placa lleva lleva programado un tiempo de calentamiento y si en ese tiempo no alcanzaba la temperatura, salía ese error y se paraba para proteger la maquina de  un posible sobrecalentamiento, porque podía ser que sí calentase, pero que no midiese bien la temperatura y se calentase mas de la cuenta.Pero que si no calentaba podía deberse a que la fuente de alimentación no tuviese la potencia suficiente para calentar en el tiempo prefijado, y como solución me dijeron que ampliase la potencia de la fuente, por lo que instale una fuente de 600W, que debe ser suficiente. (llevaba una de 230 o 260 creo recordar)

Aun asi, el problema no se ha resuelto del todo, tengo que precalentar la cama y cuando alcanza la temperatura, entonces comenzar a imprimir, y asi funciona, pero ahora, y a pesar de hacerlo asi, cuando lleva unos 10 minutos imprimiendo me sale el "error 6" y se para. He intentado contactar con MKS, pero esta es vez no me han respondido, por eso pregunto por aquí, a ver si alguien me puede ayudar.

A mi me da la sensación de que puede tratarse de un problema de la cama, que este medio averiada y no caliente bien. Le electrónica original de esta maquina se quemo por un tema relacionado con la cama, que sigue siendo la misma, Podría ser que el problema este en la cama?

Otra cosa, no veo casi información en los foros de esta placa, es que se vende poco? la gente casi no habla de ella y hay muy poca información. Yo, a pesar de estos problemas, que creo mas bien que son debidos a la maquina, mas que a la electrónica, estoy muy contento con ella, es supersilenciosa y muy configurable, creo que es muy buena, siempre, claro, que este problema finalmente no sea de la placa. Como punto negativo es la falta de información.

Perdonad por el tocho, pero asi el problema queda un poco mas claro.
Un saludo y gracias.
  Responder
#6
Probablemente los errores que tienes se deben a la temperatura, bien al calentar o en la medida (termistores) y es probable que se deban a algo externo a la placa.
Efectivamente, los dos calentadores deben conseguir la temperatura objetivo en un tiempo preconfigurado y si no lo hacen, saltará el error correspondiente, tanto al comenzar a calentar, como durante el tiempo que estén activos.
Si el error 7 era de tiempo excedido en el calentamiento de la cama y el hotend te funciona bien, el error 6 podría ser de temperatura de la cama: tendrás que comprobar la resistencia que tienen tanto la cama como su termistor y que este último no tenga mal los cables y se desconecte esporádicamente (indicación de temperatura a 0) o haga contacto alguno de ellos con el cubo calentador (temperatura a valores muy altos).
La resistencia que debe tener la cama, depende del voltaje de trabajo y la del termistor, si es de los típicos, 100K Ohms a 25 ºC (la resistencia disminuye con el aumento de la temperatura).
  Responder
#7
Hola.
He vuelto a intentar imprimir sin temperatura en la cama, 0 grados, y me ha saltado el error igual, ya no se que pensar...
podría tratarse de la temperatura del hotend? hace poco le he puesto el bloque calefactor entero nuevo, incluyendo resistencia y termistor, después de cambiarlo he impreso algunas cosas, pocas, antes de que comenzase a salir el error, podría estar el error por ahí ??
  Responder
#8
Hola, si los problemas te han surgido después de cambiar el hotend, probablemente el error se produzca en su calentamiento.
¿Tarda mucho en alcanzar la temperatura objetivo o incluso no llega a ella?
¿Fluctúa mucho su temperatura durante las impresiones?
  Responder
#9
Hola.
Perdón por la tardanza en contestar. No, el hotend aparentemente va bien, ni tarda en calentarse ni fluctúa en la temperatura, de hecho, ya digo, inicialmente, recién cambiado, imprimió sin problema, aunque los problemas se iniciaron poco tiempo después. Me dan ganas de volver a cambiarlo, tampoco es muy caro y me quito un posible error.

He comprado una cama nueva, cuando tenga un hueco la cambiare, a ver si adelantamos algo ...
  Responder
#10
He cambiado al cama caliente. Nada, sigue en las mismas. Le he vuelto a escribir a los de MKS, a ver si me contestan, ya veremos...
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  geeetech i3 pro B + mks gen L v1 gb77 1 42 13-05-2022, 07:13 PM
Último mensaje: Simemart
  MKS Robin e3d y Windows (Problema!) mangelh 3 246 27-11-2021, 11:16 PM
Último mensaje: mangelh
  controlar mks robin nano dese ordenador esteve1300 1 216 11-10-2021, 10:27 PM
Último mensaje: Macuho
  AYUDA CON MKS SBASE V1.3, COMO REGULAR CORRIENTE DRV8825 ... fontaromanogr 6 1,775 29-05-2021, 05:40 PM
Último mensaje: fontaromanogr
  MKS no actualiza Firmware mangelh 4 769 14-02-2021, 08:06 PM
Último mensaje: mangelh