This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema de dimensiones en eje Z
#1
Hola a todos,

Llevo trabajando con mi Ender 3 pro durante un año aproximadamente.

He hecho muchas impresiones buenas, pero con el paso del tiempo, he visto que el hotend choca en la impresión arruinándola en algnos casos pero sobre todo haciendo atascos ya que no tiene suficiente espacio para realizar la extrusión.

He observado que los cubos de calibración que hago de vez en cuando, cada vez miden menos de alto, lo cual seguramente está indicando que el motor está perdiendo pasos.

He llegado hasta el punto de que un cubo de 20mm, en el eje Z mide 19.32. El eje X e Y están bien.

Parámetros de impresión habituales.

cama 60º primera capa
cama 55º resto
hotend 210º primera capa
hotend 205º resto
altura primera capa 0.2mm
altura de capa resto 0.16mm
velocidad de impresión 50mm/s
velocidad impresión paredes 25mm/s

He observado que el motor se mueve sin problemas cuando manualmente le mando que suba o baje, la varilla está lubricada y sin ningún fallo que se pueda observar a simple vista. Es cierto que cuesta que se mueva con la mano el eje, aunque girando a mano la varilla sube y baja fácilmente.

No sé por donde empezar, la extrusión en las primeras capas y si el objeto no es muy alto la hace muy bie,n aunque siempre con cierta pérdida de altura respecto a lo que debería.

Algun consejo?

Muchas gracias.
  Responder
#2
Hola @Leemonfruit, bienvenido al foro.
Que vaya variando el tamaño de las piezas con el tiempo, es bastante raro si no hay una razón mecánica que lo produzca.
En todo caso, lo que tendrás que hacer es regular los micropasos por milímetro del eje al valor que corrija la desviación en el tamaño de las piezas y una vez imprima de forma correcta, vigilar si continúa variando lo que indicaría un problema en la placa o el motor.
Si el cubo de calibración de 20 mm tiene impreso 19,32 mm, deberás multiplicar el valor actual de micropasos por milímetro por 1,035.
No te olvides de guardar en la memoria EEPROM el cambio, para que se conserve al reiniciar la máquina.
  Responder
#3
revisa tambien que las excentricas de las ruedas no esten demasiado apretadas porque si lo estan,al eje z le costara subir,y suele producir ese mismo problema.
  Responder
#4
Gracias por vuestras respuestas.

Simemart,
No creo que sean los pasos del eje Z. Tendría sentido si el fallo fuera proporcional a la altura de la impresión, pero no lo es. Corrígeme si me equivoco.

Titan83,
Anoche a las tantas hice lo que me has dicho y aflojé las excéntricas. Y la medida del Z era casi perfecta. Voy a intentar dejar el movimiento lo más suelto que pueda sin hacer que el eje X deje de estar alineado.

¿Sabéis de algún test tipo el cubo, pero que tenga más altura para seguir haciendo pruebas?¿sabeis de algún vídeo o algún tema del foro en el que se vea claramente como de suelto deber ser el movimiento en Z?

Gracias a ambos de nuevo
  Responder
#5
El movimiento del eje tiene que ser lo más suave posible, pero siempre sin que haya holgura entre las ruedas y el carril: que se mueva suave en la dirección del eje, pero nada de forma lateral.
Si tienes un calibre, no es necesario que imprimas una figura alta para comprobar eso: haz un home, mide en un punto apropiado del carro del extrusor la distancia hasta la superficie de la cama, ordena un movimiento de 100 mm en el eje Z y vuelve a medir en ese punto.
  Responder
#6
(09-02-2021, 05:08 PM)Simemart escribió: El movimiento del eje tiene que ser lo más suave posible, pero siempre sin que haya holgura entre las ruedas y el carril: que se mueva suave en la dirección del eje, pero nada de forma lateral.
Si tienes un calibre, no es necesario que imprimas una figura alta para comprobar eso: haz un home, mide en un punto apropiado del carro del extrusor la distancia hasta la superficie de la cama, ordena un movimiento de 100 mm en el eje Z y vuelve a medir en ese punto.

Si hago un movimiento de Z desde el lcd, me sale la distancia clavada, ni un ápice de error.
Es cuando se imprime algo cuando da los fallos, es como si al hacer los movimientos más cortos no tuviese la misma fuerza y perdiera pasos de forma aleatoria a lo largo de la impresión.

Por eso decía lo del test.

Gracias por tus respuestas
  Responder
#7
La fuerza necesaria para realizar los movimientos no depende de la distancia, sino de la velocidad por lo que, si al realizar la prueba de desplazamiento se mueve la distancia correcta y durante la impresión no, quizá debas comprobar qué velocidad tienes programada para el eje Z en el perfil de impresión.
  Responder
#8
(09-02-2021, 05:42 PM)Simemart escribió: La fuerza necesaria para realizar los movimientos no depende de la distancia, sino de la velocidad por lo que, si al realizar la prueba de desplazamiento se mueve la distancia correcta y durante la impresión no, quizá debas comprobar qué velocidad tienes programada para el eje Z en el perfil de impresión.

Guau, no tenía ni idea.

Esa velocidad se verá en el slicer no? No la he visto nunca. Uso slic3r y cura.

Como se debería de modificar para que no perdiera pasos? No sé, acostumbrado al resto de motores, donde lo que se mira son los pasos, no sabía que la velocidad tuviera que ver con la fuerza de empuje. A mas velocidad mayor fuerza?

Son muchas preguntas... muchas gracias.
  Responder
#9
si quieres imprimir un cubo con mas altura,es muy sencillo,en el cura lo escalas en el eje z hasta la medida que quieras,y listo.
  Responder
#10
En la fuerza necesaria para realizar un movimiento existen varias magnitudes implicadas y no solo depende de la velocidad, pero para el caso que nos ocupa se puede hacer la simplificación de decir que depende solo de la velocidad.
Los micropasos por milímetro se aplican a todos los ejes, pero solo le indican al firmware cuantos impulsos tiene que enviar a los drivers para mover el eje una distancia determinada, no influyen en la velocidad de desplazamiento del eje, aunque sí en la fuerza que tiene que hacer el motor para moverlo: a mayor número de micropasos por milímetro, menos fuerza tiene que hacer, pero más rápido tiene que girar para conseguir una velocidad determinada en el eje.
Lo que se opone al movimiento es el rozamiento y este aumenta con la velocidad. Los ejes que llevan poleas y correa dentada tienen mucho menos rozamiento que los que se mueven con husillos y aunque suelen estar mucho menos desmultiplicados que los que utilizan husillos (menos micropasos y por lo tanto más fuerza a realizar), la menor resistencia compensa con creces a la menor desmultiplicación y no necesitan tanta fuerza para moverse, de ahí que puedan alcanzar velocidades mucho más altas.
Si intentas mover el eje Z a la velocidad que se mueven el X o Y, casi con toda seguridad se bloqueará debido a que el motor no podrá aportar la fuerza necesaria para conseguirlo.
Un eje Z con husillos tipo T8-8 no se moverá bien a velocidades por encima de 10 mm/s con un motor NEMA17 de los que llevan habitualmente estas impresoras.
Si en lugar de husillos T8-8 llevase varillas de rosca métrica (habituales hace unos años), no podría pasar de la mitad de ese valor, pues la rosca métrica tiene mucho más rozamiento que la ACME que llevan los husillos.
Naturalmente, al rozamiento del sistema de arrastre de los ejes, hay que añadir el rozamiento del sistema de guiado y por ello es importante que los ejes se deslicen de forma suave (es decir, con poco rozamiento).
Quizá no sea este el origen del problema, pero comprueba en el programa de corte qué velocidad tienes configurada para el eje Z y limítala a 5 mm/s.
  Responder
#11
(09-02-2021, 07:52 PM)titan83 escribió: si quieres imprimir un cubo con mas altura,es muy sencillo,en el cura lo escalas en el eje z hasta la medida que quieras,y listo.

Es verdad! Que personaje estoy hecho.

Resulta que tras hacer muchas mediciones. Me sale que al subir el Z 100mm desde la lcd, sube 0’22mm menos de lo que debería. Todo esto después de soltar razonablemente las excéntricas como hablamos anteriormente.

No creo que sea un valor aceptable, pero lo cierto esque no lo sé.

Muchas gracias por tus comentarios.
  Responder
#12
Esa diferencia es muy pequeña para explicar el problema que indicabas en tu primer mensaje, por lo que parece claro que era debido al ajuste de las excéntricas.
Si ya tienes esa diferencia constante, puedes corregirla multiplicando el valor actual de micropasos por milímetro por 1,0022.
Por cierto, que se me olvidó indicar en mi último mensaje que también influye en este tema la aceleración que se tenga configurada en el firmware: aunque tendría que ser un valor muy elevado para causar la pérdida de pasos del motor, quizá deberías comprobarlo también.
Otra cosa a comentar respecto a las medidas de las piezas en el eje Z: dependen de la configuración de la altura inicial de impresión (punto 0 del eje Z), de la altura de capa inicial y de la altura de capa general, por lo que cuidado al comprobar la medida de las impresiones, pues puede que no tengan que tener realmente la que tiene el modelo en el programa de corte.
  Responder
#13
Muchas gracias Simemart por tus respuestas, eres un crack!

Después de varias pruebas, me lié la manta a la cabeza y desmonté la impresora entera para intentar hacer que el eje z se moviera lo más suave posible, ya que me di cuenta de que la varilla de z no estaba a la misma distancia en todos los puntos respecto al perfil de aluminio de la estructura..

Los perfiles de aluminio verticales no estaban a escuadra, estaban ligeramente torcidos. Así que los calcé por debajo con una lámina de aluminio de la pared de una lata de cocacola. En un lado fué suficiente, en el otro lado puse un trocito de folio, porque la lámina de aluminio era demasiado. Con eso quedaron a escuadra y alineados los perfiles. Había uno que no estaba totalmente alineado con el otro.

Luego monté el perfil del eje X y el perfil superior pero sin la varilla roscada de z. Observé que subía y bajaba sin nigún tipo de esfuerzo, estaba totalmente suelto.

Al montar la varilla me di cuenta de que ésta seguía estando desalineada respecto al perfil de la estructura, fue entonces cuando me dí cuenta de que el motor se inclinaba al apretar los tornillos que lo sujetan a dicho perfil. Ni siquiera la varilla entraba en la pieza de unión con el motor de lo desalineado que estaba. Tuve que poner un trozo de cartón muy fino entre el perfil y el motor del eje Z y con eso el motor se quedó alineado. Luego moví la tuerca de latón por donde pasa la varilla y por fin la varilla se quedó totalmente alineada.

Después de todo éste tocho, hice varios cubos.

[Imagen: cubos.jpg]

De derecha a izquierda, 20mm, 40mm, 60mm de altura.

El de 20mm. medía 19.65mm en Z
El de 40mm. medía 39.59mm en Z
El de 60mm. medía 59.55mm en Z

Estas medidas me dieron la impresión que de cuanto más sube Z más diferencia hay. Pero si lo analizamos de forma proporcional, cuanto más sube, menos fallo tiene el eje z en dicha impresión.

Los pasos para el de 20mm. habría que modificarlos a 407
Los pasos para el de 40mm. habría que modificarlos a 404
Los pasos para el de 60mm. habría que modificarlos a 403

Por lo tanto esta pequeña diferencia que se aprecia ahora mismo, parece relacionada con el nivelado de la cama y primera capa de impresión. Tendré que analizar eso con más detenimiento.

Lo importante esque parece que el hotend ya no golpea la impresión en ningún punto. En mi situación anterior el cubo de 60mm se habría despegado de la cama de algún golpe seguro.

Muchas gracias a todos por vuestras respuestas. Mandaré actualizaciones cuando imprima alguna pieza de cierta altura y complejidad.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Error en dimensiones Subte 2 763 07-06-2020, 02:25 PM
Último mensaje: Subte
  CONSULTA Dimensiones Impresión anycubic photon MARCOS 0 974 08-03-2019, 02:18 PM
Último mensaje: MARCOS
  Problema muy raro con las dimensiones de las piezas Gunda 1 1,429 30-08-2017, 10:17 AM
Último mensaje: Bayaz
  Cambio en las dimensiones de las piezas antodelg 14 3,256 24-09-2014, 08:26 PM
Último mensaje: antodelg
  Problema de ¿dimensiones? "solucionado" rompesquinas 3 1,520 24-02-2014, 11:13 AM
Último mensaje: rompesquinas