This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 1 voto(s) - 2 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema con potenciómetro
#1
He fabricado un mando de RC con una antigua radio de RC que tenía por casa... Aprovechando los potenciómetros para el funcionamiento con un Arduino Nano y un NRF24L01.

El problema llega desde que el potenciometro me da a veces valores entre 450 y 850, y otras entre 350 y 750, es un problema ya que esos dos valores los uso constantes en el proyecto para una función map por ejemplo map(valor,450,850,0,180), entonces cuando el potenciómetro se queda con los otros valores el servo nunca llega a 180 grados...

El voltaje que les llega sale de una pila a 9V pasando después por un LM7805, por lo que creo que no deberían haber caídas de tension en el circuito. Me lo hacen los dos potenciómetros... No sé con qué puede tener que ver.

Se os ocurre algo?


Un saludo y gracias de antemano

Enviado desde mi Mi A2 Lite mediante Tapatalk
  Responder
#2
Pues... lo primero y mas importante seria saber de que rango de resistencia estamos hablando... eses potenciometros son de 1k, 10k, 100k?
Por otro lado... se calientan? Muchas cosas pueden hacer variar la resistividad de un circuito y uno de sus modificadores suele ser la temperatura.
  Responder
#3
Si EL MISMO, potenciómetro, te da unas veces un rango de valores y otras veces otros, puede que tengas un problema de cableado. Si este es el caso, puede ser interferencias en la entrada analógica, puesto que ésta es muy sensible. ¿has instalado resistencias pulldown? Solucionaria el problema.

De todas formas como te dice el compañero, es conveniente saber los valores de los potenciómetros (supongo que tienes 2 por palanca)  y medirlos con el multímetro. Comprobar que dan valores correctos y que no tienen variaciones extrañas a lo largo del recorrido. El tiempo, la humedad y el desgaste puede que esten provocando el problema...

Aunque si te pasa en todos, yo creo que lo más probable es que sea un problema de diseño del circuito
  Responder
#4
Es muy posible que el desgaste en los potenciometros del RC esten dando valores variables.

Verifica los valores colocando un tester/multimetro leyendo la tensión de salida del potenciometro entre negativo y cursor. Y luego sacude el CONTROL RC a ver si hay cables sueltos.
  Responder


Posibles temas similares…
Tema Autor Respuestas Vistas Último mensaje
  Ayuda con potenciometro sejiozosky 11 1,650 04-11-2015, 03:56 PM
Último mensaje: sejiozosky