Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
utility/u8g.h: No such file or directory
#1
Hola.
Despues de ver el alarma que he preguntado en un post anterior, he decidio mirar el programa Marlin con el arduino, para ver por que se producia el error.
Antes de tocar nada, he intentado compilar el programa, y da el siguiente error.
Código:
Arduino:1.6.5 (Linux), Placa:"Arduino Mega or Mega 2560, ATmega2560 (Mega 2560)"

In file included from dogm_lcd_implementation.h:39:0,
                 from ultralcd.cpp:28:
dogm_font_data_marlin.h:12:25: fatal error: utility/u8g.h: No such file or directory
#include "utility/u8g.h"
                         ^
compilation terminated.
He instalado la libreria U8glib_Arduino-1.18.1.zip, desde el menu del arduino, veo que se ha instalado, porque aparecen los ejemplos que trae esta libreria.
¿Alguna forma de subsanar este error?
Saludos.
Citar
#2
Hola,

Mira que la librería esté bien en el directorio del IDE de Arduino.

Dentro de la carpeta del ejecutable del IDE debería tener la siguiente estructura.

Carpeta Arduino IDE --------> libraries ---------> U8glib ----> examples , utility .....


Si está así no debería darte ningún problema al compilar
Citar
#3
Hola

Otra cosa solucionada, al final para que funcione habia que ponerlo en
Arduino/libraries/U8glib_Arduino-1.18.1/src/utitly/
Tambien lo he puesto por si acaso en:
Arduino/libraries/U8glib_Arduino-1.18.1/src/
Citar
#4
numero110 escribió:Hola

Otra cosa solucionada, al final para que funcione habia que ponerlo en
Arduino/libraries/U8glib_Arduino-1.18.1/src/utitly/
Tambien lo he puesto por si acaso en:
Arduino/libraries/U8glib_Arduino-1.18.1/src/

Me alegro que te funcione al fin.

Un Saludo
Citar
#5
(16-09-2015, 06:35 PM)numero110 escribió: Hola

Otra cosa solucionada, al final para que funcione habia que ponerlo en
Arduino/libraries/U8glib_Arduino-1.18.1/src/utitly/
Tambien lo he puesto por si acaso en:
Arduino/libraries/U8glib_Arduino-1.18.1/src/

Hola, tengo el mismo problema, pero no entiendo que es lo que hay que poner en las direcciones que enviaste, para solucionarlo.
gracias

(16-09-2015, 06:35 PM)numero110 escribió: Hola, que es lo que hay que "poner" en las direcciones que enviaste?

Otra cosa solucionada, al final para que funcione habia que ponerlo en
Arduino/libraries/U8glib_Arduino-1.18.1/src/utitly/
Tambien lo he puesto por si acaso en:
Arduino/libraries/U8glib_Arduino-1.18.1/src/
Citar