Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
termistor del nozzle siempre a 236 grados
#1
hola, acabo de freir mi placa estoi seguro asiendo unos acotejos  se me pego un cable de los 12 volts de la resistencia del nozzle a un cable del sensor de temperatura, bajo el voltaje de la maquina i apartir d ahi siempre me marca 238 grados el nozzle, cuando desconecto el sensor la pantalla me pone "DEF" que es lo normal al desconectarlo pero al ponerlo marca 238.. estoi seguro que se me jodio algo en la board, quiero ver si puedo cambiar el componente roto, alguna idea?


resim

esta es mi placa


resim
Citar
#2
Hola, no entiendo muy bien lo que indicas que estabas haciendo cuando te sucedió este problema pero, en todo caso, parece que manipulabas los cables estando la impresora encendida.
Como has podido comprobar, no es una buena idea. Siempre que se manipule algún componente de la impresora (sobre todo eléctrico), hay que tenerla desconectada.
Para comprobar donde está el origen del problema, intercambia los sensores de temperatura (de la cama y del nozzle) en la placa (con la impresora apagada, recuerda).
Si ahora marca bien el del nozzle y mal el de la cama, es el sensor del nozzle el que ha muerto y deberás sustituirlo por uno nuevo.
Si sigue marcando mal el del nozzle, es el circuito de control del sensor del nozzle en la placa el que está mal y uno o los dos componentes que lleva ese circuito ha(n) muerto.
En concreto, son la resistencia R41 (4700 Ohms) y el condensador C47 (15 uF).
Citar
#3
entiendo, hai veces que se hacen cosas sin pensarlo , si de echo con la impresora encendida estaba arreglando un empate en el cable e hiso un pequeño corte, lo primero que ise fue comprobar si se habia jodido el sensor y no, los sensores estan bien, de echo yo tengo otra impresora anet a8 y comprobe la placa que se daño con los componentes de la otra y ase lo mismo, me dispongo a revisar ahora la resistencia y el condensador que me comentaste ,deseame suerte
Citar
#4
al final hai algo sospechoso el condensador del termistor lo cambie por otro y seguia aciendo lo mismo 236 grados la resistencia al cambiarla ya me daba otros valores pero aun asi alterados, al empesar a bajar los omhs bajaba el valor d la temperatura .. es ridiculo, con una resistencia de 100 omh me esta en 50 grados y al calentar el extrusor sube la temperatura pero la relacion con la temperatura no es real .. sigue pasando algo raro, en mi pais es imposible conseguir respuestos d placas tengo que inventar artesanalmente las cosas
Citar
#5
Si no es la resistencia, el condensador o el sensor mucho me temo que podria ser el pin analogico por el que se realiza la lectura... los microcontroladores son muy delicados, y digamos que los 12v son muy, muy peligrosos para ellos. Si este es el caso... no tendria solucion alguna ya que se habria fundido el pin directamente... si la placa fuese otra podrias utilizar otro pin analogico diferente, pero la placa anet no tiene ningun pin extra para usar que te sirva.

Esperemos que des con el problema y el pin este bien, por que si este es el caso mucho me temo que te tocará conseguirte una placa nueva.
Citar
#6
no mejora la cosa.. los valores de subida de temperatura con los que me marca el termistor no coinciden cuando me dice que esta en 80 grados ya esta resumiendo plastico por el nozzle, i no es el sensor termico probe con otro, lo que no entiendo si se jode le pin analogico porque sigue marcando, osea que le entra informacion
Citar
#7
Hola, como tener, la placa Anet sí tiene un pin libre que se podría utilizar para esa función.
Se encuentra en el conector de la pantalla (LCD pin 3) y está conectado con el pin lógico 27 (patilla 33) del ATMega1284P.
Aunque el pin actual esté dañado, internamente la MCU sigue interpretando el nivel que tenga como una lectura, aunque no tenga nada que ver con el input que esté teniendo.
Citar
#8
(14-11-2018, 01:52 AM)Simemart escribió: Hola, como tener, la placa Anet sí tiene un pin libre que se podría utilizar para esa función.
Se encuentra en el conector de la pantalla (LCD pin 3) y está conectado con el pin lógico 27 (patilla 33) del ATMega1284P.
Aunque el pin actual esté dañado, internamente la MCU sigue interpretando el nivel que tenga como una lectura, aunque no tenga nada que ver con el input que esté teniendo.

la informacion me  abre los cielos pero esta un poco a grosso modo no logro tener certesa d donde cortar y soldar podrais ser un poco mas espesifico si fueras tan amable, tengo esa impresora  sin poder usarla esperando hacerle alguna operacion. comprar respuestos esta fuera de la mesa donde vivo
Citar
#9
Hola, te detallo un poco más la información.
Naturalmente, todo lo que viene a continuación es teoría y como no lo he hecho nunca, no tengo la certeza de que funcione.  Como siempre, si decides hacerlo, será por tu cuenta y riesgo.
El circuito original de la placa Anet es este:

resim

En el punto indicado como T56 es donde conecta la línea que va al pin del ATMega1284P que se utiliza para controlar la función.
Como decía en mi anterior respuesta, el pin libre se encuentra en el conector de la pantalla y por suerte, es uno de los 7 analógicos que te quedan vivos en el ATMega1284P.
La forma más fácil de acceder a él es modificando el cable plano. Puedes ver cómo preparar el cable en este post.
La forma de conectar todo sería más o menos esta:

resim

Tal y como indica el esquema del circuito original, el condensador C sería de 15 uF y la resistencia R una 4K7 (4700 Ohms). Si utilizas un condensador con polaridad, ten en cuenta que el cable 1 es negativo (GND).
Como se ve en el dibujo, los cables 1 (GND) y 2 (+5V) tienen que seguir hacia la pantalla, pero el 3 hay que cortarlo y conectar del lado de la placa, sin que continúe hacia la pantalla.
El único problema que se podría producir es que la linea de +5V de la pantalla no soportase la conexión del termistor a ella, aunque no lo creo.
Por supuesto, si tienes el firmware de serie, es indispensable instalar uno modificable (te recomiendo Marlin 1.1.9), ya que hay que redirigir el pin original al nuevo a utilizar.
Hay que cambiar, en el archivo pins_ANET_10.h, el valor del parámetro TEMP_0_PIN. Si no me engaña el esquema, en lugar de 7 habría que poner 4.
Y eso sería todo. Como decía al principio, en teoría debería funcionar bien.
Citar
#10
La linea de 5v de la pantalla puede de sobra con el termistor, el termistor es una resistencia de 100k... no hay consumo apenas.

Si el pin usado es un pin analogico te funcionará perfectamente una vez cambies el pin en el firmware, eso si... asegurate de ponerle un -1 a la asignacion antigua de ese pin (Si era el zumbador, pues un -1 al zumbador, es un ejemplo... no se lo que va conectado ahi). Asegurate de hacerlo por que si dejas el mismo pin en dos definiciones podrias encontrarte con que se configure la entrada mal o cualquier cosa rara...

Suerte con ello.
Citar
#11
Hola, en este caso no hay ningún problema con la asignación de pines que planteo. Lo he comprobado con mi A8 y funciona correctamente la redirección de ese pin.
El pin que indico es el 4A-27D y no va conectado a nada, por eso digo que está libre. No es como si se lo estuviemos "robando" a otro servicio, en cuyo caso sí habría que desactivarlo.
Por otro lado, Marlin sabe cuales son los pines que tienen que ser analógicos y los configura en el inicio para que funcionen correctamente como ADC. Uno de ellos es TEMP_0_PIN.
Es por esto que puede haber dos pines con el mismo número, si son uno analógico y el otro digital. La placa Anet utiliza el pin digital número 4 para el ventilador, pero no interfiere con el 4 analógico.
Lo que si hay que evitar es que se utilice la parte digital de ese pin, aunque en este caso, tampoco hay ningún problema.
Yo tengo asignado ese pin al autoapagado, sin poner a -1 la asignación que tiene definida en el archivo pins_ANET_10.h y no he tenido ningún problema, lo que indica que no se usa para nada si se tiene la pantalla original.
De todas formas, nunca está de más asegurarse poniendo un -1 donde aparece el 27 en ese archivo, ya que el pin digital sigue activo aunque se esté utilizando la parte analógica.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA temperatura de la cama siempre a 110 soloyokum 13 261 13-11-2018, 01:33 PM
Último mensaje: Nullz
Pregunta CONSULTA Anet A8 temperatura cama caliente siempre a 120º daviar 7 1,175 24-03-2018, 09:03 AM
Último mensaje: daviar
  Cama caliente siempre a 86 Aguiagui5 1 276 05-03-2018, 08:08 PM
Último mensaje: neoxM3
Exclamación Termistor cama caliente Anet A8 archenemy 4 1,175 28-12-2017, 11:05 AM
Último mensaje: archenemy
  APORTE Finales de carrera siempre “On” (Editado bis). Simemart 19 1,367 24-11-2017, 02:54 PM
Último mensaje: Simemart