Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
[solucionado] Problema eje Z. SKR Mini E3
#1
Buenas tardes a todos,

Acabo de actualizar la electrónica de mi impresora a una BIGTREETECH SKR mini E3 32Bit Control + TFT35 V2.0 con TMC2209 UART

Sin embargo, tengo un problema que me mantiene atascado. El eje Z hace el típico comportamiento de pérdida de pasos, vibración y ruidos.

Ya he probado a intercambiar los motores con el eje Y:
 - Si pongo los motores Z en la salida del driver Y -> se mueven correctamente los motores Z.
 - Si pongo el motor Y en la salida del driver Z -> se mueve correctamente el motor Y.

Por tanto no sé donde puede estar el fallo. Porque estas pruebas descartan que fuesen los motores Z que estuviesen estropeados. Además, esta placa ya no incluye potenciómetros para regular la corriente en los motores.

Si leo el parámetro de corriente para cada motor (M906) obtengo los siguientes parámetros:
- X: 580
- Y: 580
- Z: 580
- E: 650

Otro dato curioso, es que cuando hago el homing en Z, cuando toca por primera vez el fin de carrera y vuelve a subir. La siguiente bajada, la realiza correctamente, sin perder pasos ni hacer ningún ruido.

Los parámetros que tengo para la configuración de los motores son los siguientes:



Código:
#define DEFAULT_AXIS_STEPS_PER_UNIT   { 80, 80, 4000, 160 }
#define DEFAULT_MAX_FEEDRATE          { 500, 500, 2, 25 }
#define DEFAULT_MAX_ACCELERATION      { 500, 500, 100, 5000 }

#define DEFAULT_ACCELERATION          500  
#define DEFAULT_RETRACT_ACCELERATION  500  
#define DEFAULT_TRAVEL_ACCELERATION   500

#define CLASSIC_JERK
#if ENABLED(CLASSIC_JERK)
 #define DEFAULT_XJERK 10.0
 #define DEFAULT_YJERK 10.0
 #define DEFAULT_ZJERK  0.4

Muchas gracias de antemano!

Un saludo
Citar
#2
Se me olvidó comentar que las varillas del eje Z son de 5mm
Citar
#3
hola a si a primeras sin pensar mucho , me decanto por la corriente del motor z me parece poca, yo probaria con la misma (parecida ) al extrusor, a ver que comportamiento hace , pero creo que seria mejor
saludos
Citar
#4
Hola, antes de pasar al problema concreto, indicar que los valores de configuración de los pasos por milímetro del eje Z que indicas, no se corresponden con un sistema de arrastre en el mismo por varillas roscadas, ya sea de rosca métrica de 5mm o Witword. O bien tienes mál configurado ese parámetro y la impresora no se mueve lo que debería o bien las varillas no son de 5 mm.
De todas formas no veo ninguna medida que se corresponda con ese valor: la más cercana sería M6 o M7, pero el valor correcto para ellas serían 4266,67 micropasos por milímetro.
Precisamente en el origen del problema que tienes, está el que utilice varillas roscadas: no están pensadas para este tipo de uso y ofrecen mucha mas resistencia al desplazamiento, lo que hace que pierdan paso los motores. Sobre todo si no están perfectamente alineadas las dos varillas, pues este tipo de rosca tiende a trabar varilla con tuerca (para eso se diseñó precisamente).
Como la resistencia depende de la velocidad de giro, es más acusada cuando se mueve el eje a mayor velocidad. Por eso no pierde pasos cuando realiza la segunda aproximación al final de carrera (se hace normalmente a la mitad de velocidad).
Por supuesto, esto se puede corregir aumentando la corriente de los motores, pero no es nada recomendable de cara a su vida útil.
La mejor solución sería cambiarlas por husillos T8-8, mucho más indicados para esta finalidad: las varillas roscadas pertenecen a la prehistoria de la impresión 3D, cuando eran la única solución disponible a bajo precio, pero ya hace mucho que no es el caso.
Citar
#5
Buenas tardes y muchas gracias a los dos por las respuestas.

(02-02-2020, 11:13 AM)hondapa escribió: hola  a si a primeras sin pensar mucho , me decanto por la corriente del motor z me parece poca, yo probaria con la misma (parecida ) al extrusor, a ver que comportamiento hace , pero creo que seria mejor
saludos

Lo curioso de la corriente, es que el eje Y puede mover los dos motores sin ningún problema, entonces no creo que sea que el eje Z necesite más corriente. Aún así, probaré y te comento.

(02-02-2020, 11:55 AM)Simemart escribió: Hola, antes de pasar al problema concreto, indicar que los valores de configuración de los pasos por milímetro del eje Z que indicas, no se corresponden con un sistema de arrastre en el mismo por varillas roscadas, ya sea de rosca métrica de 5mm o Witword. O bien tienes mál configurado ese parámetro y la impresora no se mueve lo que debería o bien las varillas no son de 5 mm.
De todas formas no veo ninguna medida que se corresponda con ese valor: la más cercana sería M6 o M7, pero el valor correcto para ellas serían 4266,67 micropasos por milímetro.
Precisamente en el origen del problema que tienes, está el que utilice varillas roscadas: no están pensadas para este tipo de uso y ofrecen mucha mas resistencia al desplazamiento, lo que hace que pierdan paso los motores. Sobre todo si no están perfectamente alineadas las dos varillas, pues este tipo de rosca tiende a trabar varilla con tuerca (para eso se diseñó precisamente).
Como la resistencia depende de la velocidad de giro, es más acusada cuando se mueve el eje a mayor velocidad. Por eso no pierde pasos cuando realiza la segunda aproximación al final de carrera (se hace normalmente a la mitad de velocidad).
Por supuesto, esto se puede corregir aumentando la corriente de los motores, pero no es nada recomendable de cara a su vida útil.
La mejor solución sería cambiarlas por husillos T8-8, mucho más indicados para esta finalidad: las varillas roscadas pertenecen a la prehistoria de la impresión 3D, cuando eran la única solución disponible a bajo precio, pero ya hace mucho que no es el caso.

Muchas gracias por toda la explicación detallada y las apreciaciones. Comentarte que la impresora es una I3 que tiene más de 7 años, pero que aún seguía usando porque fue la primera que construí. De ahí que tenga todavía las varillas roscadas de 5mm. De ponerme a cambiar a husillos ahora, también necesitaría poder imprimir los nuevos soportes, y eso, en su estado, no es posible...

Sobre la medida de los pasos, he utilizado calculadores y revisado código de otros usuarios, e indican que la cantidad es correcta (para una varilla de 5mm - paso 0.8mm, motores de 1.8º de giro por paso y configuración de los motores en 1/16). En esta web también sale la cantidad de pasos que te indico: https://blog.prusaprinters.org/calculator

De todas formas, aunque la cantidad de pasos estuviese incorrecta, entiendo que eso daría una mala escala en el eje Z de la máquina, no el hecho de que no se muevan los ejes. ¿es correcto?

Un saludo!
Citar
#6
Efectivamente, tienes razón y la varilla normal M5 tiene un paso de 0,8 mm, por lo que tienes bien ese parámetro. Consulté mal la tabla y cogí la métrica de paso pequeño, que es de 0,5 mm. Mis disculpas.
Esta configuración si puede influir, en casos extremos, en que no se puedan mover los motores, pero no en este caso.
De todas formas, el hecho de utilizar una varilla roscada tan fina, sí que requiere más esfuerzo a los motores.
Si solo tienes esa impresora, está claro que tendrás que ponerla en funcionamiento antes de poder realizar cualquier otra mejora que implique piezas impresas, pero en cuanto puedas te recomiendo que si piensas utilizar esta impresora de forma habitual, te pases a los husillos. Su precio es mínimo y la mejora es exponencial.
Para solucionar el problema que tienes actualmente, tendrás que actuar en varios frentes: revisar que las varillas estén bien alineadas y que se mueva el conjunto sin atascos; engrasar bien el conjunto varilla/tuerca para que la fricción sea lo más baja posible y aumentar algo la corriente del driver de ese eje. Si los valores que indicas son miliamperios, tienes bastante margen para ello.
Citar
#7
No te preocupes por el fallo! No pasa nada por ello.

De momento he subido la corriente como dijo también hondapa (a 850mm) y aunque hacía el homming correctamente, a la hora de la impresión todavía fallaba. Modifiqué los parámetros de la aceleración máxima en Z en el Gcode a 120 y parece que ya va correcto.

Intentaré seguir subiendo la corriente a ver si logro mayores velocidades de impresión.

Por cierto, de cara a mejorar los husillos, que recomiendas: motor con husillo incorporado o motor+acople+husillo?

Muchas gracias de nuevo!
Citar
#8
Cuidado con no excederte en la corriente del driver y vigila la temperatura de este y del motor. Quizá tengas que poner ventilación forzada en la placa.
Sobre tu pregunta, personalmente en este tipo de impresora y ya que hay que modificar algo la estructura, yo aprovecharía para sincronizar los dos husillos mediante poleas y correa cerrada, pero con un solo motor.
Si no se alimentan con drivers independientes, tener dos motores no mejora el desempeño respecto a un solo motor, sino al contrario. Las impresoras tipo Prusa I3 llevan dos motores por cuestiones de diseño, no de desempeño.
Dado que están conectados en paralelo y por tanto la corriente se divide entre los dos, con la misma regulación del driver un motor tiene ligéramente más fuerza que dos.
Solo en el caso de que decidieses llegar al máximo que da el driver (2A), sería necesario colocar los dos motores en paralelo. Aunque no es nada recomendable hacer eso.
Puedes hacerte una idea de lo que digo viendo el post de la modificación que hice en mi Anet A8.
Con el montaje original, yo prefiero que los elementos sean independientes, lo que facilita alinear correctamente los dos lados.
Aumentar la aceleración del eje puede mejorar algo el problema, pero no lo soluciona. Para que te hagas una idea, en mi A8+ tengo 50 mm/s² como máxima para ese eje, con un funcionamiento óptimo.
Citar
#9
(02-02-2020, 09:44 PM)Simemart escribió: Cuidado con no excederte en la corriente del driver y vigila la temperatura de este y del motor. Quizá tengas que poner ventilación forzada en la placa.
Sobre tu pregunta, personalmente en este tipo de impresora y ya que hay que modificar algo la estructura, yo aprovecharía para sincronizar los dos husillos mediante poleas y correa cerrada, pero con un solo motor.
Si no se alimentan con drivers independientes, tener dos motores no mejora el desempeño respecto a un solo motor, sino al contrario. Las impresoras tipo Prusa I3 llevan dos motores por cuestiones de diseño, no de desempeño.
Dado que están conectados en paralelo y por tanto la corriente se divide entre los dos, con la misma regulación del driver un motor tiene ligéramente más fuerza que dos.
Solo en el caso de que decidieses llegar al máximo que da el driver (2A), sería necesario colocar los dos motores en paralelo. Aunque no es nada recomendable hacer eso.
Puedes hacerte una idea de lo que digo viendo el post de la modificación que hice en mi Anet A8.
Con el montaje original, yo prefiero que los elementos sean independientes, lo que facilita alinear correctamente los dos lados.
Aumentar la aceleración del eje puede mejorar algo el problema, pero no lo soluciona. Para que te hagas una idea, en mi A8+ tengo 50 mm/s² como máxima para ese eje, con un funcionamiento óptimo.


Vaya rediseño que te has hecho!! mis dieces!!!

Echaré un buen análisis a ver cómo mejoró la mía.
Citar
#10
Bueno, dejo este tema solucionado y lo cierro. Al final todo se ha solucionado regulando de forma adecuada la corriente de los motores.

Muchas gracias por la ayuda!
Citar
#11
Me alegro que lo solucionases.
Un saludo.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Problema al compilar Marlin para placa SKR Mini E3 Aurican 13 559 05-09-2020, 10:46 AM
Último mensaje: DR_CUE
  Desplazamiento/salto en eje X - SOLUCIONADO PacoMB 6 268 18-05-2020, 09:44 AM
Último mensaje: Simemart
  ayuda a conectar mks pwc v2.0 a mi impresora(SOLUCIONADO) domingo 31 3,619 22-01-2020, 06:40 PM
Último mensaje: Simemart
  CONSULTA error al imprimir en una kossol mini the cg696 0 386 12-12-2018, 01:31 AM
Último mensaje: the cg696
  [SOLUCIONADO] Temperatura extrusión baja sola granota 6 4,693 03-12-2018, 07:56 PM
Último mensaje: Fendetestas