Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
duda power supply 3d printer y sensor capasitivo
#1
saludos
les comento tengo ya intalado el sensor
pero quiero poner los 12v directos a el power supply ya que tiene varios compartinmientos para añadir entiendase (+)
cuento con una placa Anet v1.0 (china) la de un solo potensiometro . hice la modificacion de las resistencias para el ground y señal y enciende tomando
corriente solo para probar delos 12v de entrada a la placa . solo fue para probar.
Creen que pueda usar uno de los compartimientos del power supply sin problema? Gracias de antemano

este es el power supply que tiene mi impresora CTC i3 pro B (clone Chino) con placa Anet v1

resim
Specification:
Product NameConfundidowitch power supply
Input Voltage: 100-120V 60Hz, 200-240V 50Hz
Output Voltage: DC 12V 20A
Output power: 240 W 
Size: Approximately 200*110*5mm(L*W*H)
Working Temperature: -10~60℃
Working Frequency: 50-60(HZ)
Protection: Short circuit / Over load / Over voltage

  Placa que tiene mi impresora
resim

sensor cual estoy trabajando
resim

Capacitance Proximity Switch NPN NO DC 6-36V 300mA 3-wire LJC18A3-H-Z/BX

Citar
#2
Hola, no hay ninguna diferencia de conectar en uno u otro de los conectores de la fuente de alimentación (power supply).
Todos los +V y todos los -V, se comportan como si fuesen un solo +V y un solo -V, por lo que es indiferente donde hagamos las conexiones, siempre que respetemos la polaridad.
Citar
#3
Gracias por tan pronta respuesta felicitaciones por los tutoriales muy comodo para trabajarlos y entendibles saludos

tengo una duda con el autoleveling
cuando ejecuto el homing todo los motores llegan a su sitio
pero el sensor probe en ves de bajar y detectar el cristal de la cama caliente
hace lo contrario Sube y para.
sabes cual seria esa linea de ajuste en espesifico para invertirlo ?
Citar
#4
Hola, si el sensor es efectivamente un NPN-NO, lo primero comprueba que en el archivo Configuration.h están así estas dos líneas:

#define X_MIN_ENDSTOP_INVERTING true
#define Z_MIN_PROBE_ENDSTOP_INVERTING true


Ahora hay que comprobar que el firmware detecta correctamente la activación del sensor.
Para ello, conecta la impresora al ordenador y utiliza un programa que permita enviar comandos gcode.
Estando el sensor desactivado, envía el comando M119. La respuesta tiene que ser z-min: open.
Estando activado, la respuesta tiene que ser z-min: TRIGGERED.
Si sucede al revés, es que el sensor no es NPN-NO y hay que poner los valores de las líneas anteriores los dos a false.
Si la respuesta al comando M119 es siempre TRIGGERED, entonces hay un mal funcionamiento, bien del sensor o del circuito de control del final de carrera del eje Z en la placa.
Para saberlo, hay que desconectar el sensor de la placa y repetir el comando. Si da como resultado z-min: open, el que falla es el sensor. Si da z-min: TRIGGERED, está mal la placa.
Citar
#5
Perfecto
es NPN-NO

(activado)
x_min: open
y_min: open
--->z_min: TRIGGERED<---

(desactivado)
x_min: open
y_min: open
--->z_min: open<---

ahora bien calibre el sensor a 2mm de la cama caliente con el cristal
doy vueltas a el tornillo de calibrar cuando enciende la luz le doy 1/2 vuelta mas para que quede .. nitido esa parte
pero aun cuando se hace el homming sigue bajando el eje Z.
te recuerdo q el sensor es capasitivo q se supone detecte metal y cristal con las cual tengo en mi impresora
Gracias como siempre
Citar
#6
Hola, los mensajes de respuesta del comando M119 indican un comportamiento correcto del sensor, aunque tendrás que vigilar que no tenga fallos esporádicos de detección.
Si no hace bien el "homing", tendrás que comprobar que el eje Z se mueve en la dirección correcta cuando le indicas que realice un movimiento y que tienes así la siguiente línea en el archivo Configuration.h:

#define Z_HOME_DIR  -1

Si se cumple todo lo anterior, tendría que hacer correctamente el "homing".
Citar
#7
no detecta la cama caliente aun asi sigue bajando el eje Z enciende el sensor y no para. seguire tocando y calibrando .. ya q no cuento con el
backup orig  por que los chinitos bloquean el bootloader y no habia manera q detectara la placa. En fin estoy desde 0 programando y viendo los tutooriales por aqui en
autoleveling logre acercar un poco al centro de la cama caliente se pasa del centro pero logre algo jajaja
el sensor lo dejare para mas adelante en lo q ajusto bien el centro de la cama caliente
la preg ahora es en que linea se aumenta o se elimina valor para lograr centralizar al X110 x Y110 (%)
Gracias por toda la ayuda

recuerda mi 3dPrinter es un clone CTC i3ProB clone de los q vende ebay .pero bien parecida a la anet A8
las medidas del Bed eran X200 x  Y200  x Z180 . de programacion pero las medidas oficial del BED son las mismas de aney A8 220x220 cambia
la altura ya q esta CTC clone es Z180 maximo osea mas pequeña q la Anet A8

el motor del extrusor de la CTC clone queda a la izquierda osea al contrario de la Anet A8
el home lo hace igual pero en la CTC la boquilla queda por fuera de la cama frontal

aqui una foto de la misma
resim
resim

Aqui se puede apreciar donde queda la boquilla ya estando en home todos los motores
resim

Edito: tengo instalado en la placa
Marlin 2.0 bugs fix
Citar
#8
Hola, como bien dices, esa impresora es casi identica a una Anet A8, por lo que puedes aplicarle todo lo que explico en mi tutorial en tres partes sobre autolevel.
Para las placas de 8 bits, como es el caso de la tuya, no tiene sentido utilizar la versión 2.0 de Marlin en lugar de la 1.1.9, ya que con esta última tienes todas las funcionalidades de aquella, pero ocupando menos memoria de programa.
Te recomiendo que sigas el tutorial desde el principio y al pie de la letra, para conseguir que te funcione correctamente el autolevel.
Pon en los post del tutorial las dudas que te puedan sugir en cada parte e intentaré solucionarlas.
Citar
#9
(06-11-2018, 06:11 PM)Simemart escribió: Hola, como bien dices, esa impresora es casi identica a una Anet A8, por lo que puedes aplicarle todo lo que explico en mi tutorial en tres partes sobre autolevel.
Para las placas de 8 bits, como es el caso de la tuya, no tiene sentido utilizar la versión 2.0 de Marlin en lugar de la 1.1.9, ya que con esta última tienes todas las funcionalidades de aquella, pero ocupando menos memoria de programa.
Te recomiendo que sigas el tutorial desde el principio y al pie de la letra, para conseguir que te funcione correctamente el autolevel.
Pon en los post del tutorial las dudas que te puedan sugir en cada parte e intentaré solucionarlas.
mmm instale la v de marlin 2.0 pq me gustaria poner wifi y en la v1.1.9no veo dicha opcion
aparte que tiene bugs fix correjidos segun lei
en fin un universo de Gracias
voy nuevamente al post de autoleveling y ahi pondre todas las dudas
Clap
Citar
#10
Hola, puedes usar la vesión que más te guste, pero no será por el soporte wifi.
Lo que indicas que trae la versión 2.0 es el soporte para una wifi muy concreta, la que trae incorporada la placa ESP32 que, como es una placa de 32 bits, la v1.1.9 no lo trae.
Pero, a no ser que tengas pensado utilizar esa placa, te será de poca utilidad.
Por la wifi no debes preocuparte, pues hay montones de usuarios usando wifi con placas y Marlin de 8 bits.
Y sobre el tema del "bugfix", yo no me creería todo lo que se puede leer por ahí, pues hay mucho desconocimiento de qué es realmente.
Lo dicho, usa la versión que prefieras.
Un saludo.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Este sensor me vale como autolevel? vegetto 2 306 28-06-2018, 02:37 AM
Último mensaje: vegetto
  problemas con el sensor cundo 1 230 22-06-2018, 11:58 PM
Último mensaje: Simemart
  CONSULTA Sensor capacitivo Anet A6 Txandro 5 410 24-05-2018, 06:58 PM
Último mensaje: Simemart
  ayuda con sensor de nivelación cundo 2 296 23-05-2018, 08:45 PM
Último mensaje: cundo
  Calibracion sensor TRONXY XY-08N NPN Ordosario 3 2,232 18-04-2017, 11:35 PM
Último mensaje: Ordosario