Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
bcn3d+ ruidos electricos motores en 1.9
#1
Ando loco intentando meter el fimware 1.9 a mi bcn3d+ , para que esta tenga el sensor bltouch. y el ultimo fiwmare por supuesto.


La compre de segunda mano, me la encontré con un carro en x impreso en metal,  con una fuente de 24v,  y con alguna pieza de pla rota.

la bcn3d+ tiene una ramps 1.4 , pololus drv8825 , y los jumpers debajo de los steppers estan con un solo jumper creo que para 1/16 de paso.

Imprimí las piezas rotas con mi anet a8, cambie la fuente a 12v, teste que los motores funcionaran,......   segui un tutorial de cambio de fimware a la 1.9, bastante bueno por cierto muy detallado.

https://www.youtube.com/watch?v=dndzfScW9bk&t=5s


con el fimware original de la bcn3d+ no presenta ruido electrónico en los motores, pero con la versión 1.9 si.

Este es el ruido que me trae de cabeza, se lo mande a un amigo pero no damos con la solución.
https://youtu.be/1U5HEYlq0Eo

Un  saludo desde Cantabria.
Citar
#2
Hola, por lo que veo la versión original debe de ser bastante antigua y se han implementado muchos cambios en las rutinas de control de drivers y motores (sobre todo en la versión 1.1.7), por lo que no sería raro que hubiese diferencias en el ruido.
De todas formas un par de cosas:
¿por qué no configuras los DRV8825 a 1/32?
¿has vuelto a calibrar los drivers con la alimentación a 12V o sigues con ellos como estaban cuando la alimentación era a 24V?
Citar