Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Sobrecalentamiento del Mega 2560 después de un corto
#1
Buenas compañer@s y feliz año nuevo a tod@s!!

Pues resulta que estoy terminando con el montaje de mi prusa i3, y haciendo pruebas de movimiento de los ejes, puse el endstop manualmente en la varilla del eje y, realizando un corto :dale2: entre algunas de las patas del final de carrera. Resultado: ahora se sobrecalienta el atmega y el regulador.
Si conecto el arduino con la ramps a traves de USB ningun problema, conecta y comunica. Pero a la que enciendo la fuente y aplico los 12V se acabó. Se amorra el regulador a 3.4V y se calienta.
He revisado componentes de la ramps y todo parece ok. He mirado los diodos sin desoldar y parecen estar bien.

Alguna idea de lo que puede estar fallando? O directamente me voy agenciando un Mega 2560 nuevo...

Gracias compañeros!!
Citar
#2
Hice lo mismo que tu. y me pasaba lo mismo.
Desoldé el diodo D1 (que hace que arduino mega se alimente de la ramps a 12V) y solucionado. El arduino se me alimenta SOLO por el USB

Pero no puedo hacer la impresora autonoma (pantalla mas lector) a no ser que le meta 5V al arduino de alguna forma.
Citar
#3
ebludt escribió:Hice lo mismo que tu. y me pasaba lo mismo.
Desoldé el diodo D1 (que hace que arduino mega se alimente de la ramps a 12V) y solucionado. El arduino se me alimenta SOLO por el USB

Pero no puedo hacer la impresora autonoma (pantalla mas lector) a no ser que le meta 5V al arduino de alguna forma.
Alimentando el arduino directamente por el jack DC a 12V (el regulador lo admite). Yo lo tengo así desde hace año y pico, y sin problemas.
NOVEDAD: CoreXY Eternal Edition (Custom) -> https://www.spainlabs.com/foros/tema-Ete...So-Edition
Mi Prusa i3, ¡con lista de componentes! -> http://www.spainlabs.com/foros/tema-Un-clon-mas
Citar
#4
Creo que las 2 opciones son adecuadas. El problema debe estar en el circuito que conmuta las alimentaciones entre el USB e VIN o en el propio regulador 1117. Osea que mientras no lo solucione tendré que alimentar el arduino por separado.

Gracias por las respuestas!!
Citar
#5
buenas,

He tenido el problema del calentamiento del Mega 2560.
El PC cuando tiene una fuente de alimentación conectado a tierra, internamente referencia el Gnd del USB a su referencia de tierra.
La fuente de alimentación externa que se conecta al ramps, puede estar a tierra, pero en mi caso no estaba en la misma referencia el Gnd.
Mega 2560: a través de la ferrita L1 se conectan entre sí el Gnd del USB del PC y el Gnd del arduino que está a su vez está unido al Gnd de la tarjeta Ramps 1.4.
Hay que tener mucho cuidado con la electrónica que no toque ni chasis ni entre sí (caparazón usb B del Arduino con un transistor del Ramps etc,)

En mi caso ocurrió lo siguiente:
Toqué la mariposa que aprieta la cama caliente al tornillo que sujeta la estructura metálica estando esta caliente, y piqué un poco de aislante (barniz/pintura) de la cama caliente. Como la mariposa tiene una sección tan grande que llega hasta la pista de la resistencia y esta perdió aislante debido a mi torpeza, se derivó directo a la estructura en un punto donde hay unos 0,45ohm a 12Vdc y 1,5ohm a Gnd. Ello conllevó la derivación de parte del voltaje de 12 Vdc a gnd y por ende que hubiera tanta corriente entre el Gnd del sistema y el Gnd del USB del PC, que rompió el L1 del Arduino.

Si no se une la fuente de alimentación del PC a tierra, el Gnd del USB no tendrá referencia, así que la derivación elevará el Gnd este también, y por ende parecerá que no habrá derivación, pero si se conecta la fuente, la corriente que circula por el cable USB será letal.
También se rompió el regulador de 5 Vdc IC1, pero tal como se decía, se puede quitar el diodo D2 del ramps, o el mismo IC1 del Arduino y así alimentar los 5Vdc desde el USB del PC y los 12 Vdc desde la fuente externa. Al no estar la tierra conectada.
Pero en un sistema electrónico que utiliza 2 fuentes de alimentación diferentes (1 el USB del PC y 2 la fuente externa) si no están unidos los Gnd de las 2 fuentes, no funciona bien, debido a que el voltaje no tendría la referencia requerida, es importante que esto se mantenga.

Consejo:
Fijarse que no haya derivación en las tarjetas y mucho cuidado con la cama caliente, que está encima de una estructura metálica y cuidado con las mariposas metálicas que pueden estar encima de una pista de la cama caliente. Solución: poner tuercas pequeñas que no resalten y así no haya ninguna derivación.
Medir el voltaje de +5Vdc y luego los +12Vdc respecto al Gnd del USB. si es mayor que 0,1..... problema.
Si solo es el L1, se puede puentear esto y así volver a unir los 2 Gnd

saludos
Citar
#6
Se te ha quemado esto:

http://www.befr.ebay.be/itm/2pz-AMS1117-...b6d&_uhb=1

No hagas experimentos y cambialo por uno nuevo, a ver si vas a estropear el usb del ordenador!
Ánimo
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  tmc 2208 anycubic i3 mega y extrusor jramon 1 103 02-12-2018, 02:13 PM
Último mensaje: Simemart
  CONSULTA (ENLACE)Problema Arduino Mega Clon, componente quemado USB Thulsa_Doom 3 257 13-08-2018, 06:30 PM
Último mensaje: Thulsa_Doom
  Corto en las ramps 1.4sb robertote 3 351 30-05-2018, 08:37 PM
Último mensaje: Shellmer
  Arduino 2560 quemado jukaramgon 17 1,554 12-06-2017, 01:38 AM
Último mensaje: gabrielchapita
  [AYUDA]Freaduino MEGA 2560 prusai2 1 756 31-01-2015, 02:21 PM
Último mensaje: WeSo