Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Smart LCD RepRap Ramps 1.4
#61
Genial, me ha dado por comprobralo, y resulta que sí tengo los diodos D1 y D2 en la RAMPs. Hay que tocar algo más o alguna conexión extra?

EDIT: Probando con el multímetro, con el USB puesto, pasa por el D1 algo más de 4V, lo normal. Si quito el USB, apenas llega a la tensión VD (ronda los 0.5v).

EDIT2: Descarto la RAMPs, he probado otra completamente nueva a la que he soldado los pines del LCD también. Pero lo mismo, en cuanto desconecto el USB, se apaga. He leído que el D1 es para que no se pare la impresión, pero del LCD no he visto nada... Con el diodo hay algún problema si se le meten 12V directamente por el jack? Y tampoco tengo claro qué pasaría si se conectan los 12V a la entrada y luego se conecta al USB con el PC. Se supone que lleva un selector automático, pero... :roto2:
Vosotros tenéis hecho algo más para que os funcione? He visto varios por el foro que la usan de manera autónoma...

EDIT3: Bueno pues me respondo a mi mismo varias horas después Confundidois1: Me he puesto a cacharrear y he probado a conectar un transformador con un jack 5.5-2.1mm y lo he conectado a la Mega. El LCD se veía raro, con mucho brillo, hasta que se ha apagado. Se supone que era un transformador a 12v, pero mi cara ha sido de :roto2: cuando le mido casi 19V de salida :dale2:
Por USB, seguía funcionando todo sin problemas, pero por la alimentación del Arduino, no había manera, por lo que he imaginado que era algún componente de esa parte del circuito, y efectivamente, al desmontarlo todo, he visto como el regulador 117-5 estaba algo tostado (las letras no se veían). Menos mal que tenía un Mega de repuesto y se lo he podido poner (aunque he pedido reguladores para ponerlo nuevo y tener un repuesto).
Al final he localizado otro jack 5.5-2.1 y lo he conectado en paralelo con la entrada a la RAMPs de 5A. He hecho pruebas de conectar y desconectar el USB con el jack alimentado a los 12V, y hasta ahora funciona sin problemas.

Al final parece que ya he conseguido que sea autónoma, lo próximo que me toca es probar el tema de convertir una PWM a una DC con un condensador. Espero no cargarme nada antes de que me lleguen los repuestos :elrisas: :elrisas: :elrisas:
NOVEDAD: CoreXY Eternal Edition (Custom) -> https://www.spainlabs.com/foros/tema-Ete...So-Edition
Mi Prusa i3, ¡con lista de componentes! -> http://www.spainlabs.com/foros/tema-Un-clon-mas
Citar
#62
Aqui estoy de nuevo con otra cosa curiosa de esas que desesperan...

Cambié los cables planos por unos mas largos para colocar de una puñetera vez la cajita delante de la impresora... la quería haber puesto en el lado derecho ya que es donde tengo la electrónica, pero entonces es imposible acceder a la tarjeta sin separarla mucho. Además, estos días tuve que cambiar la electrónica por un "quiteme de ahí esas llamas" :mrgreen:

El caso es que la pantalla no funciona de forma auntonoma como antes. Ahora para que funcione, el arduino debe estar conectado vía USB... quitando parte del sentido de la electronica con lector de tarjetas... ¿puede ser el largo de los cables? ¿la nueva electronica?
Citar
#63
Puede que los cables no estén bien climpados, y tenga un hilo que no tenga contacto. Comprueba la continuidad de los cables. Tiene que ser de eso.

Por cierto, si teneis cables ide de pc, en cualquier tienda de electrónica venden los conectores y los podeis montar en casa. Si no recuerdo mal, me costaron 0,25 euros cada uno.
Citar
#64
yo_mismo escribió:Por cierto, si teneis cables ide de pc, en cualquier tienda de electrónica venden los conectores y los podeis montar en casa. Si no recuerdo mal, me costaron 0,25 euros cada uno.

Ayer mismo, temiendome que tendría que volver a montarlos a 0,13€ en Actron.

Mola
Citar
#65
A mi electrónica le pasa exactamente lo mismo, si no lo conectas al USB, no se hace autónoma, y eso que tengo los diodos correspondientes, pero no hay manera.

Solución? Después de hacer mil pruebas y entre ellas cargarme el regulador de potencia del Arduino (ya me viene alguno de repuesto) por poner un transformador que en teoría daba 12v pero que daba 18v :roto2: y tener que cambiar la placa, puse en paralelo con la entrada de 5A de la RAMPs, un conector jack 5.5-2.1mm para alimentar el Arduino. El propio Arduino se encarga de "elegir" la entrada de alimentación, bien sea USB o el Jack, por lo que con esa entrada en paralelo, he conseguido imprimir sin problemas tanto desde el PC como de manera autónoma.
NOVEDAD: CoreXY Eternal Edition (Custom) -> https://www.spainlabs.com/foros/tema-Ete...So-Edition
Mi Prusa i3, ¡con lista de componentes! -> http://www.spainlabs.com/foros/tema-Un-clon-mas
Citar
#66
WeSo escribió:A mi electrónica le pasa exactamente lo mismo, si no lo conectas al USB, no se hace autónoma, y eso que tengo los diodos correspondientes, pero no hay manera.

Solución? Después de hacer mil pruebas y entre ellas cargarme el regulador de potencia del Arduino (ya me viene alguno de repuesto) por poner un transformador que en teoría daba 12v pero que daba 18v :roto2: y tener que cambiar la placa, puse en paralelo con la entrada de 5A de la RAMPs, un conector jack 5.5-2.1mm para alimentar el Arduino. El propio Arduino se encarga de "elegir" la entrada de alimentación, bien sea USB o el Jack, por lo que con esa entrada en paralelo, he conseguido imprimir sin problemas tanto desde el PC como de manera autónoma.

Voy a reconstruir los cables pero quiero una foto ya mismo... de hecho, te ofrezco una foto de mi relé con diodo para la cama a cambio de la tuya...
Citar
#67
jajaja con chantaje!! Lengua
Es muy simple, pero la hago esta tarde cuando esté en casa y la subo.

Precisamente lo del relé con diodo es algo que iba a hacer hoy o mañana. Es más, voy a trastear con un condensador a ver si puedo "anular" el PWM, lo único que no tengo electrolíticos (están en camino), y tengo que echar números y ver cómo lo preparo para que no me la líe :roto2:
Pero vamos, que ésto lo hago por cacharrear, porque imprimo a 60º de cama y tarda menos en calentarse que el hotend. O incluso igual me animo a ponerle otro relé al hotend :elrisas: :elrisas:
NOVEDAD: CoreXY Eternal Edition (Custom) -> https://www.spainlabs.com/foros/tema-Ete...So-Edition
Mi Prusa i3, ¡con lista de componentes! -> http://www.spainlabs.com/foros/tema-Un-clon-mas
Citar
#68
WeSo escribió:jajaja con chantaje!! Lengua
Es muy simple, pero la hago esta tarde cuando esté en casa y la subo.

Precisamente lo del relé con diodo es algo que iba a hacer hoy o mañana. Es más, voy a trastear con un condensador a ver si puedo "anular" el PWM, lo único que no tengo electrolíticos (están en camino), y tengo que echar números y ver cómo lo preparo para que no me la líe :roto2:
Pero vamos, que ésto lo hago por cacharrear, porque imprimo a 60º de cama y tarda menos en calentarse que el hotend. O incluso igual me animo a ponerle otro relé al hotend :elrisas: :elrisas:

Tienes un privado... a ver que te parece. Yo no me liaría tanto con condensadores y demás... afina bien el valor de la resistencia de la cama y coge un relé acorde. Con respecto al diodo tenía por casa unos cuantos 1N4007 de 1A, pero para lo que sirve más que suficiente.
Citar
#69
Te lo he respondido por privado, a ver qué me comentas de la idea de por qué el condensador Lengua
NOVEDAD: CoreXY Eternal Edition (Custom) -> https://www.spainlabs.com/foros/tema-Ete...So-Edition
Mi Prusa i3, ¡con lista de componentes! -> http://www.spainlabs.com/foros/tema-Un-clon-mas
Citar
#70
Pero los que habéis tenido que hacer trapicheos con el arduino y la ramps para que sea autonoma es porque no tenéis la de geteech no? porque la mia ha sido conectarla y empezar a rular, sin cables ni nada de nada.
Citar
#71
WeSo escribió:Te lo he respondido por privado, a ver qué me comentas de la idea de por qué el condensador Lengua

Es ingeniosa como poco... eso quiero verlo... como mola trastear ¿eeeh? Mola

Danidc escribió:Pero los que habéis tenido que hacer trapicheos con el arduino y la ramps para que sea autonoma es porque no tenéis la de geteech no? porque la mia ha sido conectarla y empezar a rular, sin cables ni nada de nada.

Pues no. Yo tambien tengo la pantalla de Geeetech y la electronica de Ghosthawk, pero antes no pasaba... asi que no tengo ni idea de por que es, pero no me deja encender el arduino de forma autonoma sin enchufar el usb...

Asi me mantengo a la espera de ver que ha montado WeSo...
Citar
#72
Mi LCD la compré por ebay por 17€ y funciona sin problemas. Lo del autónomo no creo que tenga que ver con la pantalla....

Alcamprieto, es muy simple lo que hice, simplemente poner uno de éstos: http://www.ebay.com/itm/1x-DC-power-supp...0688542829
Conectado en paralelo con la entrada de 5A del arduino. El positivo si no recuerdo mal, es el interior. Lo del diodo D1 y D2 (http://reprap.org/wiki/RAMPS_1.4#D1.2C_D2_-_Diodes) en teoría es para que funciona como autónoma, pero no debería ser necesario si estás alimentando el Arduino directamente (él mismo se encarga de seleccionar la fuente), en lugar de alimentarlo mediante la RAMPs.

De todos modos, luego te pongo una foto.
NOVEDAD: CoreXY Eternal Edition (Custom) -> https://www.spainlabs.com/foros/tema-Ete...So-Edition
Mi Prusa i3, ¡con lista de componentes! -> http://www.spainlabs.com/foros/tema-Un-clon-mas
Citar
#73
Solucionado, solucionado... je je... ya está puesta la clavija así que me guardo el chantaje para otra foto... je je...
Citar
#74
Ahora en Geetech esta mas cara, pero he encontrado esta en ebay:

http://www.ebay.es/itm/Reprap-Ramps-V1-4...722&_uhb=1

¿alguna sugerencia? ¿alguno ya ha comprado a este vendedor y este modelo?
saludos
Citar
#75
ruloma escribió:Ahora en Geetech esta mas cara, pero he encontrado esta en ebay:

http://www.ebay.es/itm/Reprap-Ramps-V1-4...722&_uhb=1

¿alguna sugerencia? ¿alguno ya ha comprado a este vendedor y este modelo?
saludos

Yo no he comprado a este vendedor, pero si esa es la que vende que sepas que es el modelo de Geeetech... si además lo pone en la placa en las fotos. Fíjate debajo del botón rojo.

Está muy bien de precio ya que si no recuerdo mal yo pague casi el doble en Geeetech (creo que fueron cerca de 28€) contando con los gastos de envío.
Citar
#76
Yo compré ésta:
http://www.ebay.es/itm/321184161067

Son sólo 3 céntimos menos :roto2:

Me llegó y funciona bien. Lo único es que en vez de verde, es azul el display, y que no traía los pines de conexión para soldar a la placa (menos mal que tenía algunos). Pero vamos, se lo he dicho al chino, y me ha enviado 10 tiras de 40 Sisi3 (cuestan las 10 tiras poco más de 1 euro)
Si se lo pides a él, dile que te asegure que van los pines incluidos.
NOVEDAD: CoreXY Eternal Edition (Custom) -> https://www.spainlabs.com/foros/tema-Ete...So-Edition
Mi Prusa i3, ¡con lista de componentes! -> http://www.spainlabs.com/foros/tema-Un-clon-mas
Citar
#77
yo e montado esta: http://www.reprapbcn.com/catalog/index.p...oller.html
es un poco mas cara que si la pides por ebay pero tarda dos dias en llegar. de momento me funciona de manera autonoma sin tener conectado el cable usb
Citar
#78
Y puedes aprovechar para comprar algo de material Guiño
Citar
#79
Además, los usuarios de Spainlabs tenéis un 10% de descuento en las compras:

http://spainlabs.com/foro/viewtopic.php?f=26&t=512
Citar
#80
Parece que he conseguido poner el panel, pero solo se enciende y apaga la luz. He descomentado la línea
#define REPRAP_DISCOUNT_SMART_CONTROLLER
Además me ha dejado de medir la temperatura del extrusor (no se si tendrá que ver, o es que directamente me he cargado la ramps)
¿A alguien se le ocurre qué puede ser (si no es que me he cargado algo al soldar)?

PD: Si alguien tiene un esquema de donde puedo comprobar continuidad entre los pines soldados para el LCD y algún punto de la ramps, se lo agradecería. De la línea larga he encontrado continuidad para todos los puntos (a base de ensayo y error). pero de los 8 a parte, no.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Conectar TFT tactil a ramps Jaimelito 21 4,884 17-06-2018, 06:14 PM
Último mensaje: Eduwitow
  CONSULTA Salida de 12v en RAMPS 1.4 Rubenulo 6 211 04-06-2018, 08:13 PM
Último mensaje: Rubenulo
  Corto en las ramps 1.4sb robertote 3 152 30-05-2018, 08:37 PM
Último mensaje: Shellmer
  [PROBLEMA] RAMPS EJE Z eudaldgr 8 264 11-05-2018, 06:22 PM
Último mensaje: drow
  CONSULTA Impresora 3D Nema23+Ramps 1.4+ TB6600 Kikilon42 4 323 24-04-2018, 09:55 PM
Último mensaje: Kikilon42