Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Servidor de licencias con router comtrend fibra movistar
#1
Bueno, os expongo el caso con el que llevo enfrascado 10 dias sin conseguir nada

Actualemnet estoy montando un pequeño servidor en mi casa, este pequeño servidor lo unico que tiene es un programa gestor de licencias de software, basicamente en el pc en cuestion tengo el archivo que tiene la informacion de las licencias que dispongo para utilizar, este programa lo proporciona la empresa del software.

Para dicho programa se usa el puerto 6200.

El caso es que ahora lo que quiero conseguir es que el equipo cliente, desde cualquier red, se comunique con el equipo gestor de licencias y le asigne la licencia en cuestión.
La empresa ya nos ha indicado la configuracion necesaria para su programa. Entre ellas, crear en el cliente una variable de entorno que le idica la ip del srvidor en la que tiene qe buscar la licencia

Al tener que usar por la casuistica en cuestion, desde cualquier sitio el cliente, la ip que tendremos que usar es la publica de mi red.
Aqui viene el tema, el programa gestor de licencias trabaja con la ip local de red del ordenador, y el archivo de licencias esta asignado a una tarjeta de red unica

Por lo tanto, segun yo entiendo lo que tengo que hacer para que la comunicacion se establezca es redireccionar la comunicacion con mi ip publica a la ip local (192.168.1.37) y al puerto 6200 en concreto pero no ha habido manera de conseguirlo

Podéis echarme una mano?
Citar
#2
Diria que es lo mismo que cuando abriamos los puertos en el router para usar emule o programas parecidos. Especificabas los puertos que querias abrir y listo, creo que no hace falta indicar a que IP iban destinados.
Citar
#3
La redirección de puertos se hace en la sección NAT del router.
Tienes que redireccionar el puerto 6200 externo al puerto 6200 interno de tu máquia 192.168.1.37.

Pero en los clietes desde fuera solo podrás ver la IP publica. Si no es estática tendrás que buscar un DNS dinámico para poder encontrar siempre la IP pública que le asignan al router mediante un nombre DNS.
En los clientes tendrás que poner el nombre DNS en lugar de la IP del servidor de licencias.
Citar
#4
Como bien comenta rubendito, lo debes configurar todo en el apartado NAT de tu router. No nos comentas el modelo concreto, pero tampoco importa mucho, lo importante es que tengas claro el proceso.

Debes configurar los trigger port para que apunten a la ip de tu pc que contiene las licencias. Si la configuración del router la tienes bien y no consigues que conecte, es posible que tengas que abrir el puerto 6200 en el pc de las licencias, para eso tienes que ir al firewall de windows (asumo que usas windows).

Yo no tuve problemas para poder acceder a unas camaras ip de mi casa desde el lugar de vacaciones, fue con otro router pero en esencia lo mismo.
Citar
#5
Perfecto, esta noche cuando llegue a casa voy a probar de nuevo a configurar la zona NAT de mi router, a comprobar el firewall y demas, en principio, mientras que no resetee el router mi ip publica, aunque sea dinamica, no deberia cambiar no?
Lo digo por ahorrarme el paso del DNS hasta que consiga que funcione de forma correcta
Citar
#6
manuguer escribió:mientras que no resetee el router mi ip publica, aunque sea dinamica, no deberia cambiar no?

Correcto.
Citar
#7
Pero puedes sufrir algun reseteo por parte del proveedor de internet, corte de luz, cuelgue, etc.
Citar
#8
ya ya, en elgun momento cuando consiga que funcione bien , hare el tema del dns, pero ahora mismo lo principal es que esto funcione de una vez

Por cierto, el router el modelo exacto es este WAP-5813n

La duda que me surge a la hora de hacer el port triggering es que protocolo usar??
resim
Citar
#9
Para el uso concreto que necesitas no te puedo asegurar el que debes usar, pero yo probaría con TCP, es el que usé en mi configuración y funcionaba correctamente.

Marca "custom application", ponle un nombre cualquiera y luego configuras los puertos.
Citar
#10
y el user interface?? probare con esa y si no ire cambiando a ver cual funciona jajaja
Citar
#11
Tienes que seleccionar el que aparece en tu configuración del proveedor, digamos que es la que tiene configurada por el suministrador y por defecto en el router, a no ser que hayas aprovechado el router de otro proveedor y lo hayas configurado a mano, en ese caso tienes que buscar en el router la configuración y usar la que tengas configurada allí.

Eso puedes verlo en WAN SERVICE
Citar
#12
Bueno, como esto sigue sin funcionar, voy a hacer el post lo mas completo posible para ver si se me ha pasado algo por algo
Empezamos con el programa gestor de licencias:
Programa de licencias
resim
resim
Archivo de licencias con la mac de la tarjeta de red
resim
Firewall
resim
resim

Pasamos ahora con la configuracion del router actualmente
resim
resim
resim
resim
resim

Y ahora nos vamos con los resultados que sacamos en el cliente, tapo la ip publica por si acaso
resim
Esta es una prueba de buscar licencias en la direccion de la ip publica
resim
Y esta es una variable de entorno que hay que ponerle para que busque en la direccion que le indico, en este caso tengo puesta la publica
resim

Y esto es todo lo que tengo hecho por ahora, por supuesto salta error al abrir cualquier programa diciendo que no establece conexion

estoy ya desesperao del to :dale2:
Citar
#13
Has probado el programa de licencias en local?, es decir, hacer una llamada desde el mismo equipo que tiene el programa de licencias sin pasar por el router.

Otra cosa, si tienes activado el firewall del router, desactivalo temporlamente para las pruebas y el de windows tambien, para ir descartando cosas.

Si puedes, ejecuta el comando ipconfig en el equipo que tiene las licencias para ver su configuracion de red y pegas un pantallazo.
Citar
#14
Bueno el servidor funciona dentro de mi propio ordenador, al menos descartamos que el programa no funcione jajaja

el printscreen del ipconfig lo dejo por aqui
resim
resim

Ya hay no me ha dado tiempo a probar a desactivar el firewall
Citar
#15
Veo que en ese equipo tienes varios adaptadores de red, yo probaría primero con uno sólo. Ahora que has probado el programa en el servidor, prueba que funcione haciendo la llamada desde otro equipo dentro de la red. Si funciona, ya sabes que sólo hay que centrarse en la configuración del router.

Prueba a desactivar los firewall del router y del servidor de licencias.
Citar
#16
Bueno la prubea en local ha sido un exito, funciona de forma correcta( cosa que antes nisiquera conseguia, ahora queda el asunto de hacerlo global, he probado tanto con unicamente la tarjeta de red a la que esta destinada la licencia del programa como con la dos y no hay manera firewall de windows desactivado
El caso es ahora el firewall del router, el firewall LAN esta desactivado
resim
Pero el firewall WAN parece que no
resim
este no tengo ni idea de como abrirlo y yo creo que este va a ser el ultimo paso para que funcione
Citar
#17
Ese es mas jodido de quitar... hay que ir a saco.

haz un backup de tu configuración y edita el fichero creado con extensión .conf con wordpad y edita la linea donde pone TRUE cambiandolo a FALSE.

Luego restaura, reinicia y firewall desactivado.

La otra opción es eliminar la configuración del interface ppp0.6 y crearla de nuevo sin activarlo, pero si te equivocas no conectará el router.
Citar
#18
Bueno por fin he podido abrir el firewall del router, he hecho tambien lo del tema del dns dinamico pero ahora hago ping a ester servido ro a mi ip publica y no responde
Posiblemente sea esto el problema inicial desde el principio aunque alguna vez si que me habia respondido
Que puede ser?
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
Pregunta [SOL] Tengo dos URL's en el mismo servidor en wordpress como redirigir de uno a otro Electromecánico 5 362 02-03-2018, 12:04 PM
Último mensaje: Electromecánico
Pregunta Servidor doméstico Electromecánico 2 672 14-03-2016, 10:47 PM
Último mensaje: ICEM4N
  ¿Aprovechar restos de fibra óptica? Electromecánico 5 1,227 07-04-2015, 07:24 AM
Último mensaje: Electromecánico
  Prueba un servidor linux que se autodestruye en 35 minutos sistemasorp 6 1,199 15-07-2013, 06:30 PM
Último mensaje: OverCraft