Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLUCIONADO!!!] Problema "escaleras" en piezas
#81
alejandrosela escribió:Tambien puede interpretarse que el problema es que vuestra cama no es suficientemente rígida y que se dobla con el calor demasiado.
Usais el espejo de ikea?
Teneis los muelles de la cama suficientemente comprimidos?
Usais 4 pinzas para que el espejo sea completamente solidario a la cama ? ( uno por lado)

Gracias por la info!

El tema son las variaciones que mete de varios grados al usar el sistema bang-bang. La variación he estado investigando y afecta también al cristal, no solo a la cama, además es física pura, le estás metiendo aumentos de temperatura de golpe, on variaciones de 3-4 grados en algunos casos, y se tiene que expandir, al final o hacia arriba o hacia abajo. Hay un vídeo en youtube donde lo comprueban con un calibre, y activan/desactivan con un relé y se ve claramente.

Los muelles no tienen que ver porque sujetan la cama por las 4 esquinas y el cristal va pegado a la cama, pero vamos, he probado incluso sin muelles en su día xD. Tengo un espejo de ikea y otro de otro lao.

Tiene un amigo mío la mendel y ahí la base es metálica y bastante gruesa, por lo que no sufren ese problema.
Estos días me he fijado en muchas fotos de modelos que sube la gente, y ese problema lo tienen muchísimos, pero supongo que como siempre lo ha hecho así no les parece raro... yo como al principio, por problemas de fuente, tenía la cama conectada directamente a 12v constantes me mosqueaba ver que las piezas del principio salían mejor xD
Citar
#82
En resumen, el relé da problemas? No tengo ni idea y aun no me ha llegado la conjunta pero supuestamente es una mejora no?
Citar
#83
marjacstein escribió:En resumen, el relé da problemas? No tengo ni idea y aun no me ha llegado la conjunta pero supuestamente es una mejora no?

No es tema del relé propiamente dicho, de hecho pasa también si conectas a la ramps directamente.

El problema es que el marlin (firmware de la ramps) tiene varios métodos para calentar la cama y el hotend, centrándonos en dos:

"bang-bang": Entrega corriente a la resistencia hasta alcanzar la temperatura marcada. Cuando alcanza la temperatura, apaga la corriente, cuando la temperatura baja unos grados (de 1 a 4 +-), vuelve a encender.
"pwm": Entrega corriente a la resistencia hasta alcanzar la temperatura marcada. Cuando alcanza la temperatura, "reduce" la corriente hasta adaptarla a la necesaria para mantener esa temperatura (lo que hace es encender/apagar cada 0,14 segundos por defecto), manteniendo una temperatura constante.

El hotend se calienta por pwm generalmente, la cama suele venir por defecto en "bang bang", el problema de esto es que la cama está subiendo-bajando de temperatura durante toda la impresión, con variaciones de varios grados, por lo que la cama y el cristal se expanden (calor) y se contraen (frio), como es una superficie fina, dobla hacia arriba (o hacia abajo), al final tienes una variación de altura periódica que te crea esas "escaleras".
Naturalmente si usas un relé, estas con bang bang si o sí, además los ON/OFF serán más brutos posiblemente y el efecto se note más.

El efecto que se ve en las piezas, naturalmente está relacionado con la velocidad, cuanto más rápido imprimas, tendrás escaleras cada más distancia, cuanto más lento, más escaleras tendrás. Pero suele ser constante en la frecuencia, sobre todo si imprimes con la cama a X temperatura siempre. (eso era algo que me mosqueaba mucho cuando pensaba que era cosa del eje Z xD).

Las soluciones:

- Poner la cama en modo PWM (hay que hacer autotuning)
- Imprimir con la cama fría.
- Imprimir con la cama a tope siempre (conexión directa a la fuente)
- Probar otras camas/cristales
- Crear una estructura fija debajo de la cama y fijar el cristal a esa estructura. (eso lo minimizaría)
- Cuanto más calor haga en el ambiente, menos debería pasar xD
Citar
#84
Weno, para activar el modo PWM (PID) en el marlin para la cama (conectada a la ramps, sin relé ni leches):

-> buscamos en el marlin (configuration.h ) las lineas #define PIDTEMPBED y #define BED_LIMIT_SWITCHING y las descomentamos (quitando el "//" de delante)

Encontraremos una línea que dice #ifdef PIDTEMPBED , ahí es donde deberemos escribir los valores de nuestra cama, cómo no los tenemos, tenemos que pasar un autotuning para conocerlos, para ello tenemos que descomentar unos valores por defecto, los primeros que salen en el marlin creo que son estos:

//120v 250W silicone heater into 4mm borosilicate (MendelMax 1.5+)
//from FOPDT model - kp=.39 Tp=405 Tdead=66, Tc set to 79.2, argressive factor of .15 (vs .1, 1, 10)
// #define DEFAULT_bedKp 174.56
// #define DEFAULT_bedKi 21.65
// #define DEFAULT_bedKd 351.78

Así que les quitamos los "//" que predecen a los #define.

Ahora guardamos y cargamos el marlin en la ramps.

Ahora abrimos el reptier por ejemplo, conectamos la impresora al PC y mandamos que la cama se caliente a 90 grados de manera manual.

Cuando llegue a 90 grados (más o menos), tenemos que mandarle el comando GCODE este : M303 E-1 C8 S90

Al hacerlo, en la parte de abajo del reptier nos mostrará "autotuning running" o algo así (no recuerdo ahora), y empezará a hacer unos test, tarda un rato porque hace varias iteraciones.

Una vez termine, nos dará los valores bedKp, bedKi y bedKd. para confirmarlos, desconectamos el reptier y lo volvemos a conectar, en la parte de abajo veremos que muestra los mensajes de inicio y saldrán esos valores de bedKp, bedKi y bedKd que hemos visto, después del texto "Classic PID". Apagamos la impresora

Ahora tenemos que ir al marlin otra vez, y donde teníamos lo de :

//120v 250W silicone heater into 4mm borosilicate (MendelMax 1.5+)
//from FOPDT model - kp=.39 Tp=405 Tdead=66, Tc set to 79.2, argressive factor of .15 (vs .1, 1, 10)
#define DEFAULT_bedKp 174.56
#define DEFAULT_bedKi 21.65
#define DEFAULT_bedKd 351.78

Sustituimos con los valores que nos ha dado el autotune, podemos sustituir los comentarios por el texto que queramos, suponiendo que nos han dado los valores Kp: 100, Ki: 2 y Kd 300, habría que poner algo algo así:

// la prusa me chupa la vida
//aquí están los valores del autotune
#define DEFAULT_bedKp 100
#define DEFAULT_bedKi 2
#define DEFAULT_bedKd 300

Guardamos, cargamos y a imprimir!
Citar
#85
Muchas gracias antodelg por toda la explicación! Ya me queda mas claro y cuando la tenga ya sé dónde acudir para modificarlo. Un saludo!
Citar
#86
Ahora da gusto hacer piecitas, cada vez que pienso que estuve 3 meses con este problema, que tenía también efectos secundarios en la resistencia de las piezas y separación de capas... me da ganas de tirar la impresora por la ventana xD.

Una "regadera" con ABS transparente, impresa en modo espiral con un solo trazo:

resim
resim


Y aquí como quedaban antes con el problema (y eso que es una foto con el "ángulo bueno" xD (escaleras en las piezas, capas a punto de despegarse, capas con separaciones):

resim
Citar
#87
goldmen escribió:Buenas tardes.
Tengo un pequeño problema :?: , mi cama es de 220v :o , existiría alguna manera para eliminar la escalera de las piezas Guiño , como hacer el bang bang más rápido, y la comprobación de temperatura también mas rápido Sisi3 , de esa manera la variación de temperatura sería bastante menor Guiño

La comprobación de temperatura es bastante rápida, no creo que sea el problema.

En cuanto a lo otro, no creo que puedas hacer lo, el PWM es como un "bang-bang" mucho más rápido (un "bang" cada 0,14 segundos) , pero si tienes la cama de 220v tendrás un relé, no se la máxima frecuencia que soportan, pero a 220v me parece imposible. Quizás haya alguna manera de controlar la energía que recibe la cama.

Aún así, si puedes, comprueba que tu problema es debido a la cama (intenta imprimir algo con la cama apagada), las escaleritas puede aparecer por z-wobble o z-banding (ejes Z que se menean)
Citar
#88
goldmen escribió:en una respuesta anterior

El problema es que el marlin (firmware de la ramps) tiene varios métodos para calentar la cama y el hotend, centrándonos en dos:
"bang-bang": Entrega corriente a la resistencia hasta alcanzar la temperatura marcada. Cuando alcanza la temperatura, apaga la corriente, cuando la temperatura baja unos grados (de 1 a 4 +-), vuelve a encender.
"pwm": Entrega corriente a la resistencia hasta alcanzar la temperatura marcada. Cuando alcanza la temperatura, "reduce" la corriente hasta adaptarla a la necesaria para mantener esa temperatura (lo que hace es encender/apagar cada 0,14 segundos por defecto), manteniendo una temperatura constante.

:?: Se podría controlar esta variación para que fuese de +-1º en vez de 4. Te comento la cama está en una plancha de aluminio de 3mm y yo creo que también me varia la medida, aunque encima tengo un cristal. Cuanto menos variación creo que sería mejor. :?


Mm, puede que si permita cambiar eso, pero la verdad no tengo ni idea. Aún así, yo creo que seguiría pasando en cuanto apagas y enciendes con un tiempo de diferencia. Esos 4 grados de diferencia es en casos extremos, generalmente anda entre 1-2.
Citar
#89
Te propongo otra cosa, reduce la temperatura a intervalos de 5 grados, hasta que encuentres un punto en el que el efecto disminuya. Si es un problema de dilatación, es posible que a menores temperaturas el efecto disminuya. Si el problema es que cuando la cama se calienta ésta se deforma, entonces habrá que pensar en otra cosa...
Citar
#90
a mi me pasaba a 60, 70 y 100 grados...
Citar
#91
Buenos días
A mí me pasaba lo mismo.
Se me había descolgado 1 mm el sensor de temperatura de la cama.
Había una zona de aire entre la cama y el sensor de 1mm, lo junte y ya está
Citar
#92
Francisco escribió:Buenos días
A mí me pasaba lo mismo.
Se me había descolgado 1 mm el sensor de temperatura de la cama.
Había una zona de aire entre la cama y el sensor de 1mm, lo junte y ya está

mm puede que eso influya también porque la diferencia de temperatura entre el sensor, cama y el cristal sería mucho mayor, no se me había ocurrido. Mola Mola Mola
Citar
#93
haciendo un poco de offtopic, estos días he cambiado el hotend por un j-head mk-v (porque con el 3de de 1,75mm es imposible meterse con el PLA), y estoy probando impresiones con el PLA, y la verdad es que estoy contentísimo. En piezas pequeñas se consiguen detalles mucho mejores y en piezas grandes ya no tengo warping ninguno (necesitaba hacer unas maquetas a 16x16 y con ABS era imposible, ni laca, ni abs+acetona, ni 120 grados ni leches xD. Con PLA va perfecto.

Las piezas salen muchísimo más duras y ahora que el tema de la cama está resuelto ya da gusto usar la impresora... xD

resim
resim
resim
resim
Citar
#94
Hola, gracias antodelg por el pequeño manual sobre la configuración de malin, después de seguir dicho manual y cambiar varias veces los datos (nunca me dan los mismos que puse en ...bedKp, ...bedKi y ...bedKd al volver hacer el autotune start aunque son aproximados.) me da, que ahora se calienta más rápidamente y pierde menos grados por lo que creo que es una de las configuraciones importandes hacer en la impresora.
Citar
#95
Me ha pasado una cosa curiosa estos días, sin cambiar firmware ni nada, la impresora, donde antes imprimía 17 centímetros en el eje x, ahora imprime casi 18...

Repetí unas piezas que habia hecho anteayer y ahora me las hace algo más grande, más de lo que le marco en el cura... xD
Citar
#96
Buenas antodelg
Mi buena explicación y mi felicitación por el aporte y avance te quería comentar un par de cosas a ver si me despejas las dudas
1- el cuteocto que encontré tarda unas 2hora 44 el tuyo es el mismo o tienes alguna versión más pequeña
2- y a mi últimamente el cura y el repetier me van fatal me bloquean todas la impresiones y se quedan. Medias lo que estoy haciendo es pasar el gcide a la sd e imprimir desde esta así la hacen del tirón y por lo menos no se para referente a esto no tendrás algún Tuto o algo de configuración y ajuste del repetier y configuración del sli3c sería de agradecer a ver si por lo menos la dejo fina fina ya que me tiene loco aunque poco a poco voy avanzando pero eso poco a poco

Saludos y gracias
Citar
#97
josualo escribió:Buenas antodelg
Mi buena explicación y mi felicitación por el aporte y avance te quería comentar un par de cosas a ver si me despejas las dudas
1- el cuteocto que encontré tarda unas 2hora 44 el tuyo es el mismo o tienes alguna versión más pequeña
2- y a mi últimamente el cura y el repetier me van fatal me bloquean todas la impresiones y se quedan. Medias lo que estoy haciendo es pasar el gcide a la sd e imprimir desde esta así la hacen del tirón y por lo menos no se para referente a esto no tendrás algún Tuto o algo de configuración y ajuste del repetier y configuración del sli3c sería de agradecer a ver si por lo menos la dejo fina fina ya que me tiene loco aunque poco a poco voy avanzando pero eso poco a poco

Saludos y gracias

Mm cuando los uso para calibrar los hago pequeñitos (si, en vez de cubos de calibración hago cuteoctos xD) estos están reducidos al 30% si no recuerdo mal, con poco relleno para que tarde poco. El propio cura permite escalar las figuras.
Hace tiempo que no hago uno, pero no pasaban de 10-20 minutos.

Yo suelo imprimir desde la SD, las veces que lo hice desde el PC no he tenido problemas, puede que sea tema de requisitos o que el PC tiene algún problema. Hace tiempo que no uso el repetier, estuve probándolo al principio, pero luego pasé al CURA por su sencillez (aunque el repetier permite toquetear cosas más concretas)
Citar
#98
Buenas después de ajustar la cama con pwm os dejo un foto del cuteocto i me indicáis si ya esto es una calidad aceptable            
Saludos a todos y gracias y perdonar por la intromisión pero como tenía que ver la cama por eso lo puse aquí
Citar
#99
Hay algo raro en las capas, pero diría que es por temperatura baja en el extrusor, el tema de los escalones parece que lo tienes solucionado ^^
Citar
Buenas después de ajustar la cama con pwm os dejo un foto del cuteocto i me indicáis si ya esto es una calidad aceptable [ATTACHMENT NOT FOUND][ATTACHMENT NOT FOUND][ATTACHMENT NOT FOUND]
Saludos a todos y gracias y perdonar por la intromisión pero como tenía que ver la cama por eso lo puse aquí
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  [SOLUCIONADO] Primeras capas bastante mal [Fotos] Inyector 15 4,125 10-05-2018, 07:49 PM
Último mensaje: jphurtadom
  CONSULTA Problema con impresion de piezas angelitoxo 2 169 04-05-2018, 01:38 AM
Último mensaje: angelitoxo
  [SOLUCIONADO] Pegotes de material dvera16 8 364 28-04-2018, 10:09 AM
Último mensaje: dvera16
  [SOLUCIONADO] Temperatura extrusión baja sola granota 4 1,666 09-04-2018, 01:16 PM
Último mensaje: Sinteprod
  CONSULTA [SOLUCIONADO] Z Wobble SuperCoco 12 501 09-03-2018, 12:10 AM
Último mensaje: SuperCoco