Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLUCIONADO]¿Es compatible Marlin con MKS GEN-2Z v1.1?
#1
Hola a todos, este es mi primer post y antes de nada creo que es de buena educación presentarse Guiño
Vivo en canarias y soy técnico en electrónica y aficionado a ella y me encanta cacharrear por ello me he comprado un Prusa i3 de metacrilato para montar uno mismo.

La duda que tengo es que me viene una placa MKS GEN-2Z v1.1 ya con un firmware instalado que creo es repetier-firmware, creo que es ese por el menú que aparece en el LCD porque en la documentación no hace referencia a nada.
Con este firmware ya precargado tengo un problema con las sondas de temperatura no miden la temperatura real y el fusor no llega a fundir el ABS, en el repetier marca 220ºC pero con una sonda de temperatura de un fluke me mide 160ºC, con lo cual creo que el firmware está mal configurado.
Mi intensión es meterle el Marlin que más o menos lo control pero no sé si será compatible con la electrónica que monta mi impresora.
Según leo dice que es un Arduino MEGA2560 más RAMPS1.4 todo en una misma placa pero a la hora de seleccionar la placa en el Marlin no sé que placa escoger de todas las que hay en el archivo boards.h no quiero confundirme y romper algo al seleccionar mal las entradas/salidas. a ver si alguien me echa una manita.

Gracias de ante mano
Citar
#2
Por aquí pone que si Guiño

http://reprap.org/wiki/MKS_GEN_V1.1
Citar
#3
Si, eso es lo que leí, lo que quería confirmar que las salidas/entradas coinciden con ramps 1.4 que creo que si pero quería confirmarlo con ustedes que son los expertos Lengua por si acaso me cargue algo y ¿en el caso de configurar el marlin sería escoger la placa "BOARD_RAMPS_13_EFB"? o ¿cual sería?, tengo extrusor, un fusor y dos motores en el eje Z
Citar
#4
Pues actualizo... me he arriesgado y si, es compatible pero hay que ajustar, en
Código:
#define TEMP_SENSOR
hay que sacar el -1 y poner el termistor que tenga tu impresora
y en mi Prusa de metacrilato hay que invertir el motor y
Código:
#define INVERT_Y_DIR true

y listo ya funciona para empezar ahora toca ajustar

gracias a todos
:aplauso: :aplauso: :aplauso: :yeah: :yeah: :yeah: :yeah: :yeah:
Citar
#5
Buenas Thulsa, yo también he cogido una impresora de metacrilato con la placa MKS GEN-2Z v1.1, así que me da que puede ser la misma

Te importaria pasarme el marlin que has configurado? Ando peleando con él y estoy un poco perdido...
Citar
#6
Sin problema, te paso lo que tengo, está en MEGA y lo he comprimido con ubuntu en .7z pero nuca he probado si funciona bien en el compresor de este sistema operativo. prueba y si no puedes descomprimirlo me lo dices y ya lo hago de otra manera.

https://mega.nz/#!ZccD0LBB!HkNnAjKAq-wdo...lPMnfbwUCg

EDITADO: He cambiado el parámetro del extrusor y ahora me va muuucho mejor las impresiones, edito el enlace original
Yo estoy imprimiendo con la temperatura de la cama caliente en 120ºC y la del hotend a 240ºC y las impresiones ya no me sufren de
Warping pero para poder llegar a esa temperatura con el hotend que nos viene en nuestra impresora hay que cambiar el soporte del
ventilador por que el que trae está abierto y el aire le llega al nozzle y no pasa de 230ºC.
Con este diseño que he realizado se sustituye por el que trae de serie y se soluciona el problema, espero te sirva
https://mega.nz/#!YMNFBYqY!Rh6R-cOPRywRD...LlN01wyntY
Saludos
Citar
#7
Muchísimas gracias por todo! En cuanto saque un rato me pongo a ello.

Solo para confirmar, la que yo he comprado es esta (2015 Upgraded Quality High Precision Reprap Prusa i3 DIY 3d Printer kit with 2 Rolls Filament 8GB SD card and LCD for Free
http://www.aliexpress.com/item/Hot-Full-...04108.html
(from AliExpress Android)). ¿Es la misma?

P.D.: Si hay algún problema por publicar enlaces por favor avisarme y lo quito.

Enviado desde mi m8 mediante Tapatalk
Citar
#8
Exacto, es la misma
Citar
#9
Muchísimas gracias Thulsa.

Todavía no me imprime del todo bien... pero bueno... me has solucionado muchos problemas. Gracias de verdad.

Cualquier nueva modificación o mejora que le hagas, acuérdate de mi! Mola Mola
Citar
#10
bastago escribió:Muchísimas gracias Thulsa.

Todavía no me imprime del todo bien... pero bueno... me has solucionado muchos problemas. Gracias de verdad.

Cualquier nueva modificación o mejora que le hagas, acuérdate de mi! Mola Mola


Por supuesto la comunidad está para ayudarse, A por cierto utilizo Repetier, si usas el mismo soft que yo prueba esta plantilla de Slic3r a ver que tal te va.

Te paso un par de meses de pruebas y errores y todavía sigo afinando.

Ya me dices que tal te va con esto


Archivos adjuntos
.7z   ABS-Negro.7z (Tamaño: 1.33 KB / Descargas: 40)
Citar
#11
Solo tengo PLA... pero voy a probar con esa configuración cambiándole la temperatura...

Gracias por todo Guiño
Citar
#12
hola, acabo de descargar el archivo de configuracion pero del eje z solo me funciona un motor, como puedo arreglarlo? Gracias.
Citar
#13
Pues revisa la electrónica porque eso no es normal
Citar
#14
Yo he metido el Marlin de Thulsa y sin ningun problema, a excepcion de algun defectillo en la impresion que creo que esta otro tema...

Con lo que... como te dice Thulsa, debe ser algun problema con la electronica, que los cables esten bien puesto y apretados en su sitio...
Citar
#15
(10-10-2015, 09:44 AM)Thulsa_Doom escribió: Sin problema, te paso lo que tengo, está en MEGA y lo he comprimido con ubuntu en .7z pero nuca he probado si funciona bien en el compresor de este sistema operativo. prueba y si no puedes descomprimirlo me lo dices y ya lo hago de otra manera.

https://mega.nz/#!ZccD0LBB!HkNnAjKAq-wdo...lPMnfbwUCg

EDITADO: He cambiado el parámetro del extrusor y ahora me va muuucho mejor las impresiones, edito el enlace original
               Yo estoy imprimiendo con la temperatura de la cama caliente en 120ºC y la del hotend a 240ºC y las impresiones ya no me sufren de
               Warping pero para poder llegar a esa temperatura con el hotend que nos viene en nuestra impresora hay que cambiar el soporte del
               ventilador por que el que trae está abierto y el aire le llega al nozzle y no pasa de 230ºC.
               Con este diseño que he realizado se sustituye por el que trae de serie y se soluciona el problema, espero te sirva
               https://mega.nz/#!YMNFBYqY!Rh6R-cOPRywRD...LlN01wyntY
Saludos

Estimados,

Antes que nada me presento, mi nombre es Cristobal y soy de chile...

hace tiempo tenia muchas ganas de comprarme una impresora 3d, hasta que tuve la chance y la compre... bueno la que compre es la misma que ustedes tienen... segun las descripciones y fotos que ya fueron publicadas.

Apenas la compre esta tenia una falla... el filamento no pasaba por el extrusor no habia como hacerlo pasar, decidi cambiarlo y se acabo el problema, pero esto solo dura una semana...

Ahora cuando imprimo a veces según la pantalla el sensor indica temp correcta sin embargo a veces el motor que empuja el filamento empieza a dar golpes y la impresión comienza a quedar con menos filamento ( como que se enfriara el nozzle ), después de muchas veces que suspendí la impresión por este defecto decidí en medida de solución subir temperatura desde el software (repetier ) y el problema se acababa seguía imprimiendo normal, le bajaba la temperatura hasta que esperando no volviera a pasar el mismo problema.. 

eso es un resumen de todo lo que me ha pasado....

Lo que me gustaría seria actualizar el firmware creo que no pierdo nada con probar, ahora nose si realmente valdrá la pena.... ( el link que dejaste con la descarga ya no esta activo )...

espero me puedan ayudar, de antemano muchas gracias ! saludos desde chile !!
Citar
#16
Hola Amigos. Estoy buscando ayuda. No puedo cargar el firmware para mi tarjeta mks gen-2z v1.1. Vi que aquí mostraron un Marlin, pero ya no está diponible. Alguien que me lo pueda proporcionar.?

Gracias.
Citar
#17
Reciban todos uds un cordial saludo.
Espero que este foro aun esté activo ya que he visto que la última publicación fue en el 2015.

Soy Hector Herrera les escribo desde el Paraguay.
Hace unos días compre una impresora Prusa i3 pero no he podido usarla ya que presenta los siguientes problemas (eso creo) :
1> Al dar la orden de impresión tarda mucho tiempo en alcanzar la temperatura Deseada y en muchos casos nunca llega a la temperatura.
2> Al tratar de calentar la cama, de manera inmediata se reinicia la impresora y anula la impresión.
3> Solo en 2 oportunidades me dio alegría ver trabajar a la impresora pero fue solo ilusión ya que nunca hizo la figura Deseada y su filamento no hizo nada.
4> He estado revisando (ojeando) la board GEN-2Z V1. 1 y tratar de encontrar una señal de quemado o algo así pero mi ojo inexperto no ha detectado nada.

Les comento que soy novato novato novato en este tema de la impresión 3d y lo que he aprendido lo he aprendido gracias al Internet y a los foros que ingreso para buscar la solución a mi problema.

Quiero está máquina para generar ingresos y hasta el momento he perdido tiempo y no quiero suponer que he perdido el dinero.

Por favor AYÚDENME con sus consejos que tienen y mi primer impresión óptima será dedicada a este grupo y al héroe que me ayude.

Mi WhatsApp es +595972976931

Gracias por su ayuda...
Citar
#18
Hola @Hector herrera, bienvenido al foro.
Lo primero decirte que donde has puesto la pregunta no es un foro, sino un post y bastante antiguo.
Para las preguntas que realizas, deberías haber creado un nuevo tema en el apartado Prusa del subforo Impresoras (ya que es esta tu máquina) o bien en el subforo General.
Y exponer tu número de teléfono públicamente no es muy juicioso, ni necesario para obtener ayuda en el foro.
Pasando a tus preguntas, por los síntomas que indicas parece que tienes un problema con la fuente de alimentación.
Tendrás que comprobar su estado o si tienes una de repuesto, probar con ella.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Marlin gilito 2 256 26-04-2019, 11:19 AM
Último mensaje: gilito
  CONSULTA Marlin SebaS 3 945 13-07-2018, 11:10 PM
Último mensaje: Simemart
Pregunta Cura me invierte las piezas [SOLUCIONADO] Electromecánico 6 826 08-06-2018, 06:10 PM
Último mensaje: Electromecánico
  CONSULTA [SOLUCIONADO]Error: tool 0 failure temp limit reached alinos96 1 585 04-06-2018, 01:42 PM
Último mensaje: alinos96
  Dudas sobre Repetier [SOLUCIONADO] Jaume Cat 2 1,365 13-02-2018, 11:03 AM
Último mensaje: Jaume Cat