Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Reasignar pines de la RAMPS
#1
Debido a que el End Stop del eje Z no me funciona porque los pines de la RAMPS no reciben voltaje (al principio na mas montar la impresora a veces fallaba pero ya nada) me gustaria saber si puedo reasignar la funcion de los pines que me fallan (ROJO) a otros pines, como los 2 siguientes que estan libres (AZUL).

resim
Citar
#2
En principio no debería de ser demasiado problema... Por lo menos así de primeras.

resim

No tengo aquí el firm y el ide, pero mañana por la mañana si aún no arreglaste te lo miro Guiño


Salu2
Citar
#3
Eso se escapa de mi conocimiento. Cualquier indicación mañana o cuando puedas te la agradecere muchisimo.

Un saludo.
Citar
#4
hay una pastaña , pins.h o algo de eso para cambiar los pines
Citar
#5
prueba en el archivo pins.h a cambiar esto


#ifdef RAMPS_V_1_3

#define X_STEP_PIN 54
#define X_DIR_PIN 55
#define X_ENABLE_PIN 38
#define X_MIN_PIN 3
#define X_MAX_PIN 2

#define Y_STEP_PIN 60
#define Y_DIR_PIN 61
#define Y_ENABLE_PIN 56
#define Y_MIN_PIN 14
#define Y_MAX_PIN 15

#define Z_STEP_PIN 46
#define Z_DIR_PIN 48
#define Z_ENABLE_PIN 62
#define Z_MIN_PIN 18
#define Z_MAX_PIN 19



por esto

#define Z_MIN_PIN 20
#define Z_MAX_PIN 21


Prueba a hacer homming con la mano en el interruptor de la fuente por si acaso ;-P


Salu2
Citar
#6
He probado a hacer el cambio y ahora hace corto todo el rato. He probado a conectarlo en todos los sitios pero en ninguno parece q funciona
Citar
#7
prueba con
#define Z_MIN_PIN 19
#define Z_MAX_PIN 20

Por ahí anda la cosa Guiño

Tendría que desmontar la ramps mia para ver a que pin va ese conector exactamente.

Prueba continuidad con todo apagado entre el conector correcto y el pin 18 al 21, a ver cual te da continuidad.
Citar
#8
Bueno muchas gracias por todo he encontrado la SOLUCION:

Tenía que usar el pin del Z_MAX en nuestro caso es el 19, probe a invertir de la siguiente manera:

#define Z_MIN_PIN 19
#define Z_MAX_PIN 18

Pero no se porque narices de esta manera también me fallaba los otros pines, asi que me dio por probar de la siguiente manera:

#define Z_MIN_PIN 19
#define Z_MAX_PIN 19

Y finalmente funciono!! Ya puedo volver a ponerla en marcha.
Muchas gracias!
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Consulta TMC2208 y Ramps elaspi 9 271 22-11-2018, 01:58 PM
Último mensaje: Shellmer
  CONSULTA ventajas ramps 1.4 1.6 davlinares 1 146 08-11-2018, 09:18 PM
Último mensaje: Simemart
  Conectar TFT tactil a ramps Jaimelito 22 6,033 26-08-2018, 03:52 PM
Último mensaje: Leo
  CONSULTA Ramps 1.4 hace el home al revés mocman 4 319 18-08-2018, 06:56 PM
Último mensaje: mocman
  CONSULTA Salida de 12v en RAMPS 1.4 Rubenulo 6 489 04-06-2018, 08:13 PM
Último mensaje: Rubenulo